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1.Getting Started

1.1. Welcome

Welcome to the Product Guides. Here you'll find links to start

installation, a list and quicklinks to supported products, and helpful resources to get the

most out of your experience.

First Citizens Bank

Getting Started

Access the links below to begin installation and review the latest updates in our release

notes. Explore our other content using the search bar or the navigation menu on the left.

ERP Quickstart Links Release Notes

Sage Intacct Pre-Onboarding Checklist (Intacct) Release Notes (Intacct)

Business Central

365

Pre-Onboarding Checklist (Business

Central)

Release Notes (Business

Central)

NetSuite Pre-Onboarding Checklist (NetSuite) Release Notes (NetSuite)

Product Features

Explore the features and products  supports. Click the checkmark ✓

under your ERP per product to jump directly to its documentation for setup guides and

First Citizens Bank



usage instructions.

Accounts Payable

Product NetSuite Sage Intacct Business Central

Positive Pay ✓ ✓ -

ACH - ✓ ✓

Cash Management

Product NetSuite Sage Intacct Business Central

Balances & Transactions ✓ ✓ ✓

Reconciliation Manual Export ✓ ✓ ✓

Bank Feeds

Feature NetSuite Intacct Business Central

Bank Feeds ✓ ✓ ✓

Product Support

Support 

We're here to help you get started and use the plugin. If something goes wrong, reach out

to us directly or check the Status Page for updates.

Contact Us

Click To Edit Button Label

Have a Feature Request?

Feature requests help us drive the roadmap of future developments on the integrations.

Use the section above to vote on previous ideas, or submit ideas of your own to FISPAN. 

https://support.fispan.com/firstcitizens/positive-pay-netsuite
https://support.fispan.com/firstcitizens/positive-pay-intacct
https://support.fispan.com/firstcitizens/ach-requirements
https://support.fispan.com/firstcitizens/ach-requirements
https://support.fispan.com/firstcitizens/managing-balances-and-transactions-netsuite
https://support.fispan.com/firstcitizens/managing-balances-and-transactions-intacct
https://support.fispan.com/firstcitizens/viewing-bank-statements-business-central
https://support.fispan.com/firstcitizens/managing-balances-and-transactions-netsuite#importing-bank-transactions-inside-netsuite
https://support.fispan.com/firstcitizens/managing-balances-and-transactions-intacct#balances-transactions-reconciliation
https://support.fispan.com/firstcitizens/viewing-bank-statements-business-central#filter-and-export-data
https://support.fispan.com/firstcitizens/bank-feeds
https://support.fispan.com/firstcitizens/GrS3-bank-feeds
https://support.fispan.com/firstcitizens/cUC3-bank-feeds
https://fispan-fcb.statuspage.io/


*Please note: We are always thrilled to receive feedback and feature requests for our

integrations. We work closely with our various partners to make decisions on what to

develop next. We may reach out to you directly for additional information about a feature

you've previously voted on or suggested. Lastly, due to the complexity of developing the

integrations, we are generally unable to provide timelines on features listed below. 

FISPAN is a vendor of your bank. To submit inquiries or complaints to your bank, please do

so directly with them.

NOTE: If you have a question about a feature listed under "LAUNCHED, Subject to

Bank Availability," please reach out to our Support team, or your bank representative.

Click this link to the  website to see a list of feature

requests under consideration.

FISPAN Feature Request Portal

https://portal.productboard.com/fispan/4-fispan-product-portal


2.NetSuite

2.1.Plugin Setup

2.1.1. Pre-Onboarding Checklist (NetSuite)

Use this checklist to get ready for your onboarding call. Having everything on hand will

also help you if you decide to start the installation on your own.

If you're moving your plugin to a live environment, make sure you've already completed the

 in a sandbox environment. Testing in a sandbox with all of

your custom workflows, scripts, and third-party apps is the best way to ensure everything

works smoothly before going live.

Sandbox Checklist (NetSuite)

TIP: Looking for a self-serve installation experience? Check out our guides, starting

at Step 1 here: Step 1: Invitation Email



Bring a NetSuite Administrator

The installation process requires a NetSuite Administrator (or someone with sufficient

permissions) to be present. The below is what we require this user to have access to:

Install plugin

Create access tokens

Configure features for the NetSuite company

Define permissions on scripts

Manage users/roles

If no attendees have permissions to do the above, the call may be rescheduled.

Review Multiple Currencies Setup

The plugin is built with multi-currency to support growing businesses that scale beyond

single-currency operations. In NetSuite, it is mandatory to enable the Multiple Currencies

feature. Attempting to use the plugin without this feature enabled will result in a SuiteScript

error on every page.

You can verify your Multiple Currencies setup by navigating to Setup → Company →

Enable Features. 

The Multiple Currencies feature can be found within the Company tab.

Note Your NetSuite Edition

NetSuite offers OneWorld and non-OneWorld editions. Please check if Subsidiaries are

present in your NetSuite environment. If Subsidiaries are present, you are subscribed to a

OneWorld edition.

Book Transfers and other features in your bank plugin may be incompatible with non-

OneWorld editions of NetSuite, as they require Subsidiaries to be enabled.



Confirm Sandbox Testing

If you use the Accounts Payable product, custom workflows, scripts, or any third-party

applications or plugins, we recommend testing in a NetSuite Sandbox environment before

moving to Production. This essential step ensures a smoother transition onto the plugin

and helps prevent disruption to your service.

Note Any Custom Workflows or Scripts

The plugin works best in NetSuite environments that do not have any customized

workflows or scripts that block or alter standard Accounts Payable workflows, such as bill

payment creation or the vendor record. Common examples include approval workflows. 

Please check with your 

 for what payment

approval steps are available to you.

bank representative or with a member of our onboarding or support team

Prior to installing to Production, it is recommended that you test the plugin thoroughly in a

NetSuite Sandbox environment that contains custom workflows or scripts that pertain to

Accounts Payable.

Note Any Third-Party Plugins or Applications

Other third-party plugins, applications, or integrations within NetSuite may not work

perfectly with your new bank plugin. 

Prior to installing to Production, it is recommended that you test the plugin thoroughly in a

NetSuite Sandbox environment containing relevant third-party applications to avoid any

future disruption to service.

Note Where Banking Details Are Stored

NOTE: If you are not an Accounts Payable user, please skip this step.



Make a note of where your payee's bank details are currently stored. Our supplementary

Entity Bank Details currently allows users to migrate data from NetSuite's Electronic Bank

Payments bundle, while also providing import templates for banking data that may be

stored elsewhere.

We strongly recommend using our Entity Bank Details for greater support of additional

payment types and for a smoother user experience.

Review Limitations

The NetSuite bank plugin and the supplementary Entity Bank Details are currently not able

to support the following:

Environments without NetSuite's Multiple Currencies feature enabled

Non-OneWorld NetSuite editions (no Subsidiaries)

Partial Payments

Automated writing of Balance or Transaction data directly into the NetSuite

reconciliation module(s)

Handling of payroll or employee commissions

User-specific approvals within NetSuite for payments submitted through the bank

plugin

Read from the payee bank data stored outside of our supplementary Entity Bank

Details

Conduct saved searches or run reports on bank information stored in the Entity Bank

Details

Have the Invitation Email Handy

You should have received an invitation email from your bank with links to install the Plugin

in NetSuite. Ensure that at least one person attending the call has access to this email,

whether they were the original recipient, or it was forwarded to them.



Have Your NetSuite Account ID Handy

This can be found by navigating to Setup → Company → Company Information. 

Within the Company Information page, you can find your Account ID. Copy this Account ID

somewhere and save it, as we will need this information during the installation process.

Confirm Hardware & Software Requirements

Browser support (minimum versions):

Chrome: 65

Firefox: 66

Safari: 12

Edge: 79

Operating systems (minimum versions):

Windows 7

macOS - El Capitan

Minimum screen resolution:

1200x800px

Configure NetSuite Features

While not a mandatory step, configuring your company’s NetSuite features ahead of time

will speed up the onboarding process significantly. 

Please follow the steps below to enable the required features.

1 Navigate to Enable Features

In NetSuite, go to Setup → Company → Enable Features.



2

Go to Enable Features

Enable Multiple Currencies

Under the Company tab, select Multiple Currencies.

Select Multiple Currencies



3

4

Enable Expense Reports

Under the Employees tab, enable Expense Reports (This is required for Apply Bill

Credits functionality).

Enable Expense Reports

Enable SuiteCloud 

Under the SuiteCloud tab, select the following items:

Custom Records

Client SuiteScript

Server SuiteScript

Token-Based Authentication

REST Web Services

Click Save.



5

Enable Sub Items

Set Up Accounting Preferences

Go to Setup → Accounting → Accounting Preferences.

Navigate to Accounting Preferences



6 Enable Account Numbers

Under the General tab, select the Use Account Numbers checkbox.

Enable "Use Account Numbers"

Click Save.



2.1.2. Installation

2.1.2.1. Step 1: Invitation Email

You should have received an invitation email from  with links to install

the  and easy-to-follow instructions for installation.

First Citizens Bank

First Citizens Link

The invitation email will arrive with the following subject line:

Welcome to   - Powered by FISPAN [Production] - [your-name]First Citizens Link

Invitation Email





2.1.2.2. Step 2: Register & Login

Register & Login

1

2

Create an Account

In your invitation email, select the Get Started button. You will be brought to the 

. Create your login credentials and select Create Account.FISPAN Portal

Passwords are required to be 8 characters and contain at least one uppercase,

lowercase, number and special character

Login to Your Account

Once registered, you will be redirected to the login page. Your username and

password are unique per environment, and you will have separate logins between 

 and .Sandbox Production

NOTE: The password you create here will be used every time you want to

access the . If you need to update it later on, you have the option

to use the Forgot Password option.

FISPAN Portal

https://sandbox.fispan.cloud/login
https://sys.fispan.live/login


The welcome page for Sandbox

From the welcome page, you'll be taken to the login page. Enter your username and

password to proceed. 

Setting Up SMS MFA

The first time you log in to the Production environment, you will be prompted to establish

your Multi-factor Authentication (MFA) setup. You have the option to select various

methods of MFA. 

NOTE: The Sandbox environment is used as a testing or UAT environment. For

Sandbox users, please refer to the Sandbox Checklist for test scenarios.

NOTE: Multi-factor Authentication (MFA) is only required if you are a user in the

Production environment. If accessing the Sandbox environment, you may skip this

step.



1

2

3

Enroll Phone Number

Select your country code then enter your phone number, you will receive a text

message with a 6-digit code via SMS to the phone number you provided for

enrollment.

If you are unable to receive a text message to this number, or you prefer a different

multi-factor authentication method, click Try Another Method. 

Enter Code

Enter the 6-digit code you received in the applicable field.

Select Continue.

6-digit Verification

Save Recovery Code

After setting up SMS and inputting the first one-time code, you will be presented with

a recovery code that should be stored in a safe location. This code is for resetting the

MFA, to switch the MFA type (i.e., Authenticator), or to use a different phone number. 



Recovery Code

If you would like to utilize another method for MFA (SMS, Authenticator, or Email)

instructions are available here: Setting Up Multi-Factor Authentication (NetSuite)



2.1.2.3. Step 3: Select ERP

Select Install under the NetSuite ERP box and the installation wizard will appear on your

screen. 

Select Install

The first page of the installation wizard contains a brief summary, along with prompts to

review and complete the pre-onboarding checklist.

Once you have finished the pre-onboarding checklist, use the I have completed the pre-

onboarding checklist toggle to unlock the Get Started button.

Click Get Started.



Select "Get Started" on the Welcome to the plugin Installation wizard



2.1.2.4. Step 4: Permissions

To establish a connection between your bank and NetSuite, you must agree and grant

access by clicking the toggle. Once completed, click Next.

The plugin requires this NetSuite financial data to display account balances and transaction

information. The plugin will only write to custom fields introduced by the plugin.

Review the Permissions and then click the "I agree" toggle

NOTE: Your permission list, found in your ERP, may contain more or less fields than

the example shown above.



2.1.2.5. Step 5: Let NetSuite Talk to Your Bank

About NetSuite Account ID

Your NetSuite Account ID is required to connect  to your NetSuite

environment.

First Citizens Link

If you have already shared your NetSuite Account ID with your bank representative during

the onboarding setup, you will see this field pre-populated in the installation wizard.

Register Your Account ID

If the Account ID is pre-populated:

1

2

3

Review the pre-filled Account ID to ensure it matches your NetSuite environment.

If correct, continue to Next Step.

Already Pre-Filled

If incorrect, update the Account ID field with the correct value, then click Register

System.



Update & Register

If the Account ID field is empty:

1

2

3

Locate your Account ID in NetSuite (see instructions below).

Enter the Account ID in the field.

Click Register System.



Click Register System

Locate Your Account ID in NetSuite

1

2

3

In NetSuite, navigate to Setup → Company → Company Information.

Locate your Account ID within the Company Information page.

Copy the Account ID.

Troubleshooting Registration Issues

If registration fails:

1

2

Verify that you have entered the Account ID correctly.

Ensure there are no extra spaces or characters.

IMPORTANT: NetSuite Account IDs on Sandbox environments will end with

_SB#(e.g., _SB1, _SB2). If you are a Production user, please ensure you are

copying the Account ID from your Production environment, not a Sandbox

environment.



3

4

Confirm you are using the Account ID from the correct environment (Production vs.

Sandbox).

Click Retry.

If the issue persists after verifying the Account ID, please contact Support for further

assistance.



2.1.2.6. Step 6: Install Bank SuiteApp

From NetSuite, start by navigating to Customization → SuiteCloud Development →

SuiteApp Marketplace

SuiteApp Marketplace

1

2

Search for the SuiteApp

To search for the SuiteApp, type ” " in the Keywords box and

select Search. 

First Citizens Link

Install the SuiteApp

Click on the SuiteApp. Select Install to review the SuiteApp, then select Install again

to confirm. 



Install SuiteApp

Once the SuiteApp has been installed, the tab will appear on your

NetSuite menu.

First Citizens Link

Then, head back to the wizard and select Next Step. 

Note: If you will be using Payables, you will also need to install and configure the 

Entity Bank Details bundle ID 323878. Refer to this link to install the bundle.

Entity Bank Details Installation & Setup (NetSuite)

Or you can wait to install and configure the Entity Bank Details bundle later as

described in:

Step 13: Install Entity Bank Details Bundle



2.1.2.7. Step 7: Configure NetSuite Features

Please follow the steps below to enable the required features.

1

2

Navigate to Enable Features

In NetSuite, go to Setup → Company → Enable Features.

Go to Enable Features

Enable Multiple Currencies

Under the Company tab, select Multiple Currencies.



3

Select Multiple Currencies

Enable Expense Reports

Under the Employees tab, enable Expense Reports (This is required for Apply Bill

Credits functionality).

Enable Expense Reports



4

5

Enable SuiteCloud 

Under the SuiteCloud tab, select the following items:

Custom Records

Client SuiteScript

Server SuiteScript

Token-Based Authentication

REST Web Services

Click Save.

Enable Sub Items

Set Up Accounting Preferences

Go to Setup → Accounting → Accounting Preferences.



6

Navigate to Accounting Preferences

Enable Account Numbers

Under the General tab, select the Use Account Numbers checkbox.

Enable "Use Account Numbers"

Click Save.





2.1.2.8. Step 8: Create a New Security Token

An access token from NetSuite is needed to proceed with the installation. Follow these

steps to create a new security token in NetSuite and add it to the installation wizard.

Create a New Security Token

1

2

Navigate to Manage Access Tokens

In NetSuite, navigate to the homepage.

Find Settings and select Manage Access Tokens. 

Select Manage Access Tokens on Settings

Where the Settings are located differs depending on how you have arranged content

on your homepage. By default, it is found on the bottom left of the page.

Add New My Access Token

On the My Access Tokens page, select the New My Access Token button.



Access Tokens

On the Access Tokens page, the application must be defined using the Application

Name dropdown. The application for your bank plugin was created automatically

when the plugin was installed.

Use Application Name Drop-down



Select New My Access Token, then select Integration in the Application

Name box and click Save. Once you click Save, the loaded page will show a Token Key

and a Token Secret. Copy and paste the Token ID and Token Secret to the appropriate box

in the wizard.

First Citizens Link

Once complete, select Next Step in the Wizard.

Save Access Token



IMPORTANT: The access token created during this step is tied to the NetSuite

Administrator who generated it. If this user's Administrator credentials are ever

revoked (i.e. either by losing administrator access or leaving the company), the token

will become VOID, and the plugin will stop working.

To avoid any service disruption, you must create a new token:

1. Log in to https://sys.fispan.live/

2. Deactivate the existing NetSuite connection.

3. Reactivate the connection and go through the installation wizard again.

This will generate a new access token that will replace the voided Token ID and

Token Secret.

If you encounter any issues with this process or if you do not have a login for the link

provided above, please reach out to  for assistance.FISPAN Support

IMPORTANT: To ensure your bank plugin is set up correctly, you need to understand

the minimum required permissions and user roles. Following the recommended

method for managing access tokens is crucial to preventing service disruptions.

Please refer to for the full list of required

permissions and step-by-step guidance.

Minimum Permissions (NetSuite)

https://sys.fispan.live/


2.1.2.9. Step 9: Connection Status

After entering the Token ID and Token Secret in the last step, the installation wizard will

begin to run a connection check to validate all details entered in the previous steps.

If there are no issues, a large green checkmark will appear to confirm that the connection

has been established. Click on Next Step to begin matching bank accounts.

Successful Connection Message

Failed Connection Checks

If the connection check fails, a large red X icon will appear. A list of possible reasons for

failure will appear, such as:

Validation errors from the data you entered in the previous steps

Incorrectly configured NetSuite features

The plugin is not being properly installed in NetSuite



Failed Connection Check

After reviewing and making changes in NetSuite, click Retry to rerun the Connection

Check.

Otherwise, you can click Previous Step to go back and reenter any potentially incorrect

data. Continuing to the next step in the installation wizard will also retrigger the check.

When the check is successful, click Next Step.



2.1.2.10. Step 10: Account Matching

Each ERP account should have a matching bank account. Only the matched accounts will

be used in your plugin. 

Follow these steps to learn how to match your ERP accounts with the corresponding bank

accounts.

Account Matching Setup

Match your ERP Accounts with the corresponding Bank Accounts by dragging an ERP

Account from the left and dropping it onto the desired Bank Account. 

Once you've successfully matched your accounts, click Next Step.

IMPORTANT: The Use Account Numbers preference must be enabled in NetSuite to

match your bank accounts.

To do this:

In NetSuite, go to Setup -> Accounting -> Accounting Preferences.

On the General Ledger tab, check the box next to Use Account Numbers.

After enabling this, click the X in the error banner on this page to reload your

accounts.

If you receive an error during account matching after the feature is enabled, please

contact support for further assistance.

NOTE: When installing the plugin in Sandbox, bank accounts are for testing only.

They are not connected to your live bank accounts. When installing in Production, the

listed bank accounts reflect your actual accounts.



Account Matching Step

For virtual card payments (if applicable), you will need to map the bank account to a Credit

Card type NetSuite account, not a NetSuite bank account.

Account Matching Error Troubleshooting

IMPORTANT: It might take a few moments for your accounts to appear, depending on

the number of accounts you have and how quickly NetSuite is processing them.

Please do not refresh or leave the page until everything has loaded.

NOTE: If you would like to add new accounts or functionalities after your initial

installation and set-up, please submit a request to your bank representative.

TIP: Would you like to set a default account for Account Payables? Let us know which

account you'd like by contacting . Please specify the last 4 digits of

the bank account number in your request. Each company can have only one default

source account across all subsidiaries. 

FISPAN Support



NetSuite will load your ERP accounts from the Chart of Accounts. Depending on the

number of accounts you have or your device's security settings, you might see the

following error:

"There was an error loading the bank accounts: Close this to retry!"

If this error appears, click the X to retry loading the accounts.

If you see the error again, click Next Step and finish the rest of the installation wizard.

If you are still unable to load the accounts, our support team can manually map them for

you. To do this, please provide us with the Internal ID from NetSuite.

Provide NetSuite Internal ID 

1 Search Accounts

In NetSuite, go to Lists → Accounting → Accounts → Search

Go to Search

Select Use Advanced Search.
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Select Use Advanced Search

Under the Criteria tab, in the filter box, select Type and choose Bank (and/or Credit

Card if matching for SUA payments). Then select Set.

Select Bank and Credit Card from Type Drop-down

Filter Results with Internal ID
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Under the Results tab, remove all but the Name, Account Type,

and Description fields, then add the field Internal ID.

Add Internal ID

Once complete, select Submit.

Download XLS Format

On the Account Search: Results page, please select the Microsoft Excel icon to

download this list in an XLS format.



Download XLS

Once the download is complete, please open the XLS file and add a column with the

last 4 digits of the Account the Internal ID should be mapped to. 

Save this XLS file, and you can contact  to help you troubleshoot. FISPAN Support

fcb.support@fispan.com

mailto:fcb.support@fispan.com


2.1.2.11. Step 11: Plugin Access Management

NetSuite Script Deployments

The Administrator has full access to view all plugin pages. In order to allow access to other

users and departments, follow these steps:

Select Customization → Scripting → Script Deployments. Use the following filters:

On the Type dropdown select Suitelet

On the API Version dropdown select 2.1.

Go to Script Deployments

Each of the Suitelets listed corresponds to a subtab under the  tab. Click

Edit on each of the following script deployment Suitelets you wish to edit:

First Citizens Bank

Payments HistoryFirst Citizens Bank

 Pay Vendor BillsFirst Citizens Bank

 Payment ApprovalsFirst Citizens Bank



 Balances & TransactionsFirst Citizens Bank

 Transaction Feed Config 

(Connectivity Method field used in Bank Feeds setup)

First Citizens Bank

 Trans Checks HistoryFirst Citizens Bank

 Trans ChecksFirst Citizens Bank

 User CustomizationFirst Citizens Bank

Add employee roles by selecting the appropriate, employee, department and role you

would like to assign. Then, click Save.

List of Script Deployment scripts

Note: If you are using Payables, and adding new users, make sure they have suitable

permissions to access the Entity Bank Details tab and information.

If this is the intial installation and you have already installed the Entity Bank Details

bundle or if you are adding new users, refer to the following link to edit the role

permissions for the associated Entity Bank Details Suitelet, RESTlet and User Event

script deployments:

Entity Bank Details Installation & Setup (NetSuite)





2.1.2.12.
Step 12: NetSuite Role Permission
Setup

If you receive an "INSUFFICIENT_PERMISSION" error or can't see all the accounts, it's

because your NetSuite user role does not have the correct permissions. You'll need to

update your permissions following these steps.

Update Role Permissions

The Administrator has full access to the plugin features. To set permissions for user roles,

follow these steps.

1 Go to Manage Roles

Go to Setup → Users/Roles → Manage Roles.

Go to Manage Roles

On the Manage Roles page, click Edit beside the role of choice.



2 Add List Permissions 

After selecting Edit, go to Permissions → List. 

Click the dropdown in the last row of the Permissions table. 

"Lists" Permissions

Scroll through the list, or begin typing to find and select the following permissions: 

Accounts (Level: View): Required to access the chart of accounts to fulfill the

payment request.

Currency (Level: View): Required to load the table of open bills on the Bill

Payments page.

Customers (Level: View): Required to load the Positive Pay page of the plugin.

Documents and Files (Level: View): Required to access plugin pages and

scripts to run and display the plugin. 

Vendors (Level: View): Required to load vendor bills on the plugin pay page. 

Employee Record (Level: View): Required to view transactions on the Bill

History page and to load employee expense reports on the Expense Reports

page.
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Subsidiaries (Level: View): Required to add and view subsidiaries as a column

option when customizing the Pay Vendor Bills page. 

Add Setup Permissions

Next, click Permissions → Setup. 

Click the dropdown in the last row of the Permissions table. 

"Setup" Permissions

Scroll through the list, or begin typing to find and select the following permissions:

Accounting Lists (Level: View): Required to be able to use the Pay Bills page. 

Custom Fields (Level: View): Required to pull in custom fields from the Bill

record, which are then used for customizable columns on the Pay Vendor Bills

page. This is necessary for the Pay Vendor Bills page to load if a user has any

customizations.

Custom Lists (Level: Full): Required to load the available payment methods from

your bank on the Pay page. 

SuiteScript (Level: View): Required to check if there are currently payments

being processed. 



SuiteScript Scheduling (Level: Full): Required to schedule payments for

processing.

Select Save.

Note: If you are using Payables, you will also need to install and configure the Entity

Bank Details bundle and set the NetSuite permissions required to allow selected

roles to view and interact with the Entity Bank Details tab.

If you are adding new users, make sure they have suitable permissions to access the

Entity Bank Details tab and information.

If you have already installed the Entity Bank Details bundle and assigned the role

permissions enabling the associated Entity Bank Details Suitelet, RESTlet and User

Event script deployments, refer to the following link to grant role based access to the 

Entity Bank Details tab.

Step 13: Install Entity Bank Details Bundle



2.1.2.13.
Step 13: Install Entity Bank Details
Bundle

The Entity Bank Details (EBD) bundle, combined with the standard NetSuite vendor and

employee records, will store all the information needed to submit payments.

You can add or view this vendor payment information after installation by going to Setup --

> Entity Bank Details -> Overview.

Entity Bank Details (EBD) Installation Instructions

1 Install Entity Bank Details Bundle

From the homepage, go to Customization → SuiteBundler → Search and Install

Bundles.

Go to Search & Install Bundles

NOTE: If you do not have Accounts Payable installed, please skip this step.



Search for Entity Bank Details or by Bundle ID 323878. Select the hyperlinked

bundle name, Entity Bank Details.

Entity Bank Details bundle

Select Install to review the bundle, then select Install again to confirm.

Install Bundle page
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Select OK when the dialog appears and wait for the bundle to install (this may take a

few moments). 

Manage Bundle Access - Suitelets

The administrator has full access to the Entity Bank Details bundle. To allow access

to other users and departments, follow these steps:

Go to Customization → Scripting → Script Deployments.

Go to Script Deployments

On the Script Deployments page, apply the following filters:

In the Type dropdown, select Suitelet

IMPORTANT: If you receive an error stating "You have not been granted access

to the bundle" upon attempting installation, please reach out to 

. 

FISPAN Support

Our team may need to whitelist your NetSuite Account ID before you are able to

install the Entity Bank Details bundle. Your Account ID can be found by

navigating to Setup → Company → Company Information.



In the API Version dropdown, select 2.1

A Suitelet is a custom front-end NetSuite page. Each of the Suitelets listed

corresponds to a page in the Entity Bank Details bundle. 

Select Edit on each of the following Suitelets you wish to edit:

Suitelet Description

Entity Bank

Details,

Overview

Granting users access to this script allows them to view the

Overview page. This permission, along with the Entity Bank

Details, Settings RESTlet, is required to access the Overview

page.

Entity Bank

Details,

Import/Exp

ort

Granting users access to this script will allow them to view the

Import/Export page.

Entity Bank

Details,

History

Granting users access to this script will allow them to view the

History page.

Entity Bank

Details,

Settings

Granting users access to this script will allow them to view the

Settings page to enable and disable approvals.

Entity Bank

Details,

Approvals

Granting users access to this script will allow them to view the

Approvals page to approve record changes.

Add employee roles by selecting the appropriate employee, department, and/or role

you would like to assign. 
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Filter for Suitelets on API Version 2.1

Then, select Save. 

Stay on this page for the next steps.

Manage Bundle Access - RESTlets

On the Script Deployments page, apply the following filters:

In the Type dropdown, select RESTlet.

In the API Version dropdown, select 2.1.

A RESTlet is used to define custom RESTful integrations to NetSuite, and in the

context of the Entity Bank Details bundle, is mainly used for handling the import and

export processes.

Select Edit on each of the following script deployment RESTlets you wish to edit:



RESTlet Description

Entity

Bank

Details,

Import

Service

Granting users access to this script will allow them to import a

CSV of bank account information into the Entity Bank Details

bundle.

Entity

Bank

Details,

Export

Service

Granting users access to this script will allow them to export a

CSV of bank account information from the Entity Bank Details

bundle.

Entity

Bank

Details,

History

Log

Export

Granting users access to this script will allow them to export a

CSV History Log of all changes made to any records stored within

the Entity Bank Details bundle. This history log tracks any edits,

additions, or deletions, as well as who initiated the change and

when.

Entity

Bank

Details,

Settings

This RESTlet should come with pre-enabled access for all roles.

Granting users access to this script will allow them to view the

Overview page. This permission, alongside the Entity Bank

Details, Overview Suitelet, is required to access the Overview

page.

Entity

Bank

Details,

Analytics

This RESTlet should also come with pre-enabled access for all

roles.

Add employee roles by selecting the appropriate employee, department, and/or role

you would like to assign. 
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Select Edit on the the Script Deployment

Then, select Save.

Manage Bundle Access - User Events

On the Script Deployments page, apply the following filters:

On the Type dropdown, select User Event.

On the API Version dropdown, select 2.1.

A User Event is a type of script that is executed when someone performs certain

actions on records, such as create, load, update, copy, delete, or submit.

Select Edit next to the Script Deployment User Event:
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User Event Description

Entity Bank

Details, Event 

(Record Type =

Vendor)

This User Event script allows users/roles to add or update

Vendor Bank Account information.

Entity Bank

Details, Event

(Record Type =

Employee)

This User Event script allows users/roles to add or update

Employee Bank Account information.

Add employee roles by selecting the appropriate employee, department, and/or role

you would like to assign. 

Filtering for User Events on API Version 2.1

Then, select Save.

Manage Bundle Access - Custom Records

Go to Setup → Users/Roles → Manage Roles.

Then, select Edit for the role for which you would like to grant access to the Entity

Bank Details bundle records.



Go to Manage Roles

After selecting Edit, go to the Permissions tab → Custom Record → Locate the

search box in the bottom row. 

NOTE: The owner of the custom record, which defaults to the user who

installed the Entity Bank Details bundle, will always have full access to the

record regardless of the Entity Bank Details permission level assigned to the

role being used.



Search and Select Entity Bank Details

Use the search box to find and set the correct permission level for Entity Bank

Details (FI) (Level: View):

View: Allows a user to view records.

Create: Allows a user to view and create records.

Edit: Allows a user to view, create, and edit records.

Full: Allows a user to view, create, edit, approve, and delete records. This

permission level is required to approve any changes made to vendor or

employee records.

Next, navigate to the Permissions tab → Setup → Locate the search box in the

bottom row. 

Use the search box to find and set the permission: 

Set Up Company (Level: View): Required for the Overview page and is used for

the EBD Settings RESTlet to access the Company Information page.

Within the Permissions tab, select Lists --> Locate the search box in the bottom row. 

Use the search box to find the following permission: 
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Employees (Level: View): Required to approve or view the History page for

employee records.

Then, select Save.

Storing Bank Information

Using the main navigation, go to Setup → Entity Bank Details → Overview.

Select between viewing Vendors or Employees by selecting the tabs above the table.

By default, this page opens up to show Vendors first.

Select View for the desired Vendor or Employee.

Select View for the desired Vendor or Employee

Select Add.



Select Add

Create an optional label and select the appropriate payment method, country, and

currency. Then, fill out the required fields for the specified payment method and

mark the record as Primary. 

Select Save



Then, select Save.

NOTE: The fields that appear on this page are dependent on the method,

country, and currency selected.

WARNING: All vendor and employee bank details, along with all history logs, are

stored within the Entity Bank Details bundle in your NetSuite environment. If this

bundle is uninstalled, all of this data will be permanently deleted.

To prevent data loss, you must export your data before uninstalling. Please use the

Export feature on the Import/Export page to save all your records and history logs.



2.1.2.14.
Step 14: Configure SuiteApps Reports
Balances

To give users access to the Reports Balance Portlet, they will need a Script Deployment.

Once they have access, they can view their balances by accessing the Portlet.

1

2

Access Reports Balance Portlet

Navigate to the Homepage.

Select Personalize in the top right → SuiteApps →  Reports

Balance to view balances.

First Citizens Bank

Add User Roles to Portlet

Non-admin roles need to be added to the  Reports Balance

Portlet. The administrator has full access to view all plugin pages. 

First Citizens Bank

To allow access to other users and departments, select Customization → Scripting →

Script Deployment. 

Use the following filters:



In the Type dropdown, select Portlet

In the API Version dropdown, select 2.1.

Go to Script Deployments

Search for and select Edit on the Reports Balance Portlet.

Select Edit



Add employee roles by selecting the appropriate employee, department, and role you

would like to assign. Then, select Save.



2.1.3. Post-Onboarding Checklist (NetSuite)

You are almost ready to use the plugin. There are a few additional steps that are required in

order to use the product to its full potential. Review all items in this guide to ensure you are

not missing anything.

Grant Permissions

To ensure users can view and utilize the plugin, a NetSuite administrator must grant them

permission. You can follow  and 

 to enable permissions.

Step 11: Plugin Access Management Step 12: NetSuite

Role Permission Setup

Install the Entity Bank Details SuiteApp 

The Entity Bank Details SuiteApp, in combination with the standard NetSuite vendor and

employee record, will store all information required to submit payments via the SuiteApp.

This SuiteApp stores payment details for ACH and other more complex payment methods. 

This is a mandatory install if you wish to make payments through more complex methods

outside of ACH.

You can follow  or 

 for instructions on how to install this bundle.

Entity Bank Details Installation & Setup (NetSuite) Step 13: Install Entity

Bank Details Bundle

Enter Bank Details Into the SuiteApp

NOTE: For Sandbox users, feel free to skip the steps that may not apply to your use

case. We strongly recommend following the .Sandbox Checklist (NetSuite)

NOTE: If you are not an Accounts Payable user, please skip this step.



There are a few ways to enter your vendor or employee bank details into the Entity Bank

Details bundle. They are as follows:

Option 1: Manual Entry 

Refer to Storing Bank Information on  for

instructions on how to manually add Entity Bank Details to a payee.

Step 13: Install Entity Bank Details Bundle

Option 2: Import bank details via CSV template

Refer to for instructions on how to

bulk import bank details using our pre-formatted CSV template.

Entity Bank Details Bundle Import/Export (NetSuite)

If you are a current user of NetSuite’s Electronic Bank Payments bundle, you may migrate

ACH and CHECK information using our Electronic Bank Payments export feature. Refer to

the Transferring Bank Details from Electronic Bank Payments Bundle section of

.

Entity

Bank Details Bundle Import/Export (NetSuite)

Enable Bank Feeds

The plugin adds support for Bank Feeds through a custom Connectivity Method, which

allows transactions from your bank accounts to flow automatically into NetSuite's Match

Bank Data module.

Please follow instructions on  for instructions on how to

set up your bank feeds.

Enabling Bank Feeds (NetSuite)

Set Default Payment Methods

Users are able to set a default payment method for their payees to speed up their day-to-

day payment workflow. 

NOTE: If you are not an Accounts Payable user, please skip this step.

NOTE: For Sandbox users, please skip this step.



Follow the instructions on  for how you

can do this manually on a per-payee basis, or through a mass update via CSV import.

Setting Default Payment Information (NetSuite)

If you do not have a default payment set for a payee, you may choose one at the time of

payment.



2.1.4. Sandbox Checklist (NetSuite)

If you're testing the plugin in a Sandbox environment, it's recommended to test a variety of

scenarios. This will help you confirm that your setup is properly supported and functioning

as expected.

Scenarios to Test

Below is a list of scenarios you may wish to test. Some of these scenarios may not apply to

your plugin depending on the products it supports.

1

2

3

Vendor Setup

Modify or create two vendors for testing: one as a company and one as an individual.

Be sure to include bank details and an address for each.

Expected Outcome: These vendors will be used to test bill payments and positive

pay transmissions.

ACH Bill Setup and Payment

Confirm that each vendor you're testing has a U.S. address and that their ACH

CCD/PPD details are entered.

Create a bill and fill in all mandatory fields. On the Billing tab, verify that the correct

vendor address has been automatically selected.

Expected Outcome: After the payment is successfully sent, the bill should no longer

appear on the Open Bills tab of the Pay Bills screen. If the bill is still there, check the 

Failed Bills tab on the same screen. You can also view the payment status on the 

History screen within the plugin.

Check Bill Setup and Payment

Confirm that a U.S. address has been entered for each vendor you test. 
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5

6

Create a bill, populating all fields that are mandatory. Check the Billing tab to confirm

that the correct vendor address has been selected.

On the Pay Bills page of the plugin, select the bill that was created, select Check (not

required if a default was set), and click Pay.

Expected Outcome: Once the payment is successfully sent, it should disappear from

the Open Bills tab on the Pay Bills screen. If the payment remains on the page, go to

the Failed Bills tab on the same screen. You can also view payment status in the 

History screen of the plugin.

SUA Bill Setup and Payment

Confirm that a US address has been entered for each vendor you test. Create a bill,

populating all fields that are mandatory.

Check the Billing tab to confirm that the correct vendor address has been selected.

On the Pay Bills page of the plugin, select the bill that was created, select SUA (not

required if a default was set), and click Pay.

Expected Outcome: Once the payment is successfully sent, it should disappear from

the Open Bills tab on the Pay Bills screen. If the payment remains on the page, go to

the Failed Bills tab on the same screen. You can also view payment status in the 

History screen of the plugin.

Credit Memo Setup and Payment

NetSuite allows bill credits to be applied to a bill. To do this, go to Bill Credits -> New

Transaction -> input all asterisked fields under the Expenses tab. Go to the Apply

tab and select the bill that the credit should be applied to.

On the Pay Bills page, the remaining amount (the balance after applying credits)

should appear under the Amount Due column. Pay this bill using any payment

method.

Expected Outcome: The confirmation screen should show the credited amount.

Failed Bills

All bills will automatically show as successful after clicking Pay unless there is a

customized NetSuite workflow applied.



To test the process for a failed bill, create a bill for $1991.00. Pay this bill on the Pay

Bills screen.

Expected Outcome: The bill should automatically fail and remain on the Open Bills

page. An error message should also appear on the Failed Bills screen. 



2.2.Configuration

2.2.1.Plugin Management

2.2.1.1. Mapping Bank Accounts (NetSuite)

Navigating to the Account Matching Page

Once you’ve completed the plugin installation and setup, you’ll need to map any new

accounts that are added to the plugin. If you’re setting up the plugin for the first time, you

will have completed this during Step 11: Plugin Access Management.

1 Log in to the FISPAN Portal

Head to the   you used to register for an account with  when

you installed the plugin.

Production Portal FISPAN

NOTE: Setting up in Sandbox? Use this alternative link instead: Sandbox Portal

https://sys.fispan.live/login
https://sandbox.fispan.cloud/
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Welcome Page

Log in to the Portal with the email and password you used to register. Multi-Factor

Authentication (MFA) will be required for login.

FISPAN Login

Navigate to Associate Accounts



Select the three dots in the top right corner of your ERP module and select Associate

Accounts.

Select Associate Accounts

Each ERP account should have a matching bank account. Only the matched accounts will

be used in your plugin. 

Follow these steps to learn how to match your ERP accounts with the corresponding bank

accounts.



Account Matching Setup

Match your ERP Accounts with the corresponding Bank Accounts by dragging an ERP

Account from the left and dropping it onto the desired Bank Account. 

Once you've successfully matched your accounts, click Next Step.

IMPORTANT: The Use Account Numbers preference must be enabled in NetSuite to

match your bank accounts.

To do this:

In NetSuite, go to Setup -> Accounting -> Accounting Preferences.

On the General Ledger tab, check the box next to Use Account Numbers.

After enabling this, click the X in the error banner on this page to reload your

accounts.

If you receive an error during account matching after the feature is enabled, please

contact support for further assistance.

NOTE: When installing the plugin in Sandbox, bank accounts are for testing only.

They are not connected to your live bank accounts. When installing in Production, the

listed bank accounts reflect your actual accounts.



Account Matching Step

For virtual card payments (if applicable), you will need to map the bank account to a Credit

Card type NetSuite account, not a NetSuite bank account.

Account Matching Error Troubleshooting

IMPORTANT: It might take a few moments for your accounts to appear, depending on

the number of accounts you have and how quickly NetSuite is processing them.

Please do not refresh or leave the page until everything has loaded.

NOTE: If you would like to add new accounts or functionalities after your initial

installation and set-up, please submit a request to your bank representative.

TIP: Would you like to set a default account for Account Payables? Let us know which

account you'd like by contacting . Please specify the last 4 digits of

the bank account number in your request. Each company can have only one default

source account across all subsidiaries. 

FISPAN Support



NetSuite will load your ERP accounts from the Chart of Accounts. Depending on the

number of accounts you have or your device's security settings, you might see the

following error:

"There was an error loading the bank accounts: Close this to retry!"

If this error appears, click the X to retry loading the accounts.

If you see the error again, click Next Step and finish the rest of the installation wizard.

If you are still unable to load the accounts, our support team can manually map them for

you. To do this, please provide us with the Internal ID from NetSuite.

Provide NetSuite Internal ID 

1 Search Accounts

In NetSuite, go to Lists → Accounting → Accounts → Search

Go to Search

Select Use Advanced Search.



2

Select Use Advanced Search

Under the Criteria tab, in the filter box, select Type and choose Bank (and/or Credit

Card if matching for SUA payments). Then select Set.

Select Bank and Credit Card from Type Drop-down

Filter Results with Internal ID
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Under the Results tab, remove all but the Name, Account Type,

and Description fields, then add the field Internal ID.

Add Internal ID

Once complete, select Submit.

Download XLS Format

On the Account Search: Results page, please select the Microsoft Excel icon to

download this list in an XLS format.



Download XLS

Once the download is complete, please open the XLS file and add a column with the

last 4 digits of the Account the Internal ID should be mapped to. 

Save this XLS file, and you can contact  to help you troubleshoot. FISPAN Support

Once you’ve added this information, please email this updated XLS file to the below

FISPAN Support email address: firstcitizens.support@fispan.com

The FISPAN Support Team will then map the accounts on your behalf and will follow-

up by email once complete.

mailto:firstcitizens.support@fispan.com


2.2.1.2. Updating the SuiteApp (NetSuite)

Keeping your NetSuite Bundle up to date with the latest version is crucial for ensuring you

have access to all the newest features, important bug fixes, and updates. To update your

bundle, please follow these steps.

To read more about the latest release, navigate to: Release Notes (NetSuite)

Locate the SuiteApp

Go to Customization → SuiteCloud Development → Installed SuiteApp List.

Go to Customization -> SuiteCloud Development -> Installed SuiteApp List

Update the SuiteApp

Find the   SuiteApp from the list. Then, hover over the green icon and

select Update.﻿

First Citizens Bank



Select OK on the confirmation pop-up.﻿

The SuiteApp will take a few moments to update – it will appear as Pending and then show

the progress of the update. Once complete, the status column on the Installed SuiteApp

page will show a checkmark.

Update Installed SuiteApp



2.2.1.3.
Enabling French Canadian Support
(NetSuite)

To use the plugin in French Canadian, you must first enable the French language within

your NetSuite's features. Follow the guide below for instructions on how to complete the

setup process.

Enabling French Canadian 

1

2

Navigate to Enable Features

A NetSuite Administrator must navigate to Setup --> Company --> Enable Features.

Select Enable Features

Enable Multilanguage

NOTE: This feature is in open beta, and we are open to any feedback or suggestions

about this new language option. Please send any feedback to translation-

feedback@fispan.com
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Scroll down to the International tab and ensure the Multilanguage checkbox is

checked off. 

Check Off Multilanguage

Navigate to Set Preferences 

Navigate back to the dashboard by clicking the Home button. 

Scroll down to the Settings sub-section and select Set Preferences. 
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Select Set Preferences

Select French (CA) Language

Under the localization sub-section, select your language as French (CA).

Select French (CA)



After clicking Save, your environment and plugin will be displayed in French

Canadian.

Unsupported Elements

Due to some limitations, a few elements of the plugin will remain in English:

Bank Feeds & Transactions

Banking, ERP, and Platform Error Messages (e.g., payment statuses, connection

errors)

Vendors, Bills, and Bank Accounts (these will display in the language they were

originally created in)



2.2.1.4. Uninstalling the Plugin (NetSuite)

To uninstall the plugin from your NetSuite ERP, follow these steps.

1

2

Deactivate the Plugin

Select the three dots in the top right corner and then select Deactivate to disconnect

your plugin from NetSuite through the .Portal

Select "Deactivate"

Search Installed SuiteApp

In NetSuite, go to Customization → SuiteCloud Development → Installed SuiteApp

List

https://sys.fispan.live/
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Installed SuiteApp List

Located Installed SuiteApp

Select the green dropdown button and select Uninstall to uninstall the 

 SuiteApp. Then, select OK on the pop-up to confirm.My Bank SuiteApp

Click Uninstall



4 Finalize Uninstalling the SuiteApp

NetSuite will begin uninstalling the SuiteApp. Once uninstalled, it will no longer

appear on the page and menu bar. 

You've successfully disconnected your NetSuite environment and completely

removed the plugin.



2.2.1.5. Managing Security Tokens (NetSuite)

The Access Token is essential for pushing payment status messages (processing,

successful, or failed) back into NetSuite. This token is created during the initial installation

wizard and is linked to the NetSuite administrator who performed the setup.

If the original NetSuite administrator leaves the company or has their account or privileges

revoked, the associated Access Token immediately becomes VOID. When this happens,

you will lose all automatic payment status updates from the payment plugin, which can

lead to confusion and operational issues.

This guide provides the steps to generate a new Access Token to replace the voided one,

ensuring that payment statuses flow correctly back into your NetSuite environment.

If you run into trouble, you can schedule a troubleshooting call or reach out to our support

team using the Contact Us link in the library on the left.

Reactivate the NetSuite Connection

1 Log in to FISPAN Portal

Log in to  using one of these links:FISPAN Portal

Production: https://sys.fispan.live/login

Sandbox: https://sandbox.fispan.cloud/login

https://sys.fispan.live/login
https://sandbox.fispan.cloud/login
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Portal Login Page

If you do not have a login, please contact HSBC Support. We will issue you an

invitation to enable you to configure the NetSuite connection. 

Deactivate the NetSuite Connection

Upon successful login, you should see a welcome message and NetSuite under the

Connected Apps section.



NetSuite message box with Icons listing the Connected Apps

Click on the three dots on the top right corner of the NetSuite box to open a small

submenu, and then click on Deactivate.

Click "Deactivate" on NetSuite
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After clicking Deactivate, a pop-up will appear onscreen prompting you to confirm

the action. Click Yes, Uninstall App to proceed.

Click "Yes, Uninstall App"

After clicking Yes, Uninstall App, NetSuite will disappear from the Connected Apps

section of the page and appear in the Discover More section. 

Reactivate the NetSuite Connection

Hover your cursor over the NetSuite box and click on the Install button.
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NetSuite message box with Icons listing connected apps and others grouped under

Discover More

Click "Install"

Proceed through the Installation Wizard steps

After clicking Install, you will be taken to the installation wizard.



Welcome to the plugin installation wizard!

The installation wizard has retained all information from the last time the setup was

completed. As a result, you may skip to the Creating a New Security Token step by

clicking the Next Step button.

Create a New Security Token

On the Creating a New Security Token step, the old Token ID and Token Secret created by

the last NetSuite Administrator have been retained. These two fields must be replaced as

they have become void.



"Creating a New Security Token" page

Create a New Security Token

1 Navigate to Manage Access Tokens

In NetSuite, navigate to the homepage.

Find Settings and select Manage Access Tokens. 
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Select Manage Access Tokens on Settings

Where the Settings are located differs depending on how you have arranged content

on your homepage. By default, it is found on the bottom left of the page.

Add New My Access Token

On the My Access Tokens page, select the New My Access Token button.



Access Tokens

On the Access Tokens page, the application must be defined using the Application

Name dropdown. The application for your bank plugin was created automatically

when the plugin was installed.

Use Application Name Drop-down



Select New My Access Token, then select Vantage Connect Integration in the Application

Name box and click Save. Once you click Save, the loaded page will show a Token Key

and a Token Secret. Copy and paste the Token ID and Token Secret to the appropriate box

in the wizard.

Once complete, select Next Step in the Wizard.

Save Access Token

Verify the Connection Status

The next step in the installation is a Connection Status check. If the Token ID and Token

Secret entered in the installation wizard are correct, the status will show a green

checkmark icon and a success message indicating the connection is now active.



Green circle with white check mark

Click Next Step to complete the remainder of the installation wizard.

Save and Finish the Installation Wizard

The next page is the Account Matching page. All matching has remained unchanged since

the last time a NetSuite Administrator or someone from your organization has edited it. You

can make any changes, if required.



Account Matching Step

Click Save and Finish to save all changes made in this installation wizard and to exit.

Your security tokens have now been updated.



2.2.2.User Management



2.2.2.1.
Setting Up Multi-Factor Authentication
(NetSuite)

Multi-Factor Authentication (MFA) Overview

Multi-factor authentication (MFA) adds another level of security for all users when using

the  to . With MFA, your data is protected against account breaches and

is accessed by authorized users.

FISPAN Portal login

When registering, all new users must set up Multi-Factor Authentication (MFA) by choosing

an authentication method (the default option will be shown first).

If you prefer a different method, select Try Another Method to choose one of the following

options:

SMS (preferred)

Authenticator (or similar)

Email

NOTE: MFA does not apply to the Sandbox environment.

https://sys.fispan.live/login


Authentication Methods

Setting Up SMS MFA

The first time you log in to the Production environment, you will be prompted to establish

your Multi-factor Authentication (MFA) setup. You have the option to select various

methods of MFA. 

1 Enroll Phone Number

Select your country code then enter your phone number, you will receive a text

message with a 6-digit code via SMS to the phone number you provided for

enrollment.

If you are unable to receive a text message to this number, or you prefer a different

multi-factor authentication method, click Try Another Method. 

NOTE: Multi-factor Authentication (MFA) is only required if you are a user in the

Production environment. If accessing the Sandbox environment, you may skip this

step.
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3

Enter Code

Enter the 6-digit code you received in the applicable field.

Select Continue.

6-digit Verification

Save Recovery Code

After setting up SMS and inputting the first one-time code, you will be presented with

a recovery code that should be stored in a safe location. This code is for resetting the

MFA, to switch the MFA type (i.e., Authenticator), or to use a different phone number. 



Recovery Code

Setting Up Authenticator MFA

If you would like to use an authenticator application for MFA, follow these steps.

1

2

Set Up Authentication App

Download and install a compatible app, such as Auth0 Guardian App ( , )

or , on your mobile device and complete setup.

iOS Android

Google Authenticator

Verify Your Identity

Go into the Auth0 or Google Authenticator app to view your temporary verification

code. 

Enter the code from the app into the field on your screen and select Continue.

https://apps.apple.com/us/app/auth0-guardian/id1093447833
https://play.google.com/store/apps/details?id=com.auth0.guardian
https://support.google.com/accounts/answer/1066447?hl=en&co=GENIE.Platform%3DAndroid


Authenticator

Setting Up Email MFA

Follow these steps to set up Email MFA and verify your identity. 

1

2

3

Enter Email

Add the email address where you would like to receive your authentication code.

Check Inbox

Navigate to your email inbox to retrieve the 6-digit verification code sent to you.

Verify Your Identity

Return to this screen, enter the code, and select Continue.



Email Authentication



2.2.2.2. Minimum Permissions (NetSuite)

To use the plugin, you'll need to set up two types of users: a Web Service User and an A/P

and/or Accounting User.

Web Service User

This is a generic role designed for accessing and interacting with web services, including

your bank plugin in NetSuite. It requires assigning the Bank Integration Web Service Role,

to which access tokens are attached for both the Web Service User and the role itself.

While some users choose to assign the Bank Integration Web Service Role directly to a

specific person, this creates a risk: if that user loses their NetSuite access or leaves the

company, the access tokens will become void. To avoid this, we recommend creating a

dedicated Web Services User and assigning the Bank Integration Web Service Role and

tokens to them. This significantly reduces the risk of service disruption.

A/P and/or Accounting User Role

This is the role for users who will be performing various plugin functions, such as Vendor

Payments, Positive Pay, Cash Management, and Book Transfers.

Configure User Role

To configure the appropriate role, navigate to Setup -> Users/Roles -> Manage Roles.

Then, click Edit for the existing role you would like to set up, or click New Role to create a

new one.

See the section below for the minimum permissions required for each role. 

Bank Integration Web Service Role



Permission

Sub-tab

Permission Level Detail

Transactions Find Transaction View (or

higher)

Required to void erroneous payments

Transactions Make Journal

Entry

Create (or

higher)

Required to void erroneous payments

Transactions Pay Bills View (or

higher)

Required to void erroneous payments

Lists Accounts View (or

higher)

Required to load accounts in the

installation wizard for matching

Lists Documents and

Files

View (or

higher)

Required to access plugin pages

Setup Access Token

Management

Full Required to create and manage access

tokens

Setup Log in Using

Access Tokens

Full Required to generate an Access Token

Setup SuiteScript View (or

higher)

Required to access custom scripts

Setup SuiteScript

Scheduling

Full Required to schedule payments



2.2.3.Vendor Management

2.2.3.1.
Storing Vendor Payment Information
(NetSuite)

Our bank plugin works best when paired with the Entity Bank Details (EBD). This allows you

to securely store and manage vendor and employee banking information directly within

NetSuite, supporting a wider range of complex payment types than the native system.

With this feature, you'll be able to:

Store and manage vendor bank details for various payment methods.

Import vendor bank details from a CSV file, making it easy to migrate your existing

data.

Export vendor bank details to a CSV, which is useful for backups or external use.

Migrate any previously stored vendor bank details from NetSuite's Electronic Bank

Payments bundle into the new system via CSV export.

Refer to the following pages for install, setup, and usage guides for the Entity Bank Details

bundle:

Entity Bank Details Installation & Setup (NetSuite)

Viewing Entity Bank Details (NetSuite)

Entity Bank Details Bundle Import/Export (NetSuite)

Update Entity Bank Details Bundle (NetSuite)



2.2.3.2.
Setting Default Payment Information
(NetSuite)

Save time paying bills by setting Vendor Default Payment methods, and choose to group

bills into one lump sum payment for vendors. Follow the steps in this guide to get started.

Method 1: Vendor Record

Go to a Vendor Record and select Edit. Then, select the bank plugin tab in the sub-menu.

Vendor Record

Here you will be able to set the Default Payment Method and enable the option to Group

Bills for Payment.

Method 2: Vendor List

1 Go to Customize View
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Select Lists → Relationships → Vendors. 

Customize View

Then, select Customize/Edit View.

Add Custom Fields

Add the Default Payment Method (Custom) and Group Bills for Payment

(Custom) fields for your bank to the list. 
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Vendor Search Results

Then, select Save.

Set Default Payment Method and Group Bills

Toggle the Edit option.

Edit Vendors



Select the blank area under the appropriate columns and select the Default Payment

Method or Bill Grouping option for each vendor.

Set Payment Method

Method 3: CSV Import

This method uses NetSuite's Import CSV functionality to set up default payment

information.

1 Create CSV File 

To begin, first create a CSV file with the following column headers:

Vendor ID

Default Payment Method

Group Bills for Payment

Payables Email Address [OPTIONAL]
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Sample "default_payment_information" CSV file

Populate the CSV file with the relevant Vendor IDs, the desired Default Payment

Methods [YES or NO], and an indication of whether or not you wish to Group Bills for

Payment [YES or NO]. 

Once complete, save the file and name it—we suggest using

"default_payment_information."

Upload CSV File

Then, head into NetSuite and navigate to Setup → Import/Export → Import

CSV Records.

NOTE: The Vendor ID is the field on the vendor record itself, not the internal

NetSuite ID.



Navigate to Import CSV

Set the Import Type to Relationships and the Record Type to Vendors.

Import CSV

Then select the CSV file you have created and select Next.
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Select Import Options

Select Update as the Import Option, then select Next.

Map Fields 

Map the fields as per the example below. 

Sample field mapping
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Select Next.

Import

Select Save & Run or Run to initiate the import.



2.2.4.Entity Bank Details

2.2.4.1.
Entity Bank Details Installation & Setup
(NetSuite)

The Entity Bank Details (EBD) bundle, combined with the standard NetSuite vendor and

employee records, will store all the information needed to submit payments.

You can add or view this vendor payment information after installation by going to Setup --

> Entity Bank Details -> Overview.

Entity Bank Details (EBD) Installation Instructions

1 Install Entity Bank Details Bundle

From the homepage, go to Customization → SuiteBundler → Search and Install

Bundles.

NOTE: If you do not have Accounts Payable installed, please skip this step.



Go to Search & Install Bundles

Search for Entity Bank Details or by Bundle ID 323878. Select the hyperlinked

bundle name, Entity Bank Details.

Entity Bank Details bundle

Select Install to review the bundle, then select Install again to confirm.
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Install Bundle page

Select OK when the dialog appears and wait for the bundle to install (this may take a

few moments). 

Manage Bundle Access - Suitelets

The administrator has full access to the Entity Bank Details bundle. To allow access

to other users and departments, follow these steps:

Go to Customization → Scripting → Script Deployments.

IMPORTANT: If you receive an error stating "You have not been granted access

to the bundle" upon attempting installation, please reach out to 

. 

FISPAN Support

Our team may need to whitelist your NetSuite Account ID before you are able to

install the Entity Bank Details bundle. Your Account ID can be found by

navigating to Setup → Company → Company Information.



Go to Script Deployments

On the Script Deployments page, apply the following filters:

In the Type dropdown, select Suitelet

In the API Version dropdown, select 2.1

A Suitelet is a custom front-end NetSuite page. Each of the Suitelets listed

corresponds to a page in the Entity Bank Details bundle. 

Select Edit on each of the following Suitelets you wish to edit:



Suitelet Description

Entity Bank

Details,

Overview

Granting users access to this script allows them to view the

Overview page. This permission, along with the Entity Bank

Details, Settings RESTlet, is required to access the Overview

page.

Entity Bank

Details,

Import/Exp

ort

Granting users access to this script will allow them to view the

Import/Export page.

Entity Bank

Details,

History

Granting users access to this script will allow them to view the

History page.

Entity Bank

Details,

Settings

Granting users access to this script will allow them to view the

Settings page to enable and disable approvals.

Entity Bank

Details,

Approvals

Granting users access to this script will allow them to view the

Approvals page to approve record changes.

Add employee roles by selecting the appropriate employee, department, and/or role

you would like to assign. 
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Filter for Suitelets on API Version 2.1

Then, select Save. 

Stay on this page for the next steps.

Manage Bundle Access - RESTlets

On the Script Deployments page, apply the following filters:

In the Type dropdown, select RESTlet.

In the API Version dropdown, select 2.1.

A RESTlet is used to define custom RESTful integrations to NetSuite, and in the

context of the Entity Bank Details bundle, is mainly used for handling the import and

export processes.

Select Edit on each of the following script deployment RESTlets you wish to edit:



RESTlet Description

Entity

Bank

Details,

Import

Service

Granting users access to this script will allow them to import a

CSV of bank account information into the Entity Bank Details

bundle.

Entity

Bank

Details,

Export

Service

Granting users access to this script will allow them to export a

CSV of bank account information from the Entity Bank Details

bundle.

Entity

Bank

Details,

History

Log

Export

Granting users access to this script will allow them to export a

CSV History Log of all changes made to any records stored within

the Entity Bank Details bundle. This history log tracks any edits,

additions, or deletions, as well as who initiated the change and

when.

Entity

Bank

Details,

Settings

This RESTlet should come with pre-enabled access for all roles.

Granting users access to this script will allow them to view the

Overview page. This permission, alongside the Entity Bank

Details, Overview Suitelet, is required to access the Overview

page.

Entity

Bank

Details,

Analytics

This RESTlet should also come with pre-enabled access for all

roles.

Add employee roles by selecting the appropriate employee, department, and/or role

you would like to assign. 
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Select Edit on the the Script Deployment

Then, select Save.

Manage Bundle Access - User Events

On the Script Deployments page, apply the following filters:

On the Type dropdown, select User Event.

On the API Version dropdown, select 2.1.

A User Event is a type of script that is executed when someone performs certain

actions on records, such as create, load, update, copy, delete, or submit.

Select Edit next to the Script Deployment User Event:
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User Event Description

Entity Bank

Details, Event 

(Record Type =

Vendor)

This User Event script allows users/roles to add or update

Vendor Bank Account information.

Entity Bank

Details, Event

(Record Type =

Employee)

This User Event script allows users/roles to add or update

Employee Bank Account information.

Add employee roles by selecting the appropriate employee, department, and/or role

you would like to assign. 

Filtering for User Events on API Version 2.1

Then, select Save.

Manage Bundle Access - Custom Records

Go to Setup → Users/Roles → Manage Roles.

Then, select Edit for the role for which you would like to grant access to the Entity

Bank Details bundle records.



Go to Manage Roles

After selecting Edit, go to the Permissions tab → Custom Record → Locate the

search box in the bottom row. 

NOTE: The owner of the custom record, which defaults to the user who

installed the Entity Bank Details bundle, will always have full access to the

record regardless of the Entity Bank Details permission level assigned to the

role being used.



Search and Select Entity Bank Details

Use the search box to find and set the correct permission level for Entity Bank

Details (FI) (Level: View):

View: Allows a user to view records.

Create: Allows a user to view and create records.

Edit: Allows a user to view, create, and edit records.

Full: Allows a user to view, create, edit, approve, and delete records. This

permission level is required to approve any changes made to vendor or

employee records.

Next, navigate to the Permissions tab → Setup → Locate the search box in the

bottom row. 

Use the search box to find and set the permission: 

Set Up Company (Level: View): Required for the Overview page and is used for

the EBD Settings RESTlet to access the Company Information page.

Within the Permissions tab, select Lists --> Locate the search box in the bottom row. 

Use the search box to find the following permission: 
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Employees (Level: View): Required to approve or view the History page for

employee records.

Then, select Save.

Storing Bank Information

Using the main navigation, go to Setup → Entity Bank Details → Overview.

Select between viewing Vendors or Employees by selecting the tabs above the table.

By default, this page opens up to show Vendors first.

Select View for the desired Vendor or Employee.

Select View for the desired Vendor or Employee

Select Add.



Select Add

Create an optional label and select the appropriate payment method, country, and

currency. Then, fill out the required fields for the specified payment method and

mark the record as Primary. 

Select Save



Then, select Save.

Visit  for the corresponding payment requirementsACH Requirements

Defining View-only Access to EBD

Following the steps below will provide users with view-only access to Entity Bank Detail

records with no ability to add, edit, or delete.

1

2

User Permissions Setup

Go to Setup → Users/Roles → Manage Roles.

Select Edit for the role for which you would like to grant access to the Entity Bank

Details bundle records.

Go to the Permissions tab → Setup → Locate the search box in the bottom row. Use

the search box to find the following permission:

Set Up Company (Level: View): Required for the Overview page and is used for

the EBD Settings RESTlet to access the Company Information page. 

Select Save.

Assign EBD Record Type

Navigate to Customization → Lists, Records, & Fields → Record Types

NOTE: The fields that appear on this page are dependent on the method,

country, and currency selected.

WARNING: All vendor and employee bank details, along with all history logs, are

stored within the Entity Bank Details bundle in your NetSuite environment. If this

bundle is uninstalled, all of this data will be permanently deleted.

To prevent data loss, you must export your data before uninstalling. Please use the

Export feature on the Import/Export page to save all your records and history logs.



Under the EDIT column, select Entity Bank Details (FI)

( custom_record_vendor_bank_details )

Custom Record Types

On the Custom Record Type page that opens up, select the Permissions tab. Here,

you can define which roles can have Full or View access.

Select the role of your choice, and then assign View as the access level on the Level

column.
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Define "View" level permissions on a Role of your choice

Select Save.

Assign EBD Overview Script

Next, navigate to Customization → Scripting → Script Deployments.

Filter for Suitelets on API Version 2.1
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Apply the following filters and parameters:

On the Type drop-down, select Suitelet

On the API Version drop-down, select 2.1.

Select Edit beside Entity Bank Details, Overview

( customdeploy_fispan_vbd_overview )

Under the Audience tab, select any number of roles, subsidiaries, employees,

departments, groups, or partners that require access

Select Save, and return to the Script Deployments page.

Locate EBD Event Scripts

Navigate to Customization → Scripting → Script Deployments

Apply the following filters and parameters:

On the Type drop-down, select User Event

On the API Version drop-down, select 2.1.

Filtering for User Events on API Version 2.1
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Assign Access to Vendor Bank Details

Limit a user's access to only view the Vendor's bank details with the Entity Bank

Details, Event ( customdeploy_fispan_vbd_event ) script.

Select Edit beside Entity Bank Details, Event ( customdeploy_fispan_vbd_event ).

Under the Audience tab, select any number of roles, subsidiaries, employees,

departments, groups, or partners that require access.

Select Save.

Assign Access to Employee Bank Details

Limit a user's access to only view an Employee's bank details with the Entity Bank

Details, Event ( customdeploy_fispan_vbd_event_emp ) script.

Select “Edit” beside Entity Bank Details, Event

( customdeploy_fispan_vbd_event_emp ).

Under the Audience tab, select any number of roles, subsidiaries, employees,

departments, groups, or partners that require access.

Select Save.

IMPORTANT: View-only access is not available for NetSuite users who have more

than one role defined, like a user with both the Administrator and AP Clerk roles.

This is a limitation within NetSuite itself.



2.2.4.2.
Entity Bank Details Bundle
Import/Export (NetSuite)

The Entity Bank Details (EBD) bundle integrates with the standard NetSuite Vendor Record

to securely house all necessary information for submitting payments. Once installed,

imported vendor and employee data are accessible via Setup → Entity Bank Details →

Overview. Learn how to import, export, and update EBD for both vendors and employees

in this guide.

The process for importing and exporting records on the Vendor and Employee tabs is the

same. The only difference is on the Vendor tab, which offers a specialized export utility for

users with NetSuite’s Electronic Bank Payments bundle, allowing them to conveniently

transfer and re-upload data into EBD.

Import Entity Bank Data

The process for importing EBD data is the same for both Vendor Records and Employee

Records.

1 Go to the Import/Export Tab

Go to Setup → Entity Bank Details → Import/Export
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Go to Import/Export

Import CSV template

Select Template to download a blank CSV template. Use this CSV to fill out Bank

Details for bulk upload.
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Import Data section. Click on the Download Template button to get a blank CSV

Format and Fill Out CSV

Please see the Field Requirements for CSV section of this page for a table

containing all formatting requirements for the CSV file.

Upload the Formatted CSV

In the same Import/Export screen, upload the formatted CSV document.

NOTE: Use this feature only to create new records. To update existing records,

you must use the Export CSV feature, as it includes the necessary ID column,

which is missing from the blank CSV template.

NOTE: Confirm that you use the IBAN country code (e.g., CA).

TIP: Have leading zeroes in your data? Apostrophes ['] in front of any leading

zeroes or formatting cells as "plain text" will keep leading zeroes in Microsoft

Excel or Google Sheets, but NOT Apple Numbers.



Confirm successful upload by checking the Import Logs to ensure all records were

uploaded successfully.

Import Data section

Select Import logs → Execution logs to confirm import completion.

Execution Logs



5 Check Information

Prior to sending payments, check the Entity Bank Details tab of the Vendor Record to

ensure all information is correctly updated.

Export Entity Bank Data

The process for exporting EBD data is the same for both Vendor Records and Employee

Records.

1

2

Go to the Import/Export Tab

Go to Setup → Entity Bank Details → Import/Export

Go to Import/Export

Export CSV template

IMPORTANT: All Entity Bank Details for both vendors and employees, alongside

all history logs, are stored in your NetSuite environment. Please ensure you are

regularly exporting your Entity Bank Detail records and your history logs to

prevent any potential loss, such as through uninstallation of the bundle. 



Click on the Generate Export File button to trigger a CSV download of all records

kept in EBD. 

Export Data section of the Import/Export page

The table will display a history of all exports created, alongside timestamps and

buttons to download each of these files.

Export Logs contains more information about the export files generated. This can be

found under the Execution Log tab. For each line item, it will report who initiated the

export, the number of records exported in the one file, as well as the file name for

that particular export.

Update Existing EBD Records

Use the Import/Export feature to bulk edit existing Entity Bank Details (EBD) for multiple

Employee and Vendor Records at once.

1 Export CSV File

To update existing Entity Bank Details (EBD) records, you must first export a CSV file

of those records.
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The exported CSV file is crucial because it contains a unique ID column. This ID

column is not present in the blank CSV import template and is necessary for the

system to identify and update existing data.

Make edits to the CSV

Using your preferred application (such as Microsoft Excel or Google Sheets), open

the exported CSV file to make your edits. 

EBD Vendor Export CSV opened in Numbers. Note the ID column on the far left

Ensure the ID column on the far left remains untouched.

You can also add new records to the list; simply enter them as a new row at the

bottom of the CSV file. The system will assign an ID to these new records upon

import.

Import the edited Export file

After making edits to the previously exported file, you may now import the CSV file

back into the Entity Bank Details bundle. 



Import Data section. Click "Select a CSV file" or drag-and-drop a CSV file in this

section to import your CSV file

Either Select a CSV file to upload, or drag and drop one into the Import Data section

of the Import/Export page.

Troubleshooting Common Import Issues



Issue Resolution

No success

message appears

in NetSuite after

importing Entity

Bank Data.

Check the import logs directly to verify the import status.

Records were

successfully

created, but

appear

incomplete or

inaccurate.

Records can be created even if they are missing required fields or

have incorrect formatting. Validate the imported records for

accuracy after every upload.

Duplicate bank

records are

created for a

vendor/employee.

This happens if the same records are imported more than once.

Ensure you are importing unique vendor or employee bank accounts

with each import file.

The international

payment method

is incorrectly set

or missing.

When importing, the payment method for all international wire

accounts must be entered as INTERNATIONAL_WIRE in the EBD

template. Additionally, ensure bank accounts for international wire

countries are not set to the DOMESTIC payment method in the

vendor's NetSuite profile.

FAQs

Is it possible to add additional fields?

No. NetSuite does not currently allow the addition of fields to the EBD record.

Why are the Bank Balance and Balance As Of fields in the Match Bank Data page

blank after a successful import?

This is a NetSuite limitation. The system does not populate bank balance information

because it relies on the usage of a Bank Feed, which is not integrated here.



Field Requirements for CSV

Make sure your CSV Import file follows these requirements.

IMPORTANT: Ensure any data with leading zeroes is preceded by an apostrophe '

or formatted as plain text in Microsoft Excel or Google Sheets.

NOTE: If you are using payment methods that require mandatory country codes for

Entity Bank Details, there may be additional columns that must be included in the

import. 

To ensure a successful import, we recommend first manually adding the Entity Bank

Details to the ERP system. Then, download the template; it will already display the

correct columns needed for entering any remaining details.



Name Values Description

id Numeric This is the ID number for this specific record.

This column is not available on the import

template as it is system-generated.

vendor (or

employee)

NetSuite Vendor ID or

Employee ID

Required. The Vendor or Employee ID can be

found in the URL of the Entity Record or on the

EBD Overview page.

label Anything Required. This can be entity or bank details.

This field is used to differentiate the records

when doing mass uploads.

primary YES/NO, Y/N,

TRUE/FALSE, T/F

Required. T = True, F = False. If there are

multiple bank details for a single payment

method on a single vendor being imported,

mark one as T and all others F.

country 2-letter ISO country code

(e.g., US, CA, UK)

Required. Field accepts upper, lower, and

mixed case values.

currency 3-letter currency code

required (e.g., USD, CAD)

Required. Field accepts upper, lower, and

mixed case values.

method DOMESTIC,

INTERNATIONAL_WIRE

Required. Has to be in the same format as it is

case sensitive.

Please use INTERNATIONAL_WIRE for bank

accounts set up for international wire

payments.

Please use DOMESTIC for US/Canada-based

accounts.

bankName Anything

address.lin

e1

Anything -

address.cit

y

Anything -



Name Values Description

address.st

ateProvinc

e

Anything -

address.po

stalCode

Anything -

bic Valid BIC or SWIFT code

for the country and bank

accountTy

pe

CHECKING, SAVINGS Field accepts upper, lower, and mixed case

values.

accountNu

mber

Valid account number for

this bank

localBranc

hCode

Valid branch code for this

bank

Use this field for BSB codes if the country

requires it.

paymentD

efaults.pur

poseMess

age

Anything

paymentD

efaults.pur

poseCode

Valid purpose code

paymentD

efaults.pay

mentIsoCo

de

Valid ISO code

paymentD

efaults.pay

mentCode

word

Valid payment code

paymentD

efaults.pay

Valid party type P = Parent, T = Subsidiary, G = Group, N =

Non-related



Name Values Description

mentParty

Type

paymentD

efaults.resi

dentialStat

us

Valid residential status

bankCode Valid bank code for this

bank

iban 2-letter country code,

followed by two check

digits, and up to 35

alphanumeric characters

sortCode Valid sort code for this

bank

institutionN

umber

Valid institution number

for this bank

transitNum

ber

Valid transit number for

this bank

routingNu

mber

Valid routing number for

this bank

Transferring Electronic Bank Payments Data 

Before the Entity Bank Details (EBD) bundle is installed, you are limited to making only ACH

and CPA payments. This is done through the bank plugin, using vendor information stored

in NetSuite's Electronic Bank Payments (EBP) bundle.

Once EBD is installed, the EBP bundle is no longer used to pull vendor banking data for bill

payments. Instead, EBD becomes the new source of payment information.

The EBD bundle provides the ability to transfer ACH and CPA vendor banking information

from the EBP bundle via CSV.



ACH and CPA banking information stored in the following default Payment File Formats are

supported:

ACH - CCD/PPD

ACH - CTX (Free Text)

CPA-005

Transferring ACH and CPA banking information that is stored in custom Payment File

Formats is unsupported.

To quickly transfer your supported data across bundles, follow the steps below.

1

2

Go to the Import/Export Tab

Go to Set Up → Entity Bank Details → Import/Export

Go to Import/Export

Generate CSV(s)

Select Click to show Electronic Bank Payments export



Click to show Electronic Bank Payments export

Select Generate CSV File.

This will generate a CSV file(s) dependent on the Number of Entries for Each File,

set below. 

NetSuite limits the number of records that can be pulled per file. For example, if you

have 1100 records and set the number of entries to 200, the bundle will generate five

CSVs containing 200 records and one CSV containing 100 records.



3

Generate CSV file

Import CSV(s)

Select a CSV file… or drag and drop the CSV file(s) into the Import Data box.

NOTE: The Generate Data from Electronic Bank Payments Bundle can only

extract ACH and CPA payment details. Any additional payment details must be

transferred into the Entity Bank Details bundle either via manual entry or using

the Import feature.



4

Import Data section

Then, select Import. 

Wait a few moments for the import to complete. 

Confirm Import Completion

Once complete, select Import logs → Execution logs to confirm import completion.



Confirm Status

You can also check the following places to confirm bank details have been saved:

Entity Bank Details tab on the Vendor or Employee Record

Entity Bank Details Overview page

Entity Bank Details History page



2.2.4.3. Viewing Entity Bank Details (NetSuite)

View the Vendor or Employee bank detail records in the Entity Bank Details (EBD) bundle

on the Overview page. Additionally, you can view or export all the changes taken on the

Entity Bank Details bundle in the History page.

Overview Page

The Overview page is your central hub for all vendor and employee bank detail records

stored in the EBD bundle. To see a list of all vendors or employees on your NetSuite

account, simply navigate between the Vendors and Employees tabs. The page will default

to the Vendors tab when you first open it.

For both Vendor and Employee tabs, the page displays all vendors/employees on this

NetSuite company with the following columns:

# (ID assigned by EBD)

View (Links to vendor or employee record)

Vendor or Employee Name

Email (Primary email on vendor or employee record)

Internal ID (Native NetSuite’s vendor or employee ID)

Total Records (Number of EBD records stored by this vendor or employee)

1 Navigate to the Overview Page

Go to Setup > Entity Bank Details > Overview



2

Go to Entity Bank Detailss Overview

View Vendor Bank Details

Click into Vendors to view an overview of Vendor Bank Details.

Entity Bank Details Overview page - Vendors tab



3 View Employee Bank Details

Click into Employees to view an overview of Vendor Bank Details.

Entity Bank Details Overview - Employees tab

Adding Vendor Bank Account Information

From the Vendor tab in the Overview page, you will be able to view and edit a Vendor's

bank account information. 

1 Select Vendor

Click on a Vendor you would like to add information for. 
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Click View EBD Record

Add Vendor Bank Details

You can fill in the required fields for your desired payment rail. By default, the

payment method is set to Domestic and the United States. 

Add Vendor Bank Information



For international payments, change the Method to International. 

Change the Method to International

After you have added all required information, please click Save Vendor Bank

Details.

History Page

The History page shows a table of all actions taken on the EBD bundle for every vendor

and employee. It allows you to filter logs by date and export them based on a defined date

range. By default, the page displays vendor history, but you can switch to the Employees

tab to see updates to employee records.

The table contains the following columns:

Modified

# (ID assigned by EBD, refer to Overview page)

Vendor

Type of Change (Added, Updated, or Deleted)

User



Reviewed By

Source (UI or Import)

Status (Approved or Rejected)

Actions

1

2

Navigate to the History Page

Go to Setup → Entity Bank Details → History

Navigate to Entity Bank Details History

View Vendor History

Click into Vendors to view all history logs for changes made to Vendors' Bank

Details.



3

Vendor View

View Employee History

Click into Employees to view all history logs for changes made to Employees' Bank

Details.

Employee View



4 View Changes

Click View Details on any of the logs to see the changes in detail.

Columns for Attribute, Before Changes, and After Changes appear in the View

Details pop-up for both vendors and employees.

View Changes Made

Text in red with a strikethrough under Before Changes shows the field's previous

value, while text in green under After Changes shows the new value. The specific

fields displayed depend on the Country, Currency, and Method defined, as well as

the type of change made to the EBD record.

Exporting History Logs

Users are also able to export history logs on the EBD History page for audit purposes.



1

2

3

Navigate to the History Page

Go to Setup → Entity Bank Details → History

Export History Logs

Select the Export button to trigger a CSV download.

Export button highlighted in RED

The CSV export feature will only export logs that fall within the defined date range in

the date filter. If no date range is filtered, the export will pull all logs from when EBD

was first installed.

History CSV Export Columns

The exported History CSV file includes the following columns:

IMPORTANT: All Entity Bank Details for both Vendors and Employees, alongside all

History logs, are stored in your NetSuite environment. To prevent potential data loss,

such as from uninstalling the bundle, make sure you regularly export your Entity Bank

Detail records and History logs. 



Log ID: The unique ID for the history log entry.

EBD ID: The ID of the Entity Bank Details record.

Modified On: The date and time the change was made.

Vendor ID: The ID of the vendor associated with the change.

Vendor: The name of the vendor.

Type of Change: The action that was taken (Updated, Added, or Deleted).

User: The name of the user who initiated the change.

User ID: The user ID of the person who initiated the change.

Reviewed By: The name of the user who approved or rejected the change.

Reviewed On: The time the change was approved or rejected.

Status: The final status of the change (Approved or Rejected).

Previous Entry: The state of the record before the change. This column is empty

if a new record was added. Intermediary bank account information is also

included.

Proposed Entry: The proposed change. If the entry was approved, this is the

change that was accepted. If the entry was rejected, this is the change that was

proposed. Intermediary bank account information is also included.

Reason for Rejection: The reason the change was rejected. This column is

empty if the record was approved.

NOTE: These columns will appear in the report whether or not Approvals are

enabled.



2.2.4.4.
Entity Bank Details Approvals
(NetSuite)

Before getting started with using the Approvals feature, ensure you have all Entity Bank

Details (EBD) permissions. You can confirm the required permissions in the Entity Bank

Installation Details & Setup guide.

Overview

Enabling Approvals enhances security and compliance by requiring a secondary approver

for every change made in the Entity Bank Details (EBD). This approver can be anyone who

has access to the Approvals page, but it cannot be the person who made the initial change.

A change is defined as adding a new record, updating an existing record, or deleting an

existing record.

While a change is pending, payments cannot be made to that entity, and the respective

payment page will block payments for the entity until the change has been approved.

For example, Jenna changed Company X's bank account information in Entity Bank Details.

Jenna can access the Approvals page, but she will be blocked from approving the change.

Bibek, however, has access to the Approvals page and can either approve or reject this

change.

Approval Requirements

For Approvals, there are two additional pages and permission sets. You must add these

permissions to any users who require access to the Settings and Approvals pages.

Suitelets

NOTE: Entity Bank Details Approvals works best if your NetSuite environment has no

customizations surrounding vendor or employee creation, deletion, or modification.



Entity Bank Details, Settings (customdeploy_fispan_vbd_settings): Access to the

Settings page allows users to enable or disable approvals or manage the settings of

approvals for imported records. 

Entity Bank Details, Approvals (customdeploy_fispan_vbd_approvals): Access to the

Approvals page allows users to approve record changes. 

RESTlets

Entity Bank Details, Settings RESTlet: This RESTlet should come with access pre-

enabled for all roles. Granting users access to this script will allow them to access the

Overview page. This permission, alongside the Entity Bank Details, Overview Suitelet,

is required to access the Overview page.

Permissions

Lists --> Employees (Level: View): To view the list of employee records that have

pending approvals, the history of changes made to employee records, or to make

changes to employee records.

Custom Record → Entity Bank Details (FI) (Level: Full): To approve EDB changes, the

role needs Level: Full permission on the Permissions tab.

User Events

No new User Events required.

Enabling Approvals

1 Navigate to Settings

To enable Approvals, navigate to Setup -> Entity Bank Details -> Settings. 

NOTE: For the Settings page to work properly, you must also have access to all

Subsidiaries. 



2

Click on Settings

Settings is where you can decide to enable or disable Approvals. 

Enable Approvals on All Changes

You can also enable and disable approvals for changes made via the Import page. 

Enable Approvals
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To enable these settings, select the APPROVAL ON ALL CHANGES checkbox and

click Save. 

Now, all changes must be approved before you can disable Approvals.

Approve Pending Changes Before Disabling  

By enabling Approvals, every change made via Import on the Import/Export page will

now require approval. 

Enable Skip Approval on Imports

In Settings, you can enable the Skip Approvals on Imports option. 

This setting cannot be enabled if there are pending approvals. 



Configure Approvals for the Import/Export Page

Making EBD Changes 

1 Overview Page

To make a change to a Vendor or Employee record, navigate to Setup -> Entity Bank

Details -> Overview. 
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Click on Overview

Make Changes to Entity

Select the entity you want to change.

Select a Vendor or Employee

Three types of changes trigger approvals: 
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Update

Add

Delete

Make the desired changes to the entity's record and Save.

Click Save Vendor Bank Details

Confirm the Change

When asked to confirm the change, be aware that no payments can be made to this

vendor or employee until the changes have been approved.

IMPORTANT: Turn off the PRIMARY toggle if you do not want this newly

created account to be a primary record. If a vendor or employee does not have

a primary record enabled, payments will fail. 



Click Yes, Save Changes

A blue banner will be displayed on vendor records indicating that changes are

pending, while a red alert icon will appear on the relevant bank details record.

Warning for Pending Changes
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The blue banner serves as a reminder that the completion of payments is contingent

upon the approval of the change. The alert icon signifies that the record has

changed. 

Records With Pending Changes

Should a record have a pending change, it cannot be edited again until such a

change receives either approval or rejection.

If a vendor's record currently has a pending change, you can edit, create, or delete

other records; however, the record with the pending change cannot be modified.

Bills Will Be Blocked For Payment

As a result, the payment page will display bills accompanied by a red alert icon,

indicating that payment processing is not possible, and their associated checkboxes

will be disabled.

Making EBD Changes With Import/Export

Changes to Entity Bank Details can be made via a CSV import of records, and these

changes will require approval.



1 Export EBD Data

Navigate to Setup -> Entity Bank Details -> Import/Export. 

Click on Import/Export

Import/Export, you have the option to either download a blank template or use the 

Generate Export File option to create an existing export file.
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Entity Bank Details - Import/Export page

Update Exported EBD Data

Then, make changes or add data to the export file. 

Make Changes to Data Export



3 Reimport EBD Data

Now add the updated file to the IMPORT DATA box and select Import.  

Click Import

The plugin will process the imported data and notify you if there are pending

changes for a record. 



Approvals Pending

Payments are blocked for any entity with outstanding changes until the changes are

approved or rejected.

Approving Changes

To approve changes, you must have access to the Approvals page, and you cannot be the

user who changed the entity's record.

1 Locate Pending Approvals

Navigate to Setup -> Entity Bank Details -> Approvals. 
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Click on Approvals

The page will now display any records that have outstanding changes. Click View

Details to see the change and to begin approving or rejecting changes. 

Click on View Details

View Changes
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When you click View Details, a pop-up appears and outlines the changes.

If the record you are approving is classified as a Primary Account, you will have the

option to either confirm this designation or revoke the account's status as a Primary

Account.

This option will only appear if a record's Primary setting is being updated or if a new

bank account is being added. 

Review Proposed Changes

Approve Changes

After reviewing the changes, you can Approve or Reject. If unsure about a change,

select the arrow beside the pop-up to move to the next record and return to this

change later. 

When you approve a record, a pop-up window will ask you for final confirmation.



Click Yes, Approve Changes

After approval of the change, a confirmation window will display a checkmark,

indicating that the change has been successfully approved and saved.

Navigate to the Next Record
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After 10 seconds, the pop-up moves to the next record so you can continue

reviewing changes. You can also click forward using the arrow icons. 

If there are no further changes, click Close to exit the pop-up window. 

The updated entity records can be viewed on the Overview page. Payments for this

vendor or employee are no longer blocked, allowing for the processing of any

outstanding payments.

Reject Changes

To reject a change, select Reject. 

When prompted to provide a Reason for Rejection, provide an explanation up to a

maximum of 250 characters.

Click Yes, Reject Changes

After entering the reason, select Yes, Reject Changes.

An X icon window indicates the change was rejected, and the vendor's record was

not updated. 



Navigate to the Next Record

You can now successfully make payments for this vendor or employee. 

Navigate to the next record using the arrow icon or by waiting 10 seconds. 

Approvals History 

All approvals are logged in the Entity Bank Details History, serving as a valuable resource

for audits and reviews of approval histories.

1 Locate Approval History

To view a history log of all changes, navigate to the History page: Setup -> Entity

Bank Details -> History.
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Click on History

History displays a record of all changes made and approved. If the approvals feature

was not enabled for some historical changes, some details like Reviewed By or 

Status will be missing. 

View Approved Changes 

Select View Details to see more information about a change.



View Log of Changes

For approved changes, a pop-up confirms that it has been Approved. It outlines key

information such as who indicated the change, who approved it, and what attributes

were modified. 

View Approved Change Details



Once finished looking at the pop-up, click Close.

For changes that have been approved and involve additions or updates, you have the

option to access the EBD Record. Simply click on the EBD Record link located next to

the corresponding record.

Click on View EBD Record

This link will take you to the record on the EBD Overview page. 
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View Changes

View Rejected Changes

Rejected changes will display similar information; except, it will indicate that it has

been Rejected and include the Reason for Rejection as well.

View Rejected Changes Details



4 Export Approvals History

To export these changes for your records, go to the History page and select Export.

Add a date range filter to limit the amount of data to include.

Click on View EBD Record

The History Export will display the following data: 

Log ID

EBD ID

Modified On (Date and Time)

Vendor ID

Vendor

Type of Change: Updated, Added, or Deleted

User: The user who initiated the change

User ID: The user ID of the user who initiated the change

Reviewed By: The user who approved or rejected the change

Reviewed On: The time when the change was approved or rejected

Status: Approved or Rejected



Previous Entry: This shows the data that the record contained before the

change. This will be empty if the history log item is for a net new record being

added.

Proposed Entry: If the entry was rejected, this is the change that was proposed. 

If the entry was approved, this is the change that was accepted.

Reason for Rejection: This will be empty if the record is approved

View History Export

FAQs

Is there any way to disable the Approvals feature after it is enabled?

To disable Approvals, please navigate to Setup > Entity Bank Details > Settings.

Approvals can only be disabled if there are no pending approvals.

NOTE: The same columns will appear in the report regardless of whether the

Approvals feature is enabled or disabled.



Can I set more than one approver set up for a change?

Currently, Entity Bank Details is only able to support a single approver for a change. 





2.2.4.5.
Update Entity Bank Details Bundle
(NetSuite)

Stay up to date with the latest improvements by regularly updating your Entity Bank Details

bundle for NetSuite.

1

2

Locate Bundle

Go to Customization → SuiteBundler → Search & Install Bundles → List.

Go to Search & Install Bundles List

Update Bundle

Find the Entity Bank Details bundle from the list. Then, hover over the green icon and

select Update.﻿



Select "Update"

Select Update Bundle, and select OK on the confirmation pop-up.﻿

Click "Update Bundle"

The bundle will take a few moments to update. Its status will first show as Pending,

then display the progress of the update. When the update is complete, a checkmark



will appear in the Status column on the Installed Bundles page.



2.3.Product Features

2.3.1.Cash Management

2.3.1.1.Reporting

2.3.1.1.1. Managing Bank Accounts (NetSuite)

Access your bank account balances directly within your financial management software,

using the Cash Management Reporting features. Drill down into the details of every

deposit, withdrawal, and transfer.



Follow this guide to learn how to view balances and transactions, and use bank data for

reconciliation.

Viewing Bank Accounts 

View account balances and transaction details across all of your accounts, all within

NetSuite.

1

2

Navigate to the Bank Accounts page.

Go to  → Reports → Bank Accounts.First Citizens Link

Here, you can view all of the bank accounts that you have connected with the plugin.

The bank accounts that are shown to a user depend on their level of permissions. 

For instance, if a user is restricted to a subsidiary, they can only view accounts that

are associated with that specific subsidiary and not accounts belonging to other

subsidiaries.

Select Account

Click on any account's name to view the Intraday and Previous Day Balances.
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Accounts Overview

Intraday Balances (updated time bank dependent)

Previous Day Balances (updated time bank dependent)

View Balances & Transactions

Bank Account Balances are displayed at the top of the page.

Bank Transactions that have been posted to your account are presented in the table

further below. Use the date filters to help narrow your search.



Account Balances and Transactions

You’ll see all settled transactions, debits, and credits for the account.

To see additional details about a specific transaction, click View under the Details

column.

Match Transactions for Reconciliation 

Follow these steps to start matching bank data and reconcile your accounts. 

1 Enable Transaction Matching

Go to Setup → Accounting → Chart of Accounts (Click on the title).



Chart of Accounts

Select Edit on the bank account for which you would like to use the reconciliation

feature.

Click 'Edit' to Open the Bank Account
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3

Select the Use Match Bank Data and Reconcile Account Statement Pages box to

enable this feature for the account.

Use Match Bank Data and Reconcile Account Statement Pages

Then, select Save.

Enable Bank Feeds

Ensure that Bank Feeds have been properly enabled for your account. Once Bank

Feeds have been enabled, you should be able to see transactions coming into the

Match Bank Data page daily. Transactions that settled the day before will be imported

early in the morning. 

Confirm Transaction Matches

Go to Transactions → Bank → Match Bank Data. 



Go to Match Bank Data

Select the appropriate account from the dropdown, and your transactions will appear

in the left column for matching.

If you need to manually import transactions into NetSuite's Match Bank Data page, follow

the instructions below. This process works even if your bank feeds are already enabled.

1 Navigate to Bank Accounts

Go to  → Reports → Bank AccountsFirst Citizens Link

Select the account you would like to access.
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Bank Accounts

Export BAI2 or CSV File

Apply the appropriate filters, select Export, and select the appropriate export type.

You should select BAI2 or CSV.

Export Options



3 Upload BAI2 or CSV File

Go to Transactions → Bank → Banking Import History → Upload File.

Upload File

Select Choose a file and select the file you just downloaded in the previous step.

NOTE: If the file does not download, make sure your pop-up blocker is

disabled.



Upload File

Then, select Import with a default parser, choose the appropriate account, and

select Import. 

NOTE: If you have selected a BAI2 file, you will not need to select your account,

as the bank account information is already present in the BAI2 file itself.



IMPORTANT: For the BAI2 import to succeed, the routing and bank account

numbers in the BAI2 file's first three rows must match the corresponding data

in the Chart of Accounts.

Bank Import Mapping tab

To update the Chart of Accounts records:

Navigate to the Chart of Accounts.

Click Edit on the relevant bank account.

Go to the Bank Import Mapping tab.

Ensure that Record 02 contains the routing number and Record 03

contains the full account number. This information must be an exact match

for what is in the BAI2 file.



2.3.2.Bank Feeds

2.3.2.1. Enabling Bank Feeds (NetSuite)

Bank Feeds allow for your settled bank transactions to automatically flow into NetSuite's

Match Bank Data module for reconciliation, removing the need to export and import bank

statements manually. To enable Bank Feeds, follow the instructions below. 

Please take note of the following field mappings for data received from your bank within

the Match Bank Data page in NetSuite.

� NetSuite 2026.1 Compatibility Update

NetSuite version 2026.1 introduced new functionalities for the Bank Feeds module,

including custom automated import scheduling and the ability to choose an exact

start date for historical transaction imports.

Our Bank Feeds service has been fully updated and is completely compatible with

these new features, giving you greater control over your reconciliation process from

day one!



NetSuite (Match Bank Data) Transaction Data

Transaction Date Settled Date

Type Transaction Type

Transaction Number Check Number* (if non-null) or Customer Reference*

Name Counter-Party Name*

Memo Description

Amount Amount

* Information denoted with a star will only be displayed if the transaction includes it. 

NOTE: Aside from the custom Connectivity Method and Transaction Parser that is

named after your bank, everything else discussed in this guide is owned and

managed by NetSuite. This includes, but is not limited to, the following:

Match Bank Data module

Financial Institution configuration

Format Profile configuration

Banking Import History page

As this process is managed by NetSuite, the timing and execution of the daily imports

are controlled within their system. If you are on NetSuite version 2026.1 or later, you

can customize the frequency and timing of your automated imports using the Import

Schedule subtab within your format profile. (If you do not set a custom schedule,

NetSuite will default to a randomized time between 4 AM to 7 AM PT).



Permissions

Note: Non-administrator users who will be setting up and managing Bank Feeds must

have the following permission:

Setup → Financial Institution Records – Level: Full

They must also be added as an audience for the following Script Deployment (can be

found under Customization → Scripting → Script Deployments):

Transaction Feed Config (ID: customdeploy_

_rpt_feed_s)

First Citizens Bank First Citizens Bank

Step 1: Create a New Financial Institution

Navigate to Setup → Accounting → Financial Institution.

Historical Transactions at Setup: You now have control over your historical data

sync at setup without needing to contact Support.

For NetSuite 2026.1 or later: During the account linking process, you can select

an Earliest Transaction Date for Import. This allows you to automatically import

up to 60 days of historical transactions upon setup, or pick a future date to delay

your initial import.

For NetSuite 2025.2: Upon initial setup, the system will automatically import up

to your last 60 days of historical transactions by default.

If you have any questions regarding transaction import, please reach out to First

Citizens Bank Client Services after setting up your bank feeds connection. 



Go to Financial Institution

Enter the name of your bank the Financial Institution field. Then, select Save.

Enter your bank's name as the Financial Institution



Step 2: Create a New Format Profile

On the Financial Institution, click the Format Profile: Configuration tab and select Add.

Configure Format Profile

Fill in the following fields under Primary Information:

Profile Name: Any name, we suggest  ProfileFirst Citizens Link

Profile Type: Bank Reconciliation

Connectivity Method:  Transaction FeedFirst Citizens Link

Transaction Parser:  Transaction FeedFirst Citizens Link



Fill in the required fields under Primary Information

Next, click on the Account Linking tab. 

Format Profile -> Account Linking tab

Previously, each Format Profile was only able to support one linked bank account. With this

new edition of Bank Feeds, a Format Profile can have multiple bank accounts and linked GL



accounts.

Based on the account seen under the Bank Account column, click on the space below the 

Linked GL Account to show a dropdown. In this dropdown, select the GL account that

maps to the Bank Account.

Repeat this step for all accounts you wish to enable Bank Feeds.

Once all bank accounts have been linked, click Save.

Step 3: Monitor Bank Import Process

As soon as the Format Profile is saved, a blue banner will appear to notify you that NetSuite

is beginning the bank import process.

Select Track your status in the blue banner that appears, or go to Transactions → 

 → Banking Import History.First Citizens Link

IMPORTANT: Please ensure you link all of your bank accounts on the same day to

avoid missing transactions for any unlinked bank accounts.

NOTE: You may not see transactions in the Match Bank Data page upon setup, as our

Bank Feed solution will import all prior-day transactions the day after setup and

continue to do so onwards.



Click Track your status

If the import is successful, you will see Completed under the Import Status column.

Banking Import History page with a Completed import



If the import fails, you will see Failed in the Import Status column. Select the plus (+) sign

to expand the failure reason details.

Please take a screenshot of the error message and download the CSV provided from the

link in the error message. Then, email this information to .FISPAN Support

TreasuryManagementSupport@firstcitizens.com

Troubleshooting

Identifying Errors

In the situation where a bank data import fails, the failure reason can be found on the

Banking Import History page.
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Navigate to Transactions →  → Banking Import History.First Citizens Link

Find the line item that shows the Import Status as FAILED, accompanied by a red

caution icon. 

On that line item, click on the small plus icon on the far left to expand the row.

Failure Reason

mailto:TreasuryManagementSupport@firstcitizens.com


3 After expanding the row, the Failure Reason is provided.

Unrecognized Bank Transaction Codes

Sample import failed error on the Match Bank Data page

In the event that a bank data import fails due to an unrecognized bank transaction code,

you will need to do the following:

Map any missing BAI2 codes

Retrieve Statement IDs from Connectivity Method / Parser Execution logs

Contact our Support Team with the following: 

Statement IDs from impacted accounts

The date the import failed

The date of the transactions that are missing

Please refer to the sections below for instructions on how to proceed.

Mapping Bank Transaction Codes
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Locate the Financial Institution 

Navigate to Setup → Accounting → Financial Institution.

Click Edit on the Financial Institution that you have created previously.

Select the Format Profile: Configuration tab and select Edit on the Format Profile

that you have also created previously.

Fill in the Bank Transaction Code Details

Fill in the following fields for the bank transaction code that was unrecognized:

Bank Transaction Code: The three-digit code from the error message seen on

the Banking Import History page, or on the Match Bank Data page.

Description: Fill in with the code's description, which can be found here: 

BAI.org Cash Management Balance Reporting Specifications, page 10

Bank Data Type

Credit / Debit

Bank Data Type and Credit / Debit values will be the same. They both must be either 

Credit, Debit, or N/A. This can also be found on 

, or by referring to the table below:

BAI.org Cash Management Balance

Reporting Specifications, page 10

Type Codes Description

001-099 Account status type codes

100 Total Credits summary type codes

101-399 Credit summary and detail type codes

400 Total Debits summary type codes

401-699 Debits summary and detail type codes

700-799 Loan Summary and detail type codes

900-999 Customized Type Codes

Source: BAI.org Cash Management Balance Reporting Specifications, page 10

Customized type codes should fall within the following ranges:

https://www.bai.org/docs/default-source/libraries/site-general-downloads/cash_management_2005.pdf
https://www.bai.org/docs/default-source/libraries/site-general-downloads/cash_management_2005.pdf
https://www.bai.org/docs/default-source/libraries/site-general-downloads/cash_management_2005.pdf
https://www.bai.org/docs/default-source/libraries/site-general-downloads/cash_management_2005.pdf
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Type Codes Description

900-919 Account Status Codes

920-959 Credit Summary and Detail

960-999 Debit Summary and Detail

Source: BAI.org Cash Management Balance Reporting Specifications, page 11

For any codes between the 900-999 range that are continuing to fail, please reach

out to FISPAN support.

Sample data for BAI2 code 389

Save the Code Details

Once you have entered the missing BAI2 code information, click Save on the Format

Profile.

IMPORTANT: NetSuite will attempt to re-import bank transactions, but they will

not yet appear on the Match Bank Data page. You will still need to retrieve the

Statement IDs and contact Support with affected dates to request a re-sync.

https://www.bai.org/docs/default-source/libraries/site-general-downloads/cash_management_2005.pdf


Retrieving Statement IDs from Execution Logs

In the case of a failed import, you will need to retrieve Statement IDs from the Execution

Logs from either the Connectivity Method or the Transaction Parser prior to reaching out to

our Support Team to resync transactions.
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Locate the Financial Institution 

Navigate to Setup → Accounting → Financial Institution.

Click Edit on the Financial Institution that you have created previously.

Select the Format Profile: Configuration tab and click on the Name of the Format

Profile you have created previously.

Open Transaction Feed

On the Format Profile, under Connectivity Method, click the hyperlinked Bank

Transaction Feed, and open it in a new browser tab.

Under Transaction Parser, also click the hyperlinked Bank Transaction Feed and

open it in a new browser tab.

NOTE: NetSuite will only store 30 days' worth of Execution Logs and, by default, will

only display the past 24 hours' worth of logs.



3

Hyperlinked Connectivity Method and Transaction parser

Locate Execution Logs

In both of the new tabs that were opened for the Connectivity Method and 

Transaction Parser, click the Execution Logs tab in the sub-menu. 

Connectivity Method (Financial Institution Connectivity) Execution Logs



Transaction Parser (Financial Institution Parser) Execution Logs

The Statement IDs, Account IDs, and Number of Transactions should be identical

between both the Connectivity Method and Transaction Parser. Each row

corresponds to a bank account linked with the new bank feeds service. 

Unable to see Execution Logs?

If you are unable to see any Execution Logs from the past 24 hours, you will need to add a

Date filter as a Custom View. Please note that any logs that are older than 30 days are not

stored by NetSuite.

1 Customize View

NOTE: The Connectivity Method (Financial Institution Connectivity) downloads

bank transactions from . The Execution Logs here will display any errors

relating to connectivity issues with .

FISPAN

FISPAN

The Transaction Parser (Financial Institution Parser) pushes the downloaded

bank transactions from  into the Match Bank Data page in NetSuite. The

Execution Logs here will display any errors relating to missing BAI2 codes or

other formatting issues in the bank transaction data.

FISPAN
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From the Plug-In Implementation page that you were on for either the Financial

Institution Connectivity or Financial Institution Parser, click on the Customize View

button. 

Click on Customize View

Create Custom View 

On the Customize Script Server Script Log Search Results page that just opened,

rename the Search Title to [BANK] Bank Feeds - Execution Log Dates . 

Next, click on the Available Filters sub-tab.



Rename the Search Title, then click on Available Filters

Click the dropdown in the last row of the table. Select a Date from the options.

Custom Default Script Notes View - filter by Date

Once you have added the Date, click Save. 
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This Custom View will now be available on both the Financial Institution Parser and 

Connectivity Method logs.

Access the Custom View

Clicking Save will take you back to the Plug-In Implementation page. 

From here, click on the Execution Log tab. 

Date filter applied

There will be a new option under the View dropdown, which is the Custom View you

have just created. When the new Custom View is selected, a Date filter will now

appear.

Locate Execution Log

Using the new Date filter, find the date the error occurred on. This should be the

same date you are missing transactions for. 

Once a date within the past 30 days has been selected, the table will populate with

several rows containing Statement IDs, Account IDs, and the Number of Transactions

for every bank account linked with the bank feeds service for the selected date.



Execution Log tab

Copy the contents of the whole table and paste into an email addressed to 

. Ensure the following is included in your messageFISPAN Support

Execution Log table contents (containing Statement IDs from impacted

accounts)

The date the import failed

The date of the transactions that are missing

With this information, our  will be able to retrieve your missing

transactions and resync them as part of your next morning's automatic import.

FISPAN Support

FAQs

I want to change the time of day my transactions sync. How do I do that?

If you are on NetSuite 2026.1, navigate to the format profile of your financial institution

record and look for the Import Schedules subtab. There, you can adjust the

frequency, start time, and preferred time zone for your automated imports.



How many days' worth of data does Bank Feeds import upon initial setup?

You can choose exactly how many days of historical data to import (up to 60 days

prior) by setting the Earliest Transaction Date for Import during the setup process. If

you don't set a date, NetSuite will automatically import up to your last 60 days of

historical transactions by default.

Can I change my "Earliest Transaction Date" after I set it up?

Once your format profile is saved and the first import runs, the date you selected is

locked in. If you made an error, you will need to unlink and re-link the bank account to

select a new date.

I set a future start date during setup, but I don't see any transactions yet. Why?

If you set a future date for your initial import, NetSuite will pause your data sync and

wait until that exact date arrives to pull the data. You will not see any transactions flow

into the Match Bank Data page until that scheduled date occurs.

Do I still need to download NetSuite's Bank Statement Parsers bundle to use Bank

Feeds?

No, this solution does not require NetSuite's Bank Statement Parsers bundle. We

recommend users keep this bundle installed so the option to revert your bank feeds

solution to the old one is still available in case.

Since all bank accounts are now matched under one Format Profile on the Financial

Institution, what happens if an import fails on one bank account?

Import failures with Bank Feeds are rare. In the case of failures, NetSuite will not

successfully sync transactions for all linked bank accounts until any errors, such as

missing BAI2 codes, have been resolved, and  has re-triggered a re-import.

Refer to the Troubleshooting section of this guide for more details.

FISPAN



What are the differences in the data in Bank Feeds compared to the legacy Bank

Feeds? 

The new bank feeds use BAI codes, which provide more details for the transaction

types. For example, previously, you would only see debits and credits as transaction

types. In the new bank feeds, you will see more detailed transaction types such as

debits, credits, ACH, transfers, fees, deposits, interest, payments, and checks.

If I need to do a manual import, what statement type can I use? 

If you are utilizing Bank Feeds, you will only be able to use the BAI2 formatting option.

Otherwise, your manual import will fail with the error: "The file could not be imported

because the date is not in the correct format."

Select NetSuite BAI2



2.3.2.2. Setting Up Permissions (NetSuite)

Ensure your users have the correct permissions to access Bank Feeds and are part of the

appropriate audience for the relevant scripts by following this guide.

Confirm User(s) Permissions

Go to Setup → User/Roles → Manage Roles

Go to Manage Roles

Under Manage Roles, select Edit on the role you would like to edit. 

After selecting Edit, go to the Permissions tab → Setup tab. 

Ensure the Permission Financial Institution Records at the level Full.



Financial Institution Records Check

Confirm User(s) Scripts

Navigate to Customization → Scripting → Script Deployment.

Use the following filters:

On the Type dropdown, select Suitelet

On the API Version dropdown, select 2.1.



Script Deployment

Select Edit

Click Edit on customdeploy_fcb_rpt_feed_s,  Transaction Feed ConfigFirst Citizens Bank

Add employee roles by selecting the appropriate employee, department, or role you would

like to assign. Then, click Save.



2.3.2.3.
Adding Accounts to Bank Feeds
(NetSuite)

Use this guide to add and configure Bank Feeds for new accounts. Bank Feeds must be

enabled before completing the following steps. For example, you might have recently

opened a new bank account with the bank and recently added the accounts to the plugin.

Add Accounts to Bank Feeds

Once the bank representative confirms that the new accounts are added to the plugin and

ready for bank feeds, please follow the following steps:

1 Locate the Financial Institution

Navigate to Setup → Accounting → Financial Institution → List (or Search).

List Financial Institutions

NOTE: If your bank requires re-authentication to add new accounts, review the steps

in Plugin Setup -> Installation -> Bank Authentication.



2

3

Edit Financial Institution

Click on the Edit button next to the existing Bank Feed's financial institution.

Edit Financial Institution 

Edit Format Profile

Select the Format Profile: Configuration tab and click the Edit button.
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Edit Format Profile

Go to the Account Linking

Select the Account Linking tab.

Go to Account Linking tab
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You will notice newly added account(s) are visible in the table. Now, click on the

space below the existing Linked GL Account(s) to show a dropdown. 

In this dropdown, select the GL account that maps to this newly added Bank Account.

Repeat this step for all accounts you wish to enable bank feeds for.

Once all bank accounts have been linked, click Save.

Monitor Bank Import Process

From here, the next step is the same as what is described in the Enabling Bank

Feeds procedure.



2.3.2.4.
Excluding Duplicate Transactions
(NetSuite)

Keep your imported bank data clean and accurate by excluding duplicated or unwanted

transactions directly within NetSuite's Match Bank Data page.

1

2

Go to the Match Bank Data

Go to Transactions → Bank → Match Bank Data.

Go to Match Bank Data

Match the Bank Data

Select the appropriate account from the dropdown menu.

Review the transactions under Imported Bank Data for any duplicated transactions

and use the checkmark to select the transaction.
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Match the Bank Data

Exclude Transactions

At the bottom of the Match Bank Data page, you can review all transactions you have

selected. After reviewing the selected transactions, select Exclude.

Exclude Duplicate Transaction





2.3.2.5. Disabling Bank Feeds (NetSuite)

To disable Bank Feeds for your banking institution, please follow these steps:

1

2

Go to the Financial Institution

Go to Setup → Accounting → Financial Institution → List.

Go to Financial Institution

Select the Financial Institution

On the Financial Institution you would like to deactivate, select Edit.
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Select Edit on the Financial Institution

Deactivate the Financial Institution

Select the box next to Inactive and select Save.

Bank Feeds have now been disabled, and NetSuite will not automatically import

transactions.



Select Inactive Checkbox



2.4.Troubleshooting

2.4.1. FAQs (NetSuite)

This page is your go-to resource for quick troubleshooting. We've compiled a list of the

most common errors and frequently asked questions you might encounter when using the 

 in NetSuite, providing you with immediate answers and resolutions.First Citizens Link

Installation &  Plugin Setup

Common Errors

Below is a list of common errors encountered during installation and plugin setup in

NetSuite. Click on any error message to view the cause and immediate troubleshooting

steps for a resolution.

"Setup required"

This error appears in a banner. You can see the banner on the bill payments or any of

the plugin pages.

This error occurs if the plugin has not been fully connected by completing the

installation wizard. Go through the installation wizard again and make sure the token

IDs are present.

This error can also happen if you don’t have currencies or the manage authentication

field enabled. 



"You do not have privileges to view plugin"

This can show up on various pages in the plugin where the current user does not have

permission to access it. 

To fix this issue, you must have a NetSuite administrator or someone with permissions

to configure scripts to assist you with the following steps.
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Navigate to Script Deployments

Go to Customization -> Scripting -> Script Deployments 

Give Access to Suitelets 

Use the following filters:

Select Suitelet in the Type dropdown

Select 2.1, in the API Version dropdown

Click Edit on each of the following script deployment Suitelets you wish to edit:

 Pay BillsFirst Citizens Bank

 Paid Bills HistoryFirst Citizens Bank

 Transfer FundsFirst Citizens Bank

 Transfer HistoryFirst Citizens Bank

 Trans Checks (Positive Pay)First Citizens Bank

 Trans Checks History (Positive Pay)First Citizens Bank

 Balances & TransactionsFirst Citizens Bank

Select the appropriate role, subsidiary, employee, or department you wish to give

access to.

Click Save.



"Cannot find the bundle/SuiteApp on Search & Install / Install button is not visible to

install"

If you see this error, you will need to get in touch with a support agent. It is likely that

your account either:

Hasn’t been whitelisted

Has an incorrect Account ID

Has a bundle/SuiteApp from a different environment

Common Questions

This list provides answers to common questions that arise during the installation process,

to help ensure a smoother setup in NetSuite.

Do we need to update the plugin, or will it auto-update?

Since the plugin does not auto-update, you must update it manually. The update

process depends on how the bank plugin was originally installed.

If the plugin is a SuiteApp: 

1
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3

Navigate to Customization -> SuiteCloud Development -> SuiteApp

Marketplace.

Find and click on the bank SuiteApp tile.

Click the Upgrade button in the top-right corner to begin the update.

If the plugin is a bundle:

1
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Navigate to Customization -> SuiteBundler -> Search & Install Bundles -> List.

Find the bank bundle.

Hover over the green icon next to it and select Update.



I’ve installed the bank plugin, but my colleagues can’t see the plugin?

Permissions must be granted to non-administrators. 

Please refer to the Plugin Access Management step in the Plugin Setup -> Installation

section of this Support Website.

My NetSuite had a Sandbox Refresh, and now I can’t use the plugin. What do I do?

When a Sandbox Refresh occurs, you will need to complete the onboarding process

again. Start by logging into sandbox.fispan.cloud and completing the onboarding

steps again.

Cash Management (Information Reporting)

Common Errors

Below is a list of common errors encountered when using the Cash Management

(Information Reporting) products in NetSuite. Click on any error message to view the cause

and immediate troubleshooting steps for a resolution.

"Bank accounts not mapping"

The error is likely due to one of these reasons:

The system can't access or map the bank account because the information has

not been entered into the NetSuite Chart of Accounts. 

To fix this, first update the plugin.

Then, check your login information before retrying the process.

Bank account information entered does not match the backend setup.

Different IDs and environments that we don’t have access to.



"Account Matching page doesn’t load bank account information"

The error is likely due to one of these reasons:

The connecting user in NetSuite lacks the required permissions (e.g., is not an

administrator).

The Consumer Key and Secret were generated incorrectly.

There are no bank accounts currently configured in your NetSuite environment.

".csv file is not downloading from the Balances and Transactions page"

You may have a pop-up blocker enabled on your browser. Please check if the pop-up

blocker is preventing the download from appearing, and then try again. 

"Account doesn't appear when using NetSuite’s reconciliation feature (Match Bank

Data)"

It looks like the account you're trying to use isn't appearing when you use NetSuite's

native bank reconciliation feature, Match Bank Data.

This usually means the account isn't configured for reconciliation in your Chart of

Accounts. You'll need to edit the account settings to enable the reconciliation feature. 
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Go to Setup -> Accounting -> Chart of Accounts

For the account you need to reconcile, select Edit.

Check the box labeled Use Match Bank Data and Reconcile Account Statement

pages.

Click Save.

After following these steps, the account should now be available when you use the

Match Bank Data feature.



"Manual Match Bank Data Import Failing: The file could not be imported because the

date is not in the correct format."

If you are running into this error message when completing a manual import, select

NetSuite BAI2 as your Export Format instead. 

Select NetSuite BAI2

Common Questions

This list provides answers to common questions that arise when using the Cash

Management (Information Reporting) features in NetSuite. 



Why is my plugin no longer connected in the Production environment?

If you are logged in and the plugin is no longer connected, the NetSuite Production

may have been refreshed. You will need to re-establish this connection. 
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Log in to Production

Log in to  and run through the wizard again. sys.fispan.live

Deactivate Plugin

If the plugin is still showing as Active or Connected, click on the three dots and

select Deactivate.

If you have updated from a Bank plugin version that is older than 2022.2.0, the

updated plugin bundle will come with a premade Integration Record. 

Define New Token

On the Creating a New Security Token step, you will need to define a new Token

ID and Token Secret. 

Please refer to 'Create a New Security Token in the NetSuite -> Plugin Setup ->

Installation section of this support site for instructions on how to do this.

Revoke Old Tokens [OPTIONAL]

After creating the new Access Token, you may revoke the old ones associated

with this bank bundle. 

You can do this by following the steps below:

Navigate to the homepage.

Find the Settings box on the homepage. By default, this is located on the

bottom left.

Click on Manage Access Tokens.

Click Edit beside the Token you wish to revoke.

Click Revoke.

https://sys.fispan.live/login


Why is my plugin no longer connected in the Sandbox environment?

If you are logged in and the plugin is no longer connected, the NetSuite Sandbox may

have been refreshed. You will need to re-establish this connection. 
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Log in to Sandbox

Log in to  and run through the wizard again. sandbox.fispan.cloud

Deactivate Plugin

If the plugin is still showing as Active or Connected, click on the three dots and

select Deactivate.

If you have updated from a Bank plugin version that is older than 2022.2.0, the

updated plugin bundle will come with a premade Integration Record. 

Define New Token

On the Creating a New Security Token step, you will need to define a new Token

ID and Token Secret. 

Please refer to Create a New Security Token of the NetSuite -> Plugin Setup ->

Installation section of this Support Site for instructions on how to do this.

Revoke Old Tokens [OPTIONAL]

After creating the new Access Token, you may revoke the old ones associated

with this bank bundle. 

You can do this by following the steps below:

Navigate to the homepage.

Find the Settings box on the homepage. By default, this is located on the

bottom left.

Click on Manage Access Tokens.

Click Edit beside the Token you wish to revoke.

Click Revoke.

http://sandbox.fispan.cloud/


Why is the Manage Access Tokens link not visible in the Settings box on the Home

Page?

This is likely the result of Token-Based Authentication not being enabled on this

NetSuite Company. 

Please refer to Configure NetSuite Feature of the NetSuite -> Plugin Setup ->

Installation section of this Support Site for instructions on how to enable.

Will I receive an error message if the bank feeds do not import?

No, the plugin itself does not send email notifications or support push notification

messaging. However, the NetSuite admin who set up the bank feeds for clients in

NetSuite can receive email notifications from the native NetSuite account regarding

successful import or failure. Please contact your NetSuite administrator to resolve the

issue.

For multi-entities, can the company name be unique per bank account?

Yes. Contact your bank and ask them to enter a unique Account Holder Name for each

bank account using the details you provide. If there is an entry in the Account Details -

> Account Holder Name field, this name will appear on vendor payments; otherwise, it

will default to the Account Label (i.e., Company Name).

For example, if the umbrella company is ACME Holdings, the name on the payments

would appear as coming from ACME North or ACME South, etc., based on the bank

account used for the payment.

Accounts Payable

Common Errors

Below is a list of common errors encountered when using the Accounts Payable features in

NetSuite. Click on any error message to view the cause and immediate troubleshooting

steps for a resolution.



"You have entered an Invalid Field Value [###] for the following field: [account]."

This is an error generated by NetSuite when the subsidiary on the payee (i.e. Vendor)

does not match the subsidiary the bill is associated with. 

Users are recommended to use the Subsidiary filter on the Pay Vendor Bills page

when paying bills to a specific subsidiary.

Using the Subsidiary filter will also filter out Source Accounts that users want to use

for bill payments in the Confirm Payment window during the final step of making a

payment.

"There seems to be a communication error with the Bank API."

This error can be seen on various pages in the bank bundle, such as the Pay Vendor

Bills page.

This error is likely caused by Multiple Currencies not being enabled on this NetSuite

Company. To confirm whether this is the case, please refer to Step 7 of the NetSuite -

> Plugin Configuration -> Installation and Set-up section of this Support Site for how

to enable this. 

If Multiple Currencies is already enabled, please check the NetSuite Execution Logs by

following the steps below:
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Navigate to Customizations -> Scripting -> Script Execution Logs

Select ALL in the LOG LEVEL filter

Click the DATE/TIME column to reorder the table so that the most recent logs

appear at the top.

Check the SCRIPT and DETAIL columns to see whether the error is related to the

bank bundle and where specifically the error occurred.

If the error appears to be related to the bank bundle, please reach out to support with

a screenshot of the above Script Execution Logs.



Payments not batching

If you see this error, batching may not be enabled. Get in touch with a support agent to

check this for you. 

Address/Location errors when making payments

The Address must appear on both the Bill and the Vendor. If you have updated the

Address on the Vendor already, NetSuite does not automatically update the address on

any open Bills for that same vendor. 

You must go into the open bill(s) and update the address:
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Go to the Bill record

Click the Billing subtab

Select the Vendor address in the Vendor Select dropdown field

Click Edit

Click Save

"Payment request rejected because it failed uniqueness check. We suspect this is a

duplicate payment."

You're seeing this error because you're attempting to process a payment for a bill that

has already been paid using the plugin. Essentially, there is already a payment

recorded against that bill's NetSuite Internal Bill ID. The system is preventing a

duplicate payment.

If you need to void the existing payment and then resubmit it, you must follow a

specific process through the bank plugin. Please refer to the Voiding and Repaying

Bills page within the NetSuite -> Vendor Payables section of this support site for

detailed instructions on how to properly void and repay the bill.



Custom records are not enabled

The bank payment plugin relies on Custom Records to function correctly. We use a

custom record to create and track the bill payment record for you.

If this feature isn't enabled, the plugin cannot create that necessary custom record.

This prevents us from correctly marking bills as paid, which ultimately stops you from

using the plugin altogether.

Enable this feature by following these steps: 
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Hover over Setup

Hover over Company

Click Enable Features

Click the Suitecloud tab

Go to the SuiteBuilder section

Check the Custom Records box



"Please enter value(s) for: Department, Location."

This is an error generated by NetSuite when there is a mismatch between the

mandatory fields required for a Bill in comparison to a Payment. The error may appear

if you try to pay a bill under a different subsidiary than your source (disbursement)

account.

To resolve this, follow these steps:

1 Go to Transaction Forms

Navigate to Customization → Forms → Transaction Forms. 

Navigate to Transaction Forms

Click Edit beside the Bill form you typically use and that is marked as Preferred.
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Click "Edit" for a Preferred Bill form

Locate Department and Location

On the Custom Transaction Form page for the selected Bill form, click on the 

Screen Fields → Main sub-tabs. 



3

Department and Location fields on Bill form

Find the Department and Location fields and make note of whether they have 

Show and/or Mandatory enabled. 

If Department and Location cannot be found under the Screen Fields list, check

the Sublists sub-tab.

Match Bill Form and Bill Payment 

Navigate back to the Transaction Forms page, and click Edit beside the Bill

Payment form you typically use and that is Preferred. 



Click "Edit" on a "Preferred" Bill Payment form

On the Custom Transaction Form page for the selected Bill Payment form, click

on the Screen Fields → Main sub-tabs. 

Like with the Bill form previously, find the Department and Location fields.

Check if Show and/or Mandatory is enabled and whether they match the Show

and Mandatory selections on the Bill form.



Department and Location fields on Bill Payment form

Make the appropriate changes on the Show and Mandatory fields on 

Department and Location on the Bill Payment form to match the same field

selections for Show and Mandatory fields on Department and Location on the

Bill form.

Common Questions

This list provides answers to common questions that arise when using the Accounts

Payable features in NetSuite. 

Can I pay multiple invoices in one payment rather than making a payment for each

invoice?

Yes, you can enable this feature by going into the Vendor, selecting Edit, and ticking

the box for Group Bills for Payment under the Bank tab. This feature will group all

selected bills for a single vendor into one lump sum payment.



Why does the Payment Status of a failed bill stay as Processing?

This Processing status can take between 3 to 4 business days to clear, even if the bill

payment has failed. If the bill appears again on the Open Bills tab on the Pay Vendor

Bills page, you may safely retry this bill payment. 



Why is my bill still open in NetSuite even though I processed the payment and

received no error message?

If your bill remains open after payment, check these potential causes:

The required bundles, either the Entity Bank Details bundle (ID 323878) or

NetSuite's Electronic Bank Payments bundle, may not be installed. Verify their

installation status.

Your current role might lack the permissions needed for the bank plugin or

associated scripts. See the Plugin Access Management and NetSuite Role

Permission steps in the NetSuite -> Plugin Setup -> Installation section of our

website.

You may be attempting to pay a bill that is locked because the relevant

Accounting Period has already been closed.

To find out if the bill/account is locked:

1

2

3

Open the bill in question

Click the Open Bills tab

The bill will have a lock symbol on the top left corner if the bill is locked,

If the relevant Accounting Period is closed, you should reopen the Accounting Period

by following these steps:

1

2

Go to Setup -> Accounting -> Manage Accounting Periods

Click Edit on the Accounting Period and enable the Allow Non-GL Changes 

option.

Your AP team might have some internal controls over the above Accounting Period

steps. 

Please refer to the Failed Bills page on the NetSuite -> Troubleshooting section of this

support site for more details.



How do I store my vendor payment information?

Download our free NetSuite bundle, Entity Bank Details (ID 323878). If you cannot find

it on the Search & Install Bundles page, please reach out to our support team as you

may need to be whitelisted.

Why doesn't my account appear in the Source Account drop-down menu on the Pay

Vendor Bills page?

Applying this Subsidiary filter on the Pay Vendor Bills page impacts what Source

Accounts are available, as the Source Accounts must be tied to the selected

subsidiary. If no Source Accounts are linked to this subsidiary, no Source Account will

be displayed. 



2.4.2. NACHA 2021 FAQs

Do these NACHA 2021 Data Security Rules apply to me?

Likely not! It is important to note that Phase 1 of this new ruling applies to ACH

Originators and Third-Parties with more than 6 million ACH payments annually. Should

you make more than 6 million payments annually, NACHA will not enforce this rule for

an additional period of one year from the effective date with respect to covered

entities that are working in good faith toward compliance, but that will require

additional time to implement solutions. 

 is investigating potential workarounds with NetSuite to allow clients to proceed

with enabling the NACHA data security changes in the future.

FISPAN

Is my Vendor’s Account information still secure when making payments through my

bank's plugin?

Yes!  utilizes a secure HTTPS connection protocol and completes 0Auth2

authentication with every request for data. This information is then sent from FISPAN

to your bank via SSH File Transfer Protocol (SFTP).

FISPAN

I have already enabled NACHA Rules in NetSuite. What do I do now?

If you’ve already enabled NACHA rules, you will likely experience an error message

when trying to initiate ACH payments through the bank plugin. This is because

enabling NACHA rules results in the encryption of your Vendor’s bank account

information. Without the encryption key, it is unable to decrypt this information, thus

resulting in account numbers appearing as a ciphertext. 

To workaround this, we have created a separate bundle called Entity Bank Details 

(Bundle ID 323878) that allows you to store your vendor’s bank account information.

Please let us know you have enabled NACHA Rules, and we can get you set up to

begin using this bundle.



2.4.3. Failed Bills (NetSuite)

This article serves as a resource to assist you in resolving error messages or issues that

may arise with failed bills.

Error Messages

Why does my Vendor Bill remain open after payment with no error message?

This usually happens when the bill is tied to an Accounting Period that was Locked

before your payment plugin was installed. The plugin is designed to respect pre-

existing locks.

Solution:

1

2

3

Go to Setup -> Accounting -> Manage Accounting Periods.

Click the closed period associated with the bill.

Check the Allow Non G/L changes box and save. This action permits the

payment execution without opening the period for general ledger changes.

Vendor Bills that are associated with an Accounting Period that is locked after the

plugin has been installed will not be impacted.

"Payment request rejected because it failed the uniqueness check. We suspect this

is a duplicate payment."

This occurs when a Bill Payment was previously applied and then manually voided in

NetSuite. NetSuite will allow you to change the data fields on the Vendor Bill, but will

not allow you to change the system-generated Bill ID.

Solution: You must create a brand-new Vendor Bill to process the payment through

the plugin.



"Please enter value(s) for: Department, Class, Location, …."

There is a discrepancy between the mandatory fields required on your Vendor Bill form

and the fields required on your Bill Payment form. NetSuite needs them to match.

Solution:

1

2

Go to both the Vendor Bill and Bill Payment forms and click Customize (top

right).

Ensure that the mandatory requirements for all fields (under Screen Fields and 

Sublist Fields), like Department and Class, are identical on both forms.

Alternatively, remove the mandatory requirement for these fields entirely on both

forms.

"Payment with overridden address cannot be processed. Please update the billing

address fields while the override checkbox is unchecked in all the bills to be

processed for this vendor."

The vendor's address has the Override checkbox enabled on the Vendor record.

Solution:

1

2

3

4

Navigate to the affected Vendor record.

Find the Address sub-tab and click the pencil icon next to the address.

Uncheck the Override checkbox in the pop-up and Save.

If the payment still fails, open the affected Bill, click Edit, and re-select the newly

saved address under the Billing sub-tab to refresh the bill's reference. Save the 

Bill and retry the payment.



"Last attempt failed to deliver with error: FuseException: Failed to send payment

status update to Netsuite with a 400 Response: ... "FAILED_BILL_PAYMENT_VOID",

"message" ... Please enter value(s) for: field "

The payment failed, and the plugin couldn't successfully void the transaction because

a field  (usually the Memo) is marked as mandatory on the underlying Journal Entry

form.

Solution (Modify Journal Form): 

1

2

3

4

Go to Customization -> Forms -> Transaction Forms.

Find and Edit your preferred Journal form.

Click the Screen Fields sub-tab.

Find the field  listed in the error (e.g., Memo). Uncheck the Mandatory box

and click Save.

"The bills you submitted have already been paid through the system. Please contact

support if you need to resubmit these bills for payment."

The system recognizes the bill(s) as previously paid and already having a status of

pending or completed. The system will reject the new request to prevent accidental

duplicate payments.

Solution Options: 

Submit a detailed ticket (reference the vendor, bill ID, amount, and time of the

blocked payment) to the support team. The support team can correct the status

of the previous payment, allowing you to resubmit.

If you need an immediate solution, create a copy of the blocked bill and submit

the new copy for payment.



"You have entered an Invalid Field Value XX for the following field: Account."

This error occurs when the bill(s) selected for payment are linked to a subsidiary that

differs from the subsidiary linked to the NetSuite account used for the payment

attempt.

Solution: To resolve this error, you will need to ensure that the subsidiaries for both

the bills and the NetSuite account match during their payment run.

"You have entered an Invalid Field Value XX for the following field: XXX"

In other cases, where the Account is not mentioned, the error is typically linked to a

specific field on the bill (e.g. you have entered an invalid field value for: Class,

Location, Department, etc). In such cases, the Class, Location, and Department 

inputted on the bill is currently marked as Inactive in NetSuite. NetSuite will prevent

the successful payment of a bill where something inactive has been entered on the bill.

Solution: To resolve this issue, you will navigate to the Class, Department or Location

pages (depending on the error) in NetSuite, click Show Inactive, and temporarily mark

the Class, Department, or Location listed on the bill active (by unchecking the 

Inactive box). Upon saving the changes, the customer can re-process their payments

and then reset the information as Inactive again afterwards. There is no way around

this error, even if the customer opts to no longer show the Class, Location, or 

Department field on their bill, as NetSuite will still store this information on the bill,

producing the same error again.

"You have entered an Invalid Field Value XX for the following field: Vendor."

In this case, NetSuite is preventing payment because the vendor is currently marked

as Inactive.

Solution: To resolve this, simply uncheck the Vendor is Inactive box on the vendor

record to make the vendor active again and retry the payments.



2.4.4.
NetSuite Approval Limitations
(Informational)

NetSuite has a workflow system for creating approvals that may cause issues with the

plugin. Approvals can occur at different stages in the lifecycle of a bill and payment. 

Generally, the Bill Approval workflow is supported by , while the Payment Approval

workflow is NOT supported. Having a Payment Approval workflow will result in a failed bill

payment. Additionally, support for Vendor/Employee Change Approval workflow depends

on your specific configuration. Typically, this workflow might block the Entity Bank Details

Approval functionality.

FISPAN

Unsupported Approvals

Payment Approval Workflow

This approval workflow is NOT supported by  and will result in failed bill payments.

This payment approval flow requires someone to approve each payment, based on rules or

configuration set up in NetSuite.

FISPAN

Why? Without a payment approval workflow, two things happen behind the scenes when a

payment is submitted:

The payment request is sent from NetSuite to the bank for processing.

A Bill Payment is created, marking the bill as Closed. Custom fields on the bill are

updated with the latest payment status information.

However, if the payment approval is set up, the plugin is blocked from creating a bill

payment record in NetSuite, resulting in a failed bill payment. 

NOTE: This page is for informational purposes only and should not be used as a

guide to make changes to the configuration of your NetSuite environment. For

support with your NetSuite native approval flows, please reach out to your NetSuite

consultant directly.



Vendor/Employee Change Approval Workflow

Some clients may have customizations or workflows related to vendor/employee creation,

deletion, or modification. These customizations/workflows may conflict with our Entity

Bank Details Approval functionality, preventing approvers from approving or rejecting

changes made to Entity Bank Details records.

TIP: To identify if your workflow is impacting the plugin, we recommend testing our

plugin functionality in your up-to-date Sandbox environment. This will help determine

if your current vendor/employee change approval workflow affects the plugin.



2.5.Release Notes

2.5.1. Release Notes (NetSuite)

To learn how to update your bundle visit: Updating the SuiteApp (NetSuite)

Also see: Entity Bank Detail Release Notes

2026

May 2026

2026.5.0 - May 13, 2026

Added Bank Accounts Page Enhancements.

Fixed Enhance bank account name tooltips on the Pay Bills page.

New Products Added

We are excited to announce a streamlined UI refresh and enhanced data visibility for our

clients. This update focuses on better organization for diverse account types and improved

NOTE: These updates are part of our May 2026 release. While you may see these

features documented in our guides earlier, please note that all changes will officially

go live on May 13, 2026.



transaction tracking.

The page you know as Balances and Transactions is evolving. To support our expanding

ecosystem of account types, we have rebranded this space to Bank Accounts. This new UI

provides a cleaner foundation for managing multiple financial streams in one place.

Key Benefits and Highlights

1

2

3

4

New "Counterparty Name" Column

To help you identify partners and sources faster, we’ve added a Counterparty

Name column to the Transactions model.

NOTE: This column will appear blank as we are working on extracting out this

information.

 Dedicated Deposit Account Tabs

Organization just got easier. Use the new Deposit Account Type tab to instantly

access all information related to your checking and savings accounts, keeping

them distinct from other account types.

Enhanced Filtering & Search

Stop digging through rows of data. You can now perform targeted searches and

filter your views by:

Bank Reference

Customer Reference

Amount

Description

Post Date

Visual UI Refresh & Country Identifiers

We’ve added Country Images (flags/identifiers) to the account interface. This

allows you to spot the geographic source of funds and account origins at a

single glance, providing better global context for your Treasury team.



Improvements

We’ve fixed a display issue on the Pay Bills page where tooltips for bank accounts with

long names weren't appearing correctly in the Confirm Payment pop-up. Now, when you

hover over a truncated name, the full account title displays clearly, allowing you to verify

your payment details with total confidence before submitting.

Confirm Payment Pop-up

April 2026

2026.4.0 - April 15, 2026

Improved Bank Feeds Update for NetSuite 2026.1.

Updates

We have enhanced our Bank Feeds integration to fully support the new custom scheduling

and transaction import features in NetSuite's 2026.1 release. During initial account setup,

you can now independently select a custom start date to automatically sync up to 60 days

of historical transactions. This update eliminates our previous "tomorrow onwards"



restriction, meaning you no longer need to contact Support to backfill past data.

Additionally, our service seamlessly responds to NetSuite's new custom scheduling,

ensuring your data imports exactly when you need it. For clients still operating on NetSuite

2025.2, our system will automatically sync up to the last 60 days of historical data by

default upon connecting.



2.5.2. Entity Bank Detail Release Notes

To learn how to update the Entity Bank Details bundle visit: Update Entity Bank Details

Bundle (NetSuite)

2026

May 2026

2026.2.0 - May 13, 2026

Improved General improvements and bug fixes.

NOTE: These updates are part of our May 2026 release. While you may see these

features documented in our guides earlier, please note that all changes will officially

go live on May 13, 2026.



3. Intacct



3.1.Plugin Setup

3.1.1. Pre-Onboarding Checklist (Intacct)

Prior to joining an onboarding call, please follow the steps below to ensure that the

installation process runs smoothly. Any missed steps may result in the onboarding call

being cancelled and rescheduled to a later time. 

Bring a Sage Intacct Administrator

Our onboarding calls require a Sage Intacct Administrator to be present, as they will need

to enable a number of settings, create a web service user, install the plugin, and assign

various permissions.

Enable Platform Services

Ensure that the Platform Services module has been enabled on your Sage Intacct

environment. This module allows third-party applications, such as the  to

be installed in your Sage Intacct environment. 

First Citizens Link

The administrator of the ERP should see Platform Services on the menu bar. 



Platform Services enabled

If an administrator is not able to see Platform Services, please contact your Sage Intacct

Account Manager to enable Platform Services on your account. You will not be able to

onboard on the plugin without the Platform Services module. 

Enable Web Services Users

Enabling the Web Services feature on your Sage Intacct account is required to allow the

plugin to communicate with your Sage Intacct environment. 

1 Go to Company → Admin tab → Subscriptions.



2

3

Go to subscriptions

Confirm that Web Services is enabled, then select Done. 

If they are not, select the toggle to enable Web Services. 

Green toggle indicating that Web Services is enabled



Enable Banking Cloud

To utilize the Bank Feeds product, the Banking Cloud will also need to be enabled. 

1

2

3

4

Go to Company → Admin → Subscriptions. 

Confirm that Sage Cloud Services are enabled. If they are not, select the toggle to

enable Sage Cloud Services.

After enabling Sage Cloud Services, hit Configure, and confirm that the Enable Bank

Feeds functionality is checked.

Enable Bank Feeds

Then select Save.

Enable ISO Country Codes



1

2

3

Go to Company. 

Under the General Information section, confirm that ISO Country Codes is checked.

Enable ISO Country Codes

Select Save.

Disable Payment Approvals Inside Intacct 

The plugin does not support Payment Approvals inside Intacct. If you leverage Intacct's

payment approval currently, we strongly recommend moving that process inside the bank

approval portal. 

Continuing to use that process increases the chances that a bill stays open inside Intacct

even though it has been paid already. Navigate to the Intacct Approval Process

(Informational) section of the product guides for more information. 

Confirm Sandbox Testing



All users moving into Production can test the bank plugin in a Sage Intacct Sandbox

environment alongside any customizations or third-party plugins, or applications. This will

ensure a smoother transition onto the bank plugin and help avoid any future disruption to

service.

Please refer to the Sandbox Checklist (Intacct) page for a number of suggested scenarios

to test.

Review Custom Fields

The plugin requires at least 14 custom fields to be available to install within Intacct. Please

ensure you have at least 14 available custom fields to successfully install the plugin. 

This requirement is due to Intacct's limit of 100 custom fields. If further support is needed

in identifying which custom fields can be removed, clients should reach out directly to their

Sage Consultant. Their consultant can provide guidance on the purpose of each field and

whether it can be deleted. 

To review your current custom fields:

1

2

3

Navigate to Platform Services -> Custom Fields

Check the existing fields under Object: AP Bill.

Identify any unused or redundant fields that can be deleted.

Support for Console Environments

TIP: Speak with a  if you do not wish to enable a Sage Intacct

Sandbox environment.

FISPAN representative

NOTE: After completing the prerequisites, proceed to Step 1 in the installation guide

to begin installing the plugin.



The plugin's full functionality is not currently guaranteed for clients operating within a

Multi-Entity Distributed Console or any form of console environment. 

Confirm Hardware & Software Requirements

Browser support (minimum versions):

Chrome: 65

Firefox: 66

Safari: 12

Edge: 79

Operating systems (minimum versions):

Windows 7

macOS - El Capitan

Minimum screen resolution:

1200x800px



3.1.2. Installation

3.1.2.1. Step 1: Enable Web Services

To get started, please contact your Sage Intacct Account Manager to enable Platform

Services on your account. 

Once you have done so, follow the steps below to enable the Web Services feature on your

Sage Intacct account. This is required by Intacct to install a third-party application.

1 Go to Company → Admin tab → Subscriptions.

Go to Subscriptions



2 Confirm that Web Services is enabled, then select Done.

Select Web Services



3.1.2.2. Step 2: Invitation Email

You should have received an invitation email from  with links to install

the  and easy-to-follow instructions for installation.

First Citizens Bank

First Citizens Link

The invitation email will arrive with the following subject line:

Welcome to   - Powered by FISPAN [Production] - [your-name]First Citizens Link

Invitation Email



3.1.2.3. Step 3: Registration & Login

Register & Login

1

2

Create an Account

In your invitation email, select the Get Started button. You will be brought to the 

. Create your login credentials and select Create Account.FISPAN Portal

Passwords are required to be 8 characters and contain at least one uppercase,

lowercase, number and special character

Login to Your Account

Once registered, you will be redirected to the login page. Your username and

password are unique per environment, and you will have separate logins between 

 and .Sandbox Production

NOTE: The password you create here will be used every time you want to

access the . If you need to update it later on, you have the option

to use the Forgot Password option.

FISPAN Portal

https://sandbox.fispan.cloud/login
https://sys.fispan.live/login


The welcome page for Sandbox

From the welcome page, you'll be taken to the login page. Enter your username and

password to proceed. 

Setting Up SMS MFA

The first time you log in to the Production environment, you will be prompted to establish

your Multi-factor Authentication (MFA) setup. You have the option to select various

methods of MFA. 

NOTE: The Sandbox environment is used as a testing or UAT environment. For

Sandbox users, please refer to the Sandbox Checklist for test scenarios.

NOTE: Multi-factor Authentication (MFA) is only required if you are a user in the

Production environment. If accessing the Sandbox environment, you may skip this

step.



1
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Enroll Phone Number

Select your country code then enter your phone number, you will receive a text

message with a 6-digit code via SMS to the phone number you provided for

enrollment.

If you are unable to receive a text message to this number, or you prefer a different

multi-factor authentication method, click Try Another Method. 

Enter Code

Enter the 6-digit code you received in the applicable field.

Select Continue.

6-digit Verification

Save Recovery Code

After setting up SMS and inputting the first one-time code, you will be presented with

a recovery code that should be stored in a safe location. This code is for resetting the

MFA, to switch the MFA type (i.e., Authenticator), or to use a different phone number. 



Recovery Code

If you would like to utilize another method for MFA (SMS, Authenticator, or Email)

instructions are available here: . Setting up Multi-Factor Authentication



3.1.2.4. Step 4: Select ERP

Select Install on the Intacct ERP box and the installation wizard will appear on your screen. 

Select Install



3.1.2.5. Step 5: Overview

The first page of the installation wizard provides a brief summary. Before you continue, you

must review and complete the pre-onboarding checklist.

When you're finished, click the toggle next to "I have completed the pre-onboarding

checklist." This will activate the Get Started button.

To proceed to the next step, click Get Started.

Select Get Started



3.1.2.6. Step 6: Permissions

To establish a connection between your bank and Sage Intacct, you must agree and grant

access by toggling the slider. 

Review the Permissions and then click the "I agree" toggle

Once completed, click Next.

To display account balances and transaction information, the plugin requires read access

to Intacct financial data but only modifies its own designated custom fields.

NOTE: Your permission list, found in your ERP, may contain more fields than the

example shown.



3.1.2.7. Step 7: Web Services Authorization

Authorization to the Web Services feature should be done in Intacct using the following

steps.

1

2

Go to Company

Company → Setup → Company.

Go to Company tab

Authorize Web Services

Under the Security in the Web Services Authorizations section, click Edit at the top

right and then click Add to add each of the following Sender IDs:

ajax

FI.SPAN MPP



Add Sender IDs

Then, click Save.

NOTE: The Sender IDs are case-sensitive.



3.1.2.8. Step 8: Create Web Service User

To ensure that the plugin is able to communicate with Sage Intacct, a Web Service User

needs to be created in Intacct before continuing with the next step. 

1

2

Go to Web Service Users

Go to Company → Admin tab → Web Service Users.

Go to Web Service Users

Add New Web Service User

Select Add to create a new Web Service User, then fill in the required fields:

User ID: Anything that will help you easily identify your users.

User type: Business

Admin Privileges: Full

Contact Name: Associate this Web Services User with a Contact of your

choosing 



Create Web Service User

Please note that the Contact selected within the Contact Name field must have a

First and Last Name. 

If you do not already have a Contact to choose from, you may create one by clicking

on the drop-down, then Add.

NOTE: An alert will appear, stating: "Check license availability before adding

users." 

It is recommended to validate this with your Sage Intacct representative.



Add a Contact, if one is not available

After clicking Add, fill in the following fields on the Contact Information tab of the

Contact Information window:

Last name

First name

Primary email address

Suggested contact name

Print as



3

Contact Information window

Then, click Save.

Complete Web Service User Form

On the Web Services user information page, the following fields will be auto-

populated from the chosen or newly created Contact.

Last Name

First Name

Email Address



Completed Web Services User form

Then, select Save.

NOTE: You will receive an email from Sage Intacct with the credentials. We

recommend saving the Web Service User credentials as they are required in the

installation wizard. 



3.1.2.9.
Step 9: Enter Web Service User
Credentials

Return to the installation wizard and type in the credentials you received in the previous

step. 

Enter Credentials

Then, select Next Step.

IMPORTANT: Please make sure you use the Web Service User credentials and not

the Sage Intacct login (normal user) credentials. 



3.1.2.10. Step 10: Install Plugin

This next step guides you through installing the plugin with the installation wizard.

1

2

Install the Plugin

Select the Start Automatic Install button. 

Install the Plugin

This will automatically install the plugin for you. 

If the installation fails, a clear reason for the failure will be provided.

Occasionally, the application may fail to install due to the unavailability of Sage

Intacct servers. 

In such cases, we recommend a manual installation by downloading the XML file

from the error page and then placing it inside Intacct's Platform Services →

Applications → New Application.

Successful Install



After the application has been successfully installed, click on Next Step.

Manual Install

If automatic installation fails, you can manually install the plugin by downloading the plugin

XML file using the link in the installation wizard. 

1
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Download XML File

From the error page displayed in the installation wizard, select here to download the

XML file.

Once the XML file pops up, save it to your computer. 

Go to Applications

In Intacct, go to Platform Services →  Applications.

Go to Applications

Install From XML

Then, select Install from XML.



Select Install from XML

Upload the application XML file by selecting Choose File. 

Select the XML you just downloaded from the installation wizard, and click Install.





3.1.2.11. Step 11: Set Permissions for a Role

Now that the plugin has been installed, you can start assigning permissions to your roles in

Intacct by following these steps.

1

2

Go to Roles

In Intacct, go to Company → Admin tab → Roles.

Go to Roles

Assign Permissions 

On the  role, select SubscriptionsFirst Citizens Bank



Select Subscriptions

Select Permissions to enable permissions accordingly for each of the following:

Company: Transaction Currencies (List, View), Entities (View), Funds/Locations

(View)

Cash Management: Checking Accounts (List, View), Savings Accounts (List,

View), Credit Card Accounts (List, View)

Accounts Payable: All Permissions

General Ledger: All Permissions

: All PermissionsFirst Citizens Bank



List of Sys Enterprise roles



Then, select Save.

Common Errors

If you receive an error message, please confirm that you have granted the 

appropriate Cash Management permissions to the Web Service User’s role subscription.

If you do not use roles inside Intacct, simply head over to the users and web

service user, click Subscriptions, and grant them the following permissions: 

Cash Management: Checking Accounts (List, View), Savings Accounts

(List, View), Credit Card Accounts (List, View)

Accounts Payable: All Permissions

Company: Transaction Currencies (List, View), Entities (View),

Funds/Locations (View)

General Ledger: All Permissions

: All PermissionsFirst Citizens Bank

List of web services users



Account Matching - "Error loading bank accounts" error message

You may receive an error like the following: "You do not have permission for the API

operation READ_BY_QUERY on objects of type trxcurrencies."



You do not have permission for the API operation READ_BY_QUERY on objects of type

trxcurrencies. 

This error means you need to adjust the role permissions for the user who encountered the

issue. This affects the user role/permissions and NOT the Web Service User. 

For the affected user, please navigate to their role permissions and add the following:

Company → Transaction Currencies (List, View).



Adding Transaction Currencies permissions



3.1.2.12.
Step 12: Assign Role to Web Service
User

In Intacct, go to Company → Admin tab → Web Service Users. 

Go to Web Service Users

Then, select Edit on the Web Service User you would like to edit.

Under the Roles Information tab, add the following roles:

::SYS::Enterprise-ROLE-FOR – Module: First Citizens Bank

Then, select Save and enter your account password.



Web Services User Infomration - Roles information tab



3.1.2.13. Step 13: Assign Role to User

In Intacct, go to Company → Admin tab → Users. 

Go to Users

Then, click Edit on the User you would like to edit.

Under the Roles Information tab, add the following roles:

::SYS::Enterprise-ROLE-FOR – Module: First Citizens Bank

Then, select Save and enter your account password.



Add <Bank Plugin Service> Role



3.1.2.14. Step 14: Connection Status

Here, the installation wizard will begin to run a connection check to validate all details

entered in the previous steps and ensure that all permissions are correctly set up.

If there are no issues, a large green checkmark will appear to confirm that the connection

has been established. 

Connection Status

Click on Next Step to begin matching bank accounts.

Failed Connection Checks

If any permissions are missing, a red X will be displayed, as shown in the screenshot

below, along with a clear explanation of the failure.



Failed Connection Check



3.1.2.15. Step 15: Account Matching

Matching Accounts
The next step in the installation wizard is to match your ERP Accounts to the corresponding

Bank Accounts.

1

2

Match Accounts

Drag an ERP Account from the left column and drop it onto the desired Bank Account.

Continue until all accounts are matched.

Select Default Account

To select your preferred default account, hover over the desired source account and

click the star icon. This sets the default selection in the source account dropdown

(you can change it anytime in the Account Matching screen here).

Account Matching - ERP Accounts and Bank Accounts 

Once you've successfully matched your accounts, click Next Step.



NOTE: When installing the plugin in Sandbox, the Bank Account ending in 1133 is

used for testing purposes ONLY. This account is not linked to any of your live

accounts with your bank. 

When installing in Production, the Bank Accounts listed will reflect your accounts set

up for use with the plugin.



3.1.2.16.
Step 16: Set Default Payment
Information

Setting a default payment method per vendor will save you significant time by

automatically pre-filling the payment type for all future transactions.

Use the steps below to select a default payment method for each vendor.

1

2

﻿In Intacct, go to Main Menu → Payment Methods Tab.﻿

Go to Payment Methods

Select the appropriate payment method from the Default Payment Method drop-

down menu.



Select a Default Payment Method

NOTE: You will only see the payment methods currently configured for both

your plugin and the specific vendor. If a payment method is missing from the

list, you must either add it to the vendor record or contact your  to

have it added to the plugin setup.

Sales Officer



3.1.2.17. Step 17: Store Vendor ACH Information

The plugin uses the Bank File fields when submitting ACH payments to vendors. The

instructions below show you how to enter this required information for your existing

vendors.

Before you begin, ensure you have permission to edit vendor bank details:

1

2

3

4

Go to Company → Admin tab → Roles. 

Then, select Subscriptions on the role you would like to edit. 

Select Permissions on the Accounts Payable Module, and check all the boxes

for Vendors (This includes List, View, Add, Edit, Delete, and Bank Details). 

Then, select Save.

Enter Vendor ACH Information

1 Go to Vendors

Navigate to Accounts Payable → Vendors and select Edit for the desired vendor.



2

Go to Vendors

Enter Vendor Details

Under the Vendor tab, enter the Vendor’s Address, City, State, Zip Code,

and Country.

Enter Vendor Details



3

4

Enable ACH Payments

Select the Bank file tab to access the vendor ACH information.

Scroll down to the Enable Setup section and select Enable ACH Payments.

Add ACH Information

The ACH Payments section will appear. Enter the Routing Number, Account

Number, Account Type, and Account Classification. 

Enter ACH Payment Information

Then, select Save. ACH will now be an available payment method for that vendor.



IMPORTANT: When you first begin using the plugin, it automatically syncs the

vendor's default payment method from the native Intacct record, but only if the

method is set to ACH or CHECK. The plugin also ensures this default is synced

when you create a new vendor.

In all other cases, the plugin will NOT be syncing the default payment method.

If you would like to change the default, follow the previous step, "Set default

payment information." This default can also be updated via CSV in a single

upload for all your vendors. 



3.1.2.18.
Step 18: Store Other Vendor Payment
Information

If applicable, you can add additional payment information within the plugin's Payment

Methods page by following the steps in this guide.

Only payment methods set up in your plugin and assigned to the specific vendor will be

visible. If a method is missing, please add it to the vendor or reach out to your 

to have it added to the plugin.

Sales Officer

Store Vendor Payment Information

Follow these steps to start storing any additional vendor payment information.

1 Go to Payment Methods 

In Intacct, go to Main Menu → Payment Methods tab

Go to the Payment Methods Tab



2 Add Bank Account

Select Edit on the vendor for which you would like to add payment information. Here,

you can choose to Add Bank Account, Add Address, or Add Email Group.

Click "Add Bank Account"

Click Add Bank Account.

Here, you will see another pop-up window titled "Payment Information: [VENDOR

NAME]" that will prompt you to enter a Country and Currency.
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Define a Country and Currency

Enter the Country and Currency for this vendor, and click Continue to Bank Details.

Add Account Details

On the Account Details pop-up, you will be prompted to fill in several fields. Please

refer to the Payment Requirements section of this Product Guide for required fields,

depending on the payment method you wish to use to pay your vendor.
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Enter required bank details

Validate Account Info

After filling in the required fields or additional fields provided by your vendor, click 

Validate Account Info.

The system may take a minute or two to validate your inputs. 

If validation fails, error messages will appear indicating any missing bank details

needed to activate certain payment methods. Review these messages carefully, then

click Return to Account Details to make further changes to bank details

If validation is successful, a confirmation message will display along with the number

of payment methods now available for paying this vendor, based on the bank details

provided. When you're ready, click Save Account with Eligible Payment Methods to

finalize.

NOTE: Depending on the country and currency selected, as well as the number

of fields completed on the Account Details screen, you may be eligible to pay

the vendor using various payment methods. In previous versions of the

Payment Methods page, you were required to first choose whether a payment

was international or domestic—this is no longer necessary.
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The "Payment Setup: [VENDOR NAME]" window will refresh and display the newly

added Bank Account details. 

Select Default Payment Method

Here, you can define a default payment method for this Vendor by clicking on the 

Select Method dropdown for the Default Payment Method field.

Payment Setup: VENDOR NAME window

Any changes to toggles (i.e., Combine Multiple Invoices) or the Default Payment

Method drop-down on the "Payment Setup: [VENDOR NAME]" window are saved

automatically. When you're happy with your changes, click outside the window or

use the back arrow in the top-left corner to close it.

TIP: The plugin supports importing vendor payment information via CSV,

allowing for immediate mass updates across all vendors. Use the Updating

Vendors via CSV guide for more information.



3.1.2.19. Step 19: Enable Bank Feeds

By enabling Bank Feeds for the plugin, your bank establishes a reliable and secure flow of

transactions from your bank into Sage Intacct’s Reconciliation module.

Bank transactions that settled the previous day are imported each morning. For example,

transactions that are settled on Tuesday will be pushed into Sage Intacct early on

Wednesday morning. The exact timing can vary depending on when your bank sends the

first transaction file (PDR).

Step 1: Locate the Account

Go to Cash Management → Checking.

Go to Checking

On the Checking page, select Edit on the account you wish to turn on Bank Feeds for.



Select Edit

Step 2: Activate Bank Feeds

Under the Banking Cloud tab, click Connect.



Connect Banking Cloud

In the search bar, search " " or select  - Powered by

FISPAN from the list of banks already displayed.

First Citizens Bank First Citizens Bank

Search for First Citizens Bank

Agree to conditions and select Continue. 



Agree to Conditions

You will be redirected to a landing page that will require you to sign in to the FISPAN

Wizard.

Select Login Now.

Select Login Now



Step 3: Match Account for Bank Feeds

After logging in, select the account from Step 1, then select Save and Finish. You will

automatically be redirected back to Sage.

Select Account

After being redirected back to Sage, select the same account and click OK.



Click Ok

Choose the date you want transactions to start from.

Choose Date



Step 4: Confirm Bank Feeds

Select Confirm to confirm the activation of Bank Feeds. Once the connection is

successful, the status will change to Connected.

Confirm Bank Feeds

NOTE: You must complete account matching within 60 minutes; otherwise, the

installation wizard will time out, the connection will fail, and the account will remain 

Pending with no transactions coming in. 

To retry, disable the account(s) under the Accounts table and reinitiate the mapping

process.

NOTE: If you are processing more than 100 transactions, we advise you to wait until

the next day to see the transactions posted.



Once the account is Connected, go to Cash Management -> Reconciliation -> Bank and

follow your native reconciliation process. 

Set Up Multi-Account Bank Feeds

Bank Feeds allows you to connect multiple accounts to the plugin. Once one bank account

has been connected to Bank Feeds by following the Enabling Bank Feeds page, other

accounts can be connected simultaneously through a financial institution connection.

Follow the steps below to set up multiple accounts for Bank Feeds.

1 Set up a Financial Institution

Go to Cash Management → Set up → Financial Institution and create a new

Financial Institution.

NOTE: If the account is in Pending status, it means that the transactions have not

been pushed for this account. You will need to wait until the transactions are

successfully pushed to this account before seeing it marked as Connected. 

NOTE:  Before you set up the Financial Institution, ensure that both Cash

Management and Sage Cloud Services are enabled in the Subscriptions section. In

the Sage Cloud Services configuration, confirm the Enable Bank Feeds checkbox is

checked as per the Enabling Bank Feeds page.

If this does not work, please contact Sage support and ask to get access to the

Financial Institution.
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Set-up Financial Institution

This allows you to create a connection to the bank. Create the ID and Name as

desired.

Create Financial Institution

Map Accounts for Bank Feeds



Select Map Accounts and choose which accounts you would like to enable on Bank

Feeds.

Map Accounts

If there are more than 100 transactions, the plugin will upload them into the system in

batches of 100. This may cause some transactions to appear initially, while others will

appear later. Typically, it takes a few hours to view all your transactions.

NOTE: You must complete account matching within 60 minutes; otherwise, the

installation wizard will time out, the connection will fail, and the account will

remain Pending with no transactions coming in.

To retry, disable the account(s) under the Accounts table and reinitiate the

mapping process.



Map Accounts

After mapping the accounts, the Banking cloud statuses can be seen in the Accounts

tab.

Account Status



To view your account information, click Bank Transactions in the Cash Management

module. You can also view this information through the Reconciliation module. 

Observe Bank Transactions



3.1.3. Post-Onboarding Checklist (Intacct)

You are almost ready to use the plugin. There are a few additional steps required to use the

product to its full potential. Review all items in this guide to ensure you are not missing

anything.

Grant Permissions

To ensure users can view and utilize the plugin, a Sage Intacct administrator must grant

them permission. You can follow , 

 and  to enable permissions.

Step 11: Set Permissions for a Role Step 12: Assign Role

to Web Service User Step 13: Assign Role to User

Enable All Payment Methods

If you require payment methods that are not currently displayed on the Pay Page, please

contact your bank relationship manager.

They can initiate the process of adding other payment methods, which is typically fast and

straightforward. Do not hesitate to contact our support team if you encounter any issues

during or after this process.

Once the new payment method is set up, you will be able to add the necessary vendor

details to the Payment Method’s Page for each vendor you wish to pay using that new

option. This process is explained in more detail in the following sections.

Store All Check & ACH information in Intacct

Sage Intacct natively stores both ACH and CHECK payment information. You can modify

this information directly within the vendor record.

NOTE: For Sandbox users, feel free to skip the steps that may not apply to your use

case. We strongly recommend following the . Sandbox Checklist (Intacct)



Confirm you have added the required information:

CHECK: A valid address must be present on the vendor record.

ACH: Valid bank information must be entered within the Bank File section of the

vendor record.

The payment method dropdown in the plugin will display ACH and CHECK options if both

of the following conditions are met:

1. Both methods have been enabled by the bank (refer to the Enable All Payment

Methods section of this guide).

2. There is sufficient and valid information in the corresponding Sage Intacct vendor

record (as outlined above).

Add Additional Payment Information

Are you looking to add other payment methods than CHECK & ACH? The plugin offers a

secure and reliable way to store that information.

To learn how to add this information, read the guide: 

. Alternatively, you can save time by performing a simple CSV import using the

steps in ). This method takes only minutes and

updates all vendor records at once.

Step 18: Store Other Vendor Payment

Information

Updating Vendors via CSV (Intacct)

Set up Vendors' Default Payment Method

The final post-onboarding check is setting up your vendors with a default payment method

enabled.

You can do this manually by navigating to Plugin -> Payment Methods, clicking Edit on the

right, and selecting a default option from the list of available payment methods.

TIP: You can also mass import this information natively by following this guide: 

.Updating Vendors via CSV (Intacct)



Modifying the default payment method

If you prefer to perform this action via a CSV import, that is also possible. Follow the steps

explained in  to set up default payment methods for all

your vendors.

Updating Vendors via CSV (Intacct)

Add Bank Accounts to Bank Feeds

If you would like to receive a daily push of bank transactions inside the reconciliation

module of Sage Intacct, we recommend setting up bank feeds. The setup process takes

minutes and allows you to set up all of your accounts at once.

Follow  for more information. Step 19: Enable Bank Feeds



3.1.4. Sandbox Checklist (Intacct)

If you're testing the plugin in a Sandbox environment, it's recommended to test a variety of

scenarios. This will help you confirm that your setup is properly supported and functioning

as expected.

Scenarios to Test

Below is a list of scenarios you may wish to test. 

1

2

Vendor Setup

Modify or create two vendors: one listed as a company and the other as an

individual. The vendors should have bank details (under 'bank file') and a complete

address set up. Additionally, a default payment method can be configured within

Intacct.

Expected Outcome: These two vendors will be used when testing bill payments and

positive pay transmissions. Both vendors should appear in the Payment Methods tab

of the plugin. If any ACH information has been populated in Intacct, it will be visible in

this Payment Methods section (click Edit to view it).

If a default payment method has been set, it will also appear on the vendor record

within the plugin.

ACH Bill Setup and Payment

Verify that each vendor you test has a US address and ACH payment details entered.

Create a bill, ensuring all mandatory fields are populated.

1. Go to the Pay Bills page in the plugin.

2. Select the bill you just created.

3. Select ACH as the payment method (skip if ACH is set as the default).

4. Click Pay. 



3

4

Expected Outcome: Once the payment is successfully sent, it should disappear from

the Open Bills tab on the Pay Bills page. 

If the payment remains on the page, go to the Failed Bills tab on the same screen, or

view the payment status in the History page of the plugin.

Check Bill Setup and Payment

Verify that each vendor you test has an address and payment details entered.

Create a bill, ensuring all mandatory fields are populated.

1. Go to the Pay Bills page in the plugin.

2. Select the bill you just created.

3. Select Check as the payment method (skip if Check is set as the default).

4. Click Pay. 

Expected Outcome: Once the payment is successfully sent, it should disappear from

the Open Bills tab on the Pay Bills page. 

If the payment remains on the page, go to the Failed Bills tab on the same screen, or

view the payment status in the History page of the plugin.

Discount Setup and Payment

Verify that the plugin correctly applies a vendor discount during the bill payment

process. 

First, in Intacct, create a bill, filling in all mandatory fields and ensuring a valid

payment term (with a discount) is selected. If a suitable term doesn't exist, create

one under Accounts Payable -> Setup -> More -> Terms.

Then, on the plugin's Pay Bills page:

1. Select the bill that was created and choose the payment method (if no default).

2. Confirm the discount amount is populated (adjust the discount date by clicking

the amount if necessary).

3. Click Pay.

Expected Outcome: Once the payment is successful, the bill should disappear from

the Open Bills tab. If the payment remains on the page, go to the Failed Bills tab to
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find if the bill failed. 

Navigate to the plugin's History Page and verify that the Paid Amount correctly

reflects the discount term deduction.

Adjustments Setup and Payment

Verify that the plugin correctly applies a debit adjustment (credit memo) during the

bill payment process.

In Intacct, go to the Bill page and create a new bill, filling in all mandatory fields.

Create an Adjustment (credit memo):

1. Navigate to Accounts Payable -> Adjustment.

2. Create a new Adjustment, ensuring the type is Debit Memo.

3. Complete all required fields.

Go back to the Adjustments page and confirm that the new debit memo appears in

the list.

Expected Outcome: The bill should disappear from the Open Bills tab upon

successful payment. If the payment remains on the page, go to the Failed Bills tab to

find if the bill failed. You can also view payment status in the History screen of the

plugin. 

To complete the test, verify the following:

From the History page, verify that the bill's Paid Amount correctly accounts for

the adjustment. 

Return to the plugin's Pay screen (or vendor detail). Verify that the Credits

Available balance has been correctly reduced by the amount you applied to the

paid bill. 

Failed Bills

All bills will automatically show as successful after clicking Pay. To test the process

for a failed bill, create a bill of $1991.00. Pay this bill on the Pay Bills screen.

Expected Outcome: The bill should automatically fail and remain on the Open Bills

page. An error message should also appear on the Failed Bills screen.



The bill's status should remain Posted.



3.2.Configuration

3.2.1.Plugin Management

3.2.1.1. Mapping Bank Accounts (Intacct)

Once the  installation and setup are completed, you are still able to map

any new bank accounts that are added to the plugin. 

First Citizens Link

Navigate to Accounts

1 Log in to FISPAN Portal

Head to the   or the  you used to register for an

account with  when you installed the plugin.

Production Portal Sandbox Portal

FISPAN

https://sys.fispan.live/login
https://sandbox.fispan.cloud/
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Go to the Portal

Log in to the portal with the email and password you used to register.

Log In

Go to Accounts

Select Associate Accounts and map the accounts you would like to map.



Select Associate Accounts

Matching Accounts
The next step in the installation wizard is to match your ERP Accounts to the corresponding

Bank Accounts.

1

2

Match Accounts

Drag an ERP Account from the left column and drop it onto the desired Bank Account.

Continue until all accounts are matched.

Select Default Account

To select your preferred default account, hover over the desired source account and

click the star icon. This sets the default selection in the source account dropdown

(you can change it anytime in the Account Matching screen here).



Account Matching - ERP Accounts and Bank Accounts 

Once you've successfully matched your accounts, click Next Step.

Map Additional Accounts or Change Existing Mapping

To map any additional accounts or alter an existing mapping, you would need to go to 

 and log in. sys.fispan.live

Once logged in, you can click on the three dots on the top right of the Sage Intacct® tile

and click on Associate Accounts. This will open the Account Matching screen, where you

can map any additional accounts or alter the existing mapping.

NOTE: When installing the plugin in Sandbox, the Bank Account ending in 1133 is

used for testing purposes ONLY. This account is not linked to any of your live

accounts with your bank. 

When installing in Production, the Bank Accounts listed will reflect your accounts set

up for use with the plugin.

https://sys.fispan.live/login


Select Associate Accounts



3.2.1.2. Updating the Plugin (Intacct)

Keeping the  up to date with the latest version is crucial for ensuring you

have access to all the newest features, important bug fixes, and updates. To update,

please follow these steps.

First Citizens Link

1

2

3

Log In to FISPAN Portal

To update the plugin in your Production environment, please go

to   and log in.﻿sys.fispan.live

If you are updating the plugin in your Sandbox environment, please go

to   and log in.sandbox.fispan.cloud

Update Plugin

Select the 3-dot action button in the top right corner of Intacct. Then,

select Update in order to update the plugin.

Select Update

Automatically Install 

https://sys.fispan.live/login
https://sandbox.fispan.cloud/


To install the updated plugin, select the Automatic Install button. 

Select Automatic Install

You have now successfully updated the plugin!

Manual Install

If automatic installation fails, you can manually install the updated plugin by downloading

the plugin XML file using the link in the installation wizard. 

1

2

Download XML File

From the error page displayed in the installation wizard, select here to download the

XML file.

Once the XML file pops up, save it to your computer. 

Go to Applications

In Intacct, go to Platform Services →  Applications.
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Go to Applications

Install From XML

Then, select Install from XML.

Select Install from XML



Upload the application XML file by selecting Choose File. 

Select the XML you just downloaded from the installation wizard, and click Install.



3.2.1.3. Uninstalling the Plugin (Intacct)

To disconnect from the plugin, follow the steps in this guide.

1

2

Disconnect Intacct from Plugin

Log in to  using your  credentials.https://sys.fispan.live/login FISPAN Portal

Click on the three dots on the top left of the box titled 'Intacct'. In the drop-down

menu, click Deactivate.

Click "Deactivate" in the drop-down menu

Remove the Application from Intacct

Log in to Intacct and navigate to Platform Services → Applications.

https://sys.fispan.live/login


Navigate to "Applications" in Intacct

Find your bank plugin in the Custom Applications list. Click Edit beside your bank

plugin.

Click "Edit" beside your bank plugin

Under Deployment Status, unselect the checkbox This application is deployed.



Unselect "This application is deployed"

Select Save at the top right. 

After unselecting "This application is deployed", click Save

Select Del beside the bank plugin and confirm the deletion.
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Click "Delete" beside the bank plugin

The plugin will disappear from the Intacct environment. 

Remove Smart Rules

Navigate to Platform Services -> Smart Rules
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Navigate to "Smart Rules"

Remove any Smart Rules containing your bank plugin name by selecting Delete.

Click "Delete" beside bank plugin-related smart rules

Remove Smart Events

Navigate to Platform Services → Smart Events



Navigate to "Smart Events"

Look up any events containing your bank plugin name and select Delete.

Click "Delete" beside bank plugin-related smart events

You've successfully disconnected your Intacct environment and completely removed

the plugin!





3.2.1.4.
Intacct Approval Process
(Informational)

Sage Intacct has two known base approval processes: Bill Approval and Payment Approval.

It is crucial to understand how each interacts with the .First Citizens Link

The plugin provides support for Sage Intacct native configurations regarding Bill Approvals;

however, Sage Intacct's Payment Approvals are not supported, which may lead to

unforeseen issues in payment processing.

Viewing your Configuration

You must have sufficient permissions in Sage Intacct to view if you have approvals

enabled. 

To check your current settings:

1 Go to Accounts Payable → Setup → Configuration.

IMPORTANT: This page is for informational purposes only and should not be used as

a guide to make changes to the configuration of your Sage Intacct environment. For

support with your Sage Intacct native approval flows, please reach out to Sage or

your Intacct implementation partner directly.
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View Approval Processes 

Scroll down the page to find two sections: “Bill approval settings” and “Payment

approval settings.”

Locate Bill approval and Payment approval settings



Bill Approval (Supported)

The Sage Intacct Bill Approval process is generally supported by your bank's Sage Intacct

integration and does not interfere with the plugin payment flow.

How it Works

Bills that are created are required to be approved prior to being available for payment. In

the plugin, bills that are created but not approved are not shown as available for payment. 

Once a bill has been approved and is in the Posted status, it will be available for payment

in the plugin.

Payment Approval (Not Supported)

Payment Approval is NOT supported. Enabling this process, which requires an internal

approval step for each payment based on Intacct rules, will lead to unexpected payment

processing behavior with the plugin.

The plugin requires that users disable the Sage Intacct Payment Approval flow before

proceeding with Production payments. Failure to disable this process will result in adverse

consequences for any payments that are rejected within the native Intacct approval

system.

What is the Risk?

When Payment Approval is disabled, the process is straightforward:

1. The payment request is immediately sent to the bank for any approvals in the bank's

systems.

2. A Bill Payment record is created in Sage Intacct, marking the original bill as closed and

updating its status fields.

When Payment Approval is enabled, this synchronization is broken. This results in:

The payment is sent to the bank immediately upon submission, just like the non-

approved flow.



However, if the payment is later rejected within Intacct's native approval process, the

system cannot recall the payment already transmitted to the bank.

The bill is returned to the Posted status (unpaid/ready for payment), meaning Intacct

shows an unpaid bill even though the bank has already processed the funds. This

creates a considerable risk of duplicate payments.



3.2.2.User Management

3.2.2.1. Setting up Multi-Factor Authentication

Multi-Factor Authentication (MFA) Overview

Multi-factor authentication (MFA) adds another level of security for all users when using

the  to . With MFA, your data is protected against account breaches and

is accessed by authorized users.

FISPAN Portal login

When registering, all new users must set up Multi-Factor Authentication (MFA) by choosing

an authentication method (the default option will be shown first).

If you prefer a different method, select Try Another Method to choose one of the following

options:

SMS (preferred)

Authenticator (or similar)

Email

NOTE: MFA does not apply to the Sandbox environment.

https://sys.fispan.live/login


Authentication Methods

Setting Up SMS MFA

The first time you log in to the Production environment, you will be prompted to establish

your Multi-factor Authentication (MFA) setup. You have the option to select various

methods of MFA. 

1 Enroll Phone Number

Select your country code then enter your phone number, you will receive a text

message with a 6-digit code via SMS to the phone number you provided for

enrollment.

If you are unable to receive a text message to this number, or you prefer a different

multi-factor authentication method, click Try Another Method. 

NOTE: Multi-factor Authentication (MFA) is only required if you are a user in the

Production environment. If accessing the Sandbox environment, you may skip this

step.
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Enter Code

Enter the 6-digit code you received in the applicable field.

Select Continue.

6-digit Verification

Save Recovery Code

After setting up SMS and inputting the first one-time code, you will be presented with

a recovery code that should be stored in a safe location. This code is for resetting the

MFA, to switch the MFA type (i.e., Authenticator), or to use a different phone number. 



Recovery Code

Setting Up Authenticator MFA

If you would like to use an authenticator application for MFA, follow these steps.

1

2

Set Up Authentication App

Download and install a compatible app, such as Auth0 Guardian App ( , )

or , on your mobile device and complete setup.

iOS Android

Google Authenticator

Verify Your Identity

Go into the Auth0 or Google Authenticator app to view your temporary verification

code. 

Enter the code from the app into the field on your screen and select Continue.

https://apps.apple.com/us/app/auth0-guardian/id1093447833
https://play.google.com/store/apps/details?id=com.auth0.guardian
https://support.google.com/accounts/answer/1066447?hl=en&co=GENIE.Platform%3DAndroid


Authenticator

Setting Up Email MFA

Follow these steps to set up Email MFA and verify your identity. 

1

2

3

Enter Email

Add the email address where you would like to receive your authentication code.

Check Inbox

Navigate to your email inbox to retrieve the 6-digit verification code sent to you.

Verify Your Identity

Return to this screen, enter the code, and select Continue.



Email Authentication



3.2.3.Vendor Management

3.2.3.1. Updating Vendors via CSV (Intacct)

The plugin allows you to update their vendor payment information in bulk through CSV

files, eliminating the need for manual changes to each individual record.

You can use this process to edit existing vendor records, to add additional line items to

existing vendors, and to create new vendor records.

Keep in mind that information stored inside native Intacct cannot be updated in the plugin.

Export and Import Functionality

This functionality allows you to manage your vendor records through a two-part process:

Export and Import.

Export creates a file containing all your current vendor records.

Import allows you to update existing records by applying changes to your vendor data.

Always export first before you begin an import. This is the best way to ensure the CSV file

is structured correctly, as the row format changes depending on the type of data you are

working with.

You can re-import the same data multiple times to update existing rows, provided the ID

fields in the file have not been modified or changed.

Follow these steps to begin the export and import process. 



1

2

Navigate to Payment Methods

From anywhere in Intacct, you can navigate to the Payment Methods page. Click on

the  button and then Payment Methods.First Citizens Link

Select Payment Methods

Export CSV

Click Export CSV. A CSV file containing all previously saved vendors is generated.
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Select Export

The import from Intacct triggers a minimum of one row of data. There are three

different data types:

BANK ACCOUNT: Each vendor with a bank account creates a row with a

data_type of BANK ACCOUNT, allowing you to modify the vendor’s bank

account.

ADDRESS: Each vendor with an address record creates a row with a data_type

of ADDRESS, allowing you to modify the vendor’s address.

EMAIL: Each vendor with an address record creates a row with a data_type of 

EMAIL, allowing you to modify the vendor’s email.

Prepare the File for Import

IMPORTANT: The CSV is pre-structured for import functionality; do not modfiy

the column structures.

NOTE: Save a copy of this file for your records so you can easily re-import the

original if necessary.



Once you have exported the existing vendor information, create the import file

containing your revised vendor information by editing the data and adding new rows

if you are incorporating new vendors.

Do not remove any of the column headers or add additional columns; otherwise, the

import will fail.

Each of the three data types requires specific data fields. Use the existing records as

a guide to which columns require data, and be sure to follow the general rules to

avoid errors that prevent a successful import.

BANK ACCOUNT: To add a new bank account, add a row and enter BANK

ACCOUNT in the data_type column. 

ADDRESS: To add a new address, add a row and enter ADDRESS in the

data_type column. 

EMAIL: To add a new email, add a row and enter EMAIL in the data_type column.

Please do not fill in the email or address fields for these columns, and ensure that the

other columns are completed according to the guidance provided in the table below.



4 Fill the CSV Table

You need to use specific default_payment_method code values that correspond to

your payment rail types.

Since a vendor can only have one default account with a default_payment_method,

you must ensure the payment method you choose is compatible with the

corresponding data type.

Navigate to Payment Methods and check in the table which payment methods are

listed for a vendor.

Here is a complete list showing which payment rail types are supported by each data

type. Use only the payment rails supported by your plugin for this specific vendor.

CSV file - table rows

NOTE: Only one line entry per vendor can have the is_default_account set to Y.

Enter the default_payment_method for the default account address record.

Only one line entry per vendor can have the "is_default_account" set to "Y"



data_type Compatible default

payment_method(s) 

for this data type

Other rules

BANK

ACCOUNT

ACH

ACH_NEXT_DAY

CPA

BACS

SEPA

WIRE

EFT_AU

WIRE_AU

EFT_SG

WIRE_SG

WIRE_NZ

EFT_NZ

WIRE_ZA

EFT_ZA

INTERNATIONAL_WIRE

INTERNATIONAL_ACH

UK_FPS

Leave the email and address fields

empty.

ADDRESS CHECK Leave the bank account and email

fields empty.

EMAIL VCC Leave the bank account and

address fields empty

CSV file - table columns



Colum

n

Name

Allowable Values (CASE

SENSITIVE)

Notes

data_t

ype

Either: ADDRESS, BANK

ACCOUNT, EMAIL

Required Field

For BANK ACCOUNT, leave the email

and address fields empty. 

For ADDRESS, leave the bank account

and email fields empty. 

For EMAIL, leave the email and address

fields empty.  

id Internal ID Leave empty if adding a new payment

method. Do not modify the value if

modifying existing payment information.

erp_ve

ndor_i

d

Intacct vendor ID Required Field

Do not modify. This field protects against

duplicate records.

vendor

_name

Intacct vendor name

is_def

ault_a

ccount

Y/N Required Field

Can only have one default Y per vendor.

All others must be N. 

default

_paym

ent_m

ethod

Please confirm that they

are in capital letters (e.g.,

ACH, ACH NEXT DAY,

CHECK, INTERNATIONAL

ACH, INTERNATIONAL

WIRE, SEPA, VCC)

Anything from the list of available

payment methods. To see what is

enabled on the vendor, navigate to 

Plugin → Payment Methods and check in

the table which payment methods are

listed for that vendor. 

Any unsupported payment type will

result in the line failing to import. If you

would like to add some payment

methods to the plugin, please contact

your bank.



Colum

n

Name

Allowable Values (CASE

SENSITIVE)

Notes

is_edit

able

Y/N Required Field

For any new lines, please enter "Y". 

Do not modify an "N" and change it to a

"Y"; doing this may break the import. 

email_

addres

ses

Any email addresses, up to

5

Separate each email address with “,”

countr

y

ISO alpha-2 country

codes

Required Field For Bank Accounts

This field accepts upper, lower, and

mixed case values. Please enter the ISO

alpha-2 country codes format. The

import will error if the user enters the full

country name (i.e., New Zealand). 

curren

cy

Currency codes Required Field For Bank Accounts

Please enter the currency following the

currency code list. This field accepts

upper, lower, and mixed case values.

accou

nt_typ

e

CHECKING or SAVINGS Required Field For Bank Accounts

This field accepts upper, lower, and

mixed case values

accou

nt_nu

mber

Vendor's account number

institut

ion_nu

mber

Vendor's institution

number

transit

_numb

er

Vendor's transit number

https://www.iban.com/country-codes
https://www.iban.com/country-codes
https://www.iban.com/currency-codes


Colum

n

Name

Allowable Values (CASE

SENSITIVE)

Notes

routin

g_num

ber

Vendor's routing number

bank_

code

iban Two letter country code,

followed by two check

digits, and up to 35

alphanumeric characters

bic Vendor's BIC or SWIFT

code for the country and

bank

bank_

name

Anything

addres

s_line

Anything

addres

s_line_

2

Anything

addres

s_city

Anything

addres

s_state

_provi

nce

Anything

addres

s_post

al_Cod

e

Anything



Colum

n

Name

Allowable Values (CASE

SENSITIVE)

Notes

local_

branch

_code

Valid branch code for this

bank

Use this field for BSB codes if the

country requires it

payme

nt_pur

pose_

messa

ge

Anything

payme

nt_pur

pose_

code

Valid purpose code

payme

nt_pay

ment_i

so_co

de

Valid sender country code

payme

nt_pay

ment_

codew

ord

Valid receiving entity

codeword

payme

nt_pay

ment_

party_t

ype

P, T, G, N P = Parent, T = Subsidiary, G = Group, N

= Non-related

payme

nt_resi

dential

resident, nonresident
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Colum

n

Name

Allowable Values (CASE

SENSITIVE)

Notes

_statu

s

sort_c

ode

Valid sort code for this

bank

Import CSV

Once the file is ready, select the Import CSV button.

Select Import

Attach the file that is ready to import and enter one valid email address to receive a

status update.

NOTE: You are not able to modify this email address after clicking Import. If the

email is incorrect, you will not get the status email, but the import will complete.
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Add Import CSV

Once the file has been uploaded, a checkmark will appear. You can expect an email

with a status update within a few minutes. 

Processing Begins

Import Confirmation Email



Once the import status changes, you will receive an email notification.

This email notification will let you know if the import has been successful. There are

3 options:

File Successfully Imported

File Successfully Imported

Import is successful, but there are line errors.

In that case, please download the CSV attached to the email that lists those

errors and submit the file again. You may leave the error column in the newly

uploaded CSV. Please note that if an error is found in one of the rows, none of

the information present in that row will be updated.



File Was Not Imported

Import was not successful.

This issue may be caused by internet connectivity problems or unsupported file

formats. Please verify your internet connection, refresh the page to attempt

again, or contact support if the problem persists.

Import CSV Example

This file shows an example of what the import file can look like for one hypothetical

vendor.



Example Vendor CSV Import file

On the Payment Methods page, when you select the vendor, it shows that the bank

account has been added.

Click on Bank Account

When you open up the bank account, you can see the values match the import. 



Confirm Values

Potential Errors



Potential errors Explanation Steps to fix the error

data_type  must be:

DEFAULT PAYMENT

METHOD or DOMESTIC

BANK ACCOUNT or

INTERNATIONAL BANK

ACCOUNT

data_type

was not

filled in.

Always include a data_type, this is a

mandatory field.

vendor_id must be 

filled in.

vendor_id

was not

filled in.

Always include a vendor_id, this is a

mandatory field.

default_payment_method 

must be of a valid 

Payment Type.

default_pa

yment_metho

d  was not

correctly

filled in.

Ensure your account has this payment

method enabled.

email_addresses 

contains email(s) with 

an invalid email 

format.

Email

address

format was

not

respected.

Follow the following format: 

 If you would like to

add multiple email addresses, ensure they

are comma-separated as

below:  , 

something@email.com

email1@email.com email2@email.

com

Both country and 

currency must be filled 

in.

Country and

currency

both need to

be filled in.

country contains 

invalid country code

Country

code is not

valid.

Select a valid country code from this list: 

ISO alpha-2 country codes

currency contains an 

invalid currency code.

Currency

code is not

valid.

Select a valid currency code from this

list: Currency codes

https://archbee-doc-uploads.s3.amazonaws.com/export/html-space/PUBLISHED-c2da-X6ep2bQRDbTf7VgY-h_CIBmH-LbQAqZk-ycYPh.html
https://archbee-doc-uploads.s3.amazonaws.com/export/html-space/PUBLISHED-c2da-X6ep2bQRDbTf7VgY-h_CIBmH-LbQAqZk-ycYPh.html
https://archbee-doc-uploads.s3.amazonaws.com/export/html-space/PUBLISHED-c2da-X6ep2bQRDbTf7VgY-h_CIBmH-LbQAqZk-ycYPh.html
https://archbee-doc-uploads.s3.amazonaws.com/export/html-space/PUBLISHED-c2da-X6ep2bQRDbTf7VgY-h_CIBmH-LbQAqZk-ycYPh.html
https://www.iban.com/country-codes
https://www.iban.com/currency-codes


3.2.3.2. Supporting Multiple Entities (Intacct)

The Sage Intacct integration supports multiple entities. Pages within the integration behave

similarly to the native pages of Sage Intacct, with respect to presentation of bills, vendors,

and bank accounts. This is available for plugin versions 2021.4 and above.

Key Updates

Bills presented in the plugin will be reflective of the Entity level you are currently viewing.

For example, bills selectable for payment at the Top Level will only be bills that can be paid

at the Top Level through the traditional Pay Bills page in Sage Intacct.

At the Entity level, you will only be able to select bank accounts eligible for payment within

that Entity. For example, when making payments in Entity A, you will not be able to select

bank accounts owned by Entity B. 

Limitation

When submitting payments at the Top Level, the Confirmation page may present all linked

bank accounts, irrespective of the Entity they belong to. If an Entity-owned bank account is

selected for payment, the payment will immediately fail, and the bills will automatically be

reopened and available for repayment. 

Intacct does not allow the use of an Entity-level bank account to make payments at the Top

Level. Please confirm that when making payments from the Top Level, an appropriate Top

Level bank account is selected as the Source Account.



3.2.3.3. Vendor Approvals (Intacct)

The Vendor Record Approvals feature provides a robust and secure method for managing

changes to vendor bank account information within your ERP. This approval process

ensures data accuracy, minimizes the risk of errors, and enhances security by requiring

authorization for changes to your vendor's banking data.

Enable Vendor Record Approvals

1

2

Login to FISPAN Portal

An ERP administrator or ERP consultant must first access the  by

logging in at . 

FISPAN Portal

sys.fispan.live

Enable Vendor Record Approvals

Click on the Vendor Record Approvals tile under Discover More.

A summary pop-up will appear. Click Enable & Configure to complete the setup. 

https://sys.fispan.live/login


Click Enable & Configure

Once enabled, you will be prompted to begin creating your workflows.

Creating a Workflow

To create your Vendor Approvals workflow for your ERP utilizing the plugin, please follow

these steps.

1 Go to Vendor Record Approvals

From the , click on the Vendor Record Approvals tile. You'll then be

prompted to start creating your workflows.

FISPAN Portal



2

Click Vendor Record Approvals

Create a Workflow

Once you are on the Vendor Record Approvals page, click Let's Get Started. 

Click Let's Get Started
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Start by giving your workflow a clear, descriptive name for easy identification later.

Next, select the entities you want the approval workflow to apply to:

Addresses: Applies to addresses added via the Payment Methods page or

changes made to the native ERP vendor record address.

Bank Accounts: Applies to bank accounts added via the Payment Methods page

or changes made to the native ERP vendor record bank account.

Email Groups: Applies to email groups added via the Payment Methods page or

changes made to the native ERP vendor record emails.

Create a Worklow

Add Approvers to Workflow

Next, you need to define the approvers for your workflow. 

In the first level, enter the approver's email address exactly as it appears on their

user record in the ERP system.

NOTE: To exclude vendor record changes synced from the ERP from this

approval process, please contact .FISPAN Support



Add another level for approval and additional approvers, if needed. You can set up to

three levels of approval. 

At each level, you can add up to five potential approvers. You can also decide how

many individual approvals are required per level (e.g. Level 1 requires 2 approvals,

Level 2 requires 3 approvals, Level 3 requires 1 approval).

Click Save

NOTE: Important Considerations:

1. No Self-Approval. You cannot approve your own Vendors. Keep this in

mind if a single user frequently acts as both the Vendor creator and an

approver.

2. Best Practice for Approvers. To avoid delays, we suggest:

Avoid having a single approver in a level. 

Adding more approvers than the required approvals (e.g., include 4

approvers in a level that requires 2 approvals). This ensures the

process can continue even if someone is unavailable.



4 Save Workflow

Once you have configured your workflow, click Save New Workflow.

Your workflow is now active. All changes made to vendors through the 

 will now follow this approval process.First Citizens Link

Editing a Workflow

You can edit or delete a workflow, but only if there are no vendor record changes pending

approval for that workflow. This prevents any confusion or errors with changes currently

going through the approval process. In the event you need to edit a workflow with

associated open vendor record changes, process or cancel any outstanding changes

associated with the workflow.

1 Select Workflow

You can edit existing workflows to adjust them. Click on the workflow you would like

to modify.

IMPORTANT:  To approve changes, users in the workflow must have both an

ERP license and the necessary plugin permissions to view Vendor Approvals,

outlined in the Intacct Required Permissions section of this page.
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Click on the Workflow

Edit Workflow 

Make your desired modifications, and click Save Changes.

Click Save



Editing Restrictions

Modifying the entities associated with a workflow will disable any other workflows that

were previously applied to those entities. Similar to making edits to workflows, all future

requests for these entities will go through the new workflow; existing requests will remain

unaffected.

Unable to Make Changes to Active Workflows

Deleting a Workflow 

Workflows with pending approvals cannot be deleted until those approvals are resolved.

Deleting an active workflow can be done following these simple steps.

1 Select Workflow

Select the workflow to delete. Then, click Delete Workflow. 
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Click Delete Workflow

Confirm Deletion

A pop-up will appear. Confirm deletion by clicking Yes, Delete Workflow.

Click Yes, Delete Workflow



Disabling a Workflow 

To disable a workflow, toggle Enable Flow. Then click Save Changes.

Click Save Changes

Intacct Required Permissions

If you are unable to access the Vendor Approvals page, you may be missing permissions.



Add Vendor Approval Permissions

Your ERP Administrator will need to navigate to the role associated with your bank's plugin

and add permissions for Vendor Approvals.

Accessing Pending Approvals

Navigate to the Vendor Approvals page within the Intacct plugin. By default, you will see

all pending approval requests for your organization.

The Approvals page table provides a comprehensive overview of every payment request,

including the following key details:

Request Date: The exact date when the payment was initiated within the plugin.

Vendor: The name of the vendor whose record was modified.

Entity: The type of data that has been changed. It will be either an address, bank

account, or email group.

User/Requested By: The name of the user who submitted the payment request.

Source: Where the change was made. It will be either Plugin UI or ERP. 



Approval Progress: A tracker that provides context for where a payment is within the

approval process.

To view only the requests assigned to you, click the Show Assigned To Me Only filter.

Click Show Assigned To Me Only

To review a specific request, click View. This will display key information such as: 

Type of Change: This indicates whether it is an update to existing details, a new

vendor bank detail, or the deletion of a vendor bank detail.

Requested Date: The date and time the change was submitted.

Requester: The user who initiated the change.

Detailed Breakdown: A comprehensive overview of the proposed changes, additions,

or deletions to the vendor's bank details.



View Pending Change

Approve a Request

1 Approve Request

After accessing your pending approvals, click into the request you would like to

approve.
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Click Approve

Click Approve to authorize the proposed changes.

Complete Approval

The request will either advance to the next level in the approval workflow (if multiple

tiers are configured) or, if you are the final approver, the vendor's bank details will be

updated accordingly on the Payment Methods page.



Click Close

Reject a Request

1 Reject Request

After accessing your pending approvals, click into the request you would like to

approve.



2

Click Reject

Click Reject to deny the proposed changes.

Provide Rejection Reason

You will be required to provide a Rejection Reason. 

IMPORTANT: Rejection is a terminal action. If a change is rejected in error, the

initiating user will need to resubmit the request.



Add a Rejection Reason

Since rejections are final, the request will not be routed to any other approvers, and

the proposed changes will be reverted.

Click Close



ERP Synced Changes 

For changes originating directly from your ERP system (ERP-synced changes), the system

restricts action to ensure data integrity by disabling the "Reject" button.

This restriction prevents accidental overwrites or conflicts with your core ERP data.

Approve ERP Synced Changes

If an ERP-synced change needs reversal or modification, the initiating user must make the

necessary adjustments directly within the ERP system.

Email Notifications

All users within a tier will receive an email when the approval request has been created. 

The email has a limit of 100 vendors at a time and will be sent every 30 minutes if there are

approval requests being created. 



View Email Notification

Impact of Pending Approvals

When an approval request is created by modifying a vendor's bank details, your plugin

updates its interface as follows:

Pay Bills Page

When a vendor has a pending change, payments cannot be processed for that vendor.

This restriction ensures you have the most up-to-date information before any payment is

initiated.



Blocked Vendors

A warning icon and a greyed-out checkbox prevent these vendors from being selected for

payment.

Payment Methods Page

On the Payment Methods page, the vendor entry will display an icon identifying the

pending changes.



Vendors with Pending Changes

If you click on the vendor, the specific record that has been changed is highlighted.

Account Marked As Under Review

If you open the record, you'll find all fields are greyed out and cannot be edited while the

approval is pending.



Unable to Edit Record

Approvals History

The Approvals History page maintains a comprehensive log of all approval requests,

including both those that have been approved and those that have been rejected.



View Approval History

To view more details about a request, you can click View and see the following fields:

Date and Time: When the approval or rejection occurred.

User: The individual who approved or rejected the request.

Reason: Any comments or explanations provided for the decision.

Source: The origin of the change request (e.g., manual update, import).



View Approved Record

View Rejected Record

Approvals History Export

You can export the Approvals History for record-keeping or analysis. The exported file

includes the following columns:



Modified On: The date the change was made

Vendor: Vendor Name

Type of Change: Updated, Added, Deleted

User Email: The user who initiated the change

Reviewed By: User emails who have approved or rejected the change

Approval/Rejection Time: The time when the final approving user reviewed the

change or when the rejection was sent.

Status: Approved or Rejected

Previous Entry: This entry reflects its state before it was changed. It will be empty if

the history log item pertains to the creation of a new record.

Proposed Entry: This entry reflects the adjustments made after a change was initiated

or rejected. If the entry was rejected, it reflects the proposed change. If the entry was

approved, it represents the accepted change.

Reason for Rejection: The reason for rejection provided by the rejecting user. This will

be empty if the record is an approved item.

To generate this export, click the Export button on the Approvals History page. 

Click Export



FAQs

Can I reject ERP-synced changes?

No, rejection is disabled for ERP-synced changes to prevent data inconsistencies.

Please contact the user who initiated the change to resolve any issues.

What if I accidentally reject a valid change?

Rejection is a terminal action. If a change is rejected in error, the initiating user must

resubmit the request.



3.3.Product Features

3.3.1.Accounts Payable

3.3.1.1.Vendor Payments

3.3.1.1.1.Bill Payments





3.3.1.1.1.1. Paying Bills (Intacct)

Paying bills in Intacct allows you to remain within your ERP system without needing to

access your bank account separately. You can pay a bill individually or improve efficiency

by processing them in groups. Follow this guide to learn how to do both.

Pay a Bill

Follow these steps to pay your first Bill with the plugin.

If your Payables page looks different than the screenshots below, you may be running an

outdated version of the plugin. Please update the plugin to use the plugin's latest features. 

1

2

Go To Payables

Go to Payables

Go to Payables.

Select Bills To Pay
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Use the filters to find the bills you would like to pay. If a default payment method has

not yet been set for the vendor, choose your payment method from the respective

column. 

Select and Pay

Then, select the bills you would like to pay using the boxes on the left and select Pay.

Confirm Payment(s)

IMPORTANT: If you delete an open bill directly within the plugin by clicking the

trash can icon on the right side of the bill, it will be removed and will not

automatically re-sync. 

To make sure a removed open bill can be reprocessed, you must go into native

Intacct (outside of the bank plugin). There, you need to make an edit to the

invoice and then resubmit it for approval. This action forces the necessary

update for the bill to be picked up and reprocessed.

NOTE: Ensure the bills you plan to pay are not duplicates of bills previously paid

via the bank plugin.
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Select the account from the dropdown menu. Before proceeding, confirm that the

number of bills, payments, and amounts are correct, and ensure all applicable credits

and discounts have been applied.

Confirm Payments

Once you have validated your bills to be paid, select Confirm.

Check the Payment Status 

Go to Payables → History.

WARNING: DO NOT attempt to reverse and repay a bill if you realize you forgot

to apply a credit or discount after clicking Confirm. Reversing and repaying the

bill yourself may cause duplicate payments.

If this situation occurs, please contact  immediately. We need to

check if the payment has already left Intacct before you attempt any reversal

and repayment.

FISPAN Support



Check Payment History

The status will appear as Received until the payment has been cleared. Once the

payment is complete, the status will display as Completed.

Review Status



We recommend checking the Failed Bills tab after sending a payment to confirm the

payment was successful. To do so, go to Payables → Failed Bills. 

A failed bill would look like the following:

Failed Bill

A failed bill remains open on the Pay page and can be resubmitted for payment.

Paying Grouped Bills

If you would like to make grouped bill payments, ensure you have enabled the Combined

Bills setting for your vendors. You can decide to have this enabled for each vendor. If you

haven't done this yet, please refer to our Enabling Grouped Bills guide.

Follow these steps to group bills into a single payment.

1 Go to Payables
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Go to Payables

Go to Payables.

Pay Grouped Bills

On the Pay page, simply select all the bills you wish to pay and click Pay.

Paying Grouped Bills
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The Confirmation Payment window appears. You can select the Source Account and

verify the number of bills against payments. Click Confirm to send the payments. 

When grouped payments are enabled for a vendor with multiple bills, the total

number of payments will be less than the number of bills being paid.

Confirmation window grouped bills

After clicking Confirm, your payment will begin transmitting. 

View Payment Status

Next, navigate to the History page to see the Payment Status. 



History Page for Grouped Bills

FAQs

How long do bills stay on the History Page?

Bills never leave the History page. As long as there is a working sync between Intacct

and the plugin, you should be able to see your paid bills. 

NOTE: Enabling the Combined Bills function means only one remittance email

will be sent. This email covers all the multiple bills that were grouped into a

single payment.

If you do not enable this feature, each paid bill is treated as a unique, separate

payment. This results in multiple payments being created and, consequently,

multiple remittance emails being sent to the vendor.



Why do I see multiple instances of the same bill on the History Page?

If you pay a bill with partial payments, the same bill will appear multiple times on the

History page. Similarly, if a bill has failed and has been repaid, it will also appear in

multiple payments on the History page.  

How many bills per page?

The plugin shows 200 bills per page. You are only able to pay one page at a time. 

Why do I receive an error 'You do not have the permissions for operation

READ_BY_QUERY on object of type locationentity'?

This is because you are missing the Entities permissions on the role/user. Navigate to 

Company -> Role -> Subscriptions and add the Entities permissions View.  

Location Error



I deleted a bill in the plugin, and I want it to appear again. How can I do that?

If you modify anything on the bill record, it should be picked up again and appear on

the Pay page of the plugin. 

Why am I not able to pay a bill that I created by duplicating an old bill I paid

previously through the plugin?

When a bill is paid through the plugin, certain custom fields on the bill record, such as

transaction IDs and statuses, are automatically filled in and are uneditable. Duplicating

these bills will copy over the contents of those custom fields into the new bill,

potentially causing payment failures.



3.3.1.1.1.2. Voiding & Repaying Bills (Intacct)

Voiding bills is supported directly within the plugin. Voided bills can later be repaid by

following the steps in this guide.

How to Void Bills

1

2

Find the Bill

Find a bill that has already been paid via the plugin on the History page (Payables →

History).

Find the Bill

Check Bill Status

Open the bill record (internalID) and confirm the bill has been PAID IN FULL. 

You can select the tab in the submenu to confirm that the bill payment has reached

the plugin.
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Check Bill Status

Select the Paid in full to see the corresponding journal entries.

Choose Journal Entries to Void

Select the journal entries that you would like to void.
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Choose Entries to Void

Void the Bill

Void the bill by clicking the Void button on any line item. If the bill was not paid in full,

it will be reopened and available for future payment.

Void the Bill



5 Check the Reopened Bill

Confirm the bill has been reopened. Fields under the subtab are still populated with

details from the first payment that was voided.

WARNING: When confirming the payment, do not reverse the bill. DO NOT

check the Reverse checkbox. Instead, simply add a payment date and an

optional memo. 

If you choose to reverse the bill, it will enter a Reversed state that the plugin

cannot read or process.

Voiding, without reversing the bill



Check Reopened Bill

Repaying a Previously Voided Bill

1 Find & Pay Bill

Find the previously voided bill on the Pay Vendor Bills page in Payables → Pay.

Pay the bill as normal.

Confirm the bill has been paid and appears on the History page. Go to Payables →

History.
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Go to Find & Pay Bill

Check the Bill Status

Open the bill record and confirm the bill has been PAID IN FULL. You can select

the submenu to confirm that the bill payment has hit the plugin and that the reference

IDs and transaction IDs are now different as seen in Step 2 of “How to Void a Bill”.

Check Bill Status





3.3.1.1.1.3. Making Adjustments (Intacct)

Adjustments, such as credit notes, must be defined at the vendor level. Once an

adjustment is created for a specific vendor, for example, a $20 credit, it will automatically

appear on all future bills for that vendor.

To ensure the credit amounts and references are correctly included in the Remittance

Advice email, you must use Account Payables → Adjustments to create credit notes and

make adjustments. 

When applying a credit amount to a bill, the system follows a rule: the oldest available

credit value for that vendor will always be applied to the payment first.

Make an Adjustment

To make an adjustment, follow these steps. 

1 Go to Adjustments

Navigate to Account Payables → Adjustments.

NOTE: Make sure that the adjustment type is a Debit Memo. The plugin does not

currently support what native Intacct calls Credit Memos.
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Go to Adjustments

Make Adjustments

Input the amount you would like to apply to the bill in the Credits to Apply field.

Apply credits



The Credits Available column is updated every time the user modifies the adjustment

in native Intacct or inputs an amount in Credits to Apply.

Please note that the applied credit cannot reduce the amount in the To Pay column to

zero or a negative value. 

Select and pay the bill as usual, and the credit will be applied.

FAQs

What if the amount is not right?

If the amount auto-populated does not match what you would like to have as an

adjustment, you can simply modify the corresponding adjustment. 

Simply head over to Account Payables -> Adjustment and select the adjustment you

would like to modify. Change the AP term, and the auto-populated adjustment in the

plugin will be automatically updated. This will directly be reflected in the Credits

Available Column.

What if there are no credits available?

It is not possible to add any adjustments within the plugin. Head over to Account

Payables → Adjustment to modify any adjustment.

IMPORTANT: Using bills with a negative amount (i.e., -$10) as adjustments is

currently not supported by the plugin. If you are using bills with negative

amounts as part of your AP workflow to create credit memos, we recommend

switching to adjustments. This is what Intacct recommends natively. 



What if there are multiple adjustments?

If there is more than one adjustment for a single vendor, native Intacct is replicated,

and these are added together. This is reflected in the Credits Available column.

On the accounting side, the adjustment with the smallest adjustment number (1 is first,

taken over 2) is first used. The end-user does not notice any difference, but this has

an impact on the way the adjustments are used and closed.

The To Pay column will change every time a new adjustment is added in the Credits to

Apply column. After the payment is completed and the memo(s) applied, the journal

entries are written, the adjustment is marked as partially paid or paid, and the Credits

Available is updated.

Why do I get an error when paying two adjustments in a row?

If you attempt to pay two adjustments consecutively for the same vendor, you may

encounter the following error: "The credits available for Vendor A are less than what

was applied to this payment."

This occurs because you tried to apply more credits than the amount currently listed

as Credits Available in Intacct. The system may not have registered the depletion of

credits from your first adjustment payment yet.

To resolve this, please resubmit the payment with an accurate credit amount. You must

either:

1. Add more credits for the vendor in native Intacct.

2. Decrease the amount of credits you are attempting to apply for the payment.

Please note that when this error occurs, the bill will not be paid and will return to the 

Bills to Pay page. It will not appear on the history page.



3.3.1.1.1.4. Applying Discounts (Intacct)

The discount feature allows you to apply available discounts to payments processed

through the plugin, and the payment request sent to the bank will automatically reflect the

discount amount.

Applying Discounts

You can apply discounts when paying a bill. Discount terms cannot be applied to bills that

are only partially paid.

To successfully apply a discount, you must meet one of the following two conditions:

1. You are paying the bill in full with a single payment.

2. You are making the final partial payment on the bill. The discount can be applied only

if this final payment clears the remaining amount due on the bill.

Follow these steps to apply discounts to a payment.

1 Set Payment Terms

Go to Accounts Payable → Bills to create or edit a bill.
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Go to Bills

Open a bill and select Terms. Enter the discount term you would like to use from the

dropdown menu.

Enter Discount

Pay with Discounts



Go to Payables. Use the filters to find the bills you would like to pay.

Go to Payables

The discount associated with that bill will auto-populate in the Discounts column and

apply to the bill by default.

Discounts column



The To Pay column is the Amount Due minus the Discounts (calculated based on the

terms and dates set on the bill) minus any additional credits applied.

Select the payment method and pay your bill as usual.

Removing a Discount 

If you want to pay a bill that has an applied discount term but choose not to use the

discount, you have two options:

1

2

Remove the Discount from Intacct

Navigate to Account Payables → Bills in native Intacct.

Select the bill you wish to modify.

Remove Discount Term

Ensure the term dropdown is left blank. This action effectively removes the discount

term from the bill record.

Temporarily Ignore the Discount



In the plugin's Payables page, simply unselect the Apply button next to the bill.

An orange notification text will appear, explaining that the bill is eligible for a

discount.

Update Discount as of Date

Modify the Discount as of date before making the payment, to ensure discounts are

applied appropriately.

To update the Discount as of date, follow these steps.

1

2

Locate Discount as of Date

Click on the Discount amount (in blue). This will open a pop-up where the discount

as of the date will be modifiable. 

Edit Discount as of Date

Now, edit the Discount as of Date and save. 

Make sure the Apply checkbox is checked and pay your bill as usual.

Please note that if a date after the discount cut-off date is selected, the discount will

be $0.

NOTE: If you navigate away from or refresh the Payables page, the Apply 

checkbox will be automatically rechecked.



Change discount as of date

FAQs

What if the amount is not right?

If the amount auto-populated does not match what you would like to have as a

discount, you can simply modify the corresponding Accounts Payable [AP] Term. 

Simply head over to Account Payables -> Bills and select the bill you would like to

modify. Change the selected AP term, and the auto-populated discount in the plugin

will be automatically updated. This will directly be reflected in the To Pay Column.

How can I change the AP term settings?

Head over to Payables -> Set Up -> More -> Terms to edit AP terms.

Are discounts supported in different currencies?

Yes, discounts are supported in all currencies.



I changed the AP term in my bill, but it is not reflected in the plugin yet. What should

I do?

The plugin always reflects exactly what is in the bill on native Intacct. If you have

updated the bill, and it is not yet updated in the Payables page, wait 30 seconds and

refresh the plugin; the bill should then be updated.

Why can I not pay a partial payment with a discount?

Discount terms cannot be applied to partially paid bills. To benefit from discounts, you

have to either:

Be paying the bill in full in one payment

Be paying the last partial payment on the bill. If there is no amount due left on the

bill (after that last payment), you can apply the discount.

Hover over the "i" icon in the Discounts and To Pay columns to receive an explanation

of the expected behavior.

What is the discount as of date?

The discount as of date is the date at which the discount is processed.

Why are Grace Days not taken into account?

Grace Days are currently not supported.

I changed the bill, but it is not reflected in the plugin yet. What should I do?

The plugin always reflects exactly what is on the bill in native Intacct. If you have

updated the bill, and it is not yet updated in the plugin Payables page, wait 30 seconds

and refresh the plugin; the bill should then be updated.



If I have multiple line items, where will the discount be applied?

If the bill is paid in full, the plugin will apply the discount proportionally, split between

each line item. 

If the bill is paid in installments, the discount will be applied to the last line item of the

last payment (the discount will not be used before the bill is paid in full).

Why is Native Intacct not passing my discount while the plugin does?

When the payment date is set to be after the discount cut-off date, but the discount as

of date is set to before the discount cut-off date, the plugin does not replicate native

Intacct.

Intacct offers a partial payment without the discount being taken into account, while

the plugin sends the payment with the discount.



3.3.1.1.2. Payment Methods (Intacct)

Manage payment methods directly in Intacct by following this guide, covering vendor

payment information and default settings.

Update Payment Methods

From anywhere in Intacct, you can navigate to the Payment Method page. 

1

2

Navigate to Payment Methods

Click on your plugin and then Payment Methods to begin. 

Select Payment Methods

Edit Vendor Details

The Payment Method page enables you to manage payment information for each

vendor. Click on the vendor you would like to manage by hovering over the vendor or

selecting the Edit button. 



View Vendors

The Payment Method pop-up will appear, which allows you to add and store three

different types of data: Bank Accounts, Addresses, and Email Groups. 

If you have any bank accounts, addresses, or emails stored natively, they will be

imported automatically upon installation of the plugin. They are not editable in the

plugin. These accounts are indicated by the ERP icon next to the label. 
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View Vendor Profile

Set Default Payment Method

On the Payment Method pop-up, you can toggle on Combine Multiple Bills. 

This allows you to send multiple bills for the same payment method as one payment.

For example, if you were processing five bills, you would be processing one payment

instead. 

You can also select a Default Payment Method from this dropdown. This will

populate every bill for this vendor on the Pay Bills page with this payment method. It

can be updated and changed every time. You can also change the payment method

on the Pay Bills page for one-off payments; it will just not default in the future. 
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Payment Settings

Add Bank Accounts 

To add bank accounts, click on the Add Bank Account button. 

Select Add Bank Account

Select the Country and Currency of the bank account you would like to add. 



New Bank Country and Currency

Next, fill in the banking information based on the data provided to you. Be sure to

enter a unique label. Once you have done that, click Validate Account Info.

Click Validate Account Info
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Next, the account information will be validated. This ensures that the values you have

entered allow you to pay only payment methods that are available based on the

information provided. For example, it will not let you make an ACH payment if no

Routing Number is provided.

However, the screen does not validate the accuracy of the information provided. 

If the validation fails, you can return to the account details and modify the

information. The information will now be re-validated. 

If the validation is successful, you will be able to toggle the payment method on and

off and save it. 

Add Addresses

To add vendor mailing addresses, click on the Add Address button. 

Note: All bank accounts will be saved as a checking account unless otherwise

indicated by changing the Type of Account field. 



Click Add Address

Add your address details to the fields. After that, click Save.

Add Address and Save

Add Email Addresses



To add email addresses, click on the Add Email Group button. 

Select Add Email Group

Add email address details to the fields. You can add up to 5 emails by clicking enter after

each entry. After that, click Save New Email Group.

Add Email Group Details



NOTE: If the remittance product is enabled, you can also use this email group to send

remittance emails. 



3.3.1.1.2.1. Enabling Grouped Bills (Intacct)

Simplify your payments by using the Combine Bills option for vendors, which allows you to

group multiple bills into a single payment. Follow these steps to learn how to enable this

feature.

1

2

Navigate to Payment Methods

From anywhere in Intacct, you can navigate to the Payment Methods page to

configure this setting. Click on the plugin and then Payment Methods to begin. 

Select Payment Methods

Enable Combine Bills

Once the page loads, click on the gear icon labeled Combined Bills.



Click on the Gear Icon

You will now be prompted to select the option you prefer.

Pick an Option

If you choose to enable this for all vendors, you will need to make updates for any

new vendors that are created in the future.
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Once the option has been selected, click Update Changes. 

Select Update Changes

Disable for Vendors

The screen will then reload, and all the toggles will be updated to match the status

you selected. From this page, you can disable specific vendors.



Combine Bills Toggle Updates

Intacct Merge Payments Setting

Alternatively, Sage Intacct offers a native setting for grouped bill payments. To utilize this

feature, ensure the Merge payment requests checkbox is enabled on the relevant Vendor

record. Follow these steps to configure this setting. 

1

2

Go to Vendor Record

Navigate to the Vendor record and select the Payment Information tab. 

Enable Grouped Payments

Click on the Merge payment requests checkbox.



Enabling Grouped Payments

Once that is enabled, you are able to group bills when paying. 



3.3.1.1.2.2. Making Partial Payments (Intacct)

Initiate Partial Payments directly from Intacct. This feature gives you the flexibility to pay

only a portion of an invoice, supporting various business needs and helping you better

manage your cash flow.

Partial Payments are available to all Intacct users on plugin version 2022.23 or later.

Making Partial Payments

Follow these steps to make your first partial payment.

1 Modify the To Pay Amount

The To Pay column is now modifiable. You can enter any amount as long as: 

The To Pay amount is greater than 0. 

The To Pay amount is not more than the amount due - the discount applied -

credits applied.

Modify To Pay Column Amount



2

3

Add Any Applicable Credits (Adjustments)

Partial Payments can be used in combination with adjustments. Refer to the Making

Adjustments article for more information. 

In the Credits to Apply column, add any amount that you would like to add to this

payment. This action does not reduce the To Pay amount; instead, it adds the

specified credit amount to your payment request. As a result, the Credits Available 

balance will be reduced by the amount you enter here.

Adding Credit to Apply to a partial payment

Select the Bills to Pay

IMPORTANT: Discount terms cannot be applied to partially paid bills. 

To take advantage of available discounts, your payment must meet one of the

following criteria:

Pay the bill in full with a single payment.

Make the final partial payment on the bill. The discount can only be applied

when this payment reduces the outstanding amount to zero.
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Select the bills you would like to pay. You can add multiple bills (even with partial

payments) to one payment run. 

Select bills to pay

Confirm Payments

Confirm the payments to complete your first partial payment.



Confirm Payments

The bill(s) you've partially paid will remain on the Pay page. They will show the

updated outstanding amount due, allowing you to make future payments until the

balance is fully settled.



FAQs

IMPORTANT: The custom fields on the native bill record will be overwritten

each time a partial payment is made. Only the latest payment information will

be available in these fields.

For example, if a bill is partially paid five times, the custom fields will only show

the details of the fifth (latest) payment.

If you need to search and view all payments made against a single bill, you

have two options: 

1. Navigate to the History page of the plugin.

2. Go to the Accounts Payable page within native Intacct.

Overwritten custom fields 

You can search this page using the payment or bill IDs.



Do I need specific permissions to use partial payments?

No, users who already have the  permissions will be able to make

partial payments.

First Citizens Link

Why can I not see the payment information on the bill record when I do multiple

partial payments?

The plugin will overwrite the custom fields every time there is a new payment made

against that bill. Only the payment information from the latest payment is made

available. This is a technical limitation with how Sage Intacct stores the information on

this record. We have improved the History page to accommodate this. 

Why can I not apply a discount to a partially paid bill?

Sage Intacct does not allow discount terms to be applied to partially paid bills. To

benefit from discounts, you have to either:

Pay the bill in full in one payment

Pay the last partial payment on the bill. If there is no amount due left on the bill

(after that last payment), you can apply a discount.

Can I pay the same bill from two different entities?

This is currently not supported by the plugin, because the plugin does not read line

details of bills. You are able to partially pay a bill, but you are not able to choose which

line item gets paid and which one does not. It always follows the same logic,

independent of which bill is chosen (see next question for my information). 

How do I know which line item gets paid first?

The logic of which line item is paid first when submitting a partial payment is the same

as native Intacct. It uses the first line item first, and then the second, until there is

nothing left to be paid. 



What does the 'View Details' button at the top right do?

View Details button

The View Details from the top right of the accordion opens up the ,

which shows more payment-related information than what is shown in the plugin. You

will be prompted to log in. Use the  password defined during the

onboarding process to log in. Reach out to support if you did not get a login during

onboarding. 

FISPAN Portal

FISPAN Portal



Example Payment Details



What does the eye button next to the bill number do?

The Eye Button next to the bill number opens the native Intacct bill record. 

Eye button next to the bill number



3.3.1.1.2.3. Check Number Limitations (Intacct)

There is a limitation with Sage Intacct where the Document Number field on a bill cannot

be overwritten once it has been populated.

When a payment is processed through the bank plugin, the Document Number of the bill is

populated with an alphanumeric Reference ID. This field is usually where you would expect

to find the Check Number.

See Reference ID appearing as "EFT: #404f7398-ceed-46b5-8d03-50a9c823a3f2"

As part of the bank plugin onboarding, your organization supplied a Check Number range.

When you process a Check Print payment, the plugin automatically retrieves the next

sequential Check Number from this range and sends it to Intacct.

Intacct's restriction prevents the plugin from overriding the standard Document Number 

field once it's populated with the alphanumeric Reference ID. Therefore, the actual check

number is recorded in a different location: it is saved under the Bank tab in a custom field

named Transaction ID on the bill.



See Transaction ID field under your Bank tab on the Bill

Because the alphanumeric Reference ID is populated instead of the Check Number, you

may discover that during reconciliation, you can only see the Reference ID on the Intacct

side and the actual Check Number on the bank side. 

Workaround

To help with reconciliation, you can create a custom view in Intacct to display the

corresponding Check Number for each alphanumeric Reference ID.

To create this report, please follow the steps below:

1 Navigate to Bills

Navigate to Accounts Payable -> Bills. 
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Click on "Bills" under the Accounts Payable Menu

Create New View

Then, click Manage Views -> Create new view. 

Click "Create new view"
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Select the columns you wish to see on the custom view. Be sure to select 

Transaction ID, Payment Method, and Reference ID. 

Select Reference ID, Transaction ID, and Payment Method. The order that these items

appear in may differ.

Next, click Save.

Filter for CHECK

After saving the view, you can filter for CHECK under the Payment Method column to

isolate bills that have been paid through Check Print via your bank plugin.



A Custom "My Bank Check Numbers" View



3.3.1.1.3.Bill Payment History

3.3.1.1.3.1. Viewing Bill History (Intacct)

All Bill Payment History is readily available in Intacct and can be accessed via the bill

history record. Follow the steps below to view your Vendor Bill Payment History.

1 Go to History

Go to Payables → History

Go to Payables



2 View Bill Payment History

The Payment History page provides a snapshot of all payments that have been made

via the plugin.

Vendor payments that are processed through the plugin will first appear Pending. 

Depending on the payment method, payments may remain pending for up to 

business days after submission, after which the payment will automatically be moved

to a Completed state.

several

View Payment History

Processing Payment Statuses:

SENT FOR PROCESSING: Payments paid through the plugin will enter this state

once they’ve been submitted for payment. 

NOTE: The Sage Intacct Bill Payment object will be created at the time of

payment submission, not when the payment is marked as Completed. If your

bank reports a payment failure, we will update the status in the History page to 

Failed and attempt to reverse the initial Vendor Bill Payment accounting entry. 



3

PROCESSING: Payments will enter this state once they have been approved and

released. 

A terminal payment status is a final status. In most scenarios, payments will not

automatically change from this status unless intervention is applied from the support

team. 

Terminal Payment Statuses:

COMPLETED: Some payments are marked as autocomplete, based on the way

the payment network handles them. Completed is considered a terminal status

and should not change.

FAILED: Payments that fail to be processed will enter this status. Payments can

fail for a variety of reasons: initial validation as a result of missing or

inappropriate information, or if the payment fails in the payment network (e.g.,

the destination bank account is closed).

CANCELLED: This status will indicate that the payment was rejected in the bank

approval portal or cancelled in the platform.

View Bill Information

By default, the History page shows the payment-related information first. 

Every row contains one payment request, with all the payment-related information:

PaymentID (referenceID), Posting Date, Vendor Name, Number of Bills in the payment

request, Total Amount, Currency, Payment Method, Last Updated, and Payment

Status.



Payment-related information

A payment request can contain multiple bills. To see that information, hit the little

arrow on the left side. This brings down the bill-focused tab, which includes: Bill

Number, Due Date, Bill Amount, Amount Due, Credit Used, Discount Used, and

Amount Paid.

Bill-related information



At the top right, the View Details button opens the plugin portal, where more

payment-related information can be found. 

TIP: Select the eye icon next to the Bill Number to open the native Intacct bill

record.

TIP: If you are looking for a specific bill, you can enter its Bill Number in the

Payment ID/Bill Number filter. This will bring all the payments related to that

specific bill. 



3.3.1.2. Positive Pay (Intacct)

The Positive Pay feature for the  enables the secure transmission of

payment details for checks cut in-house to your bank. It automatically extracts data from

checks printed using Intacct, allowing you to send a Positive Pay file for your entire check

run to the bank in just a few simple steps. Follow this guide to get started.

First Citizens Link

Prerequisites

To use this feature, Positive Pay must be enabled for your account. Please speak with your

sales representative to add this service. Also, ensure your plugin is up to date.

Before accessing the Positive Pay module, confirm the user role has been updated with the

correct permissions; it should have all the permissions granted.

Print and Confirm a Check

The plugin only transmits checks that have been both printed and confirmed inside Sage

Intacct. To complete this essential native Intacct process, follow the steps below.

1 Pay a Check

Pay a bill with Check as the selected payment method.
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Paying a bill with check as a payment method

Run a Check Run

Depending on how your Intacct environment is configured, you may need to initiate a

check run. 

To do so, navigate to Accounts Payable -> Checks -> Check Runs. Create a new

check run and click Save.



Create a New Check Run

Once you have completed that, you need to add the checks you wish to include in

the check run. To do so, use the available filters to specify the check(s) you want to

add, and select Add.

Adding Checks to Check Run
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Complete the process by clicking the Run button.

Click Run

Print and Confirm Checks

To print and confirm the check(s), navigate to Accounts Payable -> Checks -> Print

Checks.

Ensure that the check(s) you would like to print also have the Confirm checkbox

checked. 



Both Print and Confirm Checkboxes

NOTE: You may need to use the filters to view the checks you used above.

Additionally, you might need to select Preprinted Checks.

Print Options -> Select Preprinted checks radio button



Perform Positive Pay

Once the check(s) have been printed and confirmed, they will be available for

transmission. 

1

2

Go to Positive Pay

From the plugin, go to Positive Pay.

Go to Positive Pay

Transmit Checks for Positive Pay

The Positive Pay tab displays two types of checks:

Open Checks: Checks available for transmission (those in the Confirmed state).

Invalid Checks: Checks that would be transmissible if their corresponding

accounts were matched with the plugin.

Select the check(s) you wish to pay and hit Transmit. This sends the check data to

the bank for Positive Pay processing.
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Hit Transmit

Select & Print Checks

A confirmation window will appear, summarizing the checks and amounts you are

about to transmit. Please select Confirm.

Confirm Transmission



4 Transmit Positive Pay File

To view the status of your transmissions, navigate to History from the Positive Pay

tab.

You can toggle the sub-tabs to view different check types:

All Checks: Displays all transmission attempts.

Pending Checks: Shows checks currently in the transmission queue (usually for

a very short period).

Failed Checks: Lists checks where transmission was unsuccessful.

Processed Checks: Displays successful check transmissions.

Transmit Positive Pay

FAQs

TIP: You can use Export CSV in both the History and Positive Pay transmission

pages if you need to export the check data.



Which checks are available for transmission?

To be eligible for transmission, checks must meet the following criteria:

They must be from matched accounts.

They must not have been previously transmitted successfully using the plugin.

The check's state must be Confirmed (meaning it has been both printed and

confirmed).

The checks must not yet be cleared.

How can I print a check?

To print a check:

1. Pay the bill with Check as the selected payment method.

2. [Optional] Run a check run.

3. Print the check and confirm it.

What are the invalid checks?

Invalid checks are those that could be transmitted if the bank account associated with

them were matched. To transmit them, please match your account using the

installation wizard, and the checks will be available in the Open Checks column.



3.3.2.Cash Management

3.3.2.1.Reporting

3.3.2.1.1.
Managing Balances & Transactions
(Intacct)

Access your bank account balances directly within your financial management software,

using the Cash Management Reporting features. 

The Bank Accounts page allows you to see previous and intraday balances directly from

your accounts in near real-time. You can also export this data in an Intacct CSV file to use

for reconciliation.

The bank accounts that are shown to a user depend on their level of permission. For

example, if a user is restricted to a specific entity, they will only see the accounts linked to

that entity.



Viewing Bank Accounts

1

2

Go to Bank Accounts

Go to  -> Bank Accounts.First Citizens Link

Bank Accounts Page

Here, you can view all of the bank accounts that you have connected with the plugin.

View Balances and Transactions

Select the account name or view to see the previous day and intraday balances for

the chosen bank account along with transaction data.



View Account Transactions

To see the Bank Transactions, scroll down. The screen displays the information as it

appears on a bank statement.

You’ll see all of the settled transactions, debits, and credits for the account.

View specific transaction



Go to the Details column → Select View to see more details about a transaction.

Balances & Transactions Reconciliation

Follow these steps to reconcile your accounts. For a much more efficient and automated

reconciliation process, we recommend leveraging the Bank Feeds product instead.

1 Export CSV File

Go to My Bank Pay -> Bank Accounts.



Bank Accounts

Select the account that you would like to access by selecting the Account Name or

by selecting View.

View Account

Select Export to export a CSV file of your transactions.



You will be given 3 export options. We recommend using the Intacct CSV if you plan

to utilize Intacct's Reconciliation module.

Export Options

If you would like to export a CSV from a different account, you can toggle between

accounts by selecting the drop-down next to Switch to Account.
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Select another account

Import CSV File

Go to Cash Management → Reconciliation → Bank

TIP: If the file does not download, make sure your pop-up blocker is disabled.



Go To Bank

Choose the Account to Reconcile, then enter the Beginning balance cutoff date, the

Statement ending date, and the Statement ending balance.

Choose to Account to Reconcile

Select Import to add a CSV file.



Import CSV File

To import your account transactions, select Choose File and upload the CSV you

exported from Balances & Transactions.

Choose Files

Select Done.



3 Select Transaction(s) to Match from Intacct

Select the transaction(s) you would like to match from Intacct and select Match to

view the unmatched transaction(s) from the plugin. 

Select Transaction to Match

Select the transaction(s) you would like to match from the plugin and select Match.



Match Transaction

These selected transaction(s) are now reconciled.



3.3.3.Bank Feeds

3.3.3.1. Bank Feed Requirements (Intacct)

To use Sage Bank Feeds, ensure you have enabled the subscription to Sage Cloud

Services as outlined in the Pre-Onboarding Checklist, and have selected the correct

permissions. Follow the steps below if there is no Banking Cloud tab available to enable

Bank Feeds.

1 Confirm ISO Country Codes are Enabled

Go to the Company.

Go to Company
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Under the General Information section, confirm that ISO Country Codes is checked,

and then select Save.

Enable ISO Country Codes

Enable Sage Cloud Services

Go to Company → Admin → Subscriptions.



Go to Subscriptions

Confirm that Sage Cloud Services are enabled. If they are not, toggle to enable Sage

Cloud Services.

Enable Sage Cloud Services
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After enabling Sage Cloud Services, please confirm that the Enable Bank Feeds

functionality is checked in the configurations.

Enable Bank Feeds

Then select Save.

Confirm Correct Permissions

To connect a bank account to bank feeds, you must have the following settings and

the permissions below. This can be checked and updated under Company -> Users.

Subscription

Cash Management

Sage Cloud Services

User type

Business user with admin privileges

Permissions

Checking accounts: Add, Edit, View, List

Savings accounts: Add, Edit, View, List



Credit card accounts: Add, Edit, View, List

Requirements to connect an account to a bank feed

If you want to find more information about this process, visit the Sage Website: 

Connect an account to a Bank Feed

Once the account has been connected, the user with the permissions to perform the

reconciliation will be able to view the incoming transactions. No special permissions

are needed to view the transactions.

https://www.intacct.com/ia/docs/en_US/help_action/Cash_Management/Banking_and_Payment_Cloud/Bank_feeds/Connections/bank-feeds-connect-account.htm?tocpath=Applications%7CCash%20Management%7CBank%20feeds%7CConnect%20to%20a%20bank%20feed%7C_____2


3.3.3.2. Reconciliation Rule & Rule Set (Intacct)

Creating a Reconciliation Rule is the best way to streamline the reconciliation process, as it

allows you to automate it. These rules can either automatically map bank transactions to

existing Intacct transactions or create new, appropriate Intacct transactions. 

If you try to reconcile without setting up a Reconciliation Rule and an associated Rule Set,

you'll likely see errors such as:

"There are no rules associated with the rule set."

"Could not create banktxnrulerun record!"

"Apply a matching rule set to this account before reconciling with an import or bank

feeds."

Follow this guide to learn how to create Reconciliation Rules and Rule Sets needed to

prevent or resolve these issues.

Create Reconciliation Rules & Rule Set

1 Create a Rule

Navigate to Cash Management -> Setup -> Reconciliation Rules -> Rules.



Reconciliation Rules

You are then able to create rules based on your preferences. You have two options:

Match Rule: Automatically match banking transactions with existing Intacct

transactions.

Create Rule: Create Intacct transactions based on banking transactions.

Intacct requires you to create at least one rule.

As an example, you could create a rule based on the document number. This is

particularly useful for any check payments made with the plugin, which will directly

match based on the document number.

You can see an example below:
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Creating a rule

Once you have created the rule, hit Save.

Apply Rule to Rule Set

Once you have created one or more rules, you need to apply them to a rule set.

Navigate to Cash Management -> Setup -> Reconciliation Rules -> Rule Set. You

should then add the rules to an existing rule set (if any) or create a new one. 

You can create a new one by clicking Add, and then adding the rule to that new rule

set. 

Hit Select Rules to add the rule you created in Step 1. Once you have added all the

rules that you want, navigate to Step 3 below. 

TIP: You may also add a Filter Rule, which allows you to filter your transactions

before applying a matching/creation rule. For more information about the rules

and their capabilities, visit:

About rules and rule sets

Please note that you cannot delete rules, but you can 

instead. 

set them to inactive

https://www-p02.intacct.com/ia/docs/en_US/help_action/Cash_Management/Reconcile/Reconciliation_rules/about-rules-rulesets.htm?cshid=Cash_Management/Reconcile/Reconciliation_rules/about-rules-rulesets.htm
https://www-p02.intacct.com/ia/docs/en_US/help_action/Cash_Management/Reconcile/Reconciliation_rules/Rules/inactivate-a-rule.htm
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Add rule to rule set

Add Rule Set to Bank Account

The final step is to make sure that the Rule Set is added to the bank account.

Still on the Rule Set page, where you create the new Rule Set (or add the rule to the

existing one), navigate to the Account tab and select the accounts you want the Rule

Set to apply to. You can select as many accounts as you wish. 



Add Rule Set to Acounts

When you are done, click Save at the top right.

You can now easily reconcile your accounts without errors, as your bank transactions

automatically match with the corresponding Intacct transactions.



3.3.3.3. Enabling Bank Feeds (Intacct)

Bank Feeds allow for your settled bank transactions to automatically flow into Intacct for

reconciliation, removing the need to export and import bank statements manually. To

enable Bank Feeds, follow the instructions below. 

Step 1: Locate the Account

Go to Cash Management → Checking.

Go to Checking

On the Checking page, select Edit on the account you wish to turn on Bank Feeds for.



Select Edit

Step 2: Activate Bank Feeds

Under the Banking Cloud tab, click Connect.



Connect Banking Cloud

In the search bar, search " " or select  - Powered by

FISPAN from the list of banks already displayed.

First Citizens Bank First Citizens Bank

Search for First Citizens Bank



Agree to the terms and conditions and select Continue.

Agree to Conditions

You will be redirected to a landing page that will require you to sign in to the FISPAN

Wizard.

Select Login Now.



Login Now

Step 3: Match Account for Bank Feeds

After logging in, select the account from Step 1, then select Save and Finish. You will

automatically be redirected back to Sage.



Select Account

After being redirected back to Sage, select the same account and click OK.

Click Ok

Choose the date you want transactions to start from.



Choose Date

Step 4: Confirm Bank Feeds

Select Confirm to confirm the activation of Bank Feeds. Once the connection is

successful, the status will change to Connected.

NOTE: You must complete account matching within 60 minutes; otherwise, the

installation wizard will time out, the connection will fail, and the account will remain 

Pending with no transactions coming in. 

To retry, disable the account(s) under the Accounts table and reinitiate the mapping

process.



Confirm Bank Feeds

Once the account is Connected, go to Cash Management -> Reconciliation -> Bank and

follow your native reconciliation process. 

By enabling Bank Feeds for the plugin, your bank establishes a reliable and secure flow of

transactions from your bank into Sage Intacct’s Reconciliation module.

Bank transactions that settled the previous day are imported each morning. For example,

transactions that are settled on Tuesday will be pushed into Sage Intacct early on

Wednesday morning. The exact timing can vary depending on when your bank sends the

first transaction file (PDR).

NOTE: If you are processing more than 100 transactions, we advise you to wait until

the next day to see the transactions posted.

NOTE: If the account is in Pending status, it means that the transactions have not

been pushed for this account. You will need to wait until the transactions are

successfully pushed to this account before seeing it marked as Connected. 



Set Up Multi-Account Bank Feeds

Bank Feeds allows you to connect multiple accounts to the plugin. Once one bank account

has been connected to Bank Feeds by following the Enabling Bank Feeds page, other

accounts can be connected simultaneously through a financial institution connection.

Follow the steps below to set up multiple accounts for Bank Feeds.

1 Set up a Financial Institution

Go to Cash Management → Set up → Financial Institution and create a new

Financial Institution.

Set-up Financial Institution

NOTE:  Before you set up the Financial Institution, ensure that both Cash

Management and Sage Cloud Services are enabled in the Subscriptions section. In

the Sage Cloud Services configuration, confirm the Enable Bank Feeds checkbox is

checked as per the Enabling Bank Feeds page.

If this does not work, please contact Sage support and ask to get access to the

Financial Institution.
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This allows you to create a connection to the bank. Create the ID and Name as

desired.

Create Financial Institution

Map Accounts for Bank Feeds

Select Map Accounts and choose which accounts you would like to enable on Bank

Feeds.



Map Accounts

If there are more than 100 transactions, the plugin will upload them into the system in

batches of 100. This may cause some transactions to appear initially, while others will

appear later. Typically, it takes a few hours to view all your transactions.

NOTE: You must complete account matching within 60 minutes; otherwise, the

installation wizard will time out, the connection will fail, and the account will

remain Pending with no transactions coming in.

To retry, disable the account(s) under the Accounts table and reinitiate the

mapping process.



Map Accounts

After mapping the accounts, the Banking cloud statuses can be seen in the Accounts

tab.

Account Status



To view your account information, click Bank Transactions in the Cash Management

module. You can also view this information through the Reconciliation module. 

Observe Bank Transactions



3.3.3.4.
Adding Accounts to Bank Feeds
(Intacct)

Use this guide to add and configure Bank Feeds for new accounts, assuming you already

have Bank Feeds enabled for existing ones. For example, you might have recently added

new bank accounts to the plugin and now need to set them up for easier reconciliation.

Set Up Multi-Account Bank Feeds

Bank Feeds allows you to connect multiple accounts to the plugin. Once one bank account

has been connected to Bank Feeds by following the Enabling Bank Feeds page, other

accounts can be connected simultaneously through a financial institution connection.

Follow the steps below to set up multiple accounts for Bank Feeds.

1 Set up a Financial Institution

Go to Cash Management → Set up → Financial Institution and create a new

Financial Institution.

NOTE:  Before you set up the Financial Institution, ensure that both Cash

Management and Sage Cloud Services are enabled in the Subscriptions section. In

the Sage Cloud Services configuration, confirm the Enable Bank Feeds checkbox is

checked as per the Enabling Bank Feeds page.

If this does not work, please contact Sage support and ask to get access to the

Financial Institution.



2

Set-up Financial Institution

This allows you to create a connection to the bank. Create the ID and Name as

desired.

Create Financial Institution

Map Accounts for Bank Feeds



Select Map Accounts and choose which accounts you would like to enable on Bank

Feeds.

Map Accounts

If there are more than 100 transactions, the plugin will upload them into the system in

batches of 100. This may cause some transactions to appear initially, while others will

appear later. Typically, it takes a few hours to view all your transactions.

NOTE: You must complete account matching within 60 minutes; otherwise, the

installation wizard will time out, the connection will fail, and the account will

remain Pending with no transactions coming in.

To retry, disable the account(s) under the Accounts table and reinitiate the

mapping process.



Map Accounts

After mapping the accounts, the Banking cloud statuses can be seen in the Accounts

tab.

Account Status



To view your account information, click Bank Transactions in the Cash Management

module. You can also view this information through the Reconciliation module. 

Observe Bank Transactions



3.3.3.5. Disabling Bank Feeds (Intacct)

To disconnect an account from Bank Feeds, follow these steps.

1

2

3

Navigate to Accounts

Navigate to Cash Management -> Accounts. 

Disconnect Account

Select the bank account you would like to disconnect. 

Click Edit and navigate to Banking Cloud. From there, click Disconnect.

Disconnect Bank Feeds Account

Confirm Status

Once you have confirmed the disconnection, the status will update to Disconnecting.

The status may stay like this for a couple of minutes. 



Disconnecting Bank Feeds Account

Once the account has been fully disconnected, the status will revert to Connect. If

desired, you are able to start the connection process again by following the Enabling

Bank Feeds guide.

Back to 'Connect' status





3.4.Troubleshooting

3.4.1. FAQs (Intacct)

This page is your go-to resource for quick troubleshooting. We've compiled a list of the

most common errors and frequently asked questions you might encounter when using the 

 in Intacct, providing you with immediate answers and resolutions.First Citizens Link

Installation & Plugin Setup

Common Questions

This list provides answers to common questions that arise during the installation process,

to help ensure a smoother setup in Intacct.

Why can't I see the accounts in the Account Matching page of the installation

wizard?

This happens when you are missing some permissions on your Web Service User.

Please refer to the Create Web Service User step inside the Installation Guide. 



Why am I failing to pass the Connection step in the installation wizard?

This occurs when you have entered incorrect information in the previous step of the

installation wizard. Ensure that you include the Web Service User information and not

the user's native Intacct credentials. Additionally, you must verify that the Web Service

User has been created with admin access.

Bank Feeds

Common Questions

This list provides answers to common questions that arise when using the Bank Feeds

product in Intacct.

Why is my account stuck in Pending status when I connected my account to Bank

Feeds?

If the account is in Pending status, it means that there have not yet been any

transactions processed for this account. You will need to wait until transactions occur

on this account before it is marked as Connected.

How do I connect more than one account at a time to Bank Feeds?

Bank Feeds allows you to connect multiple accounts to the plugin. Once one bank

account is connected to bank feeds, other accounts can be connected simultaneously

via a financial institution connection. Please refer to the guide on Multi-Account Bank

Feeds Setup.

Accounts Payable

Common Questions

This list provides answers to common questions that arise when using the Accounts

Payable product in Intacct.



How long do bills stay on the History Page?

Bills never leave the history page. As long as there is a working sync between Intacct

and the plugin, you should be able to see your paid bills. 

Why do my bills not appear inside the plugin?

There could be a few reasons that a bill created inside Intacct does not appear inside

the plugin: 

The bill is not in Posted status. If you have a bill approval in place, the bill will only

show in the plugin once it has been approved. 

The Web Service User does not have the appropriate permissions. Please refer to

the Create Web Service User guide for more information.

The bill is in a specific entity that the Web Service User does not have access to.

You may need to grant the Web Service User access to that specific entity. 

The Vendor has been marked as Don't Pay. If that is the case, simply uncheck

that box. 

Why do I see multiple instances of the same bill on the History Page?

If you pay a bill with partial payments, the same bill will appear multiple times on the

History Page. Similarly, if a bill has failed and has been repaid, it will also appear in

multiple payments on the History Page.  

How many bills load per page?

The plugin displays 200 bills per page, and you can only combine payments from bills

on one page at a time.

Why do the bills in a specific entity not show up?

This is likely because your Web Service User is missing some permissions. Please

ensure it has access to any entities you would like to utilize. This situation should

occur only when you add entities after having created the Web Service User earlier.



For multi-entities, can the company name be unique per bank account?

Yes, please contact your bank and request that they enter a unique Account Holder

Name for each bank account using the details you provide. If there is an entry in the 

Account Details -> Account Holder Name field, this name will appear on vendor

payments; otherwise, it will default to the Account Label (i.e., Company Name).

For example, if the umbrella company is ACME Holdings, the name on the payments

would appear as coming from ACME North or ACME South, etc., based on the bank

account used for the payment.

Common Errors

Below is a list of common errors encountered when using the Accounts Payable product in

Intacct. Click on any error message to view the cause and immediate troubleshooting steps

for a resolution.

"You do not have the permissions for operation READ_BY_QUERY on object of type

trxcurrencies"

This is because the multi-currency module has not been enabled. We recommend

enabling this module to avoid this error. You may need to contact Sage Support to

have it enabled. Please note that you are still able to make payments even if you do not

have multi-currencies enabled.

"You do not have the permissions for operation READ_BY_QUERY on object of type

locationentity"

This is because you are missing the Entities permissions for the role/user. Please

navigate to Company -> Subscriptions -> Role and add the Entities permissions for 

View.



3.5. Release Notes (Intacct)

To learn about how to update your plugin visit: Updating the Plugin (Intacct)

2026

May 2026

2026.6 - May 13, 2026

Added Bank Accounts Page Enhancements.

Improved Enhanced status accuracy for Payment History.

New Products Added

We are excited to announce a streamlined UI refresh and enhanced data visibility for our

clients. This update focuses on better organization for diverse account types and improved

transaction tracking.

The page you know as Balances and Transactions is evolving. To support our expanding

ecosystem of account types, we have rebranded this space to Bank Accounts. This new UI

provides a cleaner foundation for managing multiple financial streams in one place.

NOTE: These updates are part of our May 2026 release. While you may see these

features documented in our guides earlier, please note that all changes will officially

go live on May 13, 2026.



Key Benefits and Highlights

1

2

3

4

New "Counterparty Name" Column

To help you identify partners and sources faster, we’ve added a Counterparty

Name column to the Transactions model.

NOTE: This column will appear blank as we are working on extracting out this

information.

 Dedicated Deposit Account Tabs

Organization just got easier. Use the new Deposit Account Type tab to instantly

access all information related to your checking and savings accounts, keeping

them distinct from other account types.

Enhanced Filtering & Search

Stop digging through rows of data. You can now perform targeted searches and

filter your views by:

Bank Reference

Customer Reference

Amount

Description

Post Date

Visual UI Refresh & Country Identifiers

We’ve added Country Images (flags/identifiers) to the account interface. This

allows you to spot the geographic source of funds and account origins at a

single glance, providing better global context for your Treasury team.

Improvements

We’ve updated the Payment History page to ensure all transaction statuses are accurately

represented. Records designated as "Completed with Change" now populate correctly



within your history view. This update ensures the continued integrity of your payment data,

providing a comprehensive and reliable audit trail for all finalized transactions.

April 2026

2026.5 - April 15, 2026

Improved General improvements and bug fixes.

March 2026

2026.4 - March 11, 2026

Improved General improvements and bug fixes.

February 2026

2026.3 - February 11, 2026

Improved General improvements and bug fixes.

January 2026

2026.1 - January 14, 2026

Improved General improvements and bug fixes.



2025

December 2025

2025.16 - December 10, 2025

Fixed General improvements and bug fixes.

November 2025

2025.15 - November 12, 2025

Fixed General improvements and bug fixes.

October 2025

2025.14 - October 15, 2025

Fixed General improvements and bug fixes.

September 2025

2025.13 - September 10, 2025

Improved

As part of our ongoing efforts to maintain consistency across the

platform, we’ve updated the Payment Details page within the Activity

view to reflect current interface standards. 

Improved

We've updated the Open Bills page to improve how credits are applied.

Now, credits will be seamlessly and accurately applied to a wider range

of transaction amounts, making your experience smoother and more

reliable. 



August 2025

2025.12 - August 13, 2025

Improved

We've updated the plugin to support email addresses with multiple

periods in their domain names. This improvement ensures greater

flexibility and accuracy when entering and storing email information. You

can now successfully add and validate email addresses like

jane.doe@example.co.ca. 

Fixed

The vendor approval feature has been improved to handle email

addresses in a case-insensitive manner (e.g., Jane.Doe@example.com).

This ensures that users can approve requests regardless of how their

email address is capitalized.



4.Business Central

4.1.Plugin Setup

4.1.1.
Pre-Onboarding Checklist (Business
Central)

Use this checklist to get ready for your onboarding call. Having everything on hand will

also help you if you decide to start the installation on your own.

Confirm Administrator Access

In order to install your bank's Business Central integration for Cloud ( ),

the installing user is required to have the Cloud Application Administrator role within their

Microsoft Active Directory profile. You also must have a Business Central License

(Premium or Essentials). Please request that your Microsoft Administrator apply this role

before proceeding. The installation cannot be completed without this role.

Dynamics.com

https://urldefense.proofpoint.com/v2/url?u=http-3A__Dynamics.com&d=DwQFaQ&c=euGZstcaTDllvimEN8b7jXrwqOf-v5A_CdpgnVfiiMM&r=j25MqVoOXBWMzp6PUiLtQCoQ31rEYTt3NxZd2CXgxF4&m=jYVGjieIquX859vsruwMTk22pNAsEWkjgtzMOv6TJ8s&s=fJQp21btrGpxtITrmS8UMfDML9cQp3e-QmvsJzXeikc&e=


Ensure the Microsoft Azure Admin is present on the onboarding call, or that someone on

the call has the necessary permissions to install extensions and manage permissions.

Compatible Business Central Version

Please verify that you are on the Cloud (Dynamics.com) version of Business Central and

that you are running Version 18 or later.

The Business Central version can be found by selecting the (?) icon in the top right when

logged in. Select Help & Support found under the Other Resources section. 

Help icon - question mark

Scroll to find the Troubleshooting section and observe the Platform Version. For example, 

21.0.53597.54893  describes a system on Major Version 21. 

For more information, visit the . Microsoft Documentation on Version Numbers

Support Multiple Companies

https://learn.microsoft.com/en-us/dynamics365/business-central/dev-itpro/administration/version-numbers


If the organization has multiple companies, you should be utilizing Multi-Entity

Management (MEM) by Binary Stream. If your organization has multiple companies and is

not using MEM, we can only support onboarding one company at a time. 

If using MEM, please note that users will not be able to:

Write into the check ledger entries.

Batch payments.

Overwrite the "Doc No." for check payments.

Compatible Third-Party Solutions

Is your organization using any third-party integrations or extensions?

Extensions that impact core Cash Management pages or Vendor objects will likely cause

conflicts.

There are known compatible solutions that include MEM by Binary Stream and Lanham

(EDI, E-Ship, E-Receive).

Note Your Approval Processes

If you have an invoice/payment approval process in Business Central, it may interfere with

the plugin's expected behavior.

Please identify this early so we can determine the correct testing scenarios to ensure the

plugin works alongside their specific approval workflow.

Using Business Central's Remit Feature

Using Business Central's Remit-To Code on a bill does not impact the success of the

payment. However, the plugin does not pick up the specific Remit Address, nor does it

update the Vendor Card. The payment will still be issued to the address on the Vendor

Card, rather than the address added to the bill.



Configure Payment Journals

Does every company within the Production environment have a payment journal

configured?

If any company lacks a configured payment journal, the plugin installation will fail—even if

you only intend to use bank feeds. Please confirm this for each company before

installation.

Review Known Limitations

Please review the following limitations to ensure they align with your business needs.

Multiple Extensions or Scheduled Jobs

Microsoft limits the number of API calls a single user can make within a specific time

range. If the client has multiple extensions or scheduled jobs making a high volume of API

calls, they may conflict with the plugin. 

We highly recommend testing in a sandbox with all extensions and scheduled jobs running

to ensure full compatibility.

Credit Memos

Credit memos cannot be applied at the time of payment via the plugin. To have credits

appear at the time of payment, please apply the Credit Memo to the Posted Purchase

Invoice before making the payment. This can be done through the Vendor Ledger entries

or by using the Applies to Doc No. method.

Azure Government Cloud

The plugin is not hosted on Azure and currently does not meet Azure Government Cloud

requirements.

Support for Non-AP Payments



The plugin currently only supports payments to Posted Purchase Invoices. Other payment

types (e.g., Customer Refunds, Employee Expenses) are not supported.

Confirm Hardware & Software Requirements

Browser support (minimum versions):

Chrome: 65

Firefox: 66

Safari: 12

Edge: 79

Operating systems (minimum versions):

Windows 7

macOS - El Capitan

Minimum screen resolution:

1200x800px



4.1.2. Installation

4.1.2.1. Step 1: Invitation Email

You should have received an invitation email from  with links to install

the  and easy-to-follow instructions for installation.

First Citizens Bank

First Citizens Link

The invitation email will arrive with the following subject line:

Welcome to   - Powered by FISPAN [Production] - [your-name]First Citizens Link

Invitation Email





4.1.2.2. Step 2: Register & Login

Register & Login

1

2

Create an Account

In your invitation email, select the Get Started button. You will be brought to the 

. Create your login credentials and select Create Account.FISPAN Portal

Passwords are required to be 8 characters and contain at least one uppercase,

lowercase, number and special character

Login to Your Account

Once registered, you will be redirected to the login page. Your username and

password are unique per environment, and you will have separate logins between 

 and .Sandbox Production

NOTE: The password you create here will be used every time you want to

access the . If you need to update it later on, you have the option

to use the Forgot Password option.

FISPAN Portal

https://sandbox.fispan.cloud/login
https://sys.fispan.live/login


The welcome page for Sandbox

From the welcome page, you'll be taken to the login page. Enter your username and

password to proceed. 

Setting Up SMS MFA

The first time you log in to the Production environment, you will be prompted to establish

your Multi-factor Authentication (MFA) setup. You have the option to select various

methods of MFA. 

NOTE: The Sandbox environment is used as a testing or UAT environment. For

Sandbox users, please refer to the Sandbox Checklist for test scenarios.

NOTE: Multi-factor Authentication (MFA) is only required if you are a user in the

Production environment. If accessing the Sandbox environment, you may skip this

step.



1

2

3

Enroll Phone Number

Select your country code then enter your phone number, you will receive a text

message with a 6-digit code via SMS to the phone number you provided for

enrollment.

If you are unable to receive a text message to this number, or you prefer a different

multi-factor authentication method, click Try Another Method. 

Enter Code

Enter the 6-digit code you received in the applicable field.

Select Continue.

6-digit Verification

Save Recovery Code

After setting up SMS and inputting the first one-time code, you will be presented with

a recovery code that should be stored in a safe location. This code is for resetting the

MFA, to switch the MFA type (i.e., Authenticator), or to use a different phone number. 



Recovery Code

If you would like to utilize another method for MFA (SMS, Authenticator, or Email)

instructions are available here: . Setting Up Multi-Entity Management (BC365)



4.1.2.3. Step 3: Select ERP

Select Install on the Business Central box and the installation wizard will appear on your

screen.

Select Microsoft Business Central 365



4.1.2.4. Step 4: Overview

The first page of the installation wizard provides a brief summary. Before you continue, you

must review and complete the pre-onboarding checklist.

When you're finished, click the toggle next to "I have completed the pre-onboarding

checklist." This will activate the Get Started button.

To proceed to the next step, click Get Started.

Select Get Started



4.1.2.5. Step 5: Permissions

You must agree and allow access grants by clicking the slider. After doing so,

click Next Step.

The plugin requires these objects to create a bill payment or display account balances and

transaction information. The plugin will only write to custom fields introduced by the plugin.

ERP Permissions - installation wizard page



4.1.2.6. Step 6: Download Plugin

Select Download Plugin. Once you have downloaded this file, return to Business Central.

The next page of this guide and the video on this screen will guide you through the

installation process.

Install Plugin



4.1.2.7. Step 7: Install .app

Follow these steps in Business Central to install the  .app.First Citizens Link

1

2

Go to Extension Management

Search for Extension Management in the search field and select the relevant link.

Search Extension Management

Upload and Deploy Extension

Select Manage and then Upload Extension.



Select Upload Extension

Select the three dots on the Select .app file field and choose the .app file

downloaded from the installation wizard. 

Add Your .app File

Then, toggle the Accept disclaimer and select Deploy.



3 Confirm Installation

Confirm the plugin has been installed properly by navigating to Manage and

selecting Installation Status. 

Ensure the Plugin is Installed

The status column will say Completed when it has been installed properly.  



4.1.2.8. Step 8: Allow HttpClient Requests

Once the file has been deployed, click on the extension.

Click on the Extension

Then, ensure the Allow HttpClient Requests toggle is enabled. 



Enable HttpClient Request



4.1.2.9. Step 9: Authentication

To proceed, select the Connect to Business Central button in the installation wizard and

sign in with your Microsoft account.

Connect to Business Central

You should ensure this Microsoft account has access to the desired Business Central

environment.

NOTE: We recommend using an account with at least the Application Administrator

role, as this is needed to consent to third-party applications. If you have a custom

role, confirm that you can consent to both delegated and application permissions.

You will also need a Business Central license and administrator access to complete

the application installation within the ERP.

Read more about this .here

https://learn.microsoft.com/en-us/entra/identity/role-based-access-control/permissions-reference


4.1.2.10.
Step 10: Select Environment and
Company

Select the environment and company that you would like to use the plugin with. Then,

select Next Step.

Select Environment and Company



4.1.2.11. Step 11: Connection Check

After entering credentials in the last step, the installation wizard will begin to run a

connection check to validate all details entered in the previous steps.

If there are no issues, a large green checkmark will appear to confirm that the connection

has been established. Click on Next Step to begin matching bank accounts.

Confirm Connection

IMPORTANT: If you see the Invalid Credentials error, immediately confirm:

The plugin is fully installed.

You have the required Business Central license and App Admin permissions.

You selected the correct environment & company.

If the problem continues or if you changed your settings, you must reset the

connection. Go back to the authentication step, disconnect the current connection,

attempt to reconnect, and then finish the installation wizard.





4.1.2.12. Step 12: Account Matching

Match your ERP accounts with the corresponding bank accounts by dragging an ERP

account from the left and dropping it onto the desired bank account. 

Once you've successfully matched your accounts, click Next Step.

Match Accounts

NOTE: When installing the plugin in Sandbox, bank accounts are for testing only.

They are not connected to your live bank accounts. When installing in Production, the

listed bank accounts reflect your actual accounts.



4.1.2.13. Step 13: Add User Permissions

To set permissions for user roles, follow these steps. 

1 Select Users

In your Business Central account, search for and select Users.

Select Users

Find the user you would like to grant access to the plugin and select Edit.
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Select Edit

Add Permission Sets

Scroll down to User Permission Sets and select the three dots within the text box to

open the Permission Set Lookup.

Open Permission Set Lookup



Find and add the following Permission Sets as needed:

FCBV3BF - Allows users to utilize bank feeds

FCBV3CORE - Required for any user using the Plugin

FCBV3FULL - Allows users full access to the Plugin

FCBV3PB - Allows users to make payments through the Pay Bills page

FCBV3PM - Allows users to access the Payment Methods page 

FCBV3RR - Allows users to view balances and transactions on the Bank Statements

page

Once all necessary Permission Sets have been added, confirm that the page has been

saved. 

Please ensure that FCBV3CORE is granted to all plugin and non-plugin users that use

records the plugin interacts with i.e. Bank Accounts, Vendors, etc. 

This does not give non-plugin users access to the plugin pages. 



4.1.3.
Post-Onboarding Checklist (Business
Central)

You are almost ready to use the plugin. There are a few additional steps that are required in

order to use the product to its full potential. Review all items in this guide to ensure you are

not missing anything.

Grant Permissions 

To ensure users can view and utilize the plugin, an administrator must grant them

permission. You can follow  to enable permissions.Step 13: Add User Permissions

Import Vendor Bank Account Data 

If you do not currently store your vendors' bank account details in Business Central, you

must add them to make payments. Use the guide

to walk through successfully importing data into Business Central

using the plugin. 

Updating Vendor Payment Methods Via

CSV (Business Central)

Set the Default Payment Method 

Setting a default payment method and source bank account for each vendor is optional but

highly recommended. It enables you to initiate payments quickly, and you retain the

flexibility to change them later.

NOTE: For Sandbox users, feel free to skip the steps that may not apply to your use

case. We strongly recommend following the .Sandbox Checklist (Business Central)

TIP: We recommend testing the import with a few bank accounts in Sandbox first

before attempting this in Production.



Configure Bank Feeds

Configure Bank Feeds next to optimize your reconciliation process. Use the 

guide to learn how to set up this feature.

Enabling Bank

Feeds (Business Central)

Test the Plugin

Now that the setup is complete, we recommend performing test payments across all your

commonly used payment rails. Testing is the best way to familiarize yourself with the

plugin's features and ensure you know how to utilize it efficiently for all scenarios.

If you run into any issues during testing, please be sure to take screenshots! Screenshots

help us quickly and effectively assist you with troubleshooting.



4.1.4. Sandbox Checklist (Business Central)

If you're testing the plugin in a Sandbox environment, it's recommended to test a variety of

scenarios. This will help you confirm that your setup is properly supported and functioning

as expected.

Scenarios to Test

Below is a list of scenarios you may wish to test. 

1

2

3

Confirm Plugin Setup

After completing the installation wizard, navigate to the plugin and open the Bank

Statement page.

Expected Outcome: All matched bank accounts should display on this page,

complete with mock account balances and transactions.

Configure Vendors

Navigate to the Payment Method tab within the plugin and select a vendor. Any

existing vendor email, address, or bank account information will automatically sync

into the plugin.

If data is missing, select Add Bank account within the plugin and fill in test bank

account details (we recommend adding a routing number and account number to

perform a test ACH payment). Alternatively, you can add this information to the native

Vendor Bank Account card in Business Central, which will sync over after a few

moments.

Expected Outcome: Ensure at least one vendor has ACH information stored on their

bank account record to successfully make a test payment.

Create a Purchase Invoice



4

5

Create and populate a standard Purchase Invoice in Business Central. The extension

fully supports discounts and credit memos. Once complete, post the purchase

invoice.

Expected Outcome: The posted purchase invoice should be immediately available

within the payment journal, ready to be paid via the extension.

Make an ACH Payment

To initiate the payment, select the plugin in the header and choose Pay Invoices. All

Posted Purchase Invoices will load on this page. 

Locate and select the invoice you created earlier using the checkbox. After

confirming a payment method is selected, click Add to Payment Run and confirm the

payment. 

Expected Outcome: The payment submission result will appear under the Payment

History sub-tab. Additionally, the ledger will show that a payment has been created

and applied to the posted purchase invoice, successfully closing the transaction.

Trigger a Failed Payment 

Create a Purchase Invoice for exactly $1,991.00. Then, navigate to the Pay Bills page

and process the payment through the extension. 

Expected Outcome: Payments of this specific amount will be marked as failed

shortly after submission. Although a payment will be initially created and applied to

the invoice, it will then be automatically voided, resulting in the bill being made

available for a new payment attempt.



4.2.Configuration

4.2.1.Plugin Management

4.2.1.1. Mapping Bank Accounts (BC365)

Once the  installation and setup are completed, you are still able to map

any new bank accounts that are added to the plugin. 

First Citizens Link

1 Log in to Portal

Head to the   or  you used to

register for an account with FISPAN when you installed the plugin.

FISPAN Production Portal FISPAN Sandbox Portal

https://sys.fispan.live/login
https://sandbox.fispan.cloud/
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Go to FIPSAN Portal

Log in to the portal with the email and password you used to register.

Log In

Go to Accounts

Select Associate Accounts and map the accounts you would like to map.



Select Associate Accounts

Match your ERP Accounts with the appropriate Bank Account. Simply drag the ERP

Account from the left and drop it onto the bank account you would like it to be tied to.

Once you have successfully matched your accounts, select Save & Finish.

Match Your Accounts





4.2.1.2.
Setting Up Multi-Entity Management
(BC365)

If you plan to use this plugin with Multi-Entity Management (MEM) by Binary Stream,

please review the configuration requirements, user access, and limitations on this page.

MEM Configuration

The plugin requires minimal MEM configuration. The following two criteria must be met for

successful integration:

1 MEM is Enabled

In Global Search, look for the Multi-Entity Management Setup. On this page, make

sure Disable Multi-Entity Management is disabled. 

NOTE: If Multi-Entity Management (MEM) is not installed in an instance, you will need

to reach out to Binary Stream before installing the plugin. You can learn more by

going to the  website page.Binary Stream MEM

https://binarystream.com/products/D365BC-MEM/
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Ensure Disable MEM is Off

If this option is enabled, the plugin will not respect any subsidiaries when posting and

paying bills. This could potentially lead to payment failure or inaccurate records

being posted.

Global Dimension is Selected

Either Global Dimension 1 or Global Dimension 2 Code must be selected in the Entity

Dimension field. Both are supported via the plugin. 



MEM Multi-Entity Managment Setup - Set Entity Dimension

The selected Entity Dimension in the plugin's settings page will automatically sync.

You cannot toggle the MEM Enabled status within the plugin; it is automatically

toggled on as long as MEM is active in Business Central.

MEM settings



User Access

Multi-Entity Management (MEM) restricts a user's visibility and access to financial data

within the system. Access is controlled by assigning users to specific entity codes,

ensuring they can only interact with payments to these entities.

Invoices

Invoices must be assigned to an entity. 

For a user, the Pay Invoices and Payment History pages are filtered to only display invoices

assigned to entities that the user has access to. This access is granted by assigning the

user access to specific entity codes.

To set this up, use the global search functionality and search for MEM User Security

Setup. Here, users can be assigned access to specific entities. 

Assign Access to Entities

In the example above, this user is only assigned access to invoices with the entity codes

A01, B01, or B02, and will only have visibility to those records. They will not be able to see

invoices assigned to C01 or C02.



Bank Accounts

Bank accounts must also be assigned to an entity.

The same entity-based logic applied to invoices is utilized here. Bank accounts loaded on

the Pay Invoices page and the Bank Statements page will only display those assigned to

the entities the user has access to. This access is also granted by assigning the user

access to specific entity codes in the MEM User Security Setup.

Following the same example, this user would only have access to bank accounts with the

entity codes A01, B01, or B02. They will not be able to access any bank accounts assigned

to C01 or C02.

Vendors

There is no current filtering on access for vendors via the plugin. 

Disabling MEM

Please consult with your ERP Consultant and/or Binary Stream to remove MEM from your

environment.

Once uninstalled, the plugin will not be able to read or modify records for companies

specified under the Entity Dimensions.

Limitations

Since  and Multi-Entity Management by Binary Stream Software are two

independent extensions, the following features will be disabled by  upon installation

due to incompatibility with the MEM architecture.

FISPAN

FISPAN

1

2

Write Check Ledger Entries

The feature specifies whether check ledger entries should be made for any check

payments through the plugin.

Overwrite Doc No. Check Payments
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The feature specifies if the Document No. on the ledger entries should be overwritten

on check payments.

Batching Ledger Entries

This feature allows multiple invoices to be paid under one payment through the

plugin. When enabled, it combines invoices into one entry in the bank account ledger

entries, check ledger entries, and vendor ledger entries.

NOTE: Although check numbers will not be overwritten or added to the check

ledger entries, check numbers can still be accessed via the Payment History

CSV Export for your records.



4.2.1.3. Updating the Plugin (BC365)

Keeping the plugin up to date with the latest version is crucial for ensuring you have

access to all the newest features, important bug fixes, and updates. To update, please

follow these steps.

1

2

Navigate to Settings

Navigate to  and select Settings.First Citizens Link

Select Settings

Download the Update

Navigate to Actions, and select Update Plugin.
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Select Update Plugin

Confirm Download

This will prompt the user to download the latest plugin version. Select Yes to

download the file. 

Click Yes



4
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Upload the Extension

Once downloaded, search Extension Management under Global search. 

Select Installation Status

Select Manage and then click Upload Extension.

Deploy the Extension

This opens up a pop-up screen to upload and deploy extensions. You can select

the … in the Select .app file field and choose the file from your computer.
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Deploy Extension

Once selected, Accept the Disclaimer and select Deploy.

Select Deploy

Check Installation Status

To view the status of the deployment, select Installation Status under Manage.



Select Installation Status

If you are experiencing an error deploying using the above steps, on the Upload And

Deploy Extension window, enable Schema Sync Mode: Force, then select Deploy. 

Repeat Step 6: Check Installation Status.



Select Force



4.2.1.4. Reauthentication (BC365)

You may be required to reauthenticate your ERP system connection. This issue can occur

for a few reasons:

Your authentication token has expired and failed to automatically refresh.

The user account initially used for authentication is no longer active within your

organization (e.g., the user has left or their credentials were disabled).

Follow these steps to reauthenticate. 

1

2

Navigate to FISPAN

To reauthenticate, navigate to: 

Production - sys.fispan.live

Sandbox - sandbox.fispan.cloud

Reauthenticate

On this screen, under Connected Apps, click the three dots. 

Connected Apps - three dots dropdown menu - select Reauthenticate

https://sys.fispan.live/
https://sandbox.fispan.cloud/login
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Then select Reauthenticate. 

Re-Establish Connection

After clicking reauthenticate, you will be asked to log in to Business Central. This will

re-establish the connection between your bank and ERP so you can resume all

activities. 

Authenticate with Microsoft - Select Connect to Business Central



4.2.1.5. Uninstalling the Plugin (BC365)

To uninstall the plugin from Business Central, follow these steps.

1

2

Locate the Plugin

In the search bar, search for Extension Management. 

Search Extension Management

Locate the plugin in the list of extensions. There may be multiple copies of the

extension file for each update you have done. 

Use the filter on the page to find the latest version. 

Uninstall the Plugin

Once you have located the app, you can click Uninstall. 
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Select Uninstall

Review the extension details and toggle the Delete Extension Data option before

clicking Uninstall.

Extension Uninstallation window

Remove Permissions



Now that you have uninstalled the plugin, the next step is to remove user

permissions.

In the search bar, search for Users. 

Search Users

Find the users with access to the plugin and select them. 
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User Permission Sets - Select Delete Line

Delete the plugin's Permission Set from the list of User Permission Sets.

Remove Bank Feeds 

If utilizing Bank Feeds, the last step is to remove Bank Feeds from Business Central

by removing the Bank Statement Import Format from a bank account. 

Go to Cash Management → Bank Accounts and click on a bank account.

Under the Transfer tab, clear the value from the Bank Statement Import Format field.



Transfer section - Bank Statement Import Format field

Once that is completed, the box should be empty. You will need to repeat this for

every bank account that had a format selected. 

Transfer section - empty Bank Statement Import Format field



4.2.2.User Management



4.2.2.1.
Setting Up Multi-Factor Authentication
(BC365)

Multi-Factor Authentication (MFA) Overview

Multi-factor authentication (MFA) adds another level of security for all users when using

the  to . With MFA, your data is protected against account breaches and

is accessed by authorized users.

FISPAN Portal login

When registering, all new users must set up Multi-Factor Authentication (MFA) by choosing

an authentication method (the default option will be shown first).

If you prefer a different method, select Try Another Method to choose one of the following

options:

SMS (preferred)

Authenticator (or similar)

Email

NOTE: MFA does not apply to the Sandbox environment.

https://sys.fispan.live/login


Authentication Methods

Setting Up SMS MFA

The first time you log in to the Production environment, you will be prompted to establish

your Multi-factor Authentication (MFA) setup. You have the option to select various

methods of MFA. 

1 Enroll Phone Number

Select your country code then enter your phone number, you will receive a text

message with a 6-digit code via SMS to the phone number you provided for

enrollment.

If you are unable to receive a text message to this number, or you prefer a different

multi-factor authentication method, click Try Another Method. 

NOTE: Multi-factor Authentication (MFA) is only required if you are a user in the

Production environment. If accessing the Sandbox environment, you may skip this

step.
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Enter Code

Enter the 6-digit code you received in the applicable field.

Select Continue.

6-digit Verification

Save Recovery Code

After setting up SMS and inputting the first one-time code, you will be presented with

a recovery code that should be stored in a safe location. This code is for resetting the

MFA, to switch the MFA type (i.e., Authenticator), or to use a different phone number. 



Recovery Code

Setting Up Authenticator MFA

If you would like to use an authenticator application for MFA, follow these steps.

1

2

Set Up Authentication App

Download and install a compatible app, such as Auth0 Guardian App ( , )

or , on your mobile device and complete setup.

iOS Android

Google Authenticator

Verify Your Identity

Go into the Auth0 or Google Authenticator app to view your temporary verification

code. 

Enter the code from the app into the field on your screen and select Continue.

https://apps.apple.com/us/app/auth0-guardian/id1093447833
https://play.google.com/store/apps/details?id=com.auth0.guardian
https://support.google.com/accounts/answer/1066447?hl=en&co=GENIE.Platform%3DAndroid


Authenticator

Setting Up Email MFA

Follow these steps to set up Email MFA and verify your identity. 

1

2

3

Enter Email

Add the email address where you would like to receive your authentication code.

Check Inbox

Navigate to your email inbox to retrieve the 6-digit verification code sent to you.

Verify Your Identity

Return to this screen, enter the code, and select Continue.



Email Authentication



4.2.2.2. Supported Roles (BC365)

Business Central uses Roles to customize the navigation menu options for users,

highlighting different modules relevant to their job functions.

Currently, the plugin appears in the navigation bar for users assigned to the following built-

in Roles:

Accountant

Accounting Manager

AP Coordinator

Bookkeeper

Business Manager

Team Manager

To change your Role to one of the built-in roles, follow these steps.

1 Go to My Settings

Click on the Settings gear icon from anywhere in Business Central. 

NOTE: The plugin does not currently support custom-created Roles.
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Click on My Settings 

Next, click on My Settings. 

Select a Role

Click on the three dots beside the Role field. 

Click on the Three Dots



Select a Role from the list below. After you have selected, click OK. 

Select Your Role

Click OK on the My Settings page.

Click OK



3 Confirm Role

Business Central will now refresh. The navigation bar will update to reflect your

newly selected role, and you will see the plugin available for that role.

View the Updated Navigation Bar



4.2.3.Vendor Management

4.2.3.1.
Updating Vendor Payment Methods Via
CSV (Business Central)

The plugin allows users to update their vendor payment information in bulk using a

Comma-Separated Values (CSV) file, eliminating the need to manually change each vendor

record.

Keep in mind that information stored within native Business Central fields (outside of the

plugin) cannot be updated using this plugin functionality.

Export and Import Functionality

This functionality allows you to manage your vendor records through a two-part process:

Export and Import.

Export creates a file containing all your current vendor records.

Import allows you to update existing records by applying changes to your vendor data.

Always export first before you begin an import. This is the best way to ensure the CSV file

is structured correctly, as the row format changes depending on the type of data you are

working with.

You can re-import the same data multiple times to update existing rows, provided the ID

fields in the file have not been modified or changed.



Export

Follow these steps to complete the first part of the process, exporting the CSV file.

1

2

Navigate to Payment Methods 

From anywhere in Business Central, you can navigate to the Payment Methods page. 

Select Payment Methods

Click on and then Payment Methods to begin the export and

import process. 

First Citizens Link

Export CSV

Click Export CSV to create a CSV export file for all vendor records.



Click Export CSV

The import from Business Central triggers a minimum of one row of data. There are

three different data types:

BANK ACCOUNT: Each vendor with a bank account creates a row with a

data_type of BANK ACCOUNT, allowing you to modify the vendor’s bank

account.

ADDRESS: Each vendor with an address record creates a row with a data_type

of ADDRESS, allowing you to modify the vendor’s address.

EMAIL: Each vendor with an address record creates a row with a data_type of 

EMAIL, allowing you to modify the vendor’s email.

IMPORTANT: The CSV is pre-structured for import functionality; do not modify

the column structures.

NOTE: Save a copy of this file for your records so you can easily re-import the

original if necessary.



Import

Once you have exported the existing vendor bank information, create the import file

containing your revised vendor bank information by editing the data and adding new rows

if you are incorporating new vendors.

Do not remove any of the column headers or add additional columns; otherwise, the import

will fail.

1 Prepare the File for Import

Each of the three data types requires specific data fields. Use the existing records as

a guide to which columns require data, and be sure to follow the general rules to

avoid errors that prevent a successful import.

BANK ACCOUNT: To add a new bank account, add a row and enter BANK

ACCOUNT in the data_type column. 

ADDRESS: To add a new address, add a row and enter ADDRESS in the

data_type column. 

EMAIL: To add a new email, add a row and enter EMAIL in the data_type column.

Please do not fill in the email or address fields for these columns, and ensure that the

other columns are completed according to the guidance provided in the table below.



2 Fill the CSV Table

You need to use specific default_payment_method code values that correspond to

your payment rail types.

Since a vendor can only have one default account with a default_payment_method,

you must ensure the payment method you choose is compatible with the

corresponding data type.

Navigate to Plugin → Payment Methods and check in the table which payment

methods are listed for a vendor.

Here is a complete list showing which payment rail types are supported by each data

type. Use only the payment rails supported by your plugin for this specific vendor.

CSV file - table rows

NOTE: Only one line entry per vendor can have the is_default_account set to Y.

Enter the default_payment_method for the default account address record.

Only one line entry per vendor can have the "is_default_account" set to "Y"



data_type Compatible default

payment_method(s) 

for this data type

Other rules

BANK

ACCOUNT

ACH

ACH_NEXT_DAY

CPA

BACS

SEPA

WIRE

EFT_AU

WIRE_AU

EFT_SG

WIRE_SG

WIRE_NZ

EFT_NZ

WIRE_ZA

EFT_ZA

INTERNATIONAL_WIRE

INTERNATIONAL_ACH

UK_FPS

Leave the email and address fields

empty.

ADDRESS CHECK Leave the bank account and email

fields empty.

EMAIL VCC Leave the bank account and

address fields empty

CSV file - table columns



Colum

n

Name

Allowable Values (CASE

SENSITIVE)

Notes

data_t

ype

Either: ADDRESS, BANK

ACCOUNT, EMAIL

Required Field

For BANK ACCOUNT, leave the email

and address fields empty. 

For ADDRESS, leave the bank account

and email fields empty. 

For EMAIL, leave the email and address

fields empty.  

id Internal ID Leave empty if adding a new payment

method. Do not modify the value if

modifying existing payment information.

erp_ve

ndor_i

d

Business Central vendor ID Required Field

Do not modify. This field protects against

duplicate records.

vendor

_name

Business Central vendor

name

is_def

ault_a

ccount

Y/N Required Field

Can only have one default Y per vendor.

All others must be N. 

default

_paym

ent_m

ethod

Please confirm that they

are in capital letters (e.g.,

ACH, ACH NEXT DAY,

CHECK, INTERNATIONAL

ACH, INTERNATIONAL

WIRE, SEPA, VCC)

Anything from the list of available

payment methods. To see what is

enabled on the vendor, navigate to 

Plugin → Payment Methods and check in

the table which payment methods are

listed for that vendor. 

Any unsupported payment type will

result in the line failing to import. If you

would like to add some payment

methods to the plugin, please contact

your bank.



Colum

n

Name

Allowable Values (CASE

SENSITIVE)

Notes

is_edit

able

Y/N Required Field

For any new lines, please enter "Y". 

Do not modify an "N" and change it to a

"Y"; doing this may break the import. 

email_

addres

ses

Any email addresses, up to

5

Separate each email address with “,”

countr

y

ISO alpha-2 country

codes

Required Field For Bank Accounts

This field accepts upper, lower, and

mixed case values. Please enter the ISO

alpha-2 country codes format. The

import will error if the user enters the full

country name (i.e., New Zealand). 

curren

cy

Currency codes Required Field For Bank Accounts

Please enter the currency following the

currency code list. This field accepts

upper, lower, and mixed case values.

accou

nt_typ

e

CHECKING or SAVINGS Required Field For Bank Accounts

This field accepts upper, lower, and

mixed case values

accou

nt_nu

mber

Vendor's account number

institut

ion_nu

mber

Vendor's institution

number

transit

_numb

er

Vendor's transit number

https://www.iban.com/country-codes
https://www.iban.com/country-codes
https://www.iban.com/currency-codes


Colum

n

Name

Allowable Values (CASE

SENSITIVE)

Notes

routin

g_num

ber

Vendor's routing number

bank_

code

iban Two letter country code,

followed by two check

digits, and up to 35

alphanumeric characters

bic Vendor's BIC or SWIFT

code for the country and

bank

bank_

name

Anything

addres

s_line

Anything

addres

s_line_

2

Anything

addres

s_city

Anything

addres

s_state

_provi

nce

Anything

addres

s_post

al_Cod

e

Anything



Colum

n

Name

Allowable Values (CASE

SENSITIVE)

Notes

local_

branch

_code

Valid branch code for this

bank

Use this field for BSB codes if the

country requires it

payme

nt_pur

pose_

messa

ge

Anything

payme

nt_pur

pose_

code

Valid purpose code

payme

nt_pay

ment_i

so_co

de

Valid sender country code

payme

nt_pay

ment_

codew

ord

Valid receiving entity

codeword

payme

nt_pay

ment_

party_t

ype

P, T, G, N P = Parent, T = Subsidiary, G = Group, N

= Non-related

payme

nt_resi

dential

resident, nonresident
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Colum

n

Name

Allowable Values (CASE

SENSITIVE)

Notes

_statu

s

sort_c

ode

Valid sort code for this

bank

Importing CSV

Once the file is ready, select Import CSV.

Click Export CSV

Attach the file that is ready to import and enter one valid email address to receive a

status update.

NOTE: You are not able to modify this email address after clicking Import. If the

email is incorrect, you will not get the status email, but the import will complete.



Drop your CSV file here to upload or browse your computer

Once the file has been uploaded, a checkmark confirmation message will appear. 

Click Got It

Wait a few minutes to get a status update via email.



4 Import Confirmation Email

Once the import status changes, you will receive an email notification.

This email notification will let you know if the import has been successful. There are

3 options:

File Successfully Imported

File Was Sucessfully Imported

Import is successful, but there are line errors.

In that case, please download the CSV attached to the email that lists those

errors and submit the file again. You may leave the error column in the newly

uploaded CSV. Please note that if an error is found in one of the rows, none of

the information present in that row will be updated.



File Was Not Imported

Import was not successful.

This issue may be caused by internet connectivity problems or unsupported file

formats. Please verify your internet connection, refresh the page to attempt

again, or contact support if the problem persists.

Import CSV Example

This file shows an example of what the import file can look like for one hypothetical

vendor.



Example Vendor CSV Import file

In BC365, when you select the vendor, it shows that the new bank account has been

added.

Verification that bank account has been added - Payment Setup 

When you open up the bank account, you can see the values match the import. 



Bank account field values

Potential Errors



Errors Explanation Solutioning

data_type  must

be: BANK

ACCOUNT or

EMAIL or ADDRESS

data_type  w

as not filled in.

Always include a data_type, this is a mandatory

field.

vendor_id must 

be filled in.

vendor_id  w

as not filled in.

Always include a vendor_id; this is a mandatory

field.

default_payment_

method must be of 

a valid Payment 

Type.

default_paym

ent_method  w

as not

correctly filled

in.

Ensure your account has this payment method

enabled.

email_addresses 

contains email(s) 

with an invalid 

email format.

The email

address

format was

not respected.

Follow the following format: 

 you would like to add

multiple email addresses, confirm they are

comma-separated like

so:  , 

something@email.com

email1@email.com email2@email.com

Both country and 

currency must be 

filled in.

Country and

currency both

need to be

filled in.

country contains 

invalid country 

code

Country code

is not valid.

Select a valid country code from this list: ISO

alpha-2 country codes

currency 

contains an 

invalid currency 

code.

Currency code

is not valid.

Select a valid currency code from this

list: Currency codes

https://archbee-doc-uploads.s3.amazonaws.com/export/html-space/PUBLISHED-c2da-X6ep2bQRDbTf7VgY-h_CIBmH-LbQAqZk-ycYPh.html
https://archbee-doc-uploads.s3.amazonaws.com/export/html-space/PUBLISHED-c2da-X6ep2bQRDbTf7VgY-h_CIBmH-LbQAqZk-ycYPh.html
https://archbee-doc-uploads.s3.amazonaws.com/export/html-space/PUBLISHED-c2da-X6ep2bQRDbTf7VgY-h_CIBmH-LbQAqZk-ycYPh.html
https://www.iban.com/country-codes
https://www.iban.com/country-codes
https://www.iban.com/currency-codes


4.2.3.2. Vendor Approvals (Business Central)

The Vendor Record Approvals feature provides a robust and secure method for managing

changes to vendor bank account information within your ERP. This approval process

ensures data accuracy, minimizes the risk of errors, and enhances security by requiring

authorization for changes to your vendor's banking data.

Enable Vendor Record Approvals

1

2

Login to FISPAN Portal

An ERP administrator or ERP consultant must first access the  by

logging in at . 

FISPAN Portal

sys.fispan.live

Enable Vendor Record Approvals

Click on the Vendor Record Approvals tile under Discover More.

A summary pop-up will appear. Click Enable & Configure to complete the setup. 

https://sys.fispan.live/login


Click Enable & Configure

Once enabled, you will be prompted to begin creating your workflows.

Creating a Workflow

To create your Vendor Approvals workflow for your ERP utilizing the plugin, please follow

these steps.

1 Go to Vendor Record Approvals

From the , click on the Vendor Record Approvals tile. You'll then be

prompted to start creating your workflows.

FISPAN Portal



2

Click Vendor Record Approvals

Create a Workflow

Once you are on the Vendor Record Approvals page, click Let's Get Started. 

Click Let's Get Started
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Start by giving your workflow a clear, descriptive name for easy identification later.

Next, select the entities you want the approval workflow to apply to:

Addresses: Applies to addresses added via the Payment Methods page or

changes made to the native ERP vendor record address.

Bank Accounts: Applies to bank accounts added via the Payment Methods page

or changes made to the native ERP vendor record bank account.

Email Groups: Applies to email groups added via the Payment Methods page or

changes made to the native ERP vendor record emails.

Create a Worklow

Add Approvers to Workflow

Next, you need to define the approvers for your workflow. 

In the first level, enter the approver's email address exactly as it appears on their

user record in the ERP system.

NOTE: To exclude vendor record changes synced from the ERP from this

approval process, please contact .FISPAN Support



Add another level for approval and additional approvers, if needed. You can set up to

three levels of approval. 

At each level, you can add up to five potential approvers. You can also decide how

many individual approvals are required per level (e.g. Level 1 requires 2 approvals,

Level 2 requires 3 approvals, Level 3 requires 1 approval).

Click Save

NOTE: Important Considerations:

1. No Self-Approval. You cannot approve your own Vendors. Keep this in

mind if a single user frequently acts as both the Vendor creator and an

approver.

2. Best Practice for Approvers. To avoid delays, we suggest:

Avoid having a single approver in a level. 

Adding more approvers than the required approvals (e.g., include 4

approvers in a level that requires 2 approvals). This ensures the

process can continue even if someone is unavailable.



4 Save Workflow

Once you have configured your workflow, click Save New Workflow.

Your workflow is now active. All changes made to vendors through the 

 will now follow this approval process.First Citizens Link

Editing a Workflow

You can edit or delete a workflow, but only if there are no vendor record changes pending

approval for that workflow. This prevents any confusion or errors with changes currently

going through the approval process. In the event you need to edit a workflow with

associated open vendor record changes, process or cancel any outstanding changes

associated with the workflow.

1 Select Workflow

You can edit existing workflows to adjust them. Click on the workflow you would like

to modify.

IMPORTANT:  To approve changes, users in the workflow must have both an

ERP license and the necessary plugin permissions to view Vendor Approvals,

outlined in the Intacct Required Permissions section of this page.
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Click on the Workflow

Edit Workflow 

Make your desired modifications, and click Save Changes.

Click Save



Editing Restrictions

Modifying the entities associated with a workflow will disable any other workflows that

were previously applied to those entities. Similar to making edits to workflows, all future

requests for these entities will go through the new workflow; existing requests will remain

unaffected.

Unable to Make Changes to Active Workflows

Deleting a Workflow 

Workflows with pending approvals cannot be deleted until those approvals are resolved.

Deleting an active workflow can be done following these simple steps.

1 Select Workflow

Select the workflow to delete. Then, click Delete Workflow. 
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Click Delete Workflow

Confirm Deletion

A pop-up will appear. Confirm deletion by clicking Yes, Delete Workflow.

Click Yes, Delete Workflow



Disabling a Workflow 

To disable a workflow, toggle Enable Flow. Then click Save Changes.

Click Save Changes

Approvals

Accessing Pending Approvals

Navigate to the Vendor Approvals page within the Business Central plugin. By default,

you'll see all pending approval requests for your organization.

The Approvals page table provides a comprehensive overview of each payment request,

with the following key details:

Request Date: The precise date when the payment was initiated within the plugin.

Vendor: The name of the vendor that had their record modified.

Entity: The type of data changed. It will be either address, bank account or email

group.



User/Requested By: The name of the user who submitted the payment request.

Source: Where the change was made. It will be either Plugin UI or ERP. 

Approval Progress: A tracker which provides context to where a payment is within the

approval process.

To view only the requests assigned to you, click the Show Assigned To Me Only filter.

Click Show Assigned To Me Only

To review a specific request, click View. This will display key information such as: 

Type of Change: Whether it's an update to existing details, a new vendor bank detail,

or a deletion of a vendor bank detail.

Requested Date: The date and time the change was submitted.

Requester: The user who initiated the change.

Detailed Breakdown: A comprehensive view of the proposed changes, addition, or

deletion to the vendor's bank details.



View Pending Change

Approval Process

To approve a request:

Click Approve to authorize the proposed changes.

Click Approve



The request will either progress to the next level in the approval workflow (if multiple tiers

are configured) or, if you are the final approver, the vendor's bank details will be updated

accordingly in the Payment Methods page.

Click Close

To reject a request:

Click Reject to deny the proposed changes.

Important: Rejection is a terminal action. If a change is rejected in error, the initiating

user will need to resubmit the request.



Click Reject

You will be required to provide a rejection reason. 

Add a Rejection Reason

Since rejections are terminal, the request will not be routed to any other approvers and the

proposed changes will be reverted. 



Click Close

ERP Synced Changes 

Rejection Disabled: For changes that originate from your ERP system (ERP-synced

changes), the "Reject" button will be disabled.

Rationale: This restriction is in place to prevent accidental overwrites or conflicts with

the data in your ERP. Maintaining consistency between the plugin and your ERP is

crucial.

Resolution: If an ERP-synced change needs to be reversed or modified, the initiating

user must make the necessary adjustments directly within the ERP system.

Note: If you would like ERP synced changes to not be eligible for Approval, please

reach out to the support team.



Approve ERP Synced Changes

Impact on Workflows

When an approval request is created by modifying a vendor's bank details, the following

updates happen within your plugin. 

Pay Bills Page

When a vendor has a pending change, payments will not be able to be processed for this

vendor. This is to ensure that the vendor has the most up-to-date information before

payments are processed. 

A warning icon and greyed out checkbox will prevent these vendors from being paid. 



Blocked Vendors

Payment Methods Page

On the Payment Methods page, the Vendor will have an icon identifying there are pending

changes. 

Vendors with Pending Changes



If you click on the vendor, you will see the record that has been changed is highlighted. 

Account Marked As Under Review

Furthermore, if you open the record, you will see all fields are greyed out and cannot be

edited. 

Unable to Edit Record



Approvals History

The Approvals History page maintains a comprehensive log of all approval requests,

including both those that were approved and those that were rejected.

View Approval History

To view more details about a request, you can click View and see the following:

Date and Time: When the approval or rejection occurred.

User: The individual who approved or rejected the request.

Reason: Any comments or explanations provided for the decision.

Source: The origin of the change request (e.g., manual update, import).



View Approved Record

View Rejected Record

Approvals History Export

You can export the Approvals History for record-keeping or analysis. The export file

includes:



Modified On: Date the change was made

Vendor: Vendor Name

Type of Change: Updated, Added, Deleted

User Email: User who initiated the change

Reviewed By: User emails who approved or rejected the change

Approval/Rejection Time: Time when the final approving user reviewed the change or

rejection was sent

Status: Approved or Rejected

Previous Entry: What the entry looked like before it was changed

This would be EMPTY if the history log item is for a new record being created

Proposed Entry: What the entry looks like after a change was initiated or rejected

If entry was rejected, this is the change that was proposed

If the entry was approved, this is the change that was accepted

Reason for Rejection: The rejection reason provided by the rejecting user

This will be empty if the record is an approved item

To generate this export, click the Export button on the Approvals History page. 

Click Export



FAQ

Can I reject ERP-synced changes?

No, rejection is disabled for ERP-synced changes to prevent data inconsistencies.

Contact the user who initiated the change to resolve any issues.

What if I accidentally reject a valid change?

Rejection is a terminal action. If a change is rejected in error, the initiating user will

need to resubmit the request.



4.3.Product Features

4.3.1.Accounts Payable

4.3.1.1.Vendor Payments

4.3.1.1.1.Bill Payments



4.3.1.1.1.1. Paying Invoices (Business Central)

Paying bills in Business Central allows you to remain within your ERP system without

needing to access your bank account separately. Follow this guide to learn how.

Pay an Invoice

Follow these steps to pay your first invoice with the plugin.

1 Go to Pay Invoices

From anywhere in Business Central, you can navigate to the Pay Bills page. Click on 

and then Pay Invoices to begin making payments. First Citizens Link

Select Pay Invoices



2 Select Invoices to Pay

The Pay Invoices page will then load. This page will load every Posted Purchase

Invoice that is Open in your Business Central company. 

Load the Pay Invoices Page

On this page, you can multi-select your invoices across multiple pages. You can also

filter by hitting Toggle Filters and then selecting an option from this list and entering

your desired values. 

NOTE: If using Binary Stream MEM, this page will only load invoices associated

with the entity code(s) to which the user has access. 
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Define Filter Values

Select the invoices you would like to pay by selecting the checkbox. Once you have

finished selecting every invoice, you can select Add to Payment Run. 

Select Invoices

Confirm Payment(s)



A confirmation window will now appear. From here, you can change your source

account. Once you have reviewed your payment run, you can select Confirm X

Payments. 

Confirm Payments

Next, you will see that your payment has been successfully bundled. 

NOTE: If utilizing Binary Stream MEM, the Source Account dropdown will only

load bank accounts associated with the entity code(s) the user has access to. 



Click OK

From here, you can navigate to the Payment History page or stay on the Pay Invoices

page. 

Viewing Payment History

To view the status of your payments, you can select the Payment History page from the

Pay Invoices page. 



Select Payment History

The Payment History page provides a snapshot of all payments made through the plugin.

View Payment History

You can then click on each payment to view the bills that were paid in each batch. 



View More Payment Details

From here, you will be able to see details about the payment, such as the Status Message

and any Credits or Discounts used. 

Payment Statuses 

Payments that are processed through the plugin will first appear as Pending. Dependent

on the payment method, payments may remain Pending for up to  business days

after submission, after which the payment will automatically be moved to a Completed

state.

several

Processing Payment Statuses

NOTE: The Business Central Posted Purchase Invoice is marked as Closed upon

payment submission, not when the payment reaches a Completed status. 

If your bank reports a payment failure, the status on the History page will be updated

to Failed, and the system will attempt to reverse the initial ledger entry. All ledger

entries follow standard Business Central logic, using the payment method code

defined on the vendor card or leaving the field blank.



A processing status indicates that a payment has been submitted for approval and is

awaiting release.

SENT FOR PROCESSING: Payments enter this state immediately after they have been

submitted for payment via the plugin.

PROCESSING: Payments will enter this state once they have been approved and

released. 

Terminal Payment Statuses

A terminal status indicates a final state. In most cases, payments will not automatically

change from these states unless intervention is applied by the support team.

COMPLETED: This is a final status. Some payments are marked as autocomplete

based on the payment network's handling. This status should not change.

FAILED: Payments that fail to be processed enter this status. Failure can occur due to

various reasons, such as initial validation issues (missing or inappropriate information)

or failure within the payment network (e.g., the destination bank account is closed).

CANCELLED: This status indicates that the payment was rejected in the bank approval

portal or cancelled directly within the platform.



4.3.1.1.1.2.
Creating Purchase Invoices (Business
Central)

Follow these steps to create purchase invoices in Business Central.

1 Create a Purchase Invoice

On the Vendor card, select New Document → Purchase Invoice to create an invoice.

Go to Purchase Invoice

Alternatively, on the home page, select Purchasing → Purchase Invoices → New.
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Create a New Purchase Invoice

Post Invoice

Post the invoice when complete by selecting the Posting tab and selecting Post.

Post Invoice



On the Purchasing tab, the invoice is moved from the Purchase Invoices header to

the Posted Purchase Invoices header.



4.3.1.1.1.3.
Applying Credit Memos (Business
Central)

A purchase credit memo is a document issued by the seller of goods or services to the

buyer, reducing the amount the buyer owes to the seller under the terms of an earlier

invoice.

There are three methods in Business Central to apply credits: the Applies to Doc. method,

copying document lines, or manually creating the lines. Follow the steps in this guide to

learn how to apply credits with these methods.

Applies to Doc. Method

This method involves posting the credit memo first and then applying it to the open invoice

from the Vendor Ledger Entries.

1 Navigate to Vendor

Navigate to the vendor you would like to apply the memo to. 

Click Purchasing and then Vendors. 



Click Vendors 

Next, click on the vendor you would like to create the memo for. 

Click on the Vendor

On the Vendor card, select New Document and then click on Purchase Credit Memo.
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Select Purchase Credit Memo

Create & Post the Credit Memo 

Next, create the credit memo by entering the required values. 

Create the Credit Memo

Once done, click Post. 
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Click Post

Apply the Credit Memo

Navigate back to the Vendor card and select Vendor --> Vendor Ledger Entries. 

Select Vendor Ledger Entries



Locate the credit memo and click on the three dots beside it. Select Apply Entries.

Click on Apply Entries

Find the invoice you would like to apply the credit to. 

Find the Invoice



4

Set the ID by selecting the invoice and clicking Set Applies-to ID. When done, select 

Post Application. 

Click Set to Applies-to ID

Pay Reduced Invoice(s)

Pay the invoice(s) as you would normally.

Copying Document Lines

This method ensures the credit memo is applied directly to the invoice before the memo is

posted by copying the original posted invoice's details.

1 Navigate to Purchase Credit Memos

Navigate to the Purchase Credit Memos page from the Purchasing module.
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Select Purchase Credit Memo

Select the + New button to create a new Purchase Credit Memo. 

Copy Credit Memo Lines

To apply lines from an existing posted invoice, go to Prepare → Copy Document.

Click Copy Document



Select Posted Invoice for the Document Type and enter the Document No. to apply

the credit memo. 

Click OK

Once selected, select OK to copy the complete document.

The invoice details and line items will now copy into the Credit Memo page. 
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View Credit Memo Details

Modify the Credit Memo

Modify the document lines as needed. Once the lines match the vendor's credit

memo, enter the vendor's reference number in the Vendor Cr. Memo No. field.

Modify the Memo
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5

Confirm Applies-to Doc. No. 

Confirm the Applies-to Doc. No. is correct and the credit memo will be applied to the

right invoice. The invoice must be marked as Open to apply the credit memo and pay

the invoice with a reduced amount due.  

Confirm Applies-to Do. No. 

Post the Credit Memo

After confirming all details, post the document by selecting Post. 

NOTE: This field is automatically populated with the Invoice Number of the

source document. Before posting the credit memo, you must verify the number.

If it is incorrect or points to a closed invoice, you are required to change this

value to an Open invoice whose balance you intend to reduce.
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Post the Credit Memo

Confirm the Reduced Amount

On the Posted Purchase Invoice page, locate the invoice on which you applied the

credit memo. On this page, you can confirm that the amount has been successfully

reduced before attempting to pay the invoice. 

Confirm the Reduced Amount



7 Pay Reduced Invoice(s)

Pay the invoice(s) as you would normally.

Manually Creating Document Lines

Use this method when the credit memo lines need to be entered from scratch without

copying an existing invoice.

1 Navigate to Purchase Credit Memos

Navigate to the Purchase Credit Memos page from the Purchasing module.

Select Purchase Credit Memo

Select the + New button to create a new purchase credit memo. 
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Click Copy Document

Manually Create the Document Lines

Next, manually enter the Vendor Name, line items, and Vendor Credit No. in the credit

memo. 

Enter Details
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4

Add Applies-to Doc. No. 

Add the Applies-to Do. No. to ensure the credit memo will be applied to the correct

invoice. The invoice must be marked as Open to apply the credit memo and pay the

invoice with a reduced amount due.  

Add Applies-to Do. No. 

Post the Credit Memo

After confirming all details, post the document by selecting Post. 

NOTE: If the Applies-to Do. No. is incorrect or the referenced invoice is already

closed, you must change it to the Open invoice you intend to reduce before

posting the Credit Memo.
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Select Post

Confirm the Reduced Amount

On the Posted Purchase Invoice page, locate the invoice on which you applied the

credit memo. On this page, you can confirm that the amount has been successfully

reduced before attempting to pay the invoice. 

Confirm the Reduced Amount



6 Pay Reduced Invoices(s)

Pay the invoice(s) as you would normally.

Pay Reduced Bills

Limitations

Credit memos cannot be applied at the Payment Journal level. They must be applied to an

existing document before attempting a payment through the plugin. Failure to apply the

credit memo beforehand will cause the plugin to ignore the credit and remit the full invoice

amount.

Credit memos must be less than or equal to the remaining amount due on the invoice to be

successfully applied.



4.3.1.1.1.4.
Applying Discounts (Business
Central)

Setting up early payment discounts in Business Central involves configuring several key

settings to ensure the discount is calculated correctly and posted to the appropriate

accounts.

The effect of the early payment discount is determined by a combination of settings:

Payment Terms

Vendor/Customer Posting Groups

Setting the Transaction Type linked to the bank account

Payment Terms

Payment Terms define the conditions for transactions with vendors and customers. They

determine if an early payment discount is available, define the discount percentage, and

the required expiry date or duration for receiving the discount.

Search Payment Terms



Vendor/Customer Posting Groups

The Vendor and Customer Posting Groups determine which ledger accounts the actual

discount amount will be posted to.

Vendor Ledger Entries

Utilizing Discounts

When creating a Purchase Invoice, fill in the agreed-upon payment discount terms in the

Invoice Details section. Post the invoice to make it ready for payment.



Create Purchase Invoice

Navigate to the Pay Invoices page and create the payment. The discount will be applied if

paid on time.



4.3.1.1.1.5.
Batching Ledger Entries (Business
Central)

In version 2024.2.0.0+ of the plugin, batching ledger entries is available. This feature will,

unfortunately, not work for users with MEM installed. 

Follow this guide to start processing payments with the batching feature.

Enabling Batching

To start using batching, enable the feature by following these steps.

1 Go to the Settings page of the plugin and enable the Payment Entry Batching 

feature.

Toggle on Payment Entry Batching

IMPORTANT: When you enable batching, we will no longer write the Vendor Invoice

No. into the Payment Reference column in the Vendor Ledger Entries. This is

necessary due to character limits in Business Central fields.



2 Ensure that vendors have Combined Invoices enabled on their Payment Methods

page.

Toggle on Combined Invoices

Processing Payments

Start processing payments by following these simple steps.

1 Select Invoices

Navigate to the Pay Invoices page and select the invoices you would like to pay.

You can enable this for all vendors by following this guide: Grouping Payments &

Enabling Remittance (Business Central)
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Select Invoices

Confirm Payment

Submit your payment by selecting Confirm Payment. 

NOTE: Payment batching is not supported when using the Pay-to, Buy-from, or

Ship-to address for check payments.
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Select Confirm Payment

Now the payment will begin processing. 

View Batched Ledger Entries

Below are some examples of how these batched entries will appear on the various

ledgers available in Business Central. 

Vendor Ledger Entries: 



Vendor Ledger Entries

Bank Account Ledger Entries: 

Bank Account Ledger Entries

Check Ledger Entries: 



Check Ledger Entries



4.3.1.1.1.6.
Voiding & Repaying Bills (Business
Central)

Invoices paid with the plugin that are voided in Business Central can be repaid through the

plugin. Follow this guide on how to void and reopen your invoices.

Void an Invoice

Follow these steps in Business Central to properly void a payment:

1 Unapply Payment

From the Global Search bar, navigate to Vendor Ledger Entries.

Go to Vendor Ledger Entries

Select a Payment, then select Process → Unapply Entries. 
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Click Unapply Entries

Next, click Unapply on the payment object.

Click Unapply

Confirm Successfully Unapplied 
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Once the entry has been successfully unapplied, the Posted Purchase Invoice should

reopen, and you should receive a confirmation screen. 

Confirm Entries Were Unapplied

Reverse Transaction

Next, you can reverse the payment object. You can click Reverse Transaction... on

the unapplied payment object.



Click Reverse Transaction

Next, you can click Reverse to reverse the payment. 

Click Reverse

Once the payment is reversed, you will be notified. 



Confirm Payments were Reversed



4.3.1.1.2. Payment Methods (Business Central)

This page details how to manually import payment information into the plugin. If you are

interested in using Import/Export, follow the instructions here: Updating Vendor Payment

Methods Via CSV (Business Central)

Adding Payment Methods

1

2

Go to Payment Methods

From anywhere in Business Central, you can navigate to the Payment Method page.

Click on and then Payment Methods to load the page. First Citizens Link

Select Payment Methods

Add Vendor Information

On this page, you can manage payment information for each vendor. 



Select the vendor you would like to manage by hovering over the vendor and

selecting the eye icon. 

Click the Eye icon on the left side of the row

The Payment Method pop-up will appear, which allows you to add and store three

different types of information: Bank Accounts, Addresses, and Email Groups. 



View Vendor Pop-Up



3 Set Default Payment Method

On the Payment Method pop-up, you can toggle on Combine Multiple Bills. This

allows you to send multiple bills for the same payment method as one payment. For

example, five separate bills will be processed as one payment.

Use the Default Payment Method dropdown to select a preferred payment method.

This will automatically populate this method for the vendor on the Pay Bills page. 

You can manually override this default setting on the Pay Bills page for one-off

payments.

NOTE: Any Bank Accounts, Addresses, and Email Groups stored natively in

Business Central are imported automatically upon installation. These records

are indicated by an ERP icon next to the label and cannot be edited within the

plugin.

View ERP Account
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Select Default Payment Method

Add Bank Accounts 

To add bank accounts, click on the Add Bank Account button. Select the Country

and Currency of the bank account you would like to add next. 

Select Country and Currency
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Next, fill in the banking information based on the data provided to you. Be sure to

enter a unique label. Once you have done that, click Validate Account Info.

Click Validate Account Info

Validate Information

The system validates the format of the data to ensure it supports specific payment

methods (e.g., ensuring a Routing Number is present for ACH payments).

This step validates data completeness, not accuracy. It does not verify if the bank

account number itself is active or correct.

If validation fails, modify the information and try again.

If validation is successful, you can toggle specific payment methods On or Off and

save the account.

NOTE: All accounts will be saved as a Checking account unless the Type of

Account field is changed.
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Validate Bank Account

Once saved, the account is accessible from the Payment Method pop-up, where you

can edit records or toggle payment methods as needed.

Add Addresses

To add vendor mailing addresses, click on the Add Address button. Add your

address details to the fields. After that, click Save Address.



Save New Address

If Checkprint is enabled, this address will be available for check payments. You can

disable an address at any time by toggling it Off or editing the record.

Toggle Address



Adding Email Addresses

Email addresses can also be added to your vendor information from the Vendor card. To

add email addresses, follow these steps.

1 Add Email Group

From the Payment Methods page for your vendor, click on the Add Email Group

button. 

Click Add Email Group

Add your email address details to the fields. You can add up to 5 emails by clicking 

Enter after each entry. 

Click Save New Email Group.
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Save New Email

If the Email Remittance feature is enabled, you can also use the vendor's email group

to send remittance advice to. 

Update Email Group

Once the email has been added, you can edit it and toggle it on and off, as needed. 



Edit Email Group

If you would like to use this email for Virtual Card Payments, ensure that it is selected as

the Default Payment Method or select it on the Pay Invoices page. 

Select Default Payment Method



Select Payment Method



4.3.1.1.2.1.
Grouping Payments & Enabling
Remittance (Business Central)

Combined Invoices allow you to group multiple invoices for the same vendor into a single

payment, resulting in one remittance email instead of many.

Enable Combined Invoices

Follow these steps to configure Combined Invoices in Business Central.

1

2

Go to Payment Methods

From anywhere in Business Central, you can navigate to the Payment Methods page

to configure this setting. 

Click  and then Payment Methods to navigate to the page. First Citizens Link

Select Payment Methods

Access Mass Update



Once the page loads, click on the gear icon beside Combined Invoices. 

Payment Methods page 

You will now be prompted to select which option you would like. 

A prompt will appear, asking you to select which option you would like to set. You can

choose to enable or disable it for your vendors.



Select the Option Desired

If you choose to enable this for all existing vendors, remember that you will need to

manually update any new vendors created in the future.

Once the option has been selected, click Yes. 

Select Yes



3 Confirm Update

The screen will reload, and the toggles in the Combined Invoices column will update

to reflect your selection.

Updated Toggles

From here, you can manually turn off or turn on the setting for specific vendors as

needed.

Enable Remittance

You can quickly enable or disable remittance emails for all vendors at once from the

Payment Methods page.

NOTE: If the remittance advice product is activated, enabling Combined

Invoices groups multiple bills into one payment, meaning the vendor receives

just one remittance email. 

If disabled, every paid bill generates its own separate payment and remittance

email.



1

2

Go to Payment Methods

On the Payment Methods page, find the Remittance column.

Click the gear icon in the column header to open the pop-up window.

Click the Gear Icon

Access Mass Update

You will be asked to select which option you want to apply.



Select Desired Option

If you choose to disable Remittance for all existing vendors, you must manually

update the setting for any new vendors created later.

Once the option has been selected, click Yes. 

Click Yes



3 Review and Modify Vendors

The screen will reload, and all Remittance toggles will update to match your

selection.

Updated Toggles

From here, you can manually turn off or turn on the setting for individual vendors as

needed.



4.3.1.1.2.2.
Writing Check Numbers to General
Ledger (Business Central)

Configure the plugin to include the Check Number when posting check payments. Once

the payment is transmitted to the bank, the plugin will update the General Ledger with the

Check Number. 

Please note, this feature is not available for users when MEM is enabled.

Enable Write Check Ledger Entries

Follow these steps to enable this feature.

1

2

Go to Settings

From the  menu, select Settings.First Citizens Link

Select Settings

Add Invoice Number



Under the Check Payments section, toggle both Write Check Ledger

Entries and Overwrite Doc. No on Check Payments to enable them.

Settings with Check Payment toggle switches enabled

Once enabled, the Check Number will be added to the General Ledger when the

payment has passed the validation step.

View Check Numbers

After creating a check payment, you can view the posted Check Numbers in two main

places:

1 Check Ledger Entries

Search for Check Ledger Entries. This page shows the posted check numbers, along

with the vendor, date, bank account, and amount, after the payment has passed

validation.
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View Check No.

General Ledger Entries

You can also view the check numbers in the General Ledger Entries. 

View Check No. 



To view the Check Number, search General Ledger Entries. If the correct options are

enabled, the Check Number will be added to the General Ledger when the payment

has passed the validation step.

NOTE: Check Numbers and Check Ledger Entries will only populate once the

payment has been marked as Completed. 

If you are experiencing an issue with this feature after the payment has been marked

as Completed, please contact our support team. 



4.3.2.Cash Management

4.3.2.1.Reporting



4.3.2.1.1.
Viewing Bank Accounts (Business
Central)

The Cash Management Reporting features give you visibility into your previous and

intraday bank balances and transactions directly from your connected bank accounts.

Using Bank Accounts, you can also easily export this data into a Business Central-friendly

CSV file to simplify your account reconciliation process. Follow this guide to learn how to

view your banking data in Business Central.

Viewing Bank Accounts

Follow these steps to access and view your banking data:

1 Go to Bank Accounts

From anywhere in Business Central, you can navigate to the Bank Accounts page. 

Click on  and then select Bank Accounts to load the page. First Citizens Link

Navigate to Bank Accounts Page



2 View Account Summaries

On the Bank Accounts page, you will see a summary of the current balances for all

bank accounts connected to the plugin. 

To view the transactions in detail, click on the Account Name.

Bank Accounts Page

The Deposit Account Transactions page loads, providing several key sections:

Account Overview: This section lists the number of payments and the value of

those payments processed by the plugin for the current and previous month.

Balances: View current balances and switch between other connected bank

accounts from this screen.
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Bank Account Transactions

View Transaction Details

To view more details about a specific transaction on this page, select the Date. 

Transaction View Popup

A pop-up will display the transaction details.



4 Filter and Export Data

Select Show Filters to enter a specific search filter and narrow down the transactions

displayed.

Search Filters

Click Export to generate a CSV file of the displayed transactions. This file can be

used for account reconciliation or your own records.

NOTE: The information available may vary depending on what your bank

provides for each transaction.



Export Options



4.3.3.Bank Feeds

4.3.3.1.
Enabling Bank Feeds (Business
Central)

This guide covers how to set up your bank accounts for bank feed imports and how to

import your first transactions into either the Bank Account Reconciliation module or the

Payment Reconciliation Journal.

Set Up Bank Account Import Format

Before importing, you must assign the bank statement import format to your bank

accounts. 

1

2

3

4

Navigate to Cash Management → Bank Accounts.

Open the desired Bank Account card.

Navigate to the Transfer tab.

In the Bank Statement Import Format field, select FCB Bank Feed from the list.



Select FCB BANK FEED

You must repeat this step for every bank account you wish to connect. Once

complete, you are ready to import bank statements directly into the reconciliation

modules.

Bank Feeds allow you to import transactions into only one module: either the Bank Account

Reconciliation module OR the Payment Reconciliation Journal, but not both. Please select

the module that best suits your organization's workflow during the setup of your bank

feed.

Bank Account Reconciliation

Use this section to learn how to import your first transactions using the Bank Account

Reconciliation module.

1 Customize Columns

To ensure all necessary transaction data is visible, you must customize your view in

Business Central.



Select Cash Management and navigate to the Bank Statement Reconciliation 

module. Open the Bank Account you wish to configure

Select the Bank Account

The Bank Statement Reconciliation module will now load. 

Load the Bank Statement Reconcilation Module



From this screen, click the gear icon in the top right corner and select Personalize.

Select Personalize

Next, click on the Bank Statement Lines section to load the columns for this screen.

Select Bank Statement Lines



Select + Field from the top left corner.

Select + Field

A sidebar list of available columns will appear. Drag and drop the following columns

into the Bank Statement Lines section. You may reorder or resize them as needed.

We suggest adding these columns:

Additional Transaction Info

Check No. 

Document No. 

Related Party Name
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Drag and Drop Columns

Once you have added all columns, you can click Done. This will now save this

configuration.

Click Done

Field Mapping
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The table below explains how the transaction data maps to the Business Central

columns you just added.

Business Central Column Transaction Data

Transaction Date Settled Date

Document Number Customer Reference*

Related Party Name Counter Party Name*

Description Description

Amount Amount

Check No. Check No.*

Additional Transaction Info BAI2 Code

Items marked with an asterisk (*) are conditional. This data will only appear in

Business Central if it is provided in the transaction details received from the bank.

Import Transactions

Now, when you click Import Bank Statement, you can select a Start Date. 

Select yesterday's date. 



Select a Start Date

To pull new transactions, select Import Bank Statement. It will load all transactions

we have received since you last triggered an import.

Select Import Bank Statement



Payment Reconciliation Journal

If you prefer to use the Payment Reconciliation Journal, follow these steps.

1

2

Go to Payment Reconciliation Journal

Select Cash Management and then navigate to the Payment Reconciliation Journal 

module. 

Select a Bank Account

Select the bank account you would like to start with. 

Import Transactions

When prompted for a start date, select yesterday's date.



Select a Start Date

Select Import Bank Statement. The system will load all transactions received since

your last import trigger.

Import Transactions



NOTE: You may notice that your bank accounts are listed as Not Linked within

Business Central.

This is expected behavior. Because these bank feeds are provided through a

custom integration rather than Business Central’s native offering, the native

status indicator will not update. This does not affect the functionality of your

import.

Example of the Not Linked Status



4.3.3.2.
Adding Accounts to Bank Feeds
(Business Central)

To assign the newly created Bank Statement Import Format to a bank account, navigate

to Cash Management → Bank Accounts and open a Bank Account.

Under the Transfer tab, select FCB Bank Feed from the list for Bank Statement Import

Format. You will need to repeat this for each bank account. Once done, you’re ready to

import bank statements directly into the Bank Reconciliation module.

Select FCB BANK FEED

Bank Feeds allow you to import transactions into only one module: either the Bank Account

Reconciliation module OR the Payment Reconciliation Journal, but not both. Please select

the module that best suits your organization's workflow during the setup of your bank

feed.

Bank Account Reconciliation



Use this section to learn how to import your first transactions using the Bank Account

Reconciliation module.

1 Customize Columns

To ensure all necessary transaction data is visible, you must customize your view in

Business Central.

Select Cash Management and navigate to the Bank Statement Reconciliation 

module. Open the Bank Account you wish to configure

Select the Bank Account

The Bank Statement Reconciliation module will now load. 



Load the Bank Statement Reconcilation Module

From this screen, click the gear icon in the top right corner and select Personalize.

Select Personalize

Next, click on the Bank Statement Lines section to load the columns for this screen.



Select Bank Statement Lines

Select + Field from the top left corner.

Select + Field

A sidebar list of available columns will appear. Drag and drop the following columns

into the Bank Statement Lines section. You may reorder or resize them as needed.



We suggest adding these columns:

Additional Transaction Info

Check No. 

Document No. 

Related Party Name

Drag and Drop Columns

Once you have added all columns, you can click Done. This will now save this

configuration.
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3

Click Done

Field Mapping

The table below explains how the transaction data maps to the Business Central

columns you just added.

Business Central Column Transaction Data

Transaction Date Settled Date

Document Number Customer Reference*

Related Party Name Counter Party Name*

Description Description

Amount Amount

Check No. Check No.*

Additional Transaction Info BAI2 Code

Items marked with an asterisk (*) are conditional. This data will only appear in

Business Central if it is provided in the transaction details received from the bank.

Import Transactions



Now, when you click Import Bank Statement, you can select a Start Date. 

Select yesterday's date. 

Select a Start Date

To pull new transactions, select Import Bank Statement. It will load all transactions

we have received since you last triggered an import.



Select Import Bank Statement

Payment Reconciliation Journal

If you prefer to use the Payment Reconciliation Journal, follow these steps.

1 Go to Payment Reconciliation Journal

Select Cash Management and then navigate to the Payment Reconciliation Journal 

module. 



2

Select a Bank Account

Select the bank account you would like to start with. 

Import Transactions

When prompted for a start date, select yesterday's date.

Select a Start Date



Select Import Bank Statement. The system will load all transactions received since

your last import trigger.

Import Transactions



NOTE: You may notice that your bank accounts are listed as Not Linked within

Business Central.

This is expected behavior. Because these bank feeds are provided through a

custom integration rather than Business Central’s native offering, the native

status indicator will not update. This does not affect the functionality of your

import.

Example of the Not Linked Status



4.3.3.3. Using Bank Feeds (Business Central)

This guide covers how to use Bank Feeds with the Bank Account Reconciliation module or

the Payment Reconciliation Journal to streamline your reconciliation process.

Bank Feeds allow you to import transactions into only one module: either the Bank Account

Reconciliation module OR the Payment Reconciliation Journal, but not both. Please select

the module that best suits your organization's workflow during the setup of your bank

feed.

Bank Account Reconciliation Module

To initiate your first Bank Feed using the Bank Account Reconciliation module, begin by

using the system search bar to locate and open Bank Account Reconciliation.

Select Bank Account Reconciliations

Once the page loads, navigate to the top menu bar, select Process, and then click New. 



Select New

You will then be prompted to select the specific Bank Account you wish to reconcile to

complete the setup.

Import With Bank Account Reconciliation 

Follow these steps to import your bank account transactions into Business Central for

reconciliation using the Bank Account Reconciliation module.

1 Go to Bank Account Reconciliation

Select Cash Management and then navigate to the Bank Account Reconciliation 

module. 

Select the Bank Account you would like to start with. 
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Select a Bank Account

Import Bank Statement

To retrieve new data, select Import Bank Statement. This action will load all

transactions received since your last import was triggered. 

Select Import Bank Statement
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If no new data is available, a system notification will appear to confirm that there are

no new transactions to import.

Expected Fields 

The list below outlines how the transaction data imports into the Business Central

columns:

Business Central Column Transaction Data

Transaction Date Settled Date

Document Number Customer Reference*

Related Party Name Counter Party Name or Related Party Name*

Description Description

Amount Amount

Check No. Check No.*

Additional Transaction Info BAI2 Code

Fields marked with an asterisk (*) are conditional. This data will only appear in

Business Central if it is provided in the bank's transaction details; not all transactions

will contain this specific information.

Match Transactions With Bank Account Reconciliation 

With your columns configured and your data imported, you are ready to begin

reconciliation using the Bank Account Reconciliation module. Follow these steps to match

the imported transactions to your existing Business Central entries.

1 Automatically Match Transactions

To use the automatic match feature, go to Matching --> Match Automatically. 



Click on Matching Automatically

The system will prompt you to enter a Transaction Date Tolerance. The

recommended tolerance depends on the payment method used; for example, ACH

and Wire payments typically settle within five business days, whereas checks

depend on when your vendor deposits them.

Enter In The Number of Tolerance Days
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Business Central will attempt to match the transactions based on these criteria. Once

the process is complete, a summary will appear displaying the number of lines

successfully matched.

Overview of Matched Transactions

Manually Match Individual Transactions

To manually match transactions, click on the corresponding transaction on both the 

Bank Statement Lines section and the Bank Account Ledger Entries section. 

With both lines selected, click Matching -> Match Manually.
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Click Match Manually

Once the transactions are matched, they will both turn green to signify success.

Successful Match Made

Manually Match Multiple Entries to One Bank Statement Line



You can also match Bank Account Ledger Entries to a single bank statement line.

First, select the target line in the Bank Statement Lines section.

Next, in the Bank Account Ledger Entries section, hold down Control (Windows) or 

Command (Mac) while clicking to select the multiple transactions you wish to group

together. 

Then, click Matching -> Match Manually.

Click Manual Matching

Once matched, the system will highlight the single statement line and the multiple

ledger entries in green, indicating they are successfully matched.
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Successful Match Made

Removing Matches

If you incorrectly match a transaction, you can easily remove the link. Select the

matched lines in both the Bank Statement Lines and Bank Account Ledger Entries 

sections.

Next, click Matching --> Remove Match. 
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Click Remove Match

The green highlighting will disappear, indicating that the transactions are no longer

matched and are available to be rematched.

Transactions are Successfully Unmatched

Deleting Transactions



If you need to delete a transaction, click on the three dots beside the Transaction

Date. 

Click on Delete

Click Yes, and the transaction will be deleted. 

Click Yes



Payment Reconcilitation Journal Module

To initiate your first Bank Feed using the Payment Reconcilitation Journal module, begin by

using the system search bar to locate and open Payment Reconcilitation Journal.

Select Cash Management → Payment Reconciliation Journal.

Select the Payment Reconciliation Journal

To complete the setup, select Process → Import Bank Transactions. 



Select Import Bank Transactions

Import With the Payment Reconciliation Journal 

Follow these steps to import your bank account transactions into Business Central for

reconciliation with the Payment Reconciliation Journal.

1 Go to Payment Reconciliation journal

Select Cash Management and then navigate to the Payment Reconciliation Journal 

module. 

Select the bank account you would like to import your transactions from.



2 Import Bank Statement

To retrieve new transactions, select Import Bank Statement. 

This action will load all transactions received since your last import was triggered. 

Import New Transactions



If no new data is available, a system notification will appear to confirm that there are

no new transactions to import.

Match Transactions With Payment Reconciliation Journal 

With your bank data imported, you are ready to begin reconciliation using the Payment

Reconciliation Journal module. Follow these steps to match the imported transactions to

your existing Business Central entries.

1 Automatically Match Transactions

To use the automatic match feature, click on Apply Automatically. 

Click Apply Automatically

A prompt will appear asking if you wish to overwrite any previously applied entries.

Select Yes or No based on your preference.
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Business Central will now attempt to match the transactions. Once completed, it will

provide a summary of the total number of lines that were matched successfully.  

Overview of Matched Transactions

Manually Matching Transactions



To match a specific transaction manually, first select the transaction line you wish to

reconcile.

Once you have selected the line, click on Manual Application --> Apply Manually. 

Click Apply Manually

You can now select the corresponding single entry or multiple entries to complete

the match.



Select Lines to Apply

Once applied, the transaction description will populate, and the Match Confidence 

status will update.

View Matched Transactions





4.4.Troubleshooting

4.4.1. FAQs (Business Central)

This page is your go-to resource for quick troubleshooting. We've compiled a list of the

most common errors and frequently asked questions you might encounter when using the 

 in Business Central, providing you with immediate answers and

resolutions.

First Citizens Link

Extension Compatibility

This section outlines which Business Central extensions are compatible with the plugin.

Unsupported Extensions 

CBIZ – Sub Entity Transactions

CBIZ is a multi-entity management tool that adds an extra dimension (the entity) when

making a payment. This restricts our plugin, which causes the payment validation to fail

and the payment to fail to leave the journal.

We recommend switching to Binary Stream’s MEM.

Supported Extensions

MEM (Multi-Entity Management) – Binary Stream



While fully supported, please note the following restrictions and configuration

requirements when using MEM with this plugin:

Batch processing is not currently available.

You must disable "Write Check Ledger Entries."

You must disable "Overwrite Doc No." for Check Payments.

Installation & Plugin Setup

Common Errors

Below is a list of common errors encountered when going through the installation and

setup steps for the plugin. Click on any error message to view the cause and the

troubleshooting steps for a resolution.

"No payment journal template has been configured on company [Your Company

Name] and AL stack trace."

This is a result of no payment journal template being configured. If you have more than

one company, they may also need the general payment journal template configured in

that company.

Solution: Confirm there is a journal with the “General Journal Template” and has the

type of “Payments”. If not, please create this journal. 

"Need Admin Approval Error in the Wizard."

You need to have admin approval to access authentication in Business Central.

Solution: A Global Azure administrator can approve this user's consent at the time of

authentication to use the application in their Azure Directory Settings. You should also

make sure the Microsoft Azure Admin is available whenever attempting to onboard the

plugin.



"Error viewing certain tables or pages, such as 'TableData and permissions on

TableData Vendor Ledger Entity Modify.'"

You need permission to view certain pages once the plugin has been installed.

Solution: Your Business Central administrator needs to assign the following permission

sets to the user. If you are only using Bank Feeds and are getting errors viewing

certain tables, you may need access to all permissions.

V3BF - Allows users to use Bank Feeds.First Citizens Bank

V3CORE - Required for any user using the plugin.First Citizens Bank

V3FULL - Allows users full access to the plugin.First Citizens Bank

V3PB - Allows users to make payments through the Pay Bills

page.

First Citizens Bank

V3PM - Allows users to access the Payment Methods page.First Citizens Bank

V3RR - Allows users to view balances and transactions on the

Bank Statements page.

First Citizens Bank

Encountering issues loading and experiencing errors on the Select Company page

of the installation wizard.

If the page displays "Loading Eligible Companies...", please allow a moment for the

process to complete. Even if the status temporarily shows "Not Installed," the system

is likely still syncing.

If you encounter an error:

1. Verify Installation: Double-check that the plugin is correctly installed in your

environment.

2. Refresh the Step: Try navigating back to the previous screen and then clicking

forward again to refresh the connection.

Common Questions

This list provides answers to common questions that arise during the installation process. 



Do I need to update my plugin, or will it automatically update?

Yes, you must manually update the plugin. We release new versions monthly with

important fixes and improvements.

Follow these steps:

1

2

Download

Go to API Credentials -> select the plugin -> Actions -> Download latest

version.

Install

Go to Extension Management -> Upload Extension -> select the new .app file ->

Accept -> Deploy.

Who from my company is needed to help connect my Business Central environment

with the plugin?

You will need a user with Azure Admin permissions. They are required to approve the

specific permissions the plugin needs to operate within your environment.

How can I avoid compatibility issues during an ERP update?

To avoid compatibility issues, ensure your plugin is on the latest version before your

ERP system updates. If needed, adjust your update timeframe until the plugin update is

complete. Please see the linked  for more information on adjusting your update

time.

guide

Accounts Payable

Common Errors

Below is a list of common errors encountered when using the Accounts Payable product in

Business Central. Click on any error message to view the cause and immediate

https://learn.microsoft.com/en-us/dynamics365/business-central/dev-itpro/administration/tenant-admin-center-update-management


troubleshooting steps for a resolution.

"Incorrect Payment Amount"

This usually occurs when discounts or credit memos conflict with the payment

amount.

Solution: Check that all discounts and credit memos are applied correctly. You may

need to unapply and reapply any attached credit memos to resolve the mismatch. If

the issue persists, please contact support. 

"Post An Entry With An Earlier Posting Date"

The invoice likely has a Post Date set in the future. The plugin processes payments

using today’s date, so it cannot settle an invoice that is technically not "posted" yet in

the system timeline.

Solution: Update the invoice so the Post Date is set to today or a past date.

An Open Posted Purchase Invoice isn't showing up on the Pay Invoices page.

If an invoice is not showing up on the Pay Bills page, please check the following. 

1

2

3

Confirm Status

Verify that the invoice has been fully posted in Business Central.

Sync Delay

If recently posted, wait a few minutes and refresh the page.

Support

If the invoice is definitely posted but still not appearing after a refresh, please

reach out to our support team to manually re-sync the invoice.



An invoice I don't want to pay is appearing on the Pay Invoices page.

If there is a bill you do not want on the Pay Invoices page is showing up on it, hover

over the specific bill in the list. Click on the small garbage can icon that appears. 

Clicking this icon only removes the bill from the plugin view. It does not delete the

invoice from your Business Central environment.

Check is not appearing as a payment option for a vendor.

This is almost always due to missing address data. The plugin requires full address

details to process a check.

Go to the Vendor Card and ensure the following fields are populated:

Address

Postal/Zip Code

State/Province

Country (This is the most commonly missed field).

If all fields are present and the option is still missing, please contact support.

Common Questions 

This list provides answers to common questions that arise when using the Accounts

Payable product in Business Central.

How do I know the status of my payments?

Navigate to Pay Invoices -> Payment History. Here you can view the status message

and the Last Updated timestamp for every transaction.



Why does the payment status of an invoice stay in Processing?

The bill is still processing because payments can take between 3 and 4 business days.

Processing differs by payment type. Some payment types don't provide a confirmation

that the payment was successfully processed, so we use automation to set the

payment as Completed after a certain number of days.

Whenever the bank receives the payment, the status changes to Processing, whether

the customer has to approve the transaction at the bank level or not. Since we don’t

get a confirmation that the transaction is complete, and some banks have a 3 or 4-

business-day settlement period, the transaction is marked as successful in our system

only after this time has passed.

What field must be filled in to send a memo to my vendors?

To have a memo transmitted with your payment, please fill in the Posting Description 

field on the Purchase Invoice. 



How can I block payments for a vendor?

To block payments for a vendor, you can navigate to the vendor record and select 

Blocked --> Payments. 

Example Vendor Card

Why can't I see the UserID of users who submitted payments?

Unfortunately, due to limitations within Business Central, we cannot capture the

submitting user's ID on payment entries.

Instead, you can view the user's email address on the plugin's Payment History page.

This information is fully exportable for auditing.

How do I know which payment method code is used when submitting payments?

The plugin will submit payments using the Payment Method Code populated on the

Vendor Record, or it will leave it blank if there is no code preselected.  



For multi-entities, can the company name be unique per bank account?

Yes. First, contact your bank to ensure they have a unique Account Holder Name

registered for each of your bank accounts.

Within the plugin, if you populate the Account Details -> Account Holder Name field,

that specific name will appear on vendor payments. If this field is left blank, the system

will default to the Account Label (i.e., the Company Name).

Example: If your umbrella company is ACME Holdings, you can configure payments to

appear as coming from ACME North or ACME South by assigning those specific

names to the respective bank accounts.

Bank Feeds

Common Errors 

Below is a list of common errors encountered when using Bank Feeds. Click on any error

message to view the cause and the troubleshooting steps for a resolution.



"The Data Exch. Column Def does not exist. Identification fields and values: Data

Exch Def Code."

The reason for this error is a configuration error in the Data Exchange Definition.

Error message

Solution:  Search for "Data Exch Definition" and open the relevant Code. Scroll to

Column Definitions to verify the column entries (specifically Column 6 in this example).

Next, go to Line Definitions, select Manage -> Field Mapping, and ensure Column 6 is

correctly matched to its Data Exchange Code.

"The file that you are trying to import is different from the specified Bank Statement

Import...... Actual Value: 'Not Settled'"

We do not support using the current date in your import. 

Solution: Please change the import date range to the prior day and try again. 

Common Questions

This list provides answers to common questions that arise when using the Bank Feeds

product in Business Central.



Does the plugin auto-match reconciliation in Business Central?

The plugin cannot auto-match bank statement lines against bank account general

ledger entries.

Can the plugin automatically update the transactions in the reconciliation module?

You will need to select the dates of the transactions you want to import. Navigate to 

Bank -> Import Bank Statements -> Select your date range. 



4.4.2. Approval Limitations (BC365)

Business Central has a workflow system for creating approvals that may cause issues with

the plugin. Approvals can occur at different stages in the lifecycle of an invoice and

payment. This page covers the approval flows not supported by the plugin and how to view

your workflow configuration in Business Central.

Unsupported Approvals

Approval flows that include releasing Posted Purchase Invoices will not work with the

plugin. Other approval flows that impact the creation of payment records are also likely to

cause issues. This includes flows that require approval to make postings to the General

Ledger, Vendor Ledger, or Check Ledgers (if enabled).

Approval flows related to approving Posted Purchase Invoices before purchase may cause

issues or delays in creating a payment due to changes in the invoice status.

Viewing Workflow Configurations

Use the global search bar to search for Workflows and identify any approval workflows

related to Purchase Invoices.

NOTE: This page is for informational purposes only and should not be used as a

guide to make changes to the configuration of your Business Central environment.

For support with your NetSuite native approval flows, please reach out to your

Business Central consultant directly.



Click on Purchase Invoice Workflow

Select a workflow to view its details. Verify if the workflow is enabled and look for events

triggered by the invoice being released.

Examine Events



You can do a further check to see if any conditions are specifically set for released

invoices. 

Further Analyze the Conditions



4.5. Release Notes (Business Central)

To learn how to update the bundle visit: Updating the Plugin (BC365)

2026

May 2026

2026.5.0.0 - May 13, 2026

Added Bank Accounts Page Enhancements.

Improved Enhanced status accuracy for Payment History.

New Products Added

We are excited to announce a streamlined UI refresh and enhanced data visibility for our

clients. This update focuses on better organization for diverse account types and improved

transaction tracking.

The page you know as Balances and Transactions is evolving. We have rebranded this

space to Bank Accounts. This new UI provides a cleaner foundation for managing multiple

financial streams in one place.

NOTE: These updates are part of our May 2026 release. While you may see these

features documented in our guides earlier, please note that all changes will officially

go live on May 13, 2026.



Key Benefits and Highlights

1

2

3

4

5

Streamlined Check Transmission

Automatically extract check details from Business Central and transmit your

entire check run to the bank with just a few clicks, saving time and minimizing

manual effort.

Real-Time Dashboard & Alerts

See counts of Open, Failed, and Invalid checks at a glance, with instant alerts

highlighting issues that need your attention.

Seamless Payment Approvals Integration

If Payment Approvals is enabled, Positive Pay transactions move into the

approval workflow before final transmission, ensuring proper controls while

preventing delays.

Comprehensive Audit Trail & History

Track every transmission’s real-time status, Completed, Failed, or In Progress,

with detailed feedback messages and who initiated the transmission.

Exception Handling & Resolution

Easily identify invalid checks caused by bank account mismatches and resolve

issues through the FISPAN Portal. Unwanted checks can be removed from the

plugin without affecting Business Central data.

Improvements

We’ve updated the Payment History page to ensure all transaction statuses are accurately

represented. Records designated as "Completed with Change" now populate correctly

within your history view. This update ensures the continued integrity of your payment data,

providing a comprehensive and reliable audit trail for all finalized transactions.



April 2026

2026.4.0.0 - April 15, 2026

Improved General improvements and bug fixes.

March 2026

2026.3.0.0 - March 11, 2026

Improved General improvements and bug fixes.

February 2026

2026.2.0.0 - February 11, 2026

Improved General improvements and bug fixes.

January 2026

2026.1.0.0 - January 14, 2026

Improved General improvements and bug fixes.

2025

December 2025



2025.11.0.0 - December 10, 2025

Fixed General improvements and bug fixes.

November 2025

2025.10.0.0 - November 12, 2025

Improved Data exchange enhancement. 

Improvements

We've upgraded the plugin to ensure more reliable and seamless data exchange. This

enhancement provides strong character support, allowing the system to effectively

process all standard global characters (UTF-8) found in transaction descriptions,

eliminating past interruptions.

October 2025

2025.9.1.0 - October 29, 2025

Fixed We addressed and resolved the deployment issue.



2025.9.0.0 - October 15, 2025

Improved

The plugin base version has been upgraded from v21 to v24. This

upgrade involved updating dependencies, platform versions, and runtime

configurations to align with the latest v24. Please ensure your ERP

version is at least 24 before updating your plugin. 

To learn more about version numbers in Business Central, please click

here: https://learn.microsoft.com/en-us/dynamics365/business-

central/dev-itpro/administration/version-numbers 

Improved

We've successfully resolved the compatibility issues between your bank

plugin and Microsoft's Business Central version 27.0.38460.38988. This

fix addresses the concerns you may have previously received from

Microsoft regarding potential compatibility problems.

You can now proceed with your Business Central upgrade. Please

ensure you upgrade your plugin before upgrading your ERP to version

27.

September 2025

2025.8.0.0 - September 10, 2025

Improved

As part of our ongoing efforts to maintain consistency across the

platform, we’ve updated the Payment Details page within the Activity

view to reflect current interface standards. 

August 2025

2025.7.0.0 - August 13, 2025

Fixed

The vendor approval feature has been improved to handle email

addresses in a case-insensitive manner (e.g., Jane.Doe@example.com).

This ensures that users can approve requests regardless of how their

email address is capitalized.





5. Payment Requirements

Your  plugin is designed to streamline your payment process by

supporting various payment methods. While it uses the standard payment fields you're

familiar with in your ERP, it also provides new custom fields to handle the complexity of

domestic and international payments.

First Citizens Bank

These new fields ensure we capture all necessary details for different payment methods.

To get started, refer to the following guides. They walk you through exactly what

information needs to be present in your Vendor records and your Bills to successfully

initiate payments using any of the supported methods.

ACH Requirements



5.1. ACH Requirements

ACH payments are used to move funds within the United States only and must always be in

USD.

For NetSuite users, the Entity Bank Details bundle is required to process ACH payments

through the plugin.

Vendor & Bill Requirements

To prevent payment delays or returns, all payments are required to have the following three

requirements:

1

2

3

Vendor Record

The Entity's full legal name, address, and phone number must be accurately

populated on the Vendor record.

Billing Address and Location

The Entity and Bill (if applicable) Billing Addresses must be located in the country of

destination and must match the country specified in the Entity Bank Details record.

Currency

The currency for the Entity Bill must be in USD.

Payment Requirements

Payment Context

Method: Domestic

Country: United States 

Currency: USD



Requirement Information

1

2

Routing Number is mandatory.

Account Number is mandatory.



6.Support

6.1. Contact Us

Need help with a specific topic? Enter keywords in the search bar on the left panel to

narrow your results. If you don't find what you need, our support team is ready to assist

you.

Search for Keywords

Support



Our support team is here to help you answer any of your questions. You can reach out to

us using the emails below.

For onboarding support inquiries relating to Enrollment Form Submissions, Onboarding

Troubleshooting, and Production Promotion Requests, please reach out to: 

Onboarding Email: TMSTechnicalImplementation@firstcitizens.com

For support inquiries relating to Account Maintenance, Production Technical Support, and

Product Feedback/Feature Requests, please reach out to:

Support Email: TreasuryManagementSupport@firstcitizens.com

mailto:TMSTechnicalImplementation@firstcitizens.com
mailto:TreasuryManagementSupport@firstcitizens.com


6.2. Feature Requests

FISPAN Feature Request Portal

UNDER CONSIDERATION IN PROGRESS RELEASED (SUBJECT TO BANK AVAILABILITY)
Portal (powered by Productboard) uses

cookies

We (Productboard) use cookies and similar

technologies to operate this portal and improve your

experience. Some information (such as IP address

and browser data) may be shared with third party

service providers and partners for analytics and

advertising purposes. We do not sell your personal

information. You can choose to opt out of this sharing

below.

Please visit Productboard’s Privacy Policy for more

information about your rights. Your use of this portal

and feedback you provide remain subject to our

Customer’s Privacy Policy.

View our 2 partners

Accept all

Reject all

Manage cookies

Have a Feature Request?

Feature requests help us drive the roadmap of future developments on the integrations.

Use the section above to vote on previous ideas, or submit ideas of your own to FISPAN. 

NOTE: If you have a question about a feature listed under "LAUNCHED, Subject to

Bank Availability," please reach out to our Support team, or your bank representative.

Click this link to the  website to see a list of feature

requests under consideration.

FISPAN Feature Request Portal

https://portal.productboard.com/siwnb1pncbmmsxd3jwnzqhpz/tabs/10-under-consideration
https://portal.productboard.com/siwnb1pncbmmsxd3jwnzqhpz/tabs/24-in-progress
https://portal.productboard.com/siwnb1pncbmmsxd3jwnzqhpz/tabs/20-released-subject-to-bank-availability-
https://www.productboard.com/privacy-policy/
https://portal.productboard.com/fispan/4-fispan-product-portal


*Please note: We are always thrilled to receive feedback and feature requests for our

integrations. We work closely with our various partners to make decisions on what to

develop next. We may reach out to you directly for additional information about a feature

you've previously voted on or suggested. Lastly, due to the complexity of developing the

integrations, we are generally unable to provide timelines on features listed below. 

FISPAN is a vendor of your bank. To submit inquiries or complaints to your bank, please do

so directly with them.


