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1.Getting Started

1.1. Welcome

The Product Guides are where you will find step-by-step walkthroughs,

support documentation, and other helpful resources.  Use the quickstart links below, or try

the search function and navigation menu on the left.

Goldman Sachs

Getting Started

ERP Quickstart Links Release Notes

NetSuite Pre-Onboarding Checklist (NetSuite) Release Notes (NetSuite)

Sage Intacct Pre-Onboarding Checklist (Intacct) Release Notes (Intacct)

Product Features

The  plugin supports the following features:Goldman Sachs

Payables

Product NetSuite Intacct

Vendor Payables ✓ ✓

Credit Memos ✓ ✓

Discounts ✓ ✓

Book Transfers (A2A) ✓ ✓



Payment Rails

Payment Rail NetSuite Intacct

ACH - US/USD ✓ ✓

Domestic Wires - US/USD ✓ ✓

Information Reporting

Product NetSuite Intacct

Balance & Transactions ✓ ✓

Reconciliation Manual Export ✓ ✓

Bank Feeds ✓ ✓

Still Have Questions?

Support

Contact Us



2.NetSuite

2.1.Plugin Setup

2.1.1. Pre-Onboarding Checklist (NetSuite)

Use this checklist to get ready for your onboarding call. Having everything on hand will

also help you if you decide to start the installation on your own.

If you're moving your plugin to a live environment, make sure you've already completed the

in a sandbox environment. Testing in a sandbox with all of

your custom workflows, scripts, and third-party apps is the best way to ensure everything

works smoothly before going live.

Sandbox Checklist (NetSuite)

Bring a NetSuite Administrator

The installation process requires a NetSuite Administrator (or someone with sufficient

permissions) to be present. The user is required to have the following permissions:



Install plugin

Create access tokens

Configure features for the NetSuite company

Define permissions on scripts

Manage users/roles

If no attendees have permissions to do the above, the call may be rescheduled.

Review Multiple Currencies Setup

The plugin is built with multi-currency to support growing businesses that scale beyond

single-currency operations. In NetSuite, it is mandatory to enable the Multiple Currencies

feature. Attempting to use the plugin without this feature enabled will result in a SuiteScript

error on every page.

You can verify your Multiple Currencies setup by navigating to Setup → Company →

Enable Features. 

The Multiple Currencies feature can be found within the Company tab.



The Multiple Currencies feature can be found within the Company tab in the International

section.

Note Your NetSuite Edition

NetSuite offers OneWorld and non-OneWorld editions. Please check if Subsidiaries are

present in your NetSuite environment by navigating to Setup → Company → Subsidiaries.

If Subsidiaries are present, you are subscribed to a OneWorld edition.

Book Transfers and other features in your bank plugin may be incompatible with non-

OneWorld editions of NetSuite, as they require Subsidiaries to be enabled.

Disable Payment Approvals Inside NetSuite

Applicable if using the Accounts Payable product. 

The plugin does not support the Payment Approval workflow inside NetSuite. If you

leverage NetSuite’s payment approval currently, we strongly recommend moving that



process inside the other payment approval options available to you.

Continuing to use that process blocks the plugin from creating a bill payment record in

NetSuite, resulting in a failed bill payment.

Confirm Sandbox Testing

If you use the Accounts Payable product, custom workflows, scripts, or any third-party

applications or plugins, we recommend testing in a NetSuite Sandbox environment before

moving to Production. This essential step ensures a smoother transition onto the plugin

and helps prevent disruption to your service.

Note Any Custom Workflows or Scripts

The plugin works best in NetSuite environments that do not have any customized

workflows or scripts that block or alter standard Accounts Payable workflows, such as bill

payment creation or the vendor record. Common examples include approval workflows. 

Please check with your  for what payment approval steps are available

to you.

TxB representative

Prior to installing to Production, it is recommended that you test the plugin thoroughly in a

NetSuite Sandbox environment that contains custom workflows or scripts that pertain to

Accounts Payable.

Note Any Third-Party Plugins or Applications

Other third-party plugins, applications, or integrations within NetSuite may not work

perfectly with your new bank plugin. 

Prior to installing to Production, it is recommended that you test the plugin thoroughly in a

NetSuite Sandbox environment containing relevant third-party applications to avoid any

future disruption to service.



Note Where Banking Details Are Stored

Make a note of where your payee's bank details are currently stored. Our supplementary

Entity Bank Details currently allows users to migrate data from NetSuite's Electronic Bank

Payments bundle, while also providing import templates for banking data that may be

stored elsewhere.

We strongly recommend using our Entity Bank Details for greater support of additional

payment types and for a smoother user experience.

Review Limitations

The NetSuite bank plugin and the supplementary Entity Bank Details are currently not able

to support the following:

Environments without NetSuite's Multiple Currencies feature enabled

Non-OneWorld NetSuite editions (no Subsidiaries)

Partial Payments

Automated writing of Balance or Transaction data directly into the NetSuite

reconciliation module(s)

Handling of payroll or employee commissions

User-specific approvals within NetSuite for payments submitted through the bank

plugin

Read from the payee bank data stored outside of our supplementary Entity Bank

Details

Conduct saved searches or run reports on bank information stored in the Entity Bank

Details

Have the Invitation Email Handy

NOTE: If you are not an Accounts Payable user, please skip this step.



You should have received an invitation email from your bank with links to install the Plugin

in NetSuite. Ensure that at least one person attending the call has access to this email,

whether they were the original recipient, or it was forwarded to them.

Have Your NetSuite Account ID Handy

This can be found by navigating to Setup → Company → Company Information. 

Within the Company Information page, you can find your Account ID. Copy this Account ID

somewhere and save it, as we will need this information during the installation process.

Confirm Hardware & Software Requirements

Browser support (minimum versions):

Chrome: 65

Firefox: 66

Safari: 12

Edge: 79



Operating systems (minimum versions):

Windows 7

macOS - El Capitan

Minimum screen resolution:

1200x800px

Configure NetSuite Features

While not a mandatory step, configuring your company’s NetSuite features ahead of time

will speed up the onboarding process significantly. 

Please follow the steps below to enable the required features.

1 Navigate to Enable Features

In NetSuite, go to Setup → Company → Enable Features.

Go to Enable Features



2

3

Enable Multiple Currencies

Under the Company tab, select Multiple Currencies.

Select Multiple Currencies

Enable Expense Reports

Under the Employees tab, enable Expense Reports (This is required for Apply Bill

Credits functionality).



4

Enable Expense Reports

Enable SuiteCloud 

Under the SuiteCloud tab, select the following items:

Custom Records

Client SuiteScript

Server SuiteScript

Token-Based Authentication

REST Web Services

Click Save.



5

Enable Sub Items

Set Up Accounting Preferences

Go to Setup → Accounting → Accounting Preferences.

Navigate to Accounting Preferences



6 Enable Account Numbers

Under the General tab, select the Use Account Numbers checkbox.

Enable "Use Account Numbers"

Click Save.



2.1.2. Installation

2.1.2.1. Step 1: Invitation Email

You should have received an invitation email with links to install the  plugin

and easy-to-follow instructions for installation.

Goldman Sachs



2.1.2.2. Step 2: Register & Login

Register & Login

1

2

Create an Account

In your invitation email, select the Get Started button. You will be brought to the 

. Create your login credentials and select Create Account.FISPAN Portal

Passwords are required to be 8 characters and contain at least one uppercase,

lowercase, number and special character

Login to Your Account

Once registered, you will be redirected to the login page. Your username and

password are unique per environment, and you will have separate logins between 

 and .Sandbox Production

NOTE: The password you create here will be used every time you want to

access the . If you need to update it later on, you have the option

to use the Forgot Password option.

FISPAN Portal

https://sandbox.fispan.cloud/login
https://sys.fispan.live/login


Welcome Page for Sandbox

From the welcome page, you'll be taken to the login page. Enter your username and

password to proceed. 

Setting Up SMS MFA

The first time you log in to the Production environment, you will be prompted to establish

your Multi-factor Authentication (MFA) setup. You have the option to select various

methods of MFA. 

1 Enroll Phone Number

NOTE: The Sandbox environment is used as a testing or UAT environment. For

Sandbox users, please refer to the Sandbox Checklist for test scenarios.

NOTE: Multi-factor Authentication (MFA) is only required if you are a user in the

Production environment. If accessing the Sandbox environment, you may skip this

step.



2

3

Select your country code then enter your phone number, you will receive a text

message with a 6-digit code via SMS to the phone number you provided for

enrollment.

If you are unable to receive a text message to this number, or you prefer a different

multi-factor authentication method, click Try Another Method. 

Enter Code

Enter the 6-digit code you received in the applicable field.

Select Continue.

6-digit Verification

Save Recovery Code

After setting up SMS and inputting the first one-time code, you will be presented with

a recovery code that should be stored in a safe location. This code is for resetting the

MFA, to switch the MFA type (i.e., Authenticator), or to use a different phone number. 



Recovery Code

If you would like to utilize another method for MFA (SMS, Authenticator, or Email)

instructions are available here: Setting Up Multi-Factor Authentication



2.1.2.3. Step 3: Select ERP

Select Install under the NetSuite ERP box and the installation wizard will appear on your

screen. 

Select Install

The first page of the installation wizard contains a brief summary, along with prompts to

review and complete the pre-onboarding checklist.

Once you have finished the pre-onboarding checklist, use the I have completed the pre-

onboarding checklist toggle to unlock the Get Started button.

Click Get Started.



Select "Get Started" on the Welcome to the plugin Installation wizard



2.1.2.4. Step 4: Permissions

To establish a connection between your bank and NetSuite, you must agree and grant

access by clicking the toggle. Once completed, click Next.

The plugin requires this NetSuite financial data to display account balances and transaction

information. The plugin will only write to custom fields introduced by the plugin.

Review the Permissions and then click the "I agree" toggle

NOTE: Your permission list, found in your ERP, may contain more or less fields than

the example shown above.



2.1.2.5. Step 5: Let NetSuite Talk to Your Bank

About NetSuite Account ID

Your NetSuite Account ID is required to connect  to your NetSuite

environment.

Goldman Sachs

If you have already shared your NetSuite Account ID with your bank representative during

the onboarding setup, you will see this field pre-populated in the installation wizard.

Register Your Account ID

If the Account ID is pre-populated:

1

2

3

Review the pre-filled Account ID to ensure it matches your NetSuite environment.

If correct, continue to Next Step.

Already Pre-Filled

If incorrect, update the Account ID field with the correct value, then click Register

System.



Update & Register

If the Account ID field is empty:

1

2

3

Locate your Account ID in NetSuite (see instructions below).

Enter the Account ID in the field.

Click Register System.



Click Register System

Locate Your Account ID in NetSuite

1

2

3

In NetSuite, navigate to Setup → Company → Company Information.

Locate your Account ID within the Company Information page.

Copy the Account ID.

Troubleshooting Registration Issues

If registration fails:

1

2

Verify that you have entered the Account ID correctly.

Ensure there are no extra spaces or characters.

IMPORTANT: NetSuite Account IDs on Sandbox environments will end with

_SB#(e.g., _SB1, _SB2). If you are a Production user, please ensure you are

copying the Account ID from your Production environment, not a Sandbox

environment.



3

4

Confirm you are using the Account ID from the correct environment (Production vs.

Sandbox).

Click Retry.

If the issue persists after verifying the Account ID, please contact Support for further

assistance.



2.1.2.6. Step 6: Install Bank SuiteApp

From NetSuite, start by navigating to Customization → SuiteCloud Development →

SuiteApp Marketplace

SuiteApp Marketplace

1

2

Search for the SuiteApp

To search for the bundle, type " " in the Keywords box and

select Search. 

Goldman Sachs

Install the SuiteApp

Select Install to review the SuiteApp, then select Install again to confirm. 

Select Ok when the pop-up box appears and wait for the bundle to install (this may

take a few moments). Once the bundle has been installed, the tab

will appear on your NetSuite menu.

Goldman Sachs

Then, head back to the installation wizard and select Next Step. 



NOTE: If you will be using Accounts Payable, you will also need to install and

configure the Entity Bank Details SuiteApp Refer to this article to install the bundle: 

Entity Bank Details SuiteApp Installation & Setup (NetSuite)

Or you can wait to install and configure the Entity Bank Details SuiteApp later, as

described in: Step 13: Install Entity Bank Details SuiteApp



2.1.2.7. Step 7: Configure NetSuite Features

Please follow the steps below to enable the required features.

1

2

Navigate to Enable Features

In NetSuite, go to Setup → Company → Enable Features.

Go to Enable Features

Enable Multiple Currencies

Under the Company tab, select Multiple Currencies.



3

Select Multiple Currencies

Enable Expense Reports

Under the Employees tab, enable Expense Reports (This is required for Apply Bill

Credits functionality).

Enable Expense Reports



4

5

Enable SuiteCloud 

Under the SuiteCloud tab, select the following items:

Custom Records

Client SuiteScript

Server SuiteScript

Token-Based Authentication

REST Web Services

Click Save.

Enable Sub Items

Set Up Accounting Preferences

Go to Setup → Accounting → Accounting Preferences.



6

Navigate to Accounting Preferences

Enable Account Numbers

Under the General tab, select the Use Account Numbers checkbox.

Enable "Use Account Numbers"

Click Save.





2.1.2.8. Step 8: Create a New Security Token

An access token from NetSuite is needed to proceed with the installation. Follow these

steps to create a new security token in NetSuite and add it to the installation wizard.

Create a New Security Token

1

2

Navigate to Manage Access Tokens

In NetSuite, navigate to the homepage.

Find Settings and select Manage Access Tokens. 

Select Manage Access Tokens on Settings

Where the Settings are located differs depending on how you have arranged content

on your homepage. By default, it is found on the bottom left of the page.

Add New My Access Token

On the My Access Tokens page, select the New My Access Token button.



Access Tokens

On the Access Tokens page, the application must be defined using the Application

Name dropdown. The application for your bank plugin was created automatically

when the plugin was installed.

Use Application Name Drop-down



3 Generate Token 

Select Integration in the Application Name box and click Save. Goldman Sachs

Once you click Save, the loaded page will show a Token Key and a Token Secret.

Copy and paste the Token ID and Token Secret to the appropriate box in the

installation wizard.

Once complete, select Next Step.

IMPORTANT: The access token created during this step is tied to the NetSuite

Administrator who generated it. If this user's Administrator credentials are ever

revoked (i.e. either by losing administrator access or leaving the company), the token

will become VOID, and the plugin will stop working.

To avoid any service disruption, you must create a new token:

1. Log in to https://sys.fispan.live/

2. Deactivate the existing NetSuite connection.

3. Reactivate the connection and go through the installation wizard again.

This will generate a new access token that will replace the voided Token ID and

Token Secret.

If you encounter any issues with this process or if you do not have a login for the link

provided above, please reach out to  for assistance.TxB Representative

IMPORTANT: To ensure your bank plugin is set up correctly, you need to understand

the minimum required permissions and user roles. Following the recommended

method for managing access tokens is crucial to preventing service disruptions.

Please refer to for the full list of required

permissions and step-by-step guidance.

Minimum Permissions (NetSuite)

https://sys.fispan.live/


2.1.2.9. Step 9: Connection Status

After entering the Token ID and Token Secret in the previous step, the installation wizard

will begin to run a connection check to validate all details entered in the previous steps.

If there are no issues, a large green checkmark will appear to confirm that the connection

has been established. Click on Next Step to begin matching bank accounts.

Successful Connection Message

Failed Connection Checks

If the connection check fails, a large red X icon will appear. A list of possible reasons for

failure will appear, such as:

Validation errors from the data you entered in the previous steps

Incorrectly configured NetSuite features

The plugin is not being properly installed in NetSuite



Failed Connection Check

After reviewing and making changes in NetSuite, click Retry to rerun the Connection

Check.

Otherwise, you can click Previous Step to go back and reenter any potentially incorrect

data. Continuing to the next step in the installation wizard will also retrigger the check.

When the check is successful, click Next Step.



2.1.2.10. Step 10: Account Matching

Each ERP account should have a matching bank account. Only the matched accounts will

be used in your plugin. 

Follow these steps to learn how to match your ERP accounts with the corresponding bank

accounts.

Account Matching Setup

Match your ERP Accounts with the corresponding Bank Accounts by dragging an ERP

Account from the left and dropping it onto the desired Bank Account. 

Once you've successfully matched your accounts, click Next Step.

IMPORTANT: The Use Account Numbers preference must be enabled in NetSuite to

match your bank accounts.

To do this:

In NetSuite, go to Setup -> Accounting -> Accounting Preferences.

On the General Ledger tab, check the box next to Use Account Numbers.

After enabling this, click the X in the error banner on this page to reload your

accounts.

If you receive an error during account matching after the feature is enabled, please

contact  Support for further assistance.Goldman Sachs

NOTE: When installing the plugin in Sandbox, bank accounts are for testing only.

They are not connected to your live bank accounts. When installing in Production, the

listed bank accounts reflect your actual accounts.



Account Matching Step

For virtual card payments (if applicable), you will need to map the bank account to a Credit

Card type NetSuite account, not a NetSuite bank account.

Account Matching Error Troubleshooting

IMPORTANT: It might take a few moments for your accounts to appear, depending on

the number of accounts you have and how quickly NetSuite is processing them.

Please do not refresh or leave the page until everything has loaded.

NOTE: If you would like to add new accounts or functionalities after your initial

installation and set-up, please submit a request to your .TxB Representative

TIP: Would you like to set a default account for Account Payables? Let us know which

account you'd like by contacting . Please specify the last 4 digits

of the bank account number in your request. Each company can have only one

default source account across all subsidiaries. 

TxB Representative



NetSuite will load your ERP accounts from the Chart of Accounts. Depending on the

number of accounts you have or your device's security settings, you might see the

following error:

"There was an error loading the bank accounts: Close this to retry!"

If this error appears, click the X to retry loading the accounts.

If you see the error again, click Next Step and finish the rest of the installation wizard.

If you are still unable to load the accounts, our support team can manually map them for

you. To do this, please provide us with the Internal ID from NetSuite.

Provide NetSuite Internal ID 

1 Search Accounts

In NetSuite, go to Lists → Accounting → Accounts → Search

Go to Search

Select Use Advanced Search.



2

Select Use Advanced Search

Under the Criteria tab, in the filter box, select Type and choose Bank (and/or Credit

Card if matching for SUA payments). Then select Set.

Select Bank and Credit Card from Type Drop-down

Filter Results with Internal ID



3

Under the Results tab, remove all but the Name, Account Type,

and Description fields, then add the field Internal ID.

Add Internal ID

Once complete, select Submit.

Download XLS Format

On the Account Search: Results page, please select the Microsoft Excel icon to

download this list in an XLS format.



Download XLS

Once the download is complete, please open the XLS file and add a column with the

last 4 digits of the Account the Internal ID should be mapped to. 

Save this XLS file, and you can contact  to help you troubleshoot. TxB Representative

txb-client-service@gs.com

mailto:txb-client-service@gs.com


2.1.2.11. Step 11: Plugin Access Management

To give users access to the plugin and its features, follow this guide to NetSuite Script

Deployments and Suitelets.

NetSuite Script Deployments

The Administrator has full access to view all plugin pages. In order to allow access to other

users and departments, follow these steps:

Select Customization → Scripting → Script Deployments. Use the following filters:

On the Type dropdown select Suitelet

On the API Version dropdown select 2.1.

Go to Script Deployments

Goldman Sachs NetSuite Suitelets



Each of the Suitelets listed corresponds to a subtab under the  tab. Click 

Edit on each of the following script deployment Suitelets you wish to edit:

Goldman Sachs

 Balances & TransactionsGoldman Sachs

 Pay Vendor BillsGoldman Sachs

Payments HistoryGoldman Sachs

 Transaction Feed Config (Connectivity Method field used in Bank

Feeds setup)

Goldman Sachs

 User CustomizationGoldman Sachs

Add employee roles by selecting the appropriate employee, department, and role you

would like to assign. Then, click Save.

List of Script Deployment scripts



NOTE: If you're using Accounts Payable and adding new users, confirm they have

the correct permissions to access the Entity Bank Details tab and its information.

If this is your first time installing the plugin and you've already installed the Entity

Bank Details bundle, or if you're adding new users, use the following link to edit role

permissions for the associated Entity Bank Details Suitelet, RESTlet, and User Event

script deployments:

Entity Bank Details SuiteApp Installation & Setup (NetSuite)



2.1.2.12.
Step 12: NetSuite Role Permission
Setup

If you receive an "INSUFFICIENT_PERMISSION" error or can't see all the accounts, it's

because your NetSuite user role does not have the correct permissions. You'll need to

update your permissions following these steps.

Update Role Permissions

The Administrator has full access to the plugin features. To set permissions for user roles,

follow these steps.

1 Go to Manage Roles

Go to Setup → Users/Roles → Manage Roles.

Go to Manage Roles

On the Manage Roles page, click Edit beside the role of choice.



2 Add List Permissions 

After selecting Edit, go to Permissions → List. 

Click the dropdown in the last row of the Permissions table. 

"Lists" Permissions

Scroll through the list, or begin typing to find and select the following permissions: 

Accounts (Level: View): Required to access the chart of accounts to fulfill the

payment request.

Currency (Level: View): Required to load the table of open bills on the Bill

Payments page.

Customers (Level: View): Required to load the Positive Pay page of the plugin.

Documents and Files (Level: View): Required to access plugin pages and

scripts to run and display the plugin. 

Vendors (Level: View): Required to load vendor bills on the plugin pay page. 

Employee Record (Level: View): Required to view transactions on the Bill

History page and to load employee expense reports on the Expense Reports

page.
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Subsidiaries (Level: View): Required to add and view subsidiaries as a column

option when customizing the Pay Vendor Bills page. 

Add Setup Permissions

Next, click Permissions → Setup. 

Click the dropdown in the last row of the Permissions table. 

"Setup" Permissions

Scroll through the list, or begin typing to find and select the following permissions:

Accounting Lists (Level: View): Required to be able to use the Pay Bills page. 

Custom Fields (Level: View): Required to pull in custom fields from the Bill

record, which are then used for customizable columns on the Pay Vendor Bills

page. This is necessary for the Pay Vendor Bills page to load if a user has any

customizations.

Custom Lists (Level: Full): Required to load the available payment methods from

your bank on the Pay page. 

SuiteScript (Level: View): Required to check if there are currently payments

being processed. 



SuiteScript Scheduling (Level: Full): Required to schedule payments for

processing.

Select Save.

NOTE: If you are using Accounts Payable, you will also need to install and configure

the Entity Bank Details bundle and set the NetSuite permissions required to allow

selected roles to view and interact with the Entity Bank Details tab.

If you are adding new users, make sure they have suitable permissions to access the

Entity Bank Details tab and information.

If you have already installed the Entity Bank Details bundle and assigned the role

permissions enabling the associated Entity Bank Details Suitelet, RESTlet, and User

Event Script Deployments, refer to the following link to grant role-based access to the

Entity Bank Details tab.

Step 13: Install Entity Bank Details SuiteApp



2.1.2.13.
Step 13: Install Entity Bank Details
SuiteApp

The Entity Bank Details (EBD) SuiteApp, combined with the standard NetSuite vendor and

employee records, will store all the information needed to submit payments.

You can add or view this vendor payment information after installation by going to Setup --

> Entity Bank Details -> Overview.

Entity Bank Details (EBD) Installation Instructions

1 Install Entity Bank Details SuiteApp

From the homepage, go to Customization → SuiteCloud Development → SuiteApp

Marketplace.

Go to SuiteApp Marketplace

NOTE: If you do not have Accounts Payable installed, please skip this step.



Search for Entity Bank Details. Select the SuiteApp tile named, Entity Bank Details.

Click on Entity Bank Details Tile

Click Install to review the SuiteApp, then select Install again to confirm.

Click Install



2 Manage SuiteApp Access - Suitelets

The administrator has full access to the Entity Bank Details SuiteApp. To allow access

to other users and departments, follow these steps:

Go to Customization → Scripting → Script Deployments.

Go to Script Deployments

On the Script Deployments page, apply the following filters:

In the Type dropdown, select Suitelet

In the API Version dropdown, select 2.1

A Suitelet is a custom front-end NetSuite page. Each of the Suitelets listed

corresponds to a page in the Entity Bank Details SuiteApp. 



Filter for Suitelets on API Version 2.1

Select Edit on each of the following Suitelets you wish to edit:
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Suitelet Description

Entity Bank

Details,

Overview

Granting users access to this script allows them to view the

Overview page. This permission, along with the Entity Bank

Details, Settings RESTlet, is required to access the Overview

page.

Entity Bank

Details,

Import/Exp

ort

Granting users access to this script will allow them to view the

Import/Export page.

Entity Bank

Details,

History

Granting users access to this script will allow them to view the

History page.

Entity Bank

Details,

Settings

Granting users access to this script will allow them to view the

Settings page to enable and disable approvals.

Entity Bank

Details,

Approvals

Granting users access to this script will allow them to view the

Approvals page to approve record changes.

Add employee roles by selecting the appropriate employee, department, and/or role

you would like to assign. 

Then, select Save. 

Stay on this page for the next steps.

Manage SuiteApp Access - RESTlets

On the Script Deployments page, apply the following filters:

In the Type dropdown, select RESTlet.

In the API Version dropdown, select 2.1.

A RESTlet is used to define custom RESTful integrations to NetSuite, and in the

context of the Entity Bank Details SuiteApp, is mainly used for handling the import

and export processes.



Select Edit on the the Script Deployment

Select Edit on each of the following script deployment RESTlets you wish to edit:
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RESTlet Description

Entity

Bank

Details,

Import

Service

Granting users access to this script will allow them to import a

CSV of bank account information into the Entity Bank Details

SuiteApp.

Entity

Bank

Details,

Export

Service

Granting users access to this script will allow them to export a

CSV of bank account information from the Entity Bank Details

SuiteApp.

Entity

Bank

Details,

History

Log

Export

Granting users access to this script will allow them to export a

CSV History Log of all changes made to any records stored within

the Entity Bank Details SuiteApp. This history log tracks any edits,

additions, or deletions, as well as who initiated the change and

when.

Entity

Bank

Details,

Settings

This RESTlet should come with pre-enabled access for all roles.

Granting users access to this script will allow them to view the

Overview page. This permission, alongside the Entity Bank

Details, Overview Suitelet, is required to access the Overview

page.

Entity

Bank

Details,

Analytics

This RESTlet should also come with pre-enabled access for all

roles.

Add employee roles by selecting the appropriate employee, department, and/or role

you would like to assign. 

Then, select Save.

Manage SuiteApp Access - User Events

On the Script Deployments page, apply the following filters:



On the Type dropdown, select User Event.

On the API Version dropdown, select 2.1.

A User Event is a type of script that is executed when someone performs certain

actions on records, such as create, load, update, copy, delete, or submit.

Filtering for User Events on API Version 2.1

Select Edit next to the Script Deployment User Event:

User Event Description

Entity Bank

Details, Event 

(Record Type =

Vendor)

This User Event script allows users/roles to add or update

Vendor Bank Account information.

Entity Bank

Details, Event

(Record Type =

Employee)

This User Event script allows users/roles to add or update

Employee Bank Account information.

Add employee roles by selecting the appropriate employee, department, and/or role

you would like to assign. 
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Then, select Save.

Manage SuiteApp Access - Custom Records

Go to Setup → Users/Roles → Manage Roles.

Then, select Edit for the role for which you would like to grant access to the Entity

Bank Details SuiteApp records.

Go to Manage Roles

After selecting Edit, go to the Permissions tab → Custom Record → Locate the

search box in the bottom row. 

NOTE: The owner of the custom record, which defaults to the user who

installed the Entity Bank Details SuiteApp, will always have full access to the

record regardless of the Entity Bank Details permission level assigned to the

role being used.



Search and Select Entity Bank Details

Use the search box to find and set the correct permission level for Entity Bank

Details (FI) (Level: View):

View: Allows a user to view records.

Create: Allows a user to view and create records.

Edit: Allows a user to view, create, and edit records.

Full: Allows a user to view, create, edit, approve, and delete records. This

permission level is required to approve any changes made to vendor or

employee records.

Next, navigate to the Permissions tab → Setup → Locate the search box in the

bottom row. 

Use the search box to find and set the permission: 

Set Up Company (Level: View): Required for the Overview page and is used for

the EBD Settings RESTlet to access the Company Information page.

Within the Permissions tab, select Lists --> Locate the search box in the bottom row. 

Use the search box to find the following permission: 
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Employees (Level: View): Required to approve or view the History page for

employee records.

Then, select Save.

Storing Bank Information

Using the main navigation, go to Setup → Entity Bank Details → Overview.

Select between viewing Vendors or Employees by selecting the tabs above the table.

By default, this page opens up to show Vendors first.

Select View for the desired Vendor or Employee.

Select View for the desired Vendor or Employee

Select Add.



Select Add

Create an optional label and select the appropriate payment method, country, and

currency. Then, fill out the required fields for the specified payment method and

mark the record as Primary. 

Select Save



Then, select Save.

NOTE: The fields that appear on this page are dependent on the method,

country, and currency selected.

WARNING: All vendor and employee bank details, along with all history logs, are

stored within the Entity Bank Details SuiteApp in your NetSuite environment. If this

SuiteApp is uninstalled, all of this data will be permanently deleted.

To prevent data loss, you must export your data before uninstalling. Please use the

Export feature on the Import/Export page to save all your records and history logs.

This is outlined in the Entity Bank Details SuiteApp Import/Export (NetSuite) page.



2.1.2.14.
Step 14: Configure SuiteApps Reports
Balances

1

2

Access Reports Balance Portlet

Navigate to the Homepage.

Select Personalize in the top right → SuiteApps →  Reports

Balance to view balances.

Goldman Sachs

Personalize - Goldman Sachs Reports Balance

Add User Roles to Portlet

Non-admin roles need to be added to the  Reports Balance Portlet.

The administrator has full access to view all plugin pages. 

Goldman Sachs

To allow access to other users and departments, select Customization → Scripting →

Script Deployment. 

Use the following filters:



In the Type dropdown, select Portlet

In the API Version dropdown, select 2.1.

Go to Script Deployments

Search for and select Edit on the Reports Balance Portlet.

Select Edit



Add employee roles by selecting the appropriate employee, department, and role you

would like to assign. Then, select Save.



2.1.3. Post-Onboarding Checklist (NetSuite)

You are almost ready to use the plugin. There are a few additional steps that are required in

order to use the product to its full potential. Review all items in this guide to ensure you are

not missing anything.

Grant Permissions

To ensure users can view and utilize the plugin, a NetSuite administrator must grant them

permission. You can follow  and 

 to enable permissions.

Step 11: Plugin Access Management Step 12: NetSuite

Role Permission Setup

Install the Entity Bank Details Bundle 

The Entity Bank Details bundle, in combination with the standard NetSuite vendor and

employee record, will store all information required to submit payments via the bundle. This

bundle stores payment details for ACH and other more complex payment methods. This is

a mandatory install if you wish to make payments through more complex methods outside

of ACH.

You can follow  or 

 for instructions on how to install this bundle.

Entity Bank Details SuiteApp Installation & Setup (NetSuite) Step 13:

Install Entity Bank Details SuiteApp

Enter Bank Details Into the Bundle

NOTE: For Sandbox users, feel free to skip the steps that may not apply to your use

case. We strongly recommend following the .Sandbox Checklist (NetSuite)

NOTE: If you are not an Accounts Payable user, please skip this step.



There are a few ways to enter your vendor or employee bank details into the Entity Bank

Details bundle. They are as follows:

Option 1: Manual Entry

Refer to Storing Bank Account Information on 

 for instructions on how to manually add Entity Bank Details to a payee.

Step 13: Install Entity Bank Details

SuiteApp

Option 2: Import via CSV Template

Refer to  for instructions on how to

bulk import bank details using our pre-formatted CSV template.

Entity Bank Details Bundle Import/Export (NetSuite)

If you are a current user of NetSuite’s Electronic Bank Payments bundle, you may migrate

ACH and CHECK information using our Electronic Bank Payments export feature. Refer to

the Transferring Bank Details from Electronic Bank Payments Bundle section of 

.

Entity

Bank Details Bundle Import/Export (NetSuite)

Enable Bank Feeds

The plugin adds support for Bank Feeds through a custom Connectivity Method, which

allows transactions from your bank accounts to flow automatically into NetSuite's Match

Bank Data module.

Please follow instructions on  for instructions on how to set up your

bank feeds.

Enabling Bank Feeds

Set Default Payment Methods

Users are able to set a default payment method for their payees to speed up their day-to-

day payment workflow. 

NOTE: If you are not an Accounts Payable user, please skip this step.

NOTE: For Sandbox users, please skip this step.



Follow the instructions on  for how you

can do this manually on a per-payee basis, or through a mass update via CSV import.

Setting Default Payment Information (NetSuite)

If you do not have a default payment set for a payee, you may choose one at the time of

payment.



2.1.4. Sandbox Checklist (NetSuite)

If you're testing the plugin in a Sandbox environment, it's recommended to test a variety of

scenarios. This will help you confirm that your setup is properly supported and functioning

as expected.

Scenarios to Test

Below is a list of scenarios you may wish to test.

Vendor Setup

Modify or create two vendors for testing by following the Viewing Entity Bank Details

(NetSuite) page: one as a company and one as an individual. Be sure to include bank

details and an address for each.

Expected Outcome: These vendors will be used to test bill payment transmissions.

ACH Bill Setup and Payment

Confirm that each vendor you're testing has a U.S. address and that their ACH CCD/PPD

details are entered.

Create a bill and fill in all mandatory fields. On the Billing tab, verify that the correct vendor

address has been automatically selected.

Expected Outcome: After the payment is successfully sent, the bill should no longer

appear on the Open Bills tab of the Pay Bills screen. If the bill is still there, check the Failed

Bills tab on the same screen. You can also view the payment status on the History screen

within the plugin.

Check Bill Setup and Payment

Confirm that a U.S. address has been entered for each vendor you test. 

Create a bill, populating all fields that are mandatory. Open the Billing tab to confirm that

the correct vendor address has been selected.



On the Pay Bills page of the plugin, select the bill that was created, select Check (not

required if a default was set), and click Pay.

Expected Outcome: Once the payment is successfully sent, it should disappear from the

Open Bills tab on the Pay Bills screen. If the payment remains on the page, go to the Failed

Bills tab on the same screen. You can also view payment status in the History screen of the

plugin.

Credit Memo Setup and Payment

NetSuite allows bill credits to be applied to a bill. To do this, go to Bill Credits -> New

Transaction -> input all asterisked fields under the Expenses tab. Go to the Apply tab and

select the bill that the credit should be applied to.

On the Pay Bills page, the remaining amount (the balance after applying credits) should

appear under the Amount Due column. Pay this bill using any payment method.

Expected Outcome: The confirmation screen should show the credited amount.

Failed Bills

All bills will automatically show as successful after clicking Pay unless there is a

customized NetSuite workflow applied.

To test the process for a failed bill, create a bill for $1991.00. Pay this bill on the Pay Bills

screen.

Expected Outcome: The bill should automatically fail and remain on the Open Bills page.

An error message should also appear on the Failed Bills screen. 



2.1.4.1. Sandbox Checklist via the Portal

The Sandbox Checklist is a structured list of post-onboarding sandbox checklist that

guides you through the plugin. This allows you to gain immediate clarity on the next steps

once you complete the onboarding wizard. It eliminates the guesswork by giving you a

clear, prioritized path through FISPAN's core capabilities, at your own pace.

Overview

Instead of relying on guided walkthroughs or back-and-forth emails to help you explore 

, we now provide a structured, automated, and product-aware path to

follow along. This allows you to arrive at production conversations better prepared, with

higher confidence, and having already experienced the key workflows firsthand!

Goldman Sachs

Sandbox Checklist on the Portal

NOTE: This is only available on the Sandbox environment.



Key Features Breakdown

1

2

3

4

My Journey Tab

A new My Journey tab now appears in the  Portal once the

onboarding wizard has been completed. This allows for tracking progress through

your Sandbox. It remains up to date as you explore the plugin.

Goldman Sachs

Automated Task Completion

As you perform actions in their ERP, such as loading bills, viewing transactions, or

confirming a payment, the sandbox checklist will mark those tasks as complete upon

the next refresh.

Tailored to Your Bank’s Products

The checklist only displays tasks relevant to the products enabled for you.

Learn More Redirect

The Sandbox Checklist includes a Learn More link that takes you directly to the

relevant section of our Product Guide or Interactive Demo, providing step-by-step

guidance exactly when and where it's needed.



2.2.Configuration

2.2.1. Setting Up Multi-Factor Authentication

Multi-Factor Authentication (MFA) Overview

Multi-factor authentication (MFA) adds another level of security for all users when using

the  to . With MFA, your data is protected against account breaches and

is accessed by authorized users.

FISPAN Portal login

When registering, all new users must set up Multi-Factor Authentication (MFA) by choosing

an authentication method (the default option will be shown first).

If you prefer a different method, select Try Another Method to choose one of the following

options:

SMS (preferred)

Authenticator (or similar)

Email

NOTE: MFA does not apply to the Sandbox environment.

https://sys.fispan.live/login


Authentication Methods

Setting Up SMS MFA

The first time you log in to the Production environment, you will be prompted to establish

your Multi-factor Authentication (MFA) setup. You have the option to select various

methods of MFA. 

1 Enroll Phone Number

Select your country code then enter your phone number, you will receive a text

message with a 6-digit code via SMS to the phone number you provided for

enrollment.

If you are unable to receive a text message to this number, or you prefer a different

multi-factor authentication method, click Try Another Method. 

NOTE: Multi-factor Authentication (MFA) is only required if you are a user in the

Production environment. If accessing the Sandbox environment, you may skip this

step.
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3

Enter Code

Enter the 6-digit code you received in the applicable field.

Select Continue.

6-digit Verification

Save Recovery Code

After setting up SMS and inputting the first one-time code, you will be presented with

a recovery code that should be stored in a safe location. This code is for resetting the

MFA, to switch the MFA type (i.e., Authenticator), or to use a different phone number. 



Recovery Code

Setting Up Authenticator MFA

If you would like to use an authenticator application for MFA, follow these steps.

1

2

Set Up Authentication App

Download and install a compatible app, such as Auth0 Guardian App ( , )

or , on your mobile device and complete setup.

iOS Android

Google Authenticator

Verify Your Identity

Go into the Auth0 or Google Authenticator app to view your temporary verification

code. 

Enter the code from the app into the field on your screen and select Continue.

https://apps.apple.com/us/app/auth0-guardian/id1093447833
https://play.google.com/store/apps/details?id=com.auth0.guardian
https://support.google.com/accounts/answer/1066447?hl=en&co=GENIE.Platform%3DAndroid


Authenticator

Setting Up Email MFA

Follow these steps to set up Email MFA and verify your identity. 

1

2

3

Enter Email

Add the email address where you would like to receive your authentication code.

Check Inbox

Navigate to your email inbox to retrieve the 6-digit verification code sent to you.

Verify Your Identity

Return to this screen, enter the code, and select Continue.



Email Authentication



2.2.2. Mapping Bank Accounts (NetSuite)

Navigating to the Account Matching Page

Once you’ve completed the plugin installation and setup, you’ll need to map any new

accounts that are added to the plugin. If you’re setting up the plugin for the first time, you

will have completed this during Step 11: Plugin Access Management.

1 Log in to the FISPAN Portal

Head to the   you used to register for an account with  when

you installed the plugin.

Production Portal FISPAN

Welcome Page

Log in to the Portal with the email and password you used to register. Multi-Factor

Authentication (MFA) will be required for login.

NOTE: Setting up in Sandbox? Use this alternative link instead: Sandbox Portal

https://sys.fispan.live/login
https://sandbox.fispan.cloud/
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FISPAN Login

Navigate to Associate Accounts

Select the three dots in the top right corner of your ERP module and select Associate

Accounts.

Select Associate Accounts



Each ERP account should have a matching bank account. Only the matched accounts will

be used in your plugin. 

Follow these steps to learn how to match your ERP accounts with the corresponding bank

accounts.

Account Matching Setup

Match your ERP Accounts with the corresponding Bank Accounts by dragging an ERP

Account from the left and dropping it onto the desired Bank Account. 

Once you've successfully matched your accounts, click Next Step.

IMPORTANT: The Use Account Numbers preference must be enabled in NetSuite to

match your bank accounts.

To do this:

In NetSuite, go to Setup -> Accounting -> Accounting Preferences.

On the General Ledger tab, check the box next to Use Account Numbers.

After enabling this, click the X in the error banner on this page to reload your

accounts.

If you receive an error during account matching after the feature is enabled, please

contact  Support for further assistance.Goldman Sachs

NOTE: When installing the plugin in Sandbox, bank accounts are for testing only.

They are not connected to your live bank accounts. When installing in Production, the

listed bank accounts reflect your actual accounts.



Account Matching Step

For virtual card payments (if applicable), you will need to map the bank account to a Credit

Card type NetSuite account, not a NetSuite bank account.

Account Matching Error Troubleshooting

IMPORTANT: It might take a few moments for your accounts to appear, depending on

the number of accounts you have and how quickly NetSuite is processing them.

Please do not refresh or leave the page until everything has loaded.

NOTE: If you would like to add new accounts or functionalities after your initial

installation and set-up, please submit a request to your .TxB Representative

TIP: Would you like to set a default account for Account Payables? Let us know which

account you'd like by contacting . Please specify the last 4 digits

of the bank account number in your request. Each company can have only one

default source account across all subsidiaries. 

TxB Representative



NetSuite will load your ERP accounts from the Chart of Accounts. Depending on the

number of accounts you have or your device's security settings, you might see the

following error:

"There was an error loading the bank accounts: Close this to retry!"

If this error appears, click the X to retry loading the accounts.

If you see the error again, click Next Step and finish the rest of the installation wizard.

If you are still unable to load the accounts, our support team can manually map them for

you. To do this, please provide us with the Internal ID from NetSuite.

Provide NetSuite Internal ID 

1 Search Accounts

In NetSuite, go to Lists → Accounting → Accounts → Search

Go to Search

Select Use Advanced Search.
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Select Use Advanced Search

Under the Criteria tab, in the filter box, select Type and choose Bank (and/or Credit

Card if matching for SUA payments). Then select Set.

Select Bank and Credit Card from Type Drop-down

Filter Results with Internal ID
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Under the Results tab, remove all but the Name, Account Type,

and Description fields, then add the field Internal ID.

Add Internal ID

Once complete, select Submit.

Download XLS Format

On the Account Search: Results page, please select the Microsoft Excel icon to

download this list in an XLS format.



Download XLS

Once the download is complete, please open the XLS file and add a column with the

last 4 digits of the Account the Internal ID should be mapped to. 

Save this XLS file, and you can contact  to help you troubleshoot. TxB Representative

Once you’ve added this information, please email this updated XLS file to the below

TxB Client Services email address: txb-client-service@gs.com

The FISPAN Support Team will then map the accounts on your behalf and will follow-

up by email once complete.

mailto:txb-client-service@gs.com


2.2.3. Minimum Permissions (NetSuite)

To use the plugin, you'll need to set up two types of users: a Web Service User and an A/P

(Accounts Payable) and/or Accounting User.

Web Service User

This is a generic role designed for accessing and interacting with web services, including

your bank plugin in NetSuite. It requires assigning the Bank Integration Web Service Role,

to which access tokens are attached for both the Web Service User and the role itself.

While some users choose to assign the Bank Integration Web Service Role directly to a

specific person, this creates a risk: if that user loses their NetSuite access or leaves the

company, the access tokens will become void. To avoid this, we recommend creating a

dedicated Web Services User and assigning the Bank Integration Web Service Role and

tokens to them. This significantly reduces the risk of service disruption.

A/P (Accounts Payable) and/or Accounting User Role

This is the role for users who will be performing various plugin functions, such as Vendor

Payments, Positive Pay, Cash Management, and Book Transfers.

Configure User Role

To configure the appropriate role, navigate to Setup -> Users/Roles -> Manage Roles.  



Then, click Edit for the existing role you would like to set up, or click New Role to create a

new one.

See the section below for the minimum permissions required for each role. 

Bank Integration Web Service Role



Permission

Sub-tab

Permission Level Detail

Transactions Find Transaction View (or

higher)

Required to void erroneous payments

Transactions Make Journal

Entry

Create (or

higher)

Required to void erroneous payments

Transactions Pay Bills View (or

higher)

Required to void erroneous payments

Lists Accounts View (or

higher)

Required to load accounts in the

installation wizard for matching

Lists Documents and

Files

View (or

higher)

Required to access plugin pages

Setup Access Token

Management

Full Required to create and manage access

tokens

Setup Log in Using

Access Tokens

Full Required to generate an Access Token

Setup SuiteScript View (or

higher)

Required to access custom scripts

Setup SuiteScript

Scheduling

Full Required to schedule payments

A/P and/or Accountant User Role



Permi

ssion

Type

Permis

sion

Level Detail

Custo

m

Recor

d

Entity

Bank

Details

(FI)

View

(or

highe

r)

Required to view vendor banking information on the Vendor

record and within the Entity Bank Details Overview page

Lists Docum

ents

and

Files

View

(or

highe

r)

Required to access plugin pages

Lists Accou

nts

View

(or

highe

r)

Required to view accounts for various plugin functions

Lists Curren

cy

View

(or

highe

r)

Required to view currencies for various plugin functions

Lists Vendor

s

View

(or

highe

r)

Required to load vendors' bills on the plugin Account Payables

pages

Lists Employ

ee

Record

View

(or

highe

r)

Required to access Vendor Bill Payments history/Expense

Reimbursement reports pages

Lists Custo

mers

View

(or

highe

r)

Required to load the Positive Pay page of the plugin

Lists Subsidi

aries

View

(or

Required to load Subsidiary-related data on the plugin Account

Payables pages to be used as a customizable column or filter



Permi

ssion

Type

Permis

sion

Level Detail

highe

r)

option

Setup SuiteS

cript

View

(or

highe

r)

Required to load plugin pages

Setup SuiteS

cript

Sched

uling

Full Required to schedule payments

Setup Accou

nting

Lists

View

(or

highe

r)

Required to load vendorcategory  data on the plugin Account

Payables pages

Setup Custo

m

Fields

View

(or

highe

r)

Required to load custom fields on plugin Account Payables

pages to be used as a customizable column or filter option

Setup Custo

m Lists

View

(or

highe

r)

Required to load the available payment methods from your

bank on the plugin's Account Payables pages

Setup Set Up

Compa

ny

Full Required for the Entity Bank Details bundle users. Used for the

EBD Settings RESTlet to access the Company Information

page. Optional, but ideal for certain filter options when

Customizing Filters on Pay Vendor Bills page. 

Trans

actio

ns

Bills View

(or

highe

r)

Required to load bills on plugin Account Payables pages



Permi

ssion

Type

Permis

sion

Level Detail

Trans

actio

ns

Find

Transa

ction

View

(or

highe

r)

Required to load bills on plugin Account Payables pages

Trans

actio

ns

Expens

e

Report

s

View

(or

highe

r)

Required to load expense reports on plugin Account Payables

pages

Trans

actio

ns

Pay

Bills

View

(or

highe

r)

Required to load bill payments in Positive Pay page of plugin

Trans

actio

ns

Check View

(or

highe

r)

Required to load checks in Positive Pay page of plugin

Trans

actio

ns

Make

Journa

l Entry

Creat

e (or

highe

r)

Required to transfer funds

Trans

actio

ns

Transf

er

Funds

View

(or

highe

r)

Required to transfer funds



2.2.4.
Storing Vendor Payment Information
(NetSuite)

Our bank plugin works best when paired with the Entity Bank Details (EBD). This allows you

to securely store and manage vendor and employee banking information directly within

NetSuite, supporting a wider range of complex payment types than the native system.

With this feature, you'll be able to:

Store and manage vendor bank details for various payment methods.

Import vendor bank details from a CSV file, making it easy to migrate your existing

data.

Export vendor bank details to a CSV, which is useful for backups or external use.

Migrate any previously stored vendor bank details from NetSuite's Electronic Bank

Payments bundle into the new system via CSV export.

Refer to the following pages for install, setup, and usage guides for the Entity Bank Details

bundle:

Entity Bank Details SuiteApp Installation & Setup (NetSuite)

Viewing Entity Bank Details (NetSuite)

Entity Bank Details Bundle Import/Export (NetSuite)

Update Entity Bank Details Bundle



2.2.5.
Setting Default Payment Information
(NetSuite)

Save time paying bills by setting Vendor Default Payment methods, and choose to group

bills into one lump sum payment for vendors. Follow the steps in this guide to get started.

Method 1: Vendor Record

Go to a Vendor Record and select Edit. Then, select the bank plugin tab in the sub-menu.

Vendor Record

Here you will be able to set the Default Payment Method and enable the option to Group

Bills for Payment.

Method 2: Vendor List

1 Go to Customize View



2

Select Lists → Relationships → Vendors. 

Customize View

Then, select Customize/Edit View.

Add Custom Fields

Add the Default Payment Method (Custom) and Group Bills for Payment

(Custom) fields for your bank to the list. 



3

Vendor Search Results

Then, select Save.

Set Default Payment Method and Group Bills

Toggle the Edit option.

Edit Vendors



Select the blank area under the appropriate columns and select the Default Payment

Method or Bill Grouping option for each vendor.

Set Payment Method

Method 3: CSV Import

This method uses NetSuite's Import CSV functionality to set up default payment

information.

1 Create CSV File 

To begin, first create a CSV file with the following column headers:

Vendor ID

Default Payment Method

Group Bills for Payment

Payables Email Address [OPTIONAL]
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Sample "default_payment_information" CSV file

Populate the CSV file with the relevant Vendor IDs, the desired Default Payment

Methods [YES or NO], and an indication of whether or not you wish to Group Bills for

Payment [YES or NO]. 

Once complete, save the file and name it—we suggest using

"default_payment_information."

Upload CSV File

Then, head into NetSuite and navigate to Setup → Import/Export → Import

CSV Records.

NOTE: The Vendor ID is the field on the vendor record itself, not the internal

NetSuite ID.



Navigate to Import CSV

Set the Import Type to Relationships and the Record Type to Vendors.

Import CSV

Then select the CSV file you have created and select Next.
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Select Import Options

Select Update as the Import Option, then select Next.

Map Fields 

Map the fields as per the example below. 

Sample field mapping
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Select Next.

Import

Select Save & Run or Run to initiate the import.



2.2.6. Updating the SuiteApp (NetSuite)

Keeping your NetSuite SuiteApp up to date with the latest version is crucial for ensuring

you have access to all the newest features, important bug fixes, and updates. To update

your bundle, please follow these steps.

Locate the SuiteApp

Go to Customization → SuiteCloud Development → Installed SuiteApp List.

Go to Customization -> SuiteCloud Development -> Installed SuiteApp List

Update the SuiteApp

TIP: To read more about the latest release, navigate to: Release Notes (NetSuite)



Find the   SuiteApp from the list. Then, hover over the green icon and

select Update.﻿

Goldman Sachs

Select OK on the confirmation pop-up.﻿

The SuiteApp will take a few moments to update – it will appear as Pending and then show

the progress of the update. Once complete, the status column on the Installed SuiteApp

page will show a checkmark.



2.2.7. Uninstalling the Plugin (NetSuite)

To uninstall the plugin from your NetSuite ERP, follow these steps.

1

2

Deactivate the Plugin

Select the three dots in the top right corner and then select Deactivate to disconnect

your plugin from NetSuite through the .Portal

Select "Deactivate"

Search Installed SuiteApp

In NetSuite, go to Customization → SuiteCloud Development → Installed SuiteApp

List

https://sys.fispan.live/
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Installed SuiteApp List

Locate Installed SuiteApp

Select the green dropdown button and select Uninstall to uninstall the 

 SuiteApp. Then, select OK on the pop-up to confirm.My Bank SuiteApp

Click Uninstall



4 Finalize Uninstalling the SuiteApp

NetSuite will begin uninstalling the SuiteApp. Once uninstalled, it will no longer

appear on the page and menu bar. 

You've successfully disconnected your NetSuite environment and completely

removed the plugin.



2.2.8. Managing Security Tokens (NetSuite)

The Access Token is essential for pushing payment status messages (processing,

successful, or failed) back into NetSuite. This token is created during the initial installation

wizard and is linked to the NetSuite administrator who performed the setup.

If the original NetSuite administrator leaves the company or has their account or privileges

revoked, the associated Access Token immediately becomes VOID. When this happens,

you will lose all automatic payment status updates from the payment plugin, which can

lead to confusion and operational issues.

This guide provides the steps to generate a new Access Token to replace the voided one,

ensuring that payment statuses flow correctly back into your NetSuite environment.

If you run into trouble, you can schedule a troubleshooting call or reach out to our support

team using the Contact Us link in the library on the left.

Reactivate the NetSuite Connection

1 Log in to FISPAN Portal

Log in to  using one of these links:FISPAN Portal

Production: https://sys.fispan.live/login

Sandbox: https://sandbox.fispan.cloud/login

https://sys.fispan.live/login
https://sandbox.fispan.cloud/login
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Portal Login Page

If you do not have a login, please contact the bank's Support team. We will issue you

an invitation to enable you to configure the NetSuite connection. 

Deactivate the NetSuite Connection

Upon successful login, you should see a welcome message and NetSuite under the

Connected Apps section.



NetSuite message box with Icons listing the Connected Apps

Click on the three dots on the top right corner of the NetSuite box to open a small

submenu, and then click on Deactivate.

Click "Deactivate" on NetSuite
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After clicking Deactivate, a pop-up will appear onscreen prompting you to confirm

the action. Click Yes, Uninstall App to proceed.

Click "Yes, Uninstall App"

After clicking Yes, Uninstall App, NetSuite will disappear from the Connected Apps

section of the page and appear in the Discover More section. 

Reactivate the NetSuite Connection

Hover your cursor over the NetSuite box and click on the Install button.
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NetSuite message box with Icons listing connected apps and others grouped under

Discover More

Click "Install"

Proceed through the Installation Wizard steps

After clicking Install, you will be taken to the installation wizard.



Welcome to the plugin installation wizard!

The installation wizard has retained all information from the last time the setup was

completed. As a result, you may skip to the Creating a New Security Token step by

clicking the Next Step button.

Create a New Security Token

On the Creating a New Security Token step, the old Token ID and Token Secret created by

the last NetSuite Administrator have been retained. These two fields must be replaced as

they have become void.



"Creating a New Security Token" page

Create a New Security Token

1 Navigate to Manage Access Tokens

In NetSuite, navigate to the homepage.

Find Settings and select Manage Access Tokens. 
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Select Manage Access Tokens on Settings

Where the Settings are located differs depending on how you have arranged content

on your homepage. By default, it is found on the bottom left of the page.

Add New My Access Token

On the My Access Tokens page, select the New My Access Token button.



Access Tokens

On the Access Tokens page, the application must be defined using the Application

Name dropdown. The application for your bank plugin was created automatically

when the plugin was installed.

Use Application Name Drop-down



Select New My Access Token, then select Goldman Sachs Integration in the Application

Name box and click Save. Once you click Save, the loaded page will show a Token Key

and a Token Secret. Copy and paste the Token ID and Token Secret to the appropriate box

in the wizard.

Once complete, select Next Step in the Wizard.

Save Access Token

Verify the Connection Status

The next step in the installation is a Connection Status check. If the Token ID and Token

Secret entered in the installation wizard are correct, the status will show a green

checkmark icon and a success message indicating the connection is now active.



Green circle with white check mark

Click Next Step to complete the remainder of the installation wizard.

Save and Finish the Installation Wizard

The next page is the Account Matching page. All matching has remained unchanged since

the last time a NetSuite Administrator or someone from your organization has edited it. You

can make any changes, if required.



Account Matching Step

Click Save and Finish to save all changes made in this installation wizard and to exit.

Your security tokens have now been updated.



2.2.9.Entity Bank Details

2.2.9.1. Entity Bank Details for NetSuite

The Entity Bank Details (EBD) SuiteApp is designed to securely store and manage detailed

banking information for both vendors and employees directly within NetSuite, supporting a

wider range of complex payment types.

After you install the SuiteApp, you can add or view vendor payment information by going to

Setup -> Entity Bank Details -> Overview.

To get started, follow the instructions in this article: Entity Bank Details SuiteApp

Installation & Setup (NetSuite)

IMPORTANT: All vendor and employee bank details and history logs are stored in

your NetSuite environment. Be sure to regularly export your Entity Bank Detail

records and history logs to prevent data loss, such as what would happen if the 

SuiteApp were uninstalled.

Uninstalling the Entity Bank Details SuiteApp will permanently delete all data. Always

use the export feature on the Import/Export page to back up your data before

uninstalling.



2.2.9.2.
Entity Bank Details SuiteApp
Installation & Setup (NetSuite)

The Entity Bank Details (EBD) SuiteApp, combined with the standard NetSuite vendor and

employee records, will store all the information needed to submit payments.

You can add or view this vendor payment information after installation by going to Setup --

> Entity Bank Details -> Overview.

Entity Bank Details (EBD) Installation Instructions

1 Install Entity Bank Details SuiteApp

From the homepage, go to Customization → SuiteCloud Development → SuiteApp

Marketplace.

Go to SuiteApp Marketplace

NOTE: If you do not have Accounts Payable installed, please skip this step.



Search for Entity Bank Details. Select the SuiteApp tile named, Entity Bank Details.

Click on Entity Bank Details Tile

Click Install to review the SuiteApp, then select Install again to confirm.

Click Install



2 Manage SuiteApp Access - Suitelets

The administrator has full access to the Entity Bank Details SuiteApp. To allow access

to other users and departments, follow these steps:

Go to Customization → Scripting → Script Deployments.

Go to Script Deployments

On the Script Deployments page, apply the following filters:

In the Type dropdown, select Suitelet

In the API Version dropdown, select 2.1

A Suitelet is a custom front-end NetSuite page. Each of the Suitelets listed

corresponds to a page in the Entity Bank Details SuiteApp. 



Filter for Suitelets on API Version 2.1

Select Edit on each of the following Suitelets you wish to edit:



3

Suitelet Description

Entity Bank

Details,

Overview

Granting users access to this script allows them to view the

Overview page. This permission, along with the Entity Bank

Details, Settings RESTlet, is required to access the Overview

page.

Entity Bank

Details,

Import/Exp

ort

Granting users access to this script will allow them to view the

Import/Export page.

Entity Bank

Details,

History

Granting users access to this script will allow them to view the

History page.

Entity Bank

Details,

Settings

Granting users access to this script will allow them to view the

Settings page to enable and disable approvals.

Entity Bank

Details,

Approvals

Granting users access to this script will allow them to view the

Approvals page to approve record changes.

Add employee roles by selecting the appropriate employee, department, and/or role

you would like to assign. 

Then, select Save. 

Stay on this page for the next steps.

Manage SuiteApp Access - RESTlets

On the Script Deployments page, apply the following filters:

In the Type dropdown, select RESTlet.

In the API Version dropdown, select 2.1.

A RESTlet is used to define custom RESTful integrations to NetSuite, and in the

context of the Entity Bank Details SuiteApp, is mainly used for handling the import

and export processes.



Select Edit on the the Script Deployment

Select Edit on each of the following script deployment RESTlets you wish to edit:
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RESTlet Description

Entity

Bank

Details,

Import

Service

Granting users access to this script will allow them to import a

CSV of bank account information into the Entity Bank Details

SuiteApp.

Entity

Bank

Details,

Export

Service

Granting users access to this script will allow them to export a

CSV of bank account information from the Entity Bank Details

SuiteApp.

Entity

Bank

Details,

History

Log

Export

Granting users access to this script will allow them to export a

CSV History Log of all changes made to any records stored within

the Entity Bank Details SuiteApp. This history log tracks any edits,

additions, or deletions, as well as who initiated the change and

when.

Entity

Bank

Details,

Settings

This RESTlet should come with pre-enabled access for all roles.

Granting users access to this script will allow them to view the

Overview page. This permission, alongside the Entity Bank

Details, Overview Suitelet, is required to access the Overview

page.

Entity

Bank

Details,

Analytics

This RESTlet should also come with pre-enabled access for all

roles.

Add employee roles by selecting the appropriate employee, department, and/or role

you would like to assign. 

Then, select Save.

Manage SuiteApp Access - User Events

On the Script Deployments page, apply the following filters:



On the Type dropdown, select User Event.

On the API Version dropdown, select 2.1.

A User Event is a type of script that is executed when someone performs certain

actions on records, such as create, load, update, copy, delete, or submit.

Filtering for User Events on API Version 2.1

Select Edit next to the Script Deployment User Event:

User Event Description

Entity Bank

Details, Event 

(Record Type =

Vendor)

This User Event script allows users/roles to add or update

Vendor Bank Account information.

Entity Bank

Details, Event

(Record Type =

Employee)

This User Event script allows users/roles to add or update

Employee Bank Account information.

Add employee roles by selecting the appropriate employee, department, and/or role

you would like to assign. 
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Then, select Save.

Manage SuiteApp Access - Custom Records

Go to Setup → Users/Roles → Manage Roles.

Then, select Edit for the role for which you would like to grant access to the Entity

Bank Details SuiteApp records.

Go to Manage Roles

After selecting Edit, go to the Permissions tab → Custom Record → Locate the

search box in the bottom row. 

NOTE: The owner of the custom record, which defaults to the user who

installed the Entity Bank Details SuiteApp, will always have full access to the

record regardless of the Entity Bank Details permission level assigned to the

role being used.



Search and Select Entity Bank Details

Use the search box to find and set the correct permission level for Entity Bank

Details (FI) (Level: View):

View: Allows a user to view records.

Create: Allows a user to view and create records.

Edit: Allows a user to view, create, and edit records.

Full: Allows a user to view, create, edit, approve, and delete records. This

permission level is required to approve any changes made to vendor or

employee records.

Next, navigate to the Permissions tab → Setup → Locate the search box in the

bottom row. 

Use the search box to find and set the permission: 

Set Up Company (Level: View): Required for the Overview page and is used for

the EBD Settings RESTlet to access the Company Information page.

Within the Permissions tab, select Lists --> Locate the search box in the bottom row. 

Use the search box to find the following permission: 
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Employees (Level: View): Required to approve or view the History page for

employee records.

Then, select Save.

Storing Bank Information

Using the main navigation, go to Setup → Entity Bank Details → Overview.

Select between viewing Vendors or Employees by selecting the tabs above the table.

By default, this page opens up to show Vendors first.

Select View for the desired Vendor or Employee.

Select View for the desired Vendor or Employee

Select Add.



Select Add

Create an optional label and select the appropriate payment method, country, and

currency. Then, fill out the required fields for the specified payment method and

mark the record as Primary. 

Select Save



Then, select Save.

The Entity Bank Details (EBD) bundle, combined with the standard NetSuite vendor and

employee records, will store all the information needed to submit payments.

You can add or view this vendor payment information after installation by going to Setup --

> Entity Bank Details -> Overview.

Entity Bank Details (EBD) Installation Instructions

1 Install Entity Bank Details Bundle

From the homepage, go to Customization → SuiteBundler → Search and Install

Bundles.

NOTE: The fields that appear on this page are dependent on the method,

country, and currency selected.

WARNING: All vendor and employee bank details, along with all history logs, are

stored within the Entity Bank Details SuiteApp in your NetSuite environment. If this

SuiteApp is uninstalled, all of this data will be permanently deleted.

To prevent data loss, you must export your data before uninstalling. Please use the

Export feature on the Import/Export page to save all your records and history logs.

This is outlined in the Entity Bank Details SuiteApp Import/Export (NetSuite) page.

NOTE: If you do not have Accounts Payable installed, please skip this step.



Go to Search & Install Bundles

Search for Entity Bank Details or by Bundle ID 323878. Select the hyperlinked

bundle name, Entity Bank Details.

Entity Bank Details bundle

Select Install to review the bundle, then select Install again to confirm.
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Install Bundle page

Select OK when the dialog appears and wait for the bundle to install (this may take a

few moments). 

Manage Bundle Access - Suitelets

The administrator has full access to the Entity Bank Details bundle. To allow access

to other users and departments, follow these steps:

Go to Customization → Scripting → Script Deployments.

IMPORTANT: If you receive an error stating "You have not been granted access

to the bundle" upon attempting installation, please reach out to 

. TxB Representative

Our team may need to whitelist your NetSuite Account ID before you are able to

install the Entity Bank Details bundle. Your Account ID can be found by

navigating to Setup → Company → Company Information.



Go to Script Deployments

On the Script Deployments page, apply the following filters:

In the Type dropdown, select Suitelet

In the API Version dropdown, select 2.1

A Suitelet is a custom front-end NetSuite page. Each of the Suitelets listed

corresponds to a page in the Entity Bank Details bundle. 

Select Edit on each of the following Suitelets you wish to edit:



Suitelet Description

Entity Bank

Details,

Overview

Granting users access to this script allows them to view the

Overview page. This permission, along with the Entity Bank

Details, Settings RESTlet, is required to access the Overview

page.

Entity Bank

Details,

Import/Exp

ort

Granting users access to this script will allow them to view the

Import/Export page.

Entity Bank

Details,

History

Granting users access to this script will allow them to view the

History page.

Entity Bank

Details,

Settings

Granting users access to this script will allow them to view the

Settings page to enable and disable approvals.

Entity Bank

Details,

Approvals

Granting users access to this script will allow them to view the

Approvals page to approve record changes.

Add employee roles by selecting the appropriate employee, department, and/or role

you would like to assign. 
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Filter for Suitelets on API Version 2.1

Then, select Save. 

Stay on this page for the next steps.

Manage Bundle Access - RESTlets

On the Script Deployments page, apply the following filters:

In the Type dropdown, select RESTlet.

In the API Version dropdown, select 2.1.

A RESTlet is used to define custom RESTful integrations to NetSuite, and in the

context of the Entity Bank Details bundle, is mainly used for handling the import and

export processes.

Select Edit on each of the following script deployment RESTlets you wish to edit:



RESTlet Description

Entity

Bank

Details,

Import

Service

Granting users access to this script will allow them to import a

CSV of bank account information into the Entity Bank Details

bundle.

Entity

Bank

Details,

Export

Service

Granting users access to this script will allow them to export a

CSV of bank account information from the Entity Bank Details

bundle.

Entity

Bank

Details,

History

Log

Export

Granting users access to this script will allow them to export a

CSV History Log of all changes made to any records stored within

the Entity Bank Details bundle. This history log tracks any edits,

additions, or deletions, as well as who initiated the change and

when.

Entity

Bank

Details,

Settings

This RESTlet should come with pre-enabled access for all roles.

Granting users access to this script will allow them to view the

Overview page. This permission, alongside the Entity Bank

Details, Overview Suitelet, is required to access the Overview

page.

Entity

Bank

Details,

Analytics

This RESTlet should also come with pre-enabled access for all

roles.

Add employee roles by selecting the appropriate employee, department, and/or role

you would like to assign. 
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Select Edit on the the Script Deployment

Then, select Save.

Manage Bundle Access - User Events

On the Script Deployments page, apply the following filters:

On the Type dropdown, select User Event.

On the API Version dropdown, select 2.1.

A User Event is a type of script that is executed when someone performs certain

actions on records, such as create, load, update, copy, delete, or submit.

Select Edit next to the Script Deployment User Event:
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User Event Description

Entity Bank

Details, Event 

(Record Type =

Vendor)

This User Event script allows users/roles to add or update

Vendor Bank Account information.

Entity Bank

Details, Event

(Record Type =

Employee)

This User Event script allows users/roles to add or update

Employee Bank Account information.

Add employee roles by selecting the appropriate employee, department, and/or role

you would like to assign. 

Filtering for User Events on API Version 2.1

Then, select Save.

Manage Bundle Access - Custom Records

Go to Setup → Users/Roles → Manage Roles.

Then, select Edit for the role for which you would like to grant access to the Entity

Bank Details bundle records.



Go to Manage Roles

After selecting Edit, go to the Permissions tab → Custom Record → Locate the

search box in the bottom row. 

NOTE: The owner of the custom record, which defaults to the user who

installed the Entity Bank Details bundle, will always have full access to the

record regardless of the Entity Bank Details permission level assigned to the

role being used.



Search and Select Entity Bank Details

Use the search box to find and set the correct permission level for Entity Bank

Details (FI) (Level: View):

View: Allows a user to view records.

Create: Allows a user to view and create records.

Edit: Allows a user to view, create, and edit records.

Full: Allows a user to view, create, edit, approve, and delete records. This

permission level is required to approve any changes made to vendor or

employee records.

Next, navigate to the Permissions tab → Setup → Locate the search box in the

bottom row. 

Use the search box to find and set the permission: 

Set Up Company (Level: View): Required for the Overview page and is used for

the EBD Settings RESTlet to access the Company Information page.

Within the Permissions tab, select Lists --> Locate the search box in the bottom row. 

Use the search box to find the following permission: 
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Employees (Level: View): Required to approve or view the History page for

employee records.

Then, select Save.

Storing Bank Information

Using the main navigation, go to Setup → Entity Bank Details → Overview.

Select between viewing Vendors or Employees by selecting the tabs above the table.

By default, this page opens up to show Vendors first.

Select View for the desired Vendor or Employee.

Select View for the desired Vendor or Employee

Select Add.



Select Add

Create an optional label and select the appropriate payment method, country, and

currency. Then, fill out the required fields for the specified payment method and

mark the record as Primary. 

Select Save



Then, select Save.

Defining View-only Access to EBD

Following the steps below will provide users with view-only access to Entity Bank Detail

records with no ability to add, edit, or delete.

1

2

User Permissions Setup

Go to Setup → Users/Roles → Manage Roles.

Select Edit for the role for which you would like to grant access to the Entity Bank

Details SuiteApp records.

Go to the Permissions tab → Setup → Locate the search box in the bottom row. Use

the search box to find the following permission:

Set Up Company (Level: View): Required for the Overview page and is used for

the EBD Settings RESTlet to access the Company Information page. 

Select Save.

Assign EBD Record Type

Navigate to Customization → Lists, Records, & Fields → Record Types

Under the EDIT column, select Entity Bank Details (FI)

( custom_record_vendor_bank_details )

NOTE: The fields that appear on this page are dependent on the method,

country, and currency selected.

WARNING: All vendor and employee bank details, along with all history logs, are

stored within the Entity Bank Details bundle in your NetSuite environment. If this

bundle is uninstalled, all of this data will be permanently deleted.

To prevent data loss, you must export your data before uninstalling. Please use the

Export feature on the Import/Export page to save all your records and history logs.



Custom Record Types

On the Custom Record Type page that opens up, select the Permissions tab. Here,

you can define which roles can have Full or View access.

Select the role of your choice, and then assign View as the access level on the Level

column.
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Define "View" level permissions on a Role of your choice

Select Save.

Assign EBD Overview Script

Next, navigate to Customization → Scripting → Script Deployments.

Filter for Suitelets on API Version 2.1



4

Apply the following filters and parameters:

On the Type drop-down, select Suitelet

On the API Version drop-down, select 2.1.

Select Edit beside Entity Bank Details, Overview

( customdeploy_fispan_vbd_overview )

Under the Audience tab, select any number of roles, subsidiaries, employees,

departments, groups, or partners that require access

Select Save, and return to the Script Deployments page.

Locate EBD Event Scripts

Navigate to Customization → Scripting → Script Deployments

Apply the following filters and parameters:

On the Type drop-down, select User Event

On the API Version drop-down, select 2.1.

Filtering for User Events on API Version 2.1
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6

Assign Access to Vendor Bank Details

Limit a user's access to only view the Vendor's bank details with the Entity Bank

Details, Event ( customdeploy_fispan_vbd_event ) script.

Select Edit beside Entity Bank Details, Event ( customdeploy_fispan_vbd_event ).

Under the Audience tab, select any number of roles, subsidiaries, employees,

departments, groups, or partners that require access.

Select Save.

Assign Access to Employee Bank Details

Limit a user's access to only view an Employee's bank details with the Entity Bank

Details, Event ( customdeploy_fispan_vbd_event_emp ) script.

Select “Edit” beside Entity Bank Details, Event

( customdeploy_fispan_vbd_event_emp ).

Under the Audience tab, select any number of roles, subsidiaries, employees,

departments, groups, or partners that require access.

Select Save.

IMPORTANT: View-only access is not available for NetSuite users who have more

than one role defined, like a user with both the Administrator and AP Clerk roles.

This is a limitation within NetSuite itself.



2.2.9.3. Viewing Entity Bank Details (NetSuite)

View the Vendor or Employee bank detail records in the Entity Bank Details (EBD) SuiteApp

on the Overview page. Additionally, you can view or export all the changes taken on the

Entity Bank Details SuiteApp in the History page.

Overview Page

The Overview page is your central hub for all vendor and employee bank detail records

stored in the EBD SuiteApp. To see a list of all vendors or employees on your NetSuite

account, simply navigate between the Vendors and Employees tabs. The page will default

to the Vendors tab when you first open it.

For both Vendor and Employee tabs, the page displays all vendors/employees on this

NetSuite company with the following columns:

# (ID assigned by EBD)

View (Links to vendor or employee record)

Vendor or Employee Name

Email (Primary email on vendor or employee record)

Internal ID (Native NetSuite’s vendor or employee ID)

Total Records (Number of EBD records stored by this vendor or employee)

1 Navigate to the Overview Page

Go to Setup -> Entity Bank Details -> Overview
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Go to Entity Bank Details Overview

View Vendor Bank Details

Click into Vendors to view an overview of Vendor Bank Details.

Entity Bank Details Overview page - Vendors tab



3 View Employee Bank Details

Click into Employees to view an overview of Vendor Bank Details.

Entity Bank Details Overview - Employees tab

Adding Vendor Bank Account Information

From the Vendor tab in the Overview page, you will be able to view and edit a Vendor's

bank account information. 

1 Select Vendor

Click on a Vendor you would like to add information for. 
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Click View EBD Record

Add Vendor Bank Details

You can fill in the required fields for your desired payment rail. By default, the

payment method is set to Domestic and the United States. 

Add Vendor Bank Information



For international payments, change the Method to International. 

Change the Method to International

To include information for an intermediary bank, simply toggle on Intermediary Bank

Information. An intermediary bank is used for international payments to countries

where your bank doesn't have a direct relationship.



Once enabled, you can now add Intermediary Bank Account information. 

Enter Intermediary Bank Account Information

After you have added all required information, please click Save Vendor Bank

Details.

History Page

The History page shows a table of all actions taken on the EBD SuiteApp for every vendor

and employee. It allows you to filter logs by date and export them based on a defined date

range. By default, the page displays vendor history, but you can switch to the Employees

tab to see updates to employee records.

The table contains the following columns:

Modified

# (ID assigned by EBD, refer to Overview page)

Vendor

Type of Change (Added, Updated, or Deleted)



User

Reviewed By

Source (UI or Import)

Status (Approved or Rejected)

Actions

1

2

Navigate to the History Page

Go to Setup → Entity Bank Details → History

Navigate to Entity Bank Details History

View Vendor History

Click into Vendors to view all history logs for changes made to Vendors' Bank

Details.
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Vendor View

View Employee History

Click into Employees to view all history logs for changes made to Employees' Bank

Details.

Employee View



4 View Changes

Click View Details on any of the logs to see the changes in detail.

Columns for Attribute, Before Changes, and After Changes appear in the View

Details pop-up for both vendors and employees.

View Changes Made

Text in red with a strikethrough under Before Changes shows the field's previous

value, while text in green under After Changes shows the new value. The specific

fields displayed depend on the Country, Currency, and Method defined, as well as

the type of change made to the EBD record.

Exporting History Logs

Users are also able to export history logs on the EBD History page for audit purposes.
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2

3

Navigate to the History Page

Go to Setup → Entity Bank Details → History

Export History Logs

Select the Export button to trigger a CSV download.

Export button highlighted in RED

The CSV export feature will only export logs that fall within the defined date range in

the date filter. If no date range is filtered, the export will pull all logs from when EBD

was first installed.

History CSV Export Columns

The exported History CSV file includes the following columns:

IMPORTANT: All Entity Bank Details for both Vendors and Employees, alongside all

History logs, are stored in your NetSuite environment. To prevent potential data loss,

such as from uninstalling the SuiteApp, make sure you regularly export your Entity

Bank Detail records and History logs. 



Log ID: The unique ID for the history log entry.

EBD ID: The ID of the Entity Bank Details record.

Modified On: The date and time the change was made.

Vendor ID: The ID of the vendor associated with the change.

Vendor: The name of the vendor.

Type of Change: The action that was taken (Updated, Added, or Deleted).

User: The name of the user who initiated the change.

User ID: The user ID of the person who initiated the change.

Reviewed By: The name of the user who approved or rejected the change.

Reviewed On: The time the change was approved or rejected.

Status: The final status of the change (Approved or Rejected).

Previous Entry: The state of the record before the change. This column is empty

if a new record was added. Intermediary bank account information is also

included.

Proposed Entry: The proposed change. If the entry was approved, this is the

change that was accepted. If the entry was rejected, this is the change that was

proposed. Intermediary bank account information is also included.

Reason for Rejection: The reason the change was rejected. This column is

empty if the record was approved.

NOTE: These columns will appear in the report whether or not Vendor Payment

Approvals are enabled.



2.2.9.4.
Entity Bank Details Bundle
Import/Export (NetSuite)

The Entity Bank Details (EBD) SuiteApp integrates with the standard NetSuite Vendor

Record to securely house all necessary information for submitting payments. Once

installed, imported vendor and employee data are accessible via Setup → Entity Bank

Details → Overview. Learn how to import, export, and update EBD for both vendors and

employees in this guide.

The process for importing and exporting records on the Vendor and Employee tabs is the

same. The only difference is on the Vendor tab, which offers a specialized export utility for

users with NetSuite’s Electronic Bank Payments bundle, allowing them to conveniently

transfer and re-upload data into EBD.

Import Entity Bank Data

The process for importing EBD data is the same for both Vendor Records and Employee

Records.

1 Go to the Import/Export Tab

Go to Setup → Entity Bank Details → Import/Export
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Go to Import/Export

Import CSV template

Select Template to download a blank CSV template. Use this CSV to fill out Bank

Details for bulk upload.
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Import Data section. Click on the Download Template button to get a blank CSV

Format and Fill Out CSV

Please see the Field Requirements for CSV section of this page for a table

containing all formatting requirements for the CSV file.

Upload the Formatted CSV

In the same Import/Export screen, upload the formatted CSV document.

NOTE: Use this feature only to create new records. To update existing records,

you must use the Export CSV feature, as it includes the necessary ID column,

which is missing from the blank CSV template.

NOTE: Confirm that you use the IBAN country code (e.g., CA).

TIP: Have leading zeroes in your data? Apostrophes ['] in front of any leading

zeroes or formatting cells as "plain text" will keep leading zeroes in Microsoft

Excel or Google Sheets, but NOT Apple Numbers.



Confirm successful upload by checking the Import Logs to ensure all records were

uploaded successfully.

Import Data section

Select Import logs → Execution logs to confirm import completion.

Execution Logs



5 Check Information

Prior to sending payments, check the Entity Bank Details tab of the Vendor Record to

ensure all information is correctly updated.

Export Entity Bank Data

The process for exporting EBD data is the same for both Vendor Records and Employee

Records.

1

2

Go to the Import/Export Tab

Go to Setup → Entity Bank Details → Import/Export

Go to Import/Export

Export CSV template

IMPORTANT: All Entity Bank Details for both vendors and employees, alongside

all history logs, are stored in your NetSuite environment. Please ensure you are

regularly exporting your Entity Bank Detail records and your history logs to

prevent any potential loss, such as through uninstallation of the SuiteApp. 



Click on the Generate Export File button to trigger a CSV download of all records

kept in EBD. 

Export Data section of the Import/Export page

The table will display a history of all exports created, alongside timestamps and

buttons to download each of these files.

Export Logs contains more information about the export files generated. This can be

found under the Execution Log tab. For each line item, it will report who initiated the

export, the number of records exported in the one file, as well as the file name for

that particular export.

Update Existing EBD Records

Use the Import/Export feature to bulk edit existing Entity Bank Details (EBD) for multiple

Employee and Vendor Records at once.

1 Export CSV File

To update existing Entity Bank Details (EBD) records, you must first export a CSV file

of those records.
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The exported CSV file is crucial because it contains a unique ID column. This ID

column is not present in the blank CSV import template and is necessary for the

system to identify and update existing data.

Make edits to the CSV

Using your preferred application (such as Microsoft Excel or Google Sheets), open

the exported CSV file to make your edits. 

EBD Vendor Export CSV opened in Numbers. Note the ID column on the far left

Ensure the ID column on the far left remains untouched.

You can also add new records to the list; simply enter them as a new row at the

bottom of the CSV file. The system will assign an ID to these new records upon

import.

Import the edited Export file

After making edits to the previously exported file, you may now import the CSV file

back into the Entity Bank Details SuiteApp. 



Import Data section. Click "Select a CSV file" or drag-and-drop a CSV file in this

section to import your CSV file

Either Select a CSV file to upload, or drag and drop one into the Import Data section

of the Import/Export page.

Troubleshooting Common Import Issues



Issue Resolution

No success

message appears

in NetSuite after

importing Entity

Bank Data.

Check the import logs directly to verify the import status.

Records were

successfully

created, but

appear

incomplete or

inaccurate.

Records can be created even if they are missing required fields or

have incorrect formatting. Validate the imported records for

accuracy after every upload.

Duplicate bank

records are

created for a

vendor/employee.

This happens if the same records are imported more than once.

Ensure you are importing unique vendor or employee bank accounts

with each import file.

The international

payment method

is incorrectly set

or missing.

When importing, the payment method for all international wire

accounts must be entered as INTERNATIONAL_WIRE in the EBD

template. Additionally, ensure bank accounts for international wire

countries are not set to the DOMESTIC payment method in the

vendor's NetSuite profile.

FAQs

Is it possible to add additional fields?

No. NetSuite does not currently allow the addition of fields to the EBD record.

Why are the Bank Balance and Balance As Of fields in the Match Bank Data page

blank after a successful import?

This is a NetSuite limitation. The system does not populate bank balance information

because it relies on the usage of a Bank Feed, which is not integrated here.



Field Requirements for CSV

Make sure your CSV Import file follows these requirements.

IMPORTANT: Ensure any data with leading zeroes is preceded by an apostrophe '

or formatted as plain text in Microsoft Excel or Google Sheets.

NOTE: If you are using payment methods that require mandatory country codes for

Entity Bank Details, there may be additional columns that must be included in the

import. 

To ensure a successful import, we recommend first manually adding the Entity Bank

Details to the ERP system. Then, download the template; it will already display the

correct columns needed for entering any remaining details.



Name Values Description

id Numeric This is the ID number for this specific record.

This column is not available on the import

template as it is system-generated.

vendor (or

employee)

NetSuite Vendor ID or

Employee ID

Required. The Vendor or Employee ID can be

found in the URL of the Entity Record or on the

EBD Overview page.

label Anything Required. This can be entity or bank details.

This field is used to differentiate the records

when doing mass uploads.

primary YES/NO, Y/N,

TRUE/FALSE, T/F

Required. T = True, F = False. If there are

multiple bank details for a single payment

method on a single vendor being imported,

mark one as T and all others F.

country 2-letter ISO country code

(e.g., US, CA, UK)

Required. Field accepts upper, lower, and

mixed case values.

currency 3-letter currency code

required (e.g., USD, CAD)

Required. Field accepts upper, lower, and

mixed case values.

method DOMESTIC,

INTERNATIONAL_WIRE

Required. Has to be in the same format as it is

case sensitive.

Please use INTERNATIONAL_WIRE for bank

accounts set up for international wire

payments.

Please use DOMESTIC for US/Canada-based

accounts.

bankName Anything

address.lin

e1

Anything -

address.cit

y

Anything -



Name Values Description

address.st

ateProvinc

e

Anything -

address.po

stalCode

Anything -

bic Valid BIC or SWIFT code

for the country and bank

accountTy

pe

CHECKING, SAVINGS Field accepts upper, lower, and mixed case

values.

accountNu

mber

Valid account number for

this bank

localBranc

hCode

Valid branch code for this

bank

Use this field for BSB codes if the country

requires it.

paymentD

efaults.pur

poseMess

age

Anything

paymentD

efaults.pur

poseCode

Valid purpose code

paymentD

efaults.pay

mentIsoCo

de

Valid ISO code

paymentD

efaults.pay

mentCode

word

Valid payment code

paymentD

efaults.pay

Valid party type P = Parent, T = Subsidiary, G = Group, N =

Non-related



Name Values Description

mentParty

Type

paymentD

efaults.resi

dentialStat

us

Valid residential status

bankCode Valid bank code for this

bank

iban 2-letter country code,

followed by two check

digits, and up to 35

alphanumeric characters

sortCode Valid sort code for this

bank

institutionN

umber

Valid institution number

for this bank

transitNum

ber

Valid transit number for

this bank

routingNu

mber

Valid routing number for

this bank

Transferring Electronic Bank Payments Data 

Before the Entity Bank Details (EBD) SuiteApp is installed, you are limited to making only

ACH and CPA payments. This is done through the bank plugin, using vendor information

stored in NetSuite's Electronic Bank Payments (EBP) bundle.

Once EBD is installed, the EBP bundle is no longer used to pull vendor banking data for bill

payments. Instead, EBD becomes the new source of payment information.

The EBD SuiteApp provides the ability to transfer ACH and CPA vendor banking information

from the EBP bundle via CSV.



ACH and CPA banking information stored in the following default Payment File Formats are

supported:

ACH - CCD/PPD

ACH - CTX (Free Text)

CPA-005

Transferring ACH and CPA banking information that is stored in custom Payment File

Formats is unsupported.

To quickly transfer your supported data across EBP bundle and EBD SuiteApp, follow the

steps below.

1

2

Go to the Import/Export Tab

Go to Set Up → Entity Bank Details → Import/Export

Go to Import/Export

Generate CSV(s)

Select Click to show Electronic Bank Payments export



Click to show Electronic Bank Payments export

Select Generate CSV File.

This will generate a CSV file(s) dependent on the Number of Entries for Each File,

set below. 

NetSuite limits the number of records that can be pulled per file. For example, if you

have 1100 records and set the number of entries to 200, the SuiteApp will generate

five CSVs containing 200 records and one CSV containing 100 records.
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Generate CSV file

Import CSV(s)

Select a CSV file… or drag and drop the CSV file(s) into the Import Data box.

NOTE: The Generate Data from Electronic Bank Payments Bundle can only

extract ACH and CPA payment details. Any additional payment details must be

transferred into the Entity Bank Details SuiteApp either via manual entry or

using the Import feature.
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Import Data section

Then, select Import. 

Wait a few moments for the import to complete. 

Confirm Import Completion

Once complete, select Import logs → Execution logs to confirm import completion.



Confirm Status

You can also check the following places to confirm bank details have been saved:

Entity Bank Details tab on the Vendor or Employee Record

Entity Bank Details Overview page

Entity Bank Details History page



2.2.9.5.
Entity Bank Details Approvals
(NetSuite)

Before getting started with using the Approvals feature, ensure you have all Entity Bank

Details (EBD) permissions. You can confirm the required permissions in the Entity Bank

Installation Details & Setup guide.

Overview

Enabling Approvals enhances security and compliance by requiring a secondary approver

for every change made in the Entity Bank Details (EBD). This approver can be anyone who

has access to the Approvals page, but it cannot be the person who made the initial change.

A change is defined as adding a new record, updating an existing record, or deleting an

existing record.

While a change is pending, payments cannot be made to that entity, and the respective

payment page will block payments for the entity until the change has been approved.

For example, Jenna changed Company X's bank account information in Entity Bank Details.

Jenna can access the Approvals page, but she will be blocked from approving the change.

Bibek, however, has access to the Approvals page and can either approve or reject this

change.

Approval Requirements

For Approvals, there are two additional pages and permission sets. You must add these

permissions to any users who require access to the Settings and Approvals pages.

Suitelets

NOTE: Entity Bank Details Approvals works best if your NetSuite environment has no

customizations surrounding vendor or employee creation, deletion, or modification.



Entity Bank Details, Settings (customdeploy_fispan_vbd_settings): Access to the

Settings page allows users to enable or disable approvals or manage the settings of

approvals for imported records. 

Entity Bank Details, Approvals (customdeploy_fispan_vbd_approvals): Access to the

Approvals page allows users to approve record changes. 

RESTlets

Entity Bank Details, Settings RESTlet: This RESTlet should come with access pre-

enabled for all roles. Granting users access to this script will allow them to access the

Overview page. This permission, alongside the Entity Bank Details, Overview Suitelet,

is required to access the Overview page.

Permissions

Lists --> Employees (Level: View): To view the list of employee records that have

pending approvals, the history of changes made to employee records, or to make

changes to employee records.

Custom Record → Entity Bank Details (FI) (Level: Full): To approve EDB changes, the

role needs Level: Full permission on the Permissions tab.

User Events

No new User Events required.

Enabling Approvals

1 Navigate to Settings

To enable Approvals, navigate to Setup -> Entity Bank Details -> Settings. 

NOTE: For the Settings page to work properly, you must also have access to all

Subsidiaries. 
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Click on Settings

Settings is where you can decide to enable or disable Approvals. 

Enable Approvals on All Changes

You can also enable and disable approvals for changes made via the Import page. 

Enable Approvals
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To enable these settings, select the APPROVAL ON ALL CHANGES checkbox and

click Save. 

Now, all changes must be approved before you can disable Approvals.

Approve Pending Changes Before Disabling  

By enabling Approvals, every change made via Import on the Import/Export page will

now require approval. 

Enable Skip Approval on Imports

In Settings, you can enable the Skip Approvals on Imports option. 

This setting cannot be enabled if there are pending approvals. 



Configure Approvals for the Import/Export Page

Making EBD Changes 

1 Overview Page

To make a change to a Vendor or Employee record, navigate to Setup -> Entity Bank

Details -> Overview. 
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Click on Overview

Make Changes to Entity

Select the entity you want to change.

Select a Vendor or Employee

Three types of changes trigger approvals: 
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Update

Add

Delete

Make the desired changes to the entity's record and Save.

Click Save Vendor Bank Details

Confirm the Change

When asked to confirm the change, be aware that no payments can be made to this

vendor or employee until the changes have been approved.

IMPORTANT: Turn off the PRIMARY toggle if you do not want this newly

created account to be a primary record. If a vendor or employee does not have

a primary record enabled, payments will fail. 



Click Yes, Save Changes

A blue banner will be displayed on vendor records indicating that changes are

pending, while a red alert icon will appear on the relevant bank details record.

Warning for Pending Changes
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The blue banner serves as a reminder that the completion of payments is contingent

upon the approval of the change. The alert icon signifies that the record has

changed. 

Records With Pending Changes

Should a record have a pending change, it cannot be edited again until such a

change receives either approval or rejection.

If a vendor's record currently has a pending change, you can edit, create, or delete

other records; however, the record with the pending change cannot be modified.

Bills Will Be Blocked For Payment

As a result, the payment page will display bills accompanied by a red alert icon,

indicating that payment processing is not possible, and their associated checkboxes

will be disabled.

Making EBD Changes With Import/Export

Changes to Entity Bank Details can be made via a CSV import of records, and these

changes will require approval.



1 Export EBD Data

Navigate to Setup -> Entity Bank Details -> Import/Export. 

Click on Import/Export

Import/Export, you have the option to either download a blank template or use the 

Generate Export File option to create an existing export file.
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Entity Bank Details - Import/Export page

Update Exported EBD Data

Then, make changes or add data to the export file. 

Make Changes to Data Export



3 Reimport EBD Data

Now add the updated file to the IMPORT DATA box and select Import.  

Click Import

The plugin will process the imported data and notify you if there are pending

changes for a record. 



Approvals Pending

Payments are blocked for any entity with outstanding changes until the changes are

approved or rejected.

Approving Changes

To approve changes, you must have access to the Approvals page, and you cannot be the

user who changed the entity's record.

1 Locate Pending Approvals

Navigate to Setup -> Entity Bank Details -> Approvals. 
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Click on Approvals

The page will now display any records that have outstanding changes. Click View

Details to see the change and to begin approving or rejecting changes. 

Click on View Details

View Changes
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When you click View Details, a pop-up appears and outlines the changes.

If the record you are approving is classified as a Primary Account, you will have the

option to either confirm this designation or revoke the account's status as a Primary

Account.

This option will only appear if a record's Primary setting is being updated or if a new

bank account is being added. 

Review Proposed Changes

Approve Changes

After reviewing the changes, you can Approve or Reject. If unsure about a change,

select the arrow beside the pop-up to move to the next record and return to this

change later. 

When you approve a record, a pop-up window will ask you for final confirmation.



Click Yes, Approve Changes

After approval of the change, a confirmation window will display a checkmark,

indicating that the change has been successfully approved and saved.

Navigate to the Next Record
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After 10 seconds, the pop-up moves to the next record so you can continue

reviewing changes. You can also click forward using the arrow icons. 

If there are no further changes, click Close to exit the pop-up window. 

The updated entity records can be viewed on the Overview page. Payments for this

vendor or employee are no longer blocked, allowing for the processing of any

outstanding payments.

Reject Changes

To reject a change, select Reject. 

When prompted to provide a Reason for Rejection, provide an explanation up to a

maximum of 250 characters.

Click Yes, Reject Changes

After entering the reason, select Yes, Reject Changes.

An X icon window indicates the change was rejected, and the vendor's record was

not updated. 



Navigate to the Next Record

You can now successfully make payments for this vendor or employee. 

Navigate to the next record using the arrow icon or by waiting 10 seconds. 

Approvals History 

All approvals are logged in the Entity Bank Details History, serving as a valuable resource

for audits and reviews of approval histories.

1 Locate Approval History

To view a history log of all changes, navigate to the History page: Setup -> Entity

Bank Details -> History.
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Click on History

History displays a record of all changes made and approved. If the approvals feature

was not enabled for some historical changes, some details like Reviewed By or 

Status will be missing. 

View Approved Changes 

Select View Details to see more information about a change.



View Log of Changes

For approved changes, a pop-up confirms that it has been Approved. It outlines key

information such as who indicated the change, who approved it, and what attributes

were modified. 

View Approved Change Details



Once finished looking at the pop-up, click Close.

For changes that have been approved and involve additions or updates, you have the

option to access the EBD Record. Simply click on the EBD Record link located next to

the corresponding record.

Click on View EBD Record

This link will take you to the record on the EBD Overview page. 
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View Changes

View Rejected Changes

Rejected changes will display similar information; except, it will indicate that it has

been Rejected and include the Reason for Rejection as well.

View Rejected Changes Details



4 Export Approvals History

To export these changes for your records, go to the History page and select Export.

Add a date range filter to limit the amount of data to include.

Click on View EBD Record

The History Export will display the following data: 

Log ID

EBD ID

Modified On (Date and Time)

Vendor ID

Vendor

Type of Change: Updated, Added, or Deleted

User: The user who initiated the change

User ID: The user ID of the user who initiated the change

Reviewed By: The user who approved or rejected the change

Reviewed On: The time when the change was approved or rejected

Status: Approved or Rejected



Previous Entry: This shows the data that the record contained before the

change. This will be empty if the history log item is for a net new record being

added.

Proposed Entry: If the entry was rejected, this is the change that was proposed. 

If the entry was approved, this is the change that was accepted.

Reason for Rejection: This will be empty if the record is approved

View History Export

FAQs

Is there any way to disable the Approvals feature after it is enabled?

To disable Approvals, please navigate to Setup > Entity Bank Details > Settings.

Approvals can only be disabled if there are no pending approvals.

NOTE: The same columns will appear in the report regardless of whether the

Approvals feature is enabled or disabled.



Can I set more than one approver set up for a change?

Currently, Entity Bank Details is only able to support a single approver for a change. 



Why am I unable to pay my vendors/employees despite all pending changes being

approved?

Please have your NetSuite Administrator using the Administrator Role complete the

following steps:

1

2

3

4

Navigate to Customization -> Scripting ->Script Deployments.

Locate the EBD, Log Event Update script, Script ID:

customdeploy_fispan_vbd_log_update_ue, and click Edit.

On the Execute as Role field, change the value from Current User to 

Administrator.

Change from Current Role to Administrator

Click Save.



2.2.9.6. Update Entity Bank Details Bundle

Stay up to date with the latest improvements by regularly updating your Entity Bank Details

bundle. This guide will walk you through the process.

1

2

Locate SuiteApp

Go to Customization → SuiteCloud Development → SuiteApp Marketplace.

Go to SuiteApp Marketplace

Find Entity Bank Details SuiteApp

Search and open the Entity Bank Details SuiteApp tile.



Open SuiteApp Tile

Select Update 

The SuiteApp will take a few moments to update.



2.3.Features



2.3.1. Book Transfers (NetSuite)

Forget the hassle of toggling between your bank portal and your ERP or accounting

software for a simple book transfer. With , you can initiate transfers

between your company’s accounts directly from within your financial management

software. 

Goldman Sachs

Book Transfers Requirements

Book Transfers (Account Transfers) are subject to the following limitations:

1

2

3

4

Currency and Location

Both accounts must belong to the same TxB branch.

Both accounts must be domiciled in the same currency.

Account Setup

Both bank accounts must be at the same financial institution and must be linked via

the installation wizard.

Journal Entry Fields

Mandatory fields on your NetSuite Journal Entry forms must not exceed the following

list:

Date

Currency

Exchange Rate

Subsidiary

Account

Additional Mandatory Fields

Any additional mandatory fields beyond those listed above will prevent the bank

plugin from creating and saving journal entries for funds transfers.



Overview

The Book Transfer (Account Transfer) feature allows users to transfer funds between their

bank accounts. The Book Transfers create journal entries and reflect them in the General

Ledger.

The Book Transfers product does not support the use of Accounts Receivable and

Accounts Payable account types as a balancing account.

Transfer History

The plugin allows you to easily access the Transfer history by following these steps.

1 Go to History

Go to Your Bank → Transfer → History

IMPORTANT: Users on bundle version 2022.23 and older must grant access to non-

admin roles for the following RESTlets:

customdeploy_ _transfer_rGoldman Sachs

customdeploy_ _transfer_chart_rGoldman Sachs

These RESTlets can be located by navigating to Customization -> Scripting -> Script

Deployments.  

Once here, set the TYPE filter to RESTlet, search the page for transfer as seen in the

RESTlets above, click Edit, and select the appropriate roles to apply to the RESTlet

within the Audience section of the page.

Users on bundle version 2023.1.0 and newer do not need to complete this step, as

the RESTlet is applied to all roles by default. Please update to the latest version.
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Go to History Page

Here you can view the past transfers and their status: Completed or Failed

Transfer History Page

View Transfer Details



Click an ID number to view the transfer details. This action takes you to the History

page, which links to the corresponding Journal Entry record:

A Journal Entry is recorded for basic transfers.

Journal Entry Record



2.3.2.
Bill Payments
(NetSuite)

2.3.2.1. Paying Bills (NetSuite)

You can pay a vendor bill individually or improve efficiency by processing them in groups.

Follow this guide to learn how to do both.

Pay a Vendor Bill

1 Go to Vendor Bills 

Go to  → Payments → Vendor Bills.Goldman Sachs
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Navigate to the Vendor Bills page

Select a Bill to Pay

Use the filters to find the bill you would like to pay. 

If a default payment method hasn't been set for this vendor, select a method from the

respective column.

Select the checkbox next to the payment you want to make and select Pay.
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Select Pay

Confirm Payment

Select the account from the dropdown and confirm that the number of bills,

payments, and amounts are correct. 

NOTE: Only bills that are Open/Approved and do not have a Payment Hold on

them will appear on the Pay Vendor Bills page. 

This includes Open/Approved bills that are On Hold (with no Payment Hold on

them).
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Confirm Payment

Then, select OK.

Monitor Bill Processing

NOTE: The source account will only appear in the Confirm Payment pop-up if

the associated bank account has a number input in the Number field.
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Receiving Payments

Once the payment request is successfully sent, the status bar will turn green.

Payments Successfully Received

Check the Status of Payment

Go to Your Bank → Payments → History.



Go to Payments History Page

We recommend checking the Failed Bills tab after sending a payment to confirm the

payment was successful.

Payments History Page



Paying Grouped Bills

Grouping bills for payment will make it easier to manage your vendor bills within the ERP

system. There are a few prerequisites you need to address to get started.

If you would like to make grouped bill payments, please ensure you have the GROUP BILLS

FOR PAYMENT checkbox selected on the Vendor record. This can be done by navigating

to the Vendor record and selecting the sub-tab for your bank.

Select Group Bills for Payment

1

2

Go to Vendor Bills

To make a grouped bill payment, navigate to Your Bank → Payments → Vendor Bills.

Select Bills to Pay

Select more than one bill for at least one Vendor with Grouped Bills enabled, and then

select Pay.
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Select Bills to Pay as Grouped

Confirm Payment

The Confirm Payment window appears, where you can select the Source Account

and verify the number of bills compared to the payments. 

Confirm Payment



With Grouped Payments enabled for a Vendor to whom you are paying more than one

bill, the number of payments will always be less than the number of bills.

If everything looks good, select OK to transmit the payment.



2.3.2.2.
Applying Bill Credits During Payment
(NetSuite)

You can easily apply bill credits directly on the Pay Vendor Bills page in NetSuite. This

guide will help you understand the steps required.

Before starting, please ensure that the Expense Reports checkbox is selected in the Setup

→ Company → Enable Features → Employee Expenses tab. This step is required for the

Apply Bill Credits functionality.

Applying Bill Credits

1

2

Go to Vendor Bills Page

To apply bill credits, navigate to  → Payments → Vendor Bills.Goldman Sachs

Navigate to the Vendor Bills page

Select Bills to Apply Bill Credits
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Identify the bill you would like to apply bill credits to and make a payment. If a default

payment method has not been set up for a vendor, please select an appropriate

option from the Payment Method dropdown list.

Select the checkboxes next to the bills you want to apply credits to, and click Apply

Credits.

Select Bills to Apply Bill Credits

Select Vendor

Bills and bill credits are grouped by vendor and currency. Use the A/P Account drop-

down to filter bills and bill credits by different accounts. 

Find the vendor you want to apply the bill credits to and click View Bills Credits.
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Select Vendor to Apply Bill Credits

There are two methods for applying bill credits:

Auto-Apply

Manual Apply

Auto-Apply Bill Credits

The Auto-Apply function simplifies the process by automatically applying the

available bill credits to the bills. With the Auto-Apply function, bill credits are applied

to bills in order from the oldest to the newest due dates.

Select Bill Credits to Apply

The left panel contains a list of all available bill credits, including their original

amounts and available balances. This panel also displays the total number of bills and

bill credits, and how many are currently applied. Select the checkboxes for the bill

credits you wish to apply.

NOTE: The dialog will only show vendors who have bill credits available.
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Auto-Applying Bill Credits

Once selected, click the Auto-Apply button. Upon clicking Auto-Apply, you’ll notice

that bill credits are applied to bills starting from the oldest to the newest due dates.

The Total Amount Due will update to reflect the applied bill credits. 

You can manually adjust the amount of the bill credit if needed or remove bill credits

from respective bills by clicking a red cross icon.

After confirming the bill credits application, click Save Changes.

Manual Apply Bill Credits

The Manual Apply function allows you to select specific bill credits and determine the

amount to apply to particular bills, giving you precise control over the allocation of bill

credits.

Click +Add New Bill Credit and select the desired bill credit from the drop-down

menu. You can customize the amount of each bill credit to apply to a particular bill.
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Manual Apply Bill Credits

If you wish to remove the applied credits, click the Reset button. This will clear all bill

credits currently applied.

After confirming the bill credits application, click Save Changes.

Processing Bill Credits

The plugin will begin applying bill credits to the selected bills. 

NOTE: Once you manually apply bill credits, the Auto-Apply function will be

disabled. To restore the Auto-Apply function, click the Reset button.



Processing Bill Credits

The status column will indicate whether each bill credit has been successfully

applied. A green checkmark signifies a successful application, while a red caution

icon shows that the bill credit could not be applied. 

Hover over the icon to see a detailed message explaining why the credit application

failed. 
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Credit Processing Completed

To reapply the failed bill credits, click Back to Vendor Credits. If you need to apply

bill credits to another vendor, click View More Bill Credits.

Once you have finished applying bill credits, click Done.

Make Payment

Select the bills to pay and click Pay on the Pay Vendors Bill page to proceed with

payment.

The source account will only appear in the Confirm Payment pop-up if the associated

bank account has a number input in the Number field.

NOTE: Bills with a net amount due of zero after applying bill credits will not

appear on the plugin's Pay Bills or Payment History pages. These bills will be

paid directly within NetSuite.

TIP: Bill Credits works best if your NetSuite environment has no customizations

surrounding bill, bill payment, and/or bill credits creation, deletion, or

modification. 



Confirm and Make Payments

FAQs

Do I need new permissions to access this feature?

Please ensure the role is granted the following permission under Manage Roles →

Permissions tab → Transactions tab: Enter Vendor Credits (Level: Edit)

Can I apply bill credits from A/P Account X against bills from A/P Account Y?

Currently, NetSuite does not allow bill credits to be applied across different A/P

Accounts. You can only use bill credits against bills within the same A/P Account.

I paid my bill using bill credits, but I can't see it under the Payment History tab. Why?

Since the bill was fully settled using bill credits, it will not appear on the plugin's

Payment History page. Instead, it will be processed directly within NetSuite.



Does it work with discounts and credits natively applied within NetSuite?

Yes, this feature is fully compatible with both discounts and bill credits applied directly

within NetSuite.

I have a restricted view for class, location, and department, but I don’t see any

available credits in the pop-up. Why?

Please ensure that Include Unassigned is selected for each of these entities in your

restricted view settings.



How can I unapply bill credits?

To unapply bill credits, perform the following steps:

1

2

3

Navigate to Bill Credit

Navigate to the specific Bill Credit you want to unapply and click Edit.

Go to the Expenses & Items tab and click the Apply sub-tab.

Unapply Bill Credit

Clear the checkboxes for the bill(s) you no longer want the credit applied to and

click Save.

Unapply Bill Credits from a Bill

Confirm Changes

Open the Pay Bills page or the bill to confirm that the changes have been

reflected.



2.3.2.3.
Applying Bill Credits (Natively in
NetSuite)

You can leverage bill credits through NetSuite's native platform, by following these steps:

1

2

Navigate to Vendor Credits

Go to Transactions → Payables → Enter Vendor Credits.

Go to Enter Vendor Credits Page

Enter Credit Details

Select the vendor you would like to credit and fill in all other required fields. 
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Enter Credit Details

Under the Expenses & Items tab, enter the Account and Amount details, then

select Save.

Apply Credit to Bill(s)

Select Edit on the Vendor’s Bill Credit page that appears after saving the credit

details. 

Select Apply and select the bill you would like to apply the credit to, then

select Save.
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Apply Credit to Bill(s)

If the Auto Apply checkbox is selected, it will automatically select a bill from the list.

If you do not wish to apply the credit to that bill, you may select another one.

View and Pay Reduced Bill(s)

In the navigation bar, select Payments → Vendor Bills. The credit bill should now

display the Original Amount and a reduced Amount Due.



View and Pay Reduced Bill(s)

NOTE: The plugin will only transmit the amount paid in NetSuite, which will be

the remaining bill amount after any vendor credits or discounts are applied. 

For users who view payments made in the NetSuite bank plugin later in their

bank portal, the amount shown will be the same remaining bill amount that was

paid in NetSuite. 



2.3.2.4. Applying Discounts (NetSuite)

Learn how to apply discounts to payments in NetSuite with the  helping you

manage your payment discounts and processing.

Goldman Sachs

Apply Discounts to Payments

Follow these steps to learn how to apply discounts to vendor payments.

1 Confirm Purchase Discount Account

Go to Setup → Accounting → Accounting Preferences → Items/Transactions →

Purchase Discount Account.

Confirm the appropriate account is selected. The account selected here can be any

account; choose one that works best with your business. 

Select an Account to be the Purchase Discount Account

Click Save.



2 Creating Payment Terms

Terms can be created or modified in the Payment Terms page. Go

to Setup → Accounting → Accounting Lists.

Go to Accounting Lists

Select Filter → Type → Term.

From here, you can view and edit Terms that already exist, or you can

select New and create a new Term.
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Select Edit | View Term

Enter the details for your new Term. Once you are done, select Save.

Creating a Term

Setting Payment Terms

Terms can be set at the Vendor level or the Bill level.
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Set Payment Term at Vendor Level

Set Payment Term at Bill Level

Paying Discounts



Using the main navigation bar, go to the Pay Vendor Bills page via →

Payments → Vendor Bills.

Goldman Sachs

Select Payment Method

Use the filters to find the bills you would like to pay. If a default payment method has

not yet been set for the vendor, choose a payment method from the respective

column.

Discount Amount is automatically calculated on the Original Amount of the bill

based on the terms and dates set on the bill. If a discount is calculated to be available

(based on the terms), the Discount Amount box will be automatically populated.

Users can modify the discount amount by editing the value in the Discount Amount

field. 



Apply Discount

If the discount looks correct, select the bill and select Pay.

A confirmation page will appear with the To Pay amount. Select the account from the

dropdown and confirm that the number of bills, payments, and amounts are correct. 

Confirm Payment



Then, select OK.

After selecting OK, a blue payment status bar will appear at the top of the page to

show the progress of your payment.

Receiving Payments

Once the payment request is successfully sent, the status bar will turn green.
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Payments Successfully Received 

Check Status of Payment

Using the main navigation bar, go to → Payments → History.Goldman Sachs

The status will appear as Processing until the payment has been cleared. Once the

payment is complete, the status will display as Completed. 



Payments History page

Payments take four business days to appear as Completed in the plugin since there

is no positive acknowledgement from the receiving bank.

The bank plugin will only transmit the amount paid in NetSuite, which will be the

remaining bill amount after any discounts or vendor credits are applied. For users

who view payments made in the NetSuite bank plugin later in their bank portal, the

amount shown will be the same remaining bill amount that was paid in NetSuite. 

Partial Payments

Partial payments are not supported. The plugin will consistently submit the full To Pay 

amount, regardless of any discounts entered or credit memos applied, and will record the

remaining balance as a discount when processing a payment in the ledger.



Partial Payment Not Supported

Discount



2.3.2.5. Voiding and Repaying Bills (NetSuite)

Bills that are voided in native NetSuite can be repaid through the bank plugin, allowing for

multiple repayments if necessary. 

Previously paid payments with a duplicate bill ID cannot be voided and repaid directly.

Instead, you'll need to create a new copy of the bill and apply payment to the copy or

submit a ticket to  for resolution.TxB Representative

How to Void Bills

Use this simple process to void a bill using the plugin.

1 Locate the Bill

Find a bill that has already been paid via the plugin on the History page by going to 

 → Payments → History.Goldman Sachs

Payment History age showing paid bills



2 Check Bill Status

Open the Bill Record and confirm the bill has been PAID IN FULL. You can select Your

Bank's tab in the submenu to confirm that the bill payment has hit the plugin.

Check Bill is marked as "PAID IN FULL"

Confirm Bill Payment
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4

Go to Bill Payment Record

Go to Bill record → History (or Related Records) → Payments and find the Bill

Payment record associated with this Bill.

Open Bill Payment Record

Void the Bill

Void the Bill Payment by selecting the Void button.
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Void the Bill

Save the Bill

Select Save on the Voiding Journal Entry that NetSuite creates in response to the

voiding of the Bill Payment.

Save the Bill
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The next page will show a Confirmation banner, and the Voiding Journal Entry will be

marked with REVERSAL PAYMENTS APPLIED.

View Confirmation Banner

Check the Bill

Confirm the Bill has been reopened. Fields under Your Bank's subtab are still

populated with details from the first payment that was voided. The associated Bill

Payment will also appear as Voided.



Check the Bill

Bill Payment status appearing as "Voided"

Repaying a Previously Voided Bill



Follow these steps to repay your voided bills. 

1

2

Find the Voided Bill

Find the previously voided bill on the Pay Vendor Bills page by going to 

→ Payments → Vendor Bills.Goldman Sachs

Find the Voided Bill

Pay the Bill

Pay the bill as normal.
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Pay the Bill

Check the Bill Status

Confirm the bill has been paid and appears in the History page. Go to 

→ Payments → History.

Goldman Sachs

Check the Bill Status



Open the Bill record and confirm the bill has been PAID IN FULL. You can select the

tab for the  in the submenu to confirm that the bill payment has hit the

plugin and that the reference IDs and transaction IDs are now different, as seen in

Step 2 of How to Void a Bill.

Goldman Sachs

Ensure Bill is marked as "PAID IN FULL"

A new Bill Payment now appears as an associated record to this Bill, alongside the

previously voided payment.



New Bill Payment on Bill



2.3.2.6. Viewing Bill History (NetSuite)

The  maintains a log of all successful and failed payments made since its

installation. This page will guide you on how to view your Vendor Bill Payment History and

explain the different payment statuses you may encounter during regular use.

Goldman Sachs

1

2

Go to History

Navigate to → Payments → History.Goldman Sachs

Go to Payments History page

View Payments History

On the Payments -> History page, payments will be grouped into 4 different

categories:

All Transactions

Pending Transactions

Failed Transactions

Processed Transactions
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Use the filters for Payment Type, Subsidiary, and Dates to help narrow down the

number of payments shown on screen.

View Payment History

View Payments History – Pending 

Payments that are processed through the plugin will first appear under the Pending

tab, and can remain here for up to  business days, depending on the payment

method, before appearing under the Processed tab. 

several
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View Payment History - Pending

There are two Pending statuses:

Sent for Processing: This status indicates that the payment has been processed

through the bank plugin but has not yet reached your bank.

Processing: This payment has reached your bank and has been approved (if

using payment approval workflows).

View Payments History – Completed

All successful payments made through the plugin will appear under the Processed

tab after  business days. Some payments may make it here sooner, depending

on the payment method selected at the time of payment. 

several



5

View Payment History - Succeeded 

There is only one status for Completed payments:

Completed: This payment has been successful and requires no further action. A

payment's status may update to Completed within  business days after

approval (if using payment approval workflows) or sooner, depending on the

payment method.

several

View Payments History – Failed 

A payment will appear under the Failed tab if it has failed to be processed. A payment

will only remain under the Failed tab until it has been successfully paid.



View Payment History - Failed

Failed payments have the following statuses:

Validation Issue: This status describes payments that fail to be processed as a

result of missing or invalid information required for a successful payment.

Common examples include missing Country and/or State/Province on a Payee,

missing Payee bank account information, or Invoice IDs/Reference Numbers

exceeding the maximum of 35 characters.

Cancelled: This status will indicate that the payment was deleted in the Approval

App.

Failed: This status indicates an error on the payment that has prevented it from

leaving NetSuite. Common examples include subsidiary mismatches between

the payee and source account. 



2.3.2.6.1. Customizing Columns (NetSuite)

Customizable Columns give you more flexibility to personalize the vendor bill payment

experience. You can easily add, rearrange, and remove the columns you see on the Open

Bills and Failed Bills tabs of the Pay Vendor Bills page.

You can select standard fields from the Bill and Vendor records, as well as any custom

transaction body fields on the Bill record, to display as a column.

All customizations you make are saved at the user level. This means your personalized

column layout won't affect the Pay Vendor Bills page for any other user.

Keep in mind that enabling Customizable Columns requires additional permissions for user

roles. Please check the Required Permissions section on this page for details.

Accessing the Customization Feature

Follow these steps to access the Customization feature on the Pay Vendor Bills Page.

1 Locate Customize Option

The customization page is accessible from the Pay Vendor Bills page by clicking on

the Customize button.
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Customize Button Located on the Right of the Pay Vendor Bills Screen

When you click the Customize button while viewing the Open Bills tab, it will take you

to the Customize: Pay Vendor Bills - Open Bills page. 

Customize Pay Vendor Bills Page

Here, you can add, rearrange, or remove columns that are displayed on the Open

Bills tab of the Pay Vendor Bills page.



The Customize page for the Open Bills tab of the Pay Vendor Bills page

By default, the Columns sub-tab appears first.

Available and Selected Columns

On the Columns tab of either Customize: Pay Vendor Bills - Open Bills or Customize: Pay

Vendor Bills - Failed Bills pages, users can see two main sections: Available Columns,

Selected Columns.



The Customize page for the Open Bills tab of the Pay Vendor Bills page

Available Columns

The Available Columns section, located on the left half of the screen, allows the user to do

the following:

Search for available columns by typing into the search bar.

See the total number of available columns to be selected.

Click, or click and drag, available columns to be added to the Selected Columns 

section of the page.

Reset columns back to default.

This feature allows users to choose from the standard fields available on both the Bill and

Vendor records to display and rearrange columns on the Pay Vendor Bills page. 

Additionally, users can choose any custom fields available on the Bill Record, but not any

custom fields available on the Vendor Record.

Selected Columns

The Selected Columns section is on the right side of your screen. Here you can do the

following with the columns selected:



View all the columns currently visible on the Pay Vendor Bills page.

Rearrange columns:

Look for the dotted icon. If a column has this, you can drag and drop it, or select

it and use the up/down arrows to change its order.

Columns without the dotted icon cannot be rearranged.

Remove columns:

Columns that do not have a lock icon can be removed.

Hover over the column and click the Remove button that appears. You'll be asked

to confirm the removal.

Columns with a lock icon cannot be deleted.

Selected Columns behavior

Making Changes to Columns

To create a personalized view of your vendor bills, use the Customization feature by

following these steps.

1 Locate Customize Option



Navigate to  → Payments → Vendor Bills.Goldman Sachs

Navigate to the Vendor Bills page

To make customizations to columns on the Open Bills tab of the Pay Vendor Bills,

click on the Customize button. 

Customize Button on the Pay Vendor Bills Page
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To make customizations to columns on the Failed Bills or Open Bills tab of the Pay

Vendor Bills page, click first on the Failed Bills or Open Bills tab, then the Customize

button.

The Failed Bills Tab of the Pay Vendor Bills Page

Finding Available Columns

In the Available Columns section of the page, begin typing in the search bar to find

the column of your choice, or scroll through the full list to see what column options

are available.
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Option 1: Using the Search Bar to Find a Column

Option 2: Scrolling Through the Available Columns List to Find a Column

Adding and Rearranging Columns

To add a column, click on a column in the Available Columns section to move it to

the Selected Columns section. 



This will place it in the highest possible position within the Selected Columns

section, which is third, just below the columns for Due Date and Bill Number, as

these two columns cannot be repositioned. You can utilize the arrows at the top right

to further adjust the column's placement.

Option 1: Click to add a column and re-arrange using arrows

Alternatively, you can click and drag a column from the Available Columns section to

the desired position in the Selected Columns section.
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Option 2: Click and drag a column to the desired position

Removing Selected Columns

To remove a column, simply click on the column in the Selected Columns section of

the page to bring up the Remove button. It will prompt you to confirm that you wish

to remove this column. 

Click “Remove” and confirm removal by clicking “Yes, Remove Item”
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Upon clicking Yes, Remove Item, the column will reappear within the Available

Columns section.

Saving Customizations

When you are happy with your changes, click Save Changes at the bottom of the

screen to save your customizations. 

You may either return to the Pay Vendor Bills page by clicking on Go Back to Pay Bills

Page, or you may remain on the current page by clicking Close.

Changes Applied confirmation window

The Open Bills tab of the Pay Vendor Bills page will now reflect column

customizations.
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“Vendor: Category” now appears as a column in the specified position

Resetting Columns to Default

To reset your columns back to default, click on the Customize: Pay Vendor Bills

page, and click on the Reset to Default button.

Click “Reset to Default”



A dialog box will appear, prompting you to confirm whether you really want to reset

your column customizations back to default. Click on Yes, Reset to Default to

continue.

Click “Yes, Reset to Default” to confirm the reset

After clicking Yes, Reset to Default, all column customizations, including any

additions, rearrangements, and removals, have been reset to the default selection

and position of columns. 

You may continue to make more changes from here, or click Save Changes to

proceed with the default columns.

Required Permissions

A number of permissions are required for a user to fully access and make customizations

to columns and filters:

Access to the following Suitelet scripts:

 Pay Vendor BillsGoldman Sachs

 User CustomizationGoldman Sachs



Access to the below NetSuite User/Role Permission:

Custom Fields (Level: View)

Subsidiaries (Level: View)

Accounting Lists (Level: View)

Set Up Company (Level: View)

Optional, but ideal for customizable filters

Manage Accounting Periods (Level: View)

Optional, but ideal for customizable filters

Suitelet Script Access

After updating the plugin, a NetSuite Administrator is required to grant employees

permissions to the  Pay Vendor Bills Suitelet script in order for employees

to access the page where the “Customize” button is located, as well as the 

User Customization Suitelet script in order for the “Customize” button to work. 

Goldman Sachs

Goldman Sachs

Suitelet script permissions can be accessed by navigating to Customization → Scripting →

Script Deployment. 

Use the following filters:

On the Type dropdown select Suitelet

On the API Version dropdown select 2.1



Pay Vendor Bills and User Customization Suitelets

Click "Edit" beside both  Pay Vendor Bills and  User

Customization.

Goldman Sachs Goldman Sachs

Under the Audience sub-tab, select the appropriate employees, departments, and roles to

which you would like to assign permissions. Then, click Save.



Select the appropriate roles, employees, etc. In this example, AP Clerks and Controllers

have permissions

Without enabling a user permissions to the  User Customization script, a

user who clicks the “Customize” button on the Pay Vendor Bills page will be directed to an

error page, stating “You do not have privileges to view this page”.

Goldman Sachs

Assign User/Role Permissions

A NetSuite Administrator will also need to grant users permissions to Subsidiaries (Level:

View) and Custom Fields (Level: View) so the Customize page can pull in Subsidiaries and

any custom fields available on the Bill record.

1

2

Locate User/Role Permissions

Navigate to Setup → User/Roles → Manage Roles. 

Click Edit beside the role of choice.

After selecting Edit, go to the Permissions tab → List tab. 

Assign Subsidiaries Permissions

Click on the dropdown in the last row of the Permissions table. Scroll through the list

or begin typing to find the following permission: 
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Subsidiaries (Level: View): Required to add and view subsidiaries as a column

option when customizing the Pay Vendor Bills page.

Subsidiaries (Level: View) found on the Permissions tab → List tab

Assign Custom Fields Permissions

Next, click on the Permissions tab → Setup tab. Click on the dropdown in the last

row of the Permissions table. Scroll through the list, or begin typing to find the

following permission:

Custom Fields (Level: View): Required to pull in custom fields on the Bill record

to be used as a part of customizable columns on the Pay Vendor Bills page.



Custom Fields (Level: View) found on Permissions tab → Setup tab

Click Save to save your changes.

FAQs

NOTE: If Custom Fields (Level: View) permissions are not granted to a Role,

the Customize: Pay Vendor Bills page will be stuck on loading and the NetSuite

administrator will receive an email titled “SuiteScript Error Summary” or “A User

Error has Occurred” that highlights where the error occurred, which user(s)

experienced it, and the cause.

The NetSuite administrator will also receive a similar email notification when a

user who is not granted permissions for Subsidiaries (Level: View) adds and

saves the Subsidiary column to their Selected Columns list. The user will see

that their Pay Vendor Bills page will be stuck loading.



What column options do I have?

Users can choose from standard fields available on the Bill and Vendor records,

alongside any custom Transaction Body fields on the Bill record.

Why can’t I choose from Custom Entity Fields on the Vendor record?

This is currently out of scope for our first release of Customizable Columns. If this is

something that interests you, please send along any feedback you have to 

.TxB Representative

Can I make customizations to columns on any of these pages: Payments History,

Positive Pay, Positive Pay History, Balances & Transactions?

No, only the Pay Vendor Bills page is in scope for this feature.

Do the customizations I make to the Pay Vendor Bills page impact anyone else?

No, all customizations are saved on the user level.

Do any customizations I make on the Open Bills tab of the Pay Vendor Bills page

impact what I see on the Failed Bills tab?

No, all customizations are isolated to the specific tab. The Customize: Pay Vendor Bills

page will also say whether you are customizing columns on the Open Bills tab or on

the Failed Bills tab in the page title.

Why am I not able to remove or rearrange certain columns from my Selected

Columns list?

These columns are considered essential information for a bill payment and cannot be

removed. Some cannot be rearranged as they are “stickied” left or right upon

horizontal scroll for a better user experience.



Why is the Pay Vendor Bills page stuck loading?

This can be caused by various reasons and is typically related to a SuiteScript error,

that which the NetSuite administrator will receive an email when a user encounters this

problem. There are currently two known causes:

Cause #1: The user is missing a NetSuite Permission on their role for Custom Field

(Level: View)

Fix: Grant Custom Field (Level: View) NetSuite Permissions for the user’s role

Cause #2: The user is missing a NetSuite Permission on their role for Subsidiaries

(Level: View)

Fix: Grant Subsidiaries (Level: View) NetSuite Permissions for the user’s role

If neither of the above fixes works, please reach out to Support with any recent

SuiteScript errors corresponding to your bank bundle that may have been sent to the

NetSuite Administrator’s email inbox, or are visible from the Script Execution Logs

page (Customization→ Scripting → Script Execution Logs).

Why do I need to grant or be granted access to the User Customization Suitelet

script?

A Suitelet is a page, in NetSuite terms. Without access to this Suitelet script, a user

cannot access the Customize: Pay Vendor Bills page. The Customize button will still

appear on the Pay Vendor Bills page, but clicking it will result in an error page, stating

“You do not have privileges to view this page.”

Why do I need to grant or be granted access to the NetSuite User/Role Permission:

Custom Fields (Level: View)?

If Custom Fields (Level: View) permissions are not granted to a Role, the Customize:

Pay Vendor Bills page will be stuck on loading, and the NetSuite administrator will

receive an email titled “SuiteScript Error Summary” or “A User Error has Occurred” that

highlights where the error occurred, which user(s) experienced it, and the cause.



Why do I need to grant or be granted access to the NetSuite User/Role Permission:

Subsidiaries (Level: View)?

This is a required NetSuite User/Role Permission if a user wishes to add a column for 

Subsidiary on the Pay Vendor Bills page. If this permission is not granted, the

Customizable Columns feature will remain usable, except that the role/user will not be

able to add Subsidiary to their Selected Columns list and save their changes.

If Subsidiaries (Level: View) permissions are not granted to a Role, if a user in that role

adds the Subsidiary column to their Selected Columns and saves their changes, the

Pay Vendor Bills page will be stuck on loading. The NetSuite administrator will receive

an email titled “SuiteScript Error Summary” or “A User Error has Occurred” that

highlights where the error occurred, which user(s) experienced it, and the cause. 



2.3.2.6.2. Customizing Filters (NetSuite)

Customizable filters give you more flexibility to personalize the vendor bill payment

experience. You can easily add, rearrange, and remove the filters you see on the Pay

Vendor Bills page. You can select standard fields from the Bill and Vendor records, as well

as any custom entity fields on the Bill record, to use as a filter.

Just like with columns, any filter customizations you make are saved only for you (user

level). Your personalized filter setup won't affect the Pay Vendor Bills page for any other

user.

Enabling Customizable Filters requires additional permissions for user roles. Please check

the Required Permissions section on this page for the details.

Accessing the Customization Page

Follow these steps to access the Customization feature on the Pay Vendor Bills Page.

1 Locate Customize Option

The customization page is accessible from the Pay Vendor Bills page by clicking on

the Customize button.
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Customize Button Located on the Right of the Pay Vendor Bills Screen

When you click the Customize button, it will take you to the Customize: Pay Vendor

Bills - Open Bills page. 

Customize Pay Vendor Bills Page

Here, you can add, rearrange, or remove filters that are displayed on the Pay Vendor

Bills page.



Customize: Pay Vendor Bills page on the Filters sub-tab

By default, the Columns sub-tab appears first. Click the Filters sub-tab to view 

Available Filters and Selected Filters.

Available and Selected Filters

On the Filters tab of either Customize: Pay Vendor Bills - Open Bills or Customize: Pay

Vendor Bills - Failed Bills pages, users can see two main sections: Available Filters,

Selected Filters.



Customize: Pay Vendor Bills page on the Filters sub-tab

Available Filters

The Available Filters section, located on the left half of the screen, allows the user to do

the following:

Search for available filters by typing into the search bar.

See the total number of available filters to be selected.

Click, or click and drag, available filters to be added to the Selected Filters section of

the page.

Reset columns back to default.

This feature allows users to choose from the standard fields available on both the Bill and

Vendor records to display and rearrange as filters on the Pay Vendor Bills page.

NOTE: Any filter customizations made to the Customize: Pay Vendor Bills - Open

Bills page will also be applied to the Customize: Pay Vendor Bills - Failed Bills page.

It does not matter which of these pages the user makes filter customizations from, as

customizations are shared between the two Customize pages.



Additionally, users are also able to choose any custom entity fields available on the Bill

record, but not any custom fields available on the Vendor record.

Selected Filters

The Selected Filters section is located on the right half of the screen. Here, users can do

the following:

View all selected filters on the Pay Vendor Bills page.

Move filters (denoted by the dotted icon):

Users can rearrange filters by dragging the dotted icon or by using the up and

down arrows at the top right of the page after clicking a filter.

All filters can be moved/reordered, unlike columns.

Remove certain filters (denoted by NO lock icon):

Filters that can be deleted will show a Remove button on hover. Clicking Remove

will prompt the user to confirm the action.

Filters that display a lock icon cannot be removed.

There are a number of filters that cannot be removed. They are all denoted with a lock

icon.

Selected Filters behavior



Making Changes to Filters

To create a personalized view of your vendor bills, use the Customization feature by

following these steps.

1 Locate Customize Option

Navigate to  → Payments → Vendor Bills.Goldman Sachs

Navigate to the Vendor Bills page

To make customizations to filters on the Pay Vendor Bills page, click on the 

Customize button. 
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“Customize” button on the Pay Vendor Bills page

Finding Available Filters

In the Available Filters section of the page, begin typing in the search bar to find the

filter of your choice, or scroll through the full list to see what filter options are

available.

Option 1: Using the Search bar to find a filter
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Option 2: Scrolling through the Available Filters list to find a filter

Adding and Rearranging Filters

Click on a filter in the Available Filters section to add it to the Selected Filters

section. This will add it to the top of the Selected Filters section.
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Option 1: Click to add a filter and re-arrange using arrows

Alternatively, you may click and drag a filter from the Available Filters section to the

desired position in the Selected Filters section.

Option 2: Click and drag a filter to the desired position

Removing Selected Filters
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To remove a filter, simply click on the filter in the Selected Filters section of the

page. It will prompt you to confirm that you wish to remove this filter. Upon clicking 

Yes, Remove Item, the filter will reappear within the Available Filters section.

Click “Remove” and confirm removal by clicking “Yes, Remove Item”

Saving Customizations

When you are happy with your changes, click Save Changes at the bottom of the

screen to save your customizations. A dialog will appear to confirm that changes

were made successfully. You may either return to the Pay Vendor Bills page by

clicking on the Go Back to Pay Bills Page button, or you may remain on the current

page by clicking the Close button.

The Pay Vendor Bills page will now reflect filter customizations.
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“Country” now appears as a filter in the specified order

Resetting Filters to Default

To reset your filters back to default, click on the Customize button, then the Filters

tab, and finally click on the Reset to Default button.

Click Reset to Default



A dialog box will appear, prompting you to confirm whether you really want to reset

your filter customizations back to default. Click on Yes, Reset to Default to continue.

After clicking Yes, Reset to Default, all filter customizations, including any additions,

rearrangements, and removals, have been reset to the default selection and position

of filters. You may continue to make more changes from here, or click Save Changes

to proceed with the default filters.

Required Permissions

A number of permissions are required for a user to fully access and make customizations

to columns and filters:

Access to the following Suitelet scripts:

 Pay Vendor BillsGoldman Sachs

 User CustomizationGoldman Sachs

Access to the below NetSuite User/Role Permission:

Custom Fields (Level: View)

Subsidiaries (Level: View)

Accounting Lists (Level: View)

Set Up Company (Level: View)

Optional, but ideal for customizable filters

Manage Accounting Periods (Level: View)

Optional, but ideal for customizable filters

Suitelet Script Access

After updating the plugin, a NetSuite Administrator is required to grant employees

permissions to the  Pay Vendor Bills Suitelet script in order for employees

to access the page where the “Customize” button is located, as well as the 

User Customization Suitelet script in order for the “Customize” button to work. 

Goldman Sachs

Goldman Sachs

Suitelet script permissions can be accessed by navigating to Customization → Scripting →

Script Deployment. 



Use the following filters:

On the Type dropdown select Suitelet

On the API Version dropdown select 2.1

Pay Vendor Bills and User Customization Suitelets

Click "Edit" beside both  Pay Vendor Bills and  User

Customization.

Goldman Sachs Goldman Sachs

Under the Audience sub-tab, select the appropriate employees, departments, and roles to

which you would like to assign permissions. Then, click Save.



Select the appropriate roles, employees, etc. In this example, AP Clerks and Controllers

have permissions

Without enabling a user permissions to the  User Customization script, a

user who clicks the “Customize” button on the Pay Vendor Bills page will be directed to an

error page, stating “You do not have privileges to view this page”.

Goldman Sachs

NetSuite User/Role Permissions

A NetSuite Administrator will also need to grant users permissions to Subsidiaries (Level:

View) and Custom Fields (Level: View) so the Customize page can pull in Subsidiaries and

any custom fields available on the Bill record.

1

2

Locate User/Role Permissions

Navigate to Setup → User/Roles → Manage Roles. 

Click Edit beside the role of choice.

After selecting Edit, go to the Permissions tab → List tab. 

Assign Subsidiaries Permission

Click on the dropdown in the last row of the Permissions table. Scroll through the list,

or begin typing to find the following permission: 
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Subsidiaries (Level: View): Required to add and view subsidiaries as a column

option when customizing the Pay Vendor Bills page. 

Subsidiaries (Level: View) found on the Permissions tab → List tab

Assign Setup Permissions

Next, click on the Permissions tab → Setup tab. Click on the dropdown in the last row

of the Permissions table. Scroll through the list, or begin typing to find the following

permissions:

Custom Fields (Level: View): Required to pull in custom fields on the Bill record

to be used as a part of customizable columns on the Pay Vendor Bills page. 

Set Up Company (Level: View): Ideal, but not required for Customizable Filters

to function. It is only required for a user to see the dropdown options on the

Country filter. 

Manage Accounting Periods (Level: View): Ideal, but not required for

Customizable Filters to function. It is only required for a user to see the

dropdown options on the Accounting Periods filter. 



Custom Fields (Level: View) found on Permissions tab → Setup tab

Click Save to save your changes.

NOTE: If a Role is not granted Custom Fields (Level: View) permissions, the 

Customize: Pay Vendor Bills page will be stuck on loading. The NetSuite

Administrator will receive an email titled "SuiteScript Error Summary" or "A User

Error has Occurred" that highlights the location, affected user(s), and cause of

the error.

A similar email notification will be sent to the Administrator when a user without

Subsidiaries (Level: View) permissions adds and saves the Subsidiary column

to their list. In this case, the user will also experience the Pay Vendor Bills page

becoming stuck on loading.

NOTE: If a Role lacks Set Up Company (Level: View) permissions, users in that

role won't see the drop-down options for the Country filter on the Pay Vendor

Bills page. This only applies if the Country has been added as a Selected Filter

on the Customize: Pay Vendor Bills page.



FAQs

What column or filter options do I have?

Users can choose from standard fields available on the Bill and Vendor records,

alongside any custom Transaction Body fields on the Bill record.

Why can’t I choose from Custom Entity Fields on the Vendor record?

This is currently out of scope for our first release of Customizable Columns and Filters.

If this is something that interests you, please send along any feedback you have to 

.TxB Representative

Can I make customizations to columns or filters on any of these pages: Payments

History, Positive Pay, Positive Pay History, Balances & Transactions?

No, only the Pay Vendor Bills page is in scope for this feature.

Do the customizations I make to the Pay Vendor Bills page impact anyone else?

No, all customizations are saved on the user level.

NOTE: If a Role lacks Manage Accounting Periods (Level: View) permissions,

users in that role won't see drop-down options for the Accounting Periods filter

on the Pay Vendor Bills page. This only applies if Accounting Periods have been

added as a Selected Filter on the Customize: Pay Vendor Bills page.



Do any customizations I make on the Open Bills tab of the Pay Vendor Bills page

impact what I see on the Failed Bills tab?

This depends on whether customizations were made to filters or columns.

For columns, all customizations are isolated to the specific tab. The Customize: Pay

Vendor Bills page title will indicate whether you are customizing columns on the Open

Bills tab or the Failed Bills tab.

For filters, there's no impact on the distinction between Open Bills and Failed Bills. Any

changes made to filters on one tab are automatically copied over to the other.

Why is the Pay Vendor Bills page stuck loading?

This can be caused by various reasons and is typically related to a SuiteScript error

that the NetSuite Administrator will receive an email for when a user encounters this

problem. There are currently two known causes:

Cause #1: The user is missing a NetSuite Permission on their role for Custom Field

(Level: View)

Fix: Grant Custom Field (Level: View) NetSuite Permissions for the user’s role

Cause #2: The user is missing a NetSuite Permission on their role for Subsidiaries

(Level: View)

Fix: Grant Subsidiaries (Level: View) NetSuite Permissions for the user’s role

If neither of the above fixes work, please reach out to Support with any recent

SuiteScript errors corresponding to your bank bundle that may have been sent to the

NetSuite Administrator’s email inbox, or are visible from the Script Execution Logs

page (Customization→ Scripting → Script Execution Logs).

Why do I need to grant or be granted access to the User Customization Suitelet

script?

A Suitelet is a page, in NetSuite terms. Without access to this Suitelet script, a user

cannot access the Customize: Pay Vendor Bills page. The Customize button will still

appear on the Pay Vendor Bills page, but clicking it will result in an error page, stating

“You do not have privileges to view this page.”



Why do I need to grant or be granted access to the NetSuite User/Role Permission:

Custom Fields (Level: View)?

If Custom Fields (Level: View) permissions are not granted to a Role, the Customize:

Pay Vendor Bills page will be stuck on loading, and the NetSuite Administrator will

receive an email titled “SuiteScript Error Summary” or “A User Error has Occurred” that

highlights where the error occurred, which user(s) experienced it, and the cause.

Why do I need to grant or be granted access to the NetSuite User/Role Permission:

Subsidiaries (Level: View)?

This is a required NetSuite User/Role Permission if a user wishes to add a column for 

Subsidiary on the Pay Vendor Bills page. If this permission is not granted, the

Customizable Columns feature will remain usable, except that the role/user will not be

able to add Subsidiary to their Selected Columns list and save their changes.

If Subsidiaries (Level: View) permissions are not granted to a Role, if a user in that

role adds the Subsidiary column to their Selected Columns and saves their changes,

the Pay Vendor Bills page will be stuck on loading. The NetSuite Administrator will

receive an email titled “SuiteScript Error Summary” or “A User Error has Occurred” that

highlights where the error occurred, which user(s) experienced it, and the cause. 

Why do I need to grant or be granted access to the NetSuite User/Role Permission:

Set Up Company (Level: View)?

This User/Role Permission is optional and only required if a user wishes to add 

Country as a customizable filter to the Pay Vendor Bills page.

If Set Up Company (Level: View) permissions are not granted to a Role, the Pay

Vendor Bills page and Customize page will remain accessible, and users are still able

to process payments or make customizations. The user will just be unable to see drop-

down options for Country if added and saved as a customizable filter. 



Why do I need to grant or be granted access to the NetSuite User/Role Permission:

Manage Accounting Periods (Level: View)?

This User/Role Permission is optional, and only required if a user wishes to add 

Account Period as a customizable filter to the Pay Vendor Bills page.

If Manage Accounting Periods (Level: View) permissions are not granted to a Role,

the Pay Vendor Bills page and Customize page will remain accessible, and users are

still able to process payments or make customizations. The user will just be unable to

see drop-down options for Account Period if added and saved as a customizable

filter. 



2.3.3.
Bank Statements
(NetSuite)

2.3.3.1. Enabling Bank Feeds

Bank Feeds allow for your settled bank transactions to automatically flow into NetSuite's

Match Bank Data module for reconciliation, removing the need to export and import bank

statements manually. To enable Bank Feeds, follow the instructions below. 

Please take note of the following field mappings for data received from your bank within

the Match Bank Data page in NetSuite.

� NetSuite 2026.1 Compatibility Update

NetSuite version 2026.1 introduced new functionalities for the Bank Feeds module,

including custom automated import scheduling and the ability to choose an exact

start date for historical transaction imports.

Our Bank Feeds service has been fully updated and is completely compatible with

these new features, giving you greater control over your reconciliation process from

day one!



NetSuite (Match Bank Data) Transaction Data

Transaction Date Settled Date

Type Transaction Type

Transaction Number Check Number* (if non-null) or Customer Reference*

Name Counter-Party Name*

Memo Description

Amount Amount

* Information denoted with a star will only be displayed if the transaction includes it. 

NOTE: Aside from the custom Connectivity Method and Transaction Parser that is

named after your bank, everything else discussed in this guide is owned and

managed by NetSuite. This includes, but is not limited to, the following:

Match Bank Data module

Financial Institution configuration

Format Profile configuration

Banking Import History page

As this process is managed by NetSuite, the timing and execution of the daily imports

are controlled within their system. If you are on NetSuite version 2026.1 or later, you

can customize the frequency and timing of your automated imports using the Import

Schedule subtab within your format profile. (If you do not set a custom schedule,

NetSuite will default to a randomized time between 4 AM to 7 AM PT).



Locate the SuiteApp

Go to Customization → SuiteCloud Development → Installed SuiteApp List.

Go to Customization -> SuiteCloud Development -> Installed SuiteApp List

Historical Transactions at Setup: You now have control over your historical data

sync at setup without needing to contact Support.

For NetSuite 2026.1 or later: During the account linking process, you can select

an Earliest Transaction Date for Import. This allows you to automatically import

up to 60 days of historical transactions upon setup, or pick a future date to delay

your initial import.

For NetSuite 2025.2: Upon initial setup, the system will automatically import up

to your last 60 days of historical transactions by default.

If you have any questions regarding transaction import, please reach out to 

 after setting up your bank feeds connection. TxB Representative



Note: Non-administrator users who will be setting up and managing Bank Feeds must

have the following permission:

Setup → Financial Institution Records – Level: Full

They must also be added as an audience for the following Script Deployment (can be

found under Customization → Scripting → Script Deployments):

Transaction Feed Config (ID: customdeploy_

_rpt_feed_s)

Goldman Sachs Goldman Sachs

Update the SuiteApp

Find the   SuiteApp from the list. Then, hover over the green icon and

select Update.﻿

Goldman Sachs

Select OK on the confirmation pop-up.﻿

The SuiteApp will take a few moments to update – it will appear as Pending and then show

the progress of the update. Once complete, the status column on the Installed SuiteApp

page will show a checkmark.

Create a New Financial Institution

Navigate to Setup → Accounting → Financial Institution.



Go to Financial Institution

Enter the name of your bank the Financial Institution field. Then, select Save.

Enter your bank's name as the Financial Institution



Create a New Format Profile

On the Financial Institution, click the Format Profile: Configuration tab and select Add.

Configure Format Profile

Fill in the following fields under Primary Information:

Profile Name: Any name, we suggest  ProfileGoldman Sachs

Profile Type: Bank Reconciliation

Connectivity Method:  Transaction FeedGoldman Sachs

Transaction Parser:  Transaction FeedGoldman Sachs



Fill in the required fields under Primary Information

Next, click on the Account Linking tab. 

Format Profile -> Account Linking tab

Previously, each Format Profile was only able to support one linked bank account. With this

new edition of Bank Feeds, a Format Profile can have multiple bank accounts and linked GL



accounts.

Based on the account seen under the Bank Account column, click on the space below the 

Linked GL Account to show a dropdown. In this dropdown, select the GL account that

maps to the Bank Account.

Repeat this step for all accounts you wish to enable Bank Feeds.

Once all bank accounts have been linked, click Save.

Monitor Bank Import Process

As soon as the Format Profile is saved, a blue banner will appear to notify you that NetSuite

is beginning the bank import process.

Select Track your status in the blue banner that appears, or go to Transactions → 

 → Banking Import History.Goldman Sachs

IMPORTANT: Please ensure you link all of your bank accounts on the same day to

avoid missing transactions for any unlinked bank accounts.

NOTE: You may not see transactions in the Match Bank Data page upon setup, as our

Bank Feed solution will import all prior-day transactions the day after setup and

continue to do so onwards.



Click Track your status

If the import is successful, you will see Completed under the Import Status column.

Banking Import History page with a Completed import



If the import fails, you will see Failed in the Import Status column. Select the plus (+) sign

to expand the failure reason details.

Please take a screenshot of the error message and download the CSV provided from the

link in the error message. Then, email this information to .TxB Representative

txb-client-service@gs.com

Troubleshooting

Identifying Errors

In the situation where a bank data import fails, the failure reason can be found on the

Banking Import History page.

1

2

Navigate to Transactions →  → Banking Import History.Goldman Sachs

Find the line item that shows the Import Status as FAILED, accompanied by a red

caution icon. 

On that line item, click on the small plus icon on the far left to expand the row.

Failure Reason

mailto:txb-client-service@gs.com
mailto:txb-client-service@gs.com


3 After expanding the row, the Failure Reason is provided.

Unrecognized Bank Transaction Codes

Sample import failed error on the Match Bank Data page

In the event that a bank data import fails due to an unrecognized bank transaction code,

you will need to do the following:

Map any missing BAI2 codes

Retrieve Statement IDs from Connectivity Method / Parser Execution logs

Contact a  with the following: TxB Representative

Statement IDs from impacted accounts

The date the import failed

The date of the transactions that are missing

Please refer to the sections below for instructions on how to proceed.

Mapping Bank Transaction Codes
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2

Locate the Financial Institution 

Navigate to Setup → Accounting → Financial Institution.

Click Edit on the Financial Institution that you have created previously.

Select the Format Profile: Configuration tab and select Edit on the Format Profile

that you have also created previously.

Fill in the Bank Transaction Code Details

Fill in the following fields for the bank transaction code that was unrecognized:

Bank Transaction Code: The three-digit code from the error message seen on

the Banking Import History page, or on the Match Bank Data page.

Description: Fill in with the code's description, which can be found here: 

BAI.org Cash Management Balance Reporting Specifications, page 10

Bank Data Type

Credit / Debit

Bank Data Type and Credit / Debit values will be the same. They both must be either 

Credit, Debit, or N/A. This can also be found on 

, or by referring to the table below:

BAI.org Cash Management Balance

Reporting Specifications, page 10

Type Codes Description

001-099 Account status type codes

100 Total Credits summary type codes

101-399 Credit summary and detail type codes

400 Total Debits summary type codes

401-699 Debits summary and detail type codes

700-799 Loan Summary and detail type codes

900-999 Customized Type Codes

Source: BAI.org Cash Management Balance Reporting Specifications, page 10

Customized type codes should fall within the following ranges:

https://www.bai.org/docs/default-source/libraries/site-general-downloads/cash_management_2005.pdf
https://www.bai.org/docs/default-source/libraries/site-general-downloads/cash_management_2005.pdf
https://www.bai.org/docs/default-source/libraries/site-general-downloads/cash_management_2005.pdf
https://www.bai.org/docs/default-source/libraries/site-general-downloads/cash_management_2005.pdf
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Type Codes Description

900-919 Account Status Codes

920-959 Credit Summary and Detail

960-999 Debit Summary and Detail

Source: BAI.org Cash Management Balance Reporting Specifications, page 11

For any codes between the 900-999 range that are continuing to fail, please reach

out to  support.Goldman Sachs

Sample data for BAI2 code 389

Save the Code Details

Once you have entered the missing BAI2 code information, click Save on the Format

Profile.

IMPORTANT: NetSuite will attempt to re-import bank transactions, but they will

not yet appear on the Match Bank Data page. You will still need to retrieve the

Statement IDs and contact  Support with affected dates to

request a re-sync.

Goldman Sachs

https://www.bai.org/docs/default-source/libraries/site-general-downloads/cash_management_2005.pdf


Retrieving Statement IDs from Execution Logs

In the case of a failed import, you will need to retrieve Statement IDs from the Execution

Logs from either the Connectivity Method or the Transaction Parser prior to reaching out to

our Support Team to resync transactions.

1

2

Locate the Financial Institution 

Navigate to Setup → Accounting → Financial Institution  →  List

Click Edit on the Financial Institution that you have created previously.

Select the Format Profile: Configuration tab and click on the Name of the Format

Profile you have created previously.

Open Transaction Feed

On the Format Profile, under Connectivity Method, click the hyperlinked Bank

Transaction Feed, and open it in a new browser tab.

Under Transaction Parser, also click the hyperlinked Bank Transaction Feed and

open it in a new browser tab.

NOTE: NetSuite will only store 30 days' worth of Execution Logs and, by default, will

only display the past 24 hours' worth of logs.



3

Hyperlinked Connectivity Method and Transaction parser

Locate Execution Logs

In both of the new tabs that were opened for the Connectivity Method and 

Transaction Parser, click the Execution Logs tab in the sub-menu. 

Connectivity Method (Financial Institution Connectivity) Execution Logs



Transaction Parser (Financial Institution Parser) Execution Logs

The Statement IDs, Account IDs, and Number of Transactions should be identical

between both the Connectivity Method and Transaction Parser. Each row

corresponds to a bank account linked with the new bank feeds service. 

Unable to see Execution Logs?

If you are unable to see any Execution Logs from the past 24 hours, you will need to add a

Date filter as a Custom View. Please note that any logs that are older than 30 days are not

stored by NetSuite.

1 Customize View

NOTE: The Connectivity Method (Financial Institution Connectivity) downloads

bank transactions from . The Execution Logs here will display any errors

relating to connectivity issues with .

FISPAN

FISPAN

The Transaction Parser (Financial Institution Parser) pushes the downloaded

bank transactions from  into the Match Bank Data page in NetSuite. The

Execution Logs here will display any errors relating to missing BAI2 codes or

other formatting issues in the bank transaction data.

FISPAN
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From the Plug-In Implementation page that you were on for either the Financial

Institution Connectivity or Financial Institution Parser, click on the Customize View

button. 

Click on Customize View

Create Custom View 

On the Customize Script Server Script Log Search Results page that just opened,

rename the Search Title to [BANK] Bank Feeds - Execution Log Dates . 

Next, click on the Available Filters sub-tab.



Rename the Search Title, then click on Available Filters

Click the dropdown in the last row of the table. Select a Date from the options.

Custom Default Script Notes View - filter by Date

Once you have added the Date, click Save. 



3
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This Custom View will now be available on both the Financial Institution Parser and 

Connectivity Method logs.

Access the Custom View

Clicking Save will take you back to the Plug-In Implementation page. 

From here, click on the Execution Log tab. 

Date filter applied

There will be a new option under the View dropdown, which is the Custom View you

have just created. When the new Custom View is selected, a Date filter will now

appear.

Locate Execution Log

Using the new Date filter, find the date the error occurred on. This should be the

same date you are missing transactions for. 

Once a date within the past 30 days has been selected, the table will populate with

several rows containing Statement IDs, Account IDs, and the Number of Transactions

for every bank account linked with the bank feeds service for the selected date.



Execution Log tab

Copy the contents of the whole table and paste into an email addressed to 

. Ensure the following is included in your messageTxB Representative

Execution Log table contents (containing Statement IDs from impacted

accounts)

The date the import failed

The date of the transactions that are missing

With this information, our  will be able to retrieve your missing

transactions and resync them as part of your next morning's automatic import.

TxB Representative

FAQs

I want to change the time of day my transactions sync. How do I do that?

If you are on NetSuite 2026.1, navigate to the format profile of your financial institution

record and look for the Import Schedules subtab. There, you can adjust the

frequency, start time, and preferred time zone for your automated imports.



How many days' worth of data does Bank Feeds import upon initial setup?

You can choose exactly how many days of historical data to import (up to 60 days

prior) by setting the Earliest Transaction Date for Import during the setup process. If

you don't set a date, NetSuite will automatically import up to your last 60 days of

historical transactions by default.

Can I change my "Earliest Transaction Date" after I set it up?

Once your format profile is saved and the first import runs, the date you selected is

locked in. If you made an error, you will need to unlink and re-link the bank account to

select a new date.

I set a future start date during setup, but I don't see any transactions yet. Why?

If you set a future date for your initial import, NetSuite will pause your data sync and

wait until that exact date arrives to pull the data. You will not see any transactions flow

into the Match Bank Data page until that scheduled date occurs.

Do I still need to download NetSuite's Bank Statement Parsers bundle to use Bank

Feeds?

No, this solution does not require NetSuite's Bank Statement Parsers bundle. We

recommend users keep this bundle installed so the option to revert your bank feeds

solution to the old one is still available in case.

Since all bank accounts are now matched under one Format Profile on the Financial

Institution, what happens if an import fails on one bank account?

Import failures with Bank Feeds are rare. In the case of failures, NetSuite will not

successfully sync transactions for all linked bank accounts until any errors, such as

missing BAI2 codes, have been resolved, and  has re-triggered a re-import.

Refer to the Troubleshooting section of this guide for more details.

FISPAN



What are the differences in the data in Bank Feeds compared to the legacy Bank

Feeds? 

The new bank feeds use BAI codes, which provide more details for the transaction

types. For example, previously, you would only see debits and credits as transaction

types. In the new bank feeds, you will see more detailed transaction types such as

debits, credits, ACH, transfers, fees, deposits, interest, payments, and checks.

If I need to do a manual import, what statement type can I use? 

If you are utilizing Bank Feeds, you will only be able to use the BAI2 formatting option.

Otherwise, your manual import will fail with the error: "The file could not be imported

because the date is not in the correct format."

Select NetSuite BAI2



2.3.3.1.1. Setting Up Permissions

Ensure your users have the correct permissions to access Bank Feeds and are part of the

appropriate audience for the relevant scripts by following this guide.

Confirm User(s) Permissions

Go to Setup → User/Roles → Manage Roles

Go to Manage Roles

Under Manage Roles, select Edit on the role you would like to edit. 

After selecting Edit, go to the Permissions tab → Setup tab. 

Ensure the Permission, Financial Institution Records is defined at the level Full.



Financial Institution Records Check

Confirm User(s) Scripts

Navigate to Customization → Scripting → Script Deployment.

Use the following filters:

On the Type dropdown, select Suitelet

On the API Version dropdown, select 2.1.



Script Deployment

Select Edit

Click Edit on customdeploy_gs_rpt_feed_s,  Transaction Feed ConfigGoldman Sachs

Add employee roles by selecting the appropriate employee, department or role you would

like to assign. Then, click Save.



2.3.3.1.2.
Excluding Duplicate Transactions
(NetSuite)

Keep your imported bank data clean and accurate by excluding duplicated or unwanted

transactions directly within NetSuite's Match Bank Data page.

1

2

Go to the Match Bank Data

Go to Transactions → Bank → Match Bank Data.

Go to Match Bank Data

Match the Bank Data

Select the appropriate account from the dropdown menu.

Review the transactions under Imported Bank Data for any duplicated transactions

and use the checkmark to select the transaction.
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Match the Bank Data

Exclude Transactions

At the bottom of the Match Bank Data page, you can review all transactions you have

selected. After reviewing the selected transactions, select Exclude.

Exclude Duplicate Transaction





2.3.3.2.
Adding Accounts to Bank Feeds
(NetSuite)

Use this guide to add and configure Bank Feeds for new accounts. Bank Feeds must be

enabled by following the Enabling Bank Feeds (NetSuite) guide before completing the

following steps to add new accounts. For example, you might have recently opened a new

bank account with the bank and recently added the accounts to the plugin.

Add Accounts to Bank Feeds

Once the bank representative confirms that the new accounts are added to the plugin and

ready for bank feeds, please follow the following steps:

1 Locate the Financial Institution

Navigate to Setup → Accounting → Financial Institution → List (or Search).

NOTE: If your bank requires re-authentication to add new accounts, review the steps

in Plugin Setup -> Installation -> Bank Authentication.
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List Financial Institutions

Edit Financial Institution

Click on the Edit button next to the existing Bank Feed's financial institution.

Edit Financial Institution 
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Edit Format Profile

Select the Format Profile: Configuration tab and click the Edit button.

Edit Format Profile

Go to the Account Linking

Select the Account Linking tab.
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Go to Account Linking tab

You will notice newly added account(s) are visible in the table. Now, click on the

space below the existing Linked GL Account(s) to show a dropdown. 

In this dropdown, select the GL account that maps to this newly added Bank Account.

Repeat this step for all accounts you wish to enable bank feeds for.

Once all bank accounts have been linked, click Save.

Monitor Bank Import Process

From here, the next step is the same as what is described in the Enabling Bank

Feeds procedure.



2.3.3.3. Disabling Bank Feeds

To disable Bank Feeds for your banking institution, please follow these steps:

1

2

Go to the Financial Institution

Go to Setup → Accounting → Financial Institution → List.

Go to Financial Institution

Select the Financial Institution

On the Financial Institution you would like to deactivate, select Edit.
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Select Edit on the Financial Institution

Deactivate the Financial Institution

Select the box next to Inactive and select Save.

Bank Feeds have now been disabled, and NetSuite will not automatically import

transactions.



Select Inactive Checkbox



2.3.4.Cash Management

2.3.4.1.Reporting

2.3.4.1.1. Managing Bank Accounts (NetSuite)

Access your bank account balances directly within your financial management software,

using the Cash Management Reporting features. Drill down into the details of every

deposit, withdrawal, and transfer.

Follow this guide to learn how to view balances and transactions, and use bank data for

reconciliation.

Viewing Bank Accounts 

View account balances and transaction details across all of your accounts, all within

NetSuite.

1 Navigate to the Bank Accounts page.
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Go to  → Reports → Bank Accounts.Goldman Sachs

Here, you can view all of the bank accounts that you have connected with the plugin.

The bank accounts that are shown to a user depend on their level of permissions. 

For instance, if a user is restricted to a subsidiary, they can only view accounts that

are associated with that specific subsidiary and not accounts belonging to other

subsidiaries.

Select Account

Click on any account's name to view the Intraday and Previous Day Balances.

Accounts Overview

Intraday Balances (updated time bank dependent)

Previous Day Balances (updated time bank dependent)

View Balances & Transactions

Bank Account Balances are displayed at the top of the page.

Bank Transactions that have been posted to your account are presented in the table

further below. Use the date filters to help narrow your search.



Account Balances and Transactions

You’ll see all settled transactions, debits, and credits for the account.

To see additional details about a specific transaction, click View under the Details

column.

Match Transactions for Reconciliation 

Follow these steps to start matching bank data and reconcile your accounts. 

1 Enable Transaction Matching

Go to Setup → Accounting → Chart of Accounts (Click on the title).



Chart of Accounts

Select Edit on the bank account for which you would like to use the reconciliation

feature.

Click 'Edit' to Open the Bank Account
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Select the Use Match Bank Data and Reconcile Account Statement Pages box to

enable this feature for the account.

Use Match Bank Data and Reconcile Account Statement Pages

Then, select Save.

Enable Bank Feeds

Ensure that Bank Feeds have been properly enabled for your account. Once Bank

Feeds have been enabled, you should be able to see transactions coming into the

Match Bank Data page daily. Transactions that settled the day before will be imported

early in the morning. 

Confirm Transaction Matches

Go to Transactions → Bank → Match Bank Data. 



Go to Match Bank Data

Select the appropriate account from the dropdown, and your transactions will appear

in the left column for matching.

If you need to manually import transactions into NetSuite's Match Bank Data page, follow

the instructions below. This process works even if your bank feeds are already enabled.

1 Navigate to Bank Accounts

Go to  → Reports → Bank AccountsGoldman Sachs

Select the account you would like to access.
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Bank Accounts

Export BAI2 or CSV File

Apply the appropriate filters, select Export, and select the appropriate export type.

You should select BAI2 or CSV.

Export Options



3 Upload BAI2 or CSV File

Go to Transactions → Bank → Banking Import History → Upload File.

Upload File

Select Choose a file and select the file you just downloaded in the previous step.

NOTE: If the file does not download, make sure your pop-up blocker is

disabled.



Upload File

Then, select Import with a default parser, choose the appropriate account, and

select Import. 

NOTE: If you have selected a BAI2 file, you will not need to select your account,

as the bank account information is already present in the BAI2 file itself.



IMPORTANT: For the BAI2 import to succeed, the routing and bank account

numbers in the BAI2 file's first three rows must match the corresponding data

in the Chart of Accounts.

Bank Import Mapping tab

To update the Chart of Accounts records:

Navigate to the Chart of Accounts.

Click Edit on the relevant bank account.

Go to the Bank Import Mapping tab.

Ensure that Record 02 contains the routing number and Record 03

contains the full account number. This information must be an exact match

for what is in the BAI2 file.



2.3.4.1.2.
Managing Balances & Transactions
(NetSuite)

Access your bank account balances directly within your financial management software,

using the Cash Management Reporting features. Drill down into the details of every

deposit, withdrawal, and transfer.

Follow this guide to learn how to view balances and transactions, and use bank data for

reconciliation.

Viewing Balances & Transactions 

View account balances and transaction details across all of your accounts, all within

NetSuite.

1

2

Navigate to the Balances & Transactions page.

Go to  → Reports → Balances & Transactions.Goldman Sachs

Here, you can view all of the bank accounts that you have connected with the plugin.

The bank accounts that are shown to a user depend on their level of permissions. 

For instance, if a user is restricted to a subsidiary, they can only view accounts that

are associated with that specific subsidiary and not accounts belonging to other

subsidiaries.

Select Account

Click on any account's name to view the Intraday and Previous Day Balances.
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Account Summary

Intraday Balances (updated time bank dependent)

Previous Day Balances (updated time bank dependent)

View Balances & Transactions

Bank Account Balances are displayed at the top of the page.

Bank Transactions that have been posted to your account are presented in the table

further below. Use the date filters to help narrow your search.

You’ll see all settled transactions, debits, and credits for the account.



Transactions View by Account

To see additional details about a specific transaction, click View under the Details

column.

View Transaction Pop Up



Match Transactions for Reconciliation 

Follow these steps to start matching bank data and reconcile your accounts. 

1 Enable Transaction Matching

Go to Setup → Accounting → Chart of Accounts (Click on the title).

Chart of Accounts

Select Edit on the bank account for which you would like to use the reconciliation

feature.



Click 'Edit' to Open the Bank Account

Select the Use Match Bank Data and Reconcile Account Statement Pages box to

enable this feature for the account.

Use Match Bank Data and Reconcile Account Statement Pages

Then, select Save.
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Enable Bank Feeds

Ensure that Bank Feeds have been properly enabled for your account. Once Bank

Feeds have been enabled, you should be able to see transactions coming into the

Match Bank Data page daily. Transactions that settled the day before will be imported

early in the morning. 

Confirm Transaction Matches

Go to Transactions → Bank → Match Bank Data. 

Go to Match Bank Data

Select the appropriate account from the dropdown, and your transactions will appear

in the left column for matching.

Import Transactions Into NetSuite

If you need to manually import transactions into NetSuite's Match Bank Data page, follow

the instructions below. This process works even if your bank feeds are already enabled.

1 Navigate to Balances & Transactions



Go to  → Reports → Balances & TransactionsGoldman Sachs

Navigating to Balances & Transactions Page

Select the account you would like to access.

Select Account to Export Transaction
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Export BAI2 or CSV File

Apply the appropriate filters, select Export, and select the appropriate export type.

You should select BAI2 or CSV.

Select Desired Export File Type

Upload BAI2 or CSV File

Go to Transactions → Bank → Banking Import History → Upload File.

NOTE: If the file does not download, make sure your pop-up blocker is

disabled.



Upload File

Select Choose a file and select the file you just downloaded in the previous step.

Upload File

Then, select Import with a default parser, choose the appropriate account, and

select Import. 



NOTE: If you have selected a BAI2 file, you will not need to select your account,

as the bank account information is already present in the BAI2 file itself.

IMPORTANT: For the BAI2 import to succeed, the routing and bank account

numbers in the BAI2 file's first three rows must match the corresponding data

in the Chart of Accounts.

Bank Import Mapping tab

To update the Chart of Accounts records:

Navigate to the Chart of Accounts.

Click Edit on the relevant bank account.

Go to the Bank Import Mapping tab.

Ensure that Record 02 contains the routing number and Record 03

contains the full account number. This information must be an exact match

for what is in the BAI2 file.



2.3.4.1.3.
Excluding Duplicate Transactions
(NetSuite)

Keep your imported bank data clean and accurate by excluding duplicated or unwanted

transactions directly within NetSuite's Match Bank Data page.

1
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Go to the Match Bank Data

Go to Transactions → Bank → Match Bank Data.

Go to Match Bank Data

Match the Bank Data

Select the appropriate account from the dropdown menu.

Review the transactions under Imported Bank Data for any duplicated transactions

and use the checkmark to select the transaction.
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Match the Bank Data

Exclude Transactions

At the bottom of the Match Bank Data page, you can review all transactions you have

selected. After reviewing the selected transactions, select Exclude.

Exclude Duplicate Transaction





2.4.Troubleshooting

2.4.1. FAQ (NetSuite)

This page is your go-to resource for quick troubleshooting. We've compiled a list of the

most common errors and frequently asked questions you might encounter when using the 

 in NetSuite, providing you with immediate answers and resolutions.Goldman Sachs

Installation &  Plugin Setup

Common Errors

Below is a list of common errors encountered during installation and plugin setup in

NetSuite. Click on any error message to view the cause and immediate troubleshooting

steps for a resolution.

"Setup required"

This error appears in a banner. You can see the banner on the bill payments or any of

the plugin pages.

This error occurs if the plugin has not been fully connected by completing the

installation wizard. Go through the installation wizard again and make sure the token

IDs are present.

This error can also happen if you don’t have currencies or the manage authentication

field enabled. 



"You do not have privileges to view plugin"

This can show up on various pages in the plugin where the current user does not have

permission to access it. 

To fix this issue, you must have a NetSuite administrator or someone with permissions

to configure scripts to assist you with the following steps.
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Navigate to Script Deployments

Go to Customization -> Scripting -> Script Deployments 

Give Access to Suitelets 

Use the following filters:

Select Suitelet in the Type dropdown

Select 2.1, in the API Version dropdown

Click Edit on each of the following script deployment Suitelets you wish to edit:

 Pay BillsGoldman Sachs

 Paid Bills HistoryGoldman Sachs

 Transfer FundsGoldman Sachs

 Transfer HistoryGoldman Sachs

 Trans Checks (Positive Pay)Goldman Sachs

 Trans Checks History (Positive Pay)Goldman Sachs

 Balances & TransactionsGoldman Sachs

Select the appropriate role, subsidiary, employee, or department you wish to give

access to.

Click Save.



"Cannot find the bundle/SuiteApp on Search & Install / Install button is not visible to

install"

If you see this error, you will need to get in touch with a support agent. It is likely that

your account either:

Hasn’t been whitelisted

Has an incorrect Account ID

Has a bundle/SuiteApp from a different environment

Common Questions

This list provides answers to common questions that arise during the installation process,

to help ensure a smoother setup in NetSuite.

Do we need to update the plugin, or will it auto-update?

Since the plugin does not auto-update, you must update it manually. The update

process depends on how the bank plugin was originally installed.

If the plugin is a SuiteApp: 

1
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3

Navigate to Customization -> SuiteCloud Development -> SuiteApp

Marketplace.

Find and click on the bank SuiteApp tile.

Click the Upgrade button in the top-right corner to begin the update.

If the plugin is a bundle:

1

2

3

Navigate to Customization -> SuiteBundler -> Search & Install Bundles -> List.

Find the bank bundle.

Hover over the green icon next to it and select Update.



I’ve installed the bank plugin, but my colleagues can’t see the plugin?

Permissions must be granted to non-administrators. 

Please refer to the Plugin Access Management step in the Plugin Setup -> Installation

section of this Support Website.

My NetSuite had a Sandbox Refresh, and now I can’t use the plugin. What do I do?

When a Sandbox Refresh occurs, you will need to complete the onboarding process

again. Start by logging into sandbox.fispan.cloud and completing the onboarding

steps again.

Cash Management (Information Reporting)

Common Errors

Below is a list of common errors encountered when using the Cash Management

(Information Reporting) products in NetSuite. Click on any error message to view the cause

and immediate troubleshooting steps for a resolution.

"Bank accounts not mapping"

The error is likely due to one of these reasons:

The system can't access or map the bank account because the information has

not been entered into the NetSuite Chart of Accounts. 

To fix this, first update the plugin.

Then, check your login information before retrying the process.

Bank account information entered does not match the backend setup.

Different IDs and environments that we don’t have access to.



"Account Matching page doesn’t load bank account information"

The error is likely due to one of these reasons:

The connecting user in NetSuite lacks the required permissions (e.g., is not an

administrator).

The Consumer Key and Secret were generated incorrectly.

There are no bank accounts currently configured in your NetSuite environment.

".csv file is not downloading from the Balances and Transactions page"

You may have a pop-up blocker enabled on your browser. Please check if the pop-up

blocker is preventing the download from appearing, and then try again. 

"Account doesn't appear when using NetSuite’s reconciliation feature (Match Bank

Data)"

It looks like the account you're trying to use isn't appearing when you use NetSuite's

native bank reconciliation feature, Match Bank Data.

This usually means the account isn't configured for reconciliation in your Chart of

Accounts. You'll need to edit the account settings to enable the reconciliation feature. 

1

2

3

4

Go to Setup -> Accounting -> Chart of Accounts

For the account you need to reconcile, select Edit.

Check the box labeled Use Match Bank Data and Reconcile Account Statement

pages.

Click Save.

After following these steps, the account should now be available when you use the

Match Bank Data feature.



"Manual Match Bank Data Import Failing: The file could not be imported because the

date is not in the correct format."

If you are running into this error message when completing a manual import, select

NetSuite BAI2 as your Export Format instead. 

Select NetSuite BAI2

Common Questions

This list provides answers to common questions that arise when using the Cash

Management (Information Reporting) features in NetSuite. 



Why is my plugin no longer connected in the Production environment?

If you are logged in and the plugin is no longer connected, the NetSuite Production

may have been refreshed. You will need to re-establish this connection. 
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Log in to Production

Log in to  and run through the wizard again. sys.fispan.live

Deactivate Plugin

If the plugin is still showing as Active or Connected, click on the three dots and

select Deactivate.

If you have updated from a Bank plugin version that is older than 2022.2.0, the

updated plugin bundle will come with a premade Integration Record. 

Define New Token

On the Creating a New Security Token step, you will need to define a new Token

ID and Token Secret. 

Please refer to 'Create a New Security Token in the NetSuite -> Plugin Setup ->

Installation section of this support site for instructions on how to do this.

Revoke Old Tokens [OPTIONAL]

After creating the new Access Token, you may revoke the old ones associated

with this bank bundle. 

You can do this by following the steps below:

Navigate to the homepage.

Find the Settings box on the homepage. By default, this is located on the

bottom left.

Click on Manage Access Tokens.

Click Edit beside the Token you wish to revoke.

Click Revoke.

https://sys.fispan.live/login


Why is my plugin no longer connected in the Sandbox environment?

If you are logged in and the plugin is no longer connected, the NetSuite Sandbox may

have been refreshed. You will need to re-establish this connection. 
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Log in to Sandbox

Log in to  and run through the wizard again. sandbox.fispan.cloud

Deactivate Plugin

If the plugin is still showing as Active or Connected, click on the three dots and

select Deactivate.

If you have updated from a Bank plugin version that is older than 2022.2.0, the

updated plugin bundle will come with a premade Integration Record. 

Define New Token

On the Creating a New Security Token step, you will need to define a new Token

ID and Token Secret. 

Please refer to Create a New Security Token of the NetSuite -> Plugin Setup ->

Installation section of this Support Site for instructions on how to do this.

Revoke Old Tokens [OPTIONAL]

After creating the new Access Token, you may revoke the old ones associated

with this bank bundle. 

You can do this by following the steps below:

Navigate to the homepage.

Find the Settings box on the homepage. By default, this is located on the

bottom left.

Click on Manage Access Tokens.

Click Edit beside the Token you wish to revoke.

Click Revoke.

http://sandbox.fispan.cloud/


Why is the Manage Access Tokens link not visible in the Settings box on the Home

Page?

This is likely the result of Token-Based Authentication not being enabled on this

NetSuite Company. 

Please refer to Configure NetSuite Feature of the NetSuite -> Plugin Setup ->

Installation section of this Support Site for instructions on how to enable.

Will I receive an error message if the bank feeds do not import?

No, the plugin itself does not send email notifications or support push notification

messaging. However, the NetSuite admin who set up the bank feeds for clients in

NetSuite can receive email notifications from the native NetSuite account regarding

successful import or failure. Please contact your NetSuite administrator to resolve the

issue.

For multi-entities, can the company name be unique per bank account?

Yes. Contact your bank and ask them to enter a unique Account Holder Name for each

bank account using the details you provide. If there is an entry in the Account Details -

> Account Holder Name field, this name will appear on vendor payments; otherwise, it

will default to the Account Label (i.e., Company Name).

For example, if the umbrella company is ACME Holdings, the name on the payments

would appear as coming from ACME North or ACME South, etc., based on the bank

account used for the payment.

Accounts Payable

Common Errors

Below is a list of common errors encountered when using the Accounts Payable features in

NetSuite. Click on any error message to view the cause and immediate troubleshooting

steps for a resolution.



"You have entered an Invalid Field Value [###] for the following field: [account]."

This is an error generated by NetSuite when the subsidiary on the payee (i.e. Vendor)

does not match the subsidiary the bill is associated with. 

Users are recommended to use the Subsidiary filter on the Pay Vendor Bills page

when paying bills to a specific subsidiary.

Using the Subsidiary filter will also filter out Source Accounts that users want to use

for bill payments in the Confirm Payment window during the final step of making a

payment.

"There seems to be a communication error with the Bank API."

This error can be seen on various pages in the bank bundle, such as the Pay Vendor

Bills page.

This error is likely caused by Multiple Currencies not being enabled on this NetSuite

Company. To confirm whether this is the case, please refer to Step 7 of the NetSuite -

> Plugin Configuration -> Installation and Set-up section of this Support Site for how

to enable this. 

If Multiple Currencies is already enabled, please check the NetSuite Execution Logs by

following the steps below:
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Navigate to Customizations -> Scripting -> Script Execution Logs

Select ALL in the LOG LEVEL filter

Click the DATE/TIME column to reorder the table so that the most recent logs

appear at the top.

Check the SCRIPT and DETAIL columns to see whether the error is related to the

bank bundle and where specifically the error occurred.

If the error appears to be related to the bank bundle, please reach out to support with

a screenshot of the above Script Execution Logs.



Payments not batching

If you see this error, batching may not be enabled. Get in touch with a support agent to

check this for you. 

Address/Location errors when making payments

The Address must appear on both the Bill and the Vendor. If you have updated the

Address on the Vendor already, NetSuite does not automatically update the address on

any open Bills for that same vendor. 

You must go into the open bill(s) and update the address:
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Go to the Bill record

Click the Billing subtab

Select the Vendor address in the Vendor Select dropdown field

Click Edit

Click Save

"Payment request rejected because it failed uniqueness check. We suspect this is a

duplicate payment."

You're seeing this error because you're attempting to process a payment for a bill that

has already been paid using the plugin. Essentially, there is already a payment

recorded against that bill's NetSuite Internal Bill ID. The system is preventing a

duplicate payment.

If you need to void the existing payment and then resubmit it, you must follow a

specific process through the bank plugin. Please refer to the Voiding and Repaying

Bills page within the NetSuite -> Vendor Payables section of this support site for

detailed instructions on how to properly void and repay the bill.



Custom records are not enabled

The bank payment plugin relies on Custom Records to function correctly. We use a

custom record to create and track the bill payment record for you.

If this feature isn't enabled, the plugin cannot create that necessary custom record.

This prevents us from correctly marking bills as paid, which ultimately stops you from

using the plugin altogether.

Enable this feature by following these steps: 
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Hover over Setup

Hover over Company

Click Enable Features

Click the Suitecloud tab

Go to the SuiteBuilder section

Check the Custom Records box



"Please enter value(s) for: Department, Location."

This is an error generated by NetSuite when there is a mismatch between the

mandatory fields required for a Bill in comparison to a Payment. The error may appear

if you try to pay a bill under a different subsidiary than your source (disbursement)

account.

To resolve this, follow these steps:

1 Go to Transaction Forms

Navigate to Customization → Forms → Transaction Forms. 

Navigate to Transaction Forms

Click Edit beside the Bill form you typically use and that is marked as Preferred.







2

Click "Edit" for a Preferred Bill form

Locate Department and Location

On the Custom Transaction Form page for the selected Bill form, click on the 

Screen Fields → Main sub-tabs. 



3

Department and Location fields on Bill form

Find the Department and Location fields and make note of whether they have 

Show and/or Mandatory enabled. 

If Department and Location cannot be found under the Screen Fields list, check

the Sublists sub-tab.

Match Bill Form and Bill Payment 

Navigate back to the Transaction Forms page, and click Edit beside the Bill

Payment form you typically use and that is Preferred. 



Click "Edit" on a "Preferred" Bill Payment form

On the Custom Transaction Form page for the selected Bill Payment form, click

on the Screen Fields → Main sub-tabs. 

Like with the Bill form previously, find the Department and Location fields.

Check if Show and/or Mandatory is enabled and whether they match the Show

and Mandatory selections on the Bill form.



Department and Location fields on Bill Payment form

Make the appropriate changes on the Show and Mandatory fields on 

Department and Location on the Bill Payment form to match the same field

selections for Show and Mandatory fields on Department and Location on the

Bill form.

Common Questions

This list provides answers to common questions that arise when using the Accounts

Payable features in NetSuite. 

Can I pay multiple invoices in one payment rather than making a payment for each

invoice?

Yes, you can enable this feature by going into the Vendor, selecting Edit, and ticking

the box for Group Bills for Payment under the Bank tab. This feature will group all

selected bills for a single vendor into one lump sum payment.



Why does the Payment Status of a failed bill stay as Processing?

This Processing status can take between 3 to 4 business days to clear, even if the bill

payment has failed. If the bill appears again on the Open Bills tab on the Pay Vendor

Bills page, you may safely retry this bill payment. 



Why is my bill still open in NetSuite even though I processed the payment and

received no error message?

If your bill remains open after payment, check these potential causes:

The required bundles, either the Entity Bank Details bundle (ID 323878) or

NetSuite's Electronic Bank Payments bundle, may not be installed. Verify their

installation status.

Your current role might lack the permissions needed for the bank plugin or

associated scripts. See the Plugin Access Management and NetSuite Role

Permission steps in the NetSuite -> Plugin Setup -> Installation section of our

website.

You may be attempting to pay a bill that is locked because the relevant

Accounting Period has already been closed.

To find out if the bill/account is locked:

1

2

3

Open the bill in question

Click the Open Bills tab

The bill will have a lock symbol on the top left corner if the bill is locked,

If the relevant Accounting Period is closed, you should reopen the Accounting Period

by following these steps:

1

2

Go to Setup -> Accounting -> Manage Accounting Periods

Click Edit on the Accounting Period and enable the Allow Non-GL Changes 

option.

Your AP team might have some internal controls over the above Accounting Period

steps. 

Please refer to the Failed Bills page on the NetSuite -> Troubleshooting section of this

support site for more details.



How do I store my vendor payment information?

Download our free NetSuite bundle, Entity Bank Details (ID 323878). If you cannot find

it on the Search & Install Bundles page, please reach out to our support team as you

may need to be whitelisted.

Why doesn't my account appear in the Source Account drop-down menu on the Pay

Vendor Bills page?

Applying this Subsidiary filter on the Pay Vendor Bills page impacts what Source

Accounts are available, as the Source Accounts must be tied to the selected

subsidiary. If no Source Accounts are linked to this subsidiary, no Source Account will

be displayed. 



2.4.2. Failed Bills (NetSuite)

This article serves as a resource to assist you in resolving error messages or issues that

may arise with failed bills.

Error Messages

Why does my Vendor Bill remain open after payment with no error message?

This usually happens when the bill is tied to an Accounting Period that was locked

before your payment plugin was installed. The plugin is designed to respect pre-

existing locks.

Solution:

1

2

3

Go to Setup -> Accounting -> Manage Accounting Periods.

Click the closed period associated with the bill.

Check the Allow Non G/L changes box and save. This action permits the

payment execution without opening the period for general ledger changes.

Vendor Bills that are associated with an Accounting Period that is locked after the

plugin has been installed will not be impacted.

"Payment request rejected because it failed the uniqueness check. We suspect this

is a duplicate payment."

This occurs when a Bill Payment was previously applied and then manually voided in

NetSuite. NetSuite will allow you to change the data fields on the Vendor Bill, but will

not allow you to change the system-generated Bill ID.

Solution: You must create a brand-new Vendor Bill to process the payment through

the plugin.



"Please enter value(s) for: Department, Class, Location, …."

There is a discrepancy between the mandatory fields required on your Vendor Bill form

and the fields required on your Bill Payment form. NetSuite needs them to match.

Solution:

1

2

Go to both the Vendor Bill and Bill Payment forms and click Customize (top

right).

Ensure that the mandatory requirements for all fields (under Screen Fields and 

Sublist Fields), like Department and Class, are identical on both forms.

Alternatively, remove the mandatory requirement for these fields entirely on both

forms.

"Payment with overridden address cannot be processed. Please update the billing

address fields while the override checkbox is unchecked in all the bills to be

processed for this vendor."

The vendor's address has the Override checkbox enabled on the Vendor record.

Solution:

1

2

3

4

Navigate to the affected Vendor record.

Find the Address sub-tab and click the pencil icon next to the address.

Uncheck the Override checkbox in the pop-up and Save.

If the payment still fails, open the affected Bill, click Edit, and re-select the newly

saved address under the Billing sub-tab to refresh the bill's reference. Save the 

Bill and retry the payment.



"Last attempt failed to deliver with error: FuseException: Failed to send payment

status update to Netsuite with a 400 Response: ... "FAILED_BILL_PAYMENT_VOID",

"message" ... Please enter value(s) for: field "

The payment failed, and the plugin couldn't successfully void the transaction because

a field  (usually the Memo) is marked as mandatory on the underlying Journal Entry

form.

Solution (Modify Journal Form): 

1

2

3

4

Go to Customization -> Forms -> Transaction Forms.

Find and Edit your preferred Journal form.

Click the Screen Fields sub-tab.

Find the field  listed in the error (e.g., Memo). Uncheck the Mandatory box

and click Save.

"The bills you submitted have already been paid through the system. Please contact

support if you need to resubmit these bills for payment."

The system recognizes the bill(s) as previously paid and already having a status of

pending or completed. The system will reject the new request to prevent accidental

duplicate payments.

Solution Options: 

Submit a detailed ticket (reference the vendor, bill ID, amount, and time of the

blocked payment) to the support team. The support team can correct the status

of the previous payment, allowing you to resubmit.

If you need an immediate solution, create a copy of the blocked bill and submit

the new copy for payment.



"You have entered an Invalid Field Value XX for the following field: Account."

This error occurs when the bill(s) selected for payment are linked to a subsidiary that

differs from the subsidiary linked to the NetSuite account used for the payment

attempt.

Solution: To resolve this error, you will need to ensure that the subsidiaries for both

the bills and the NetSuite account match during their payment run.

"You have entered an Invalid Field Value XX for the following field: XXX"

In other cases, where the Account is not mentioned, the error is typically linked to a

specific field on the bill (e.g. you have entered an invalid field value for: Class,

Location, Department, etc). In such cases, the Class, Location, and Department 

inputted on the bill is currently marked as Inactive in NetSuite. NetSuite will prevent

the successful payment of a bill where something inactive has been entered on the bill.

Solution: To resolve this issue, you will navigate to the Class, Department or Location

pages (depending on the error) in NetSuite, click Show Inactive, and temporarily mark

the Class, Department, or Location listed on the bill active (by unchecking the 

Inactive box). Upon saving the changes, the customer can re-process their payments

and then reset the information as Inactive again afterwards. There is no way around

this error, even if the customer opts to no longer show the Class, Location, or 

Department field on their bill, as NetSuite will still store this information on the bill,

producing the same error again.

"You have entered an Invalid Field Value XX for the following field: Vendor."

In this case, NetSuite is preventing payment because the vendor is currently marked

as Inactive.

Solution: To resolve this, simply uncheck the Vendor is Inactive box on the vendor

record to make the vendor active again and retry the payments.



2.4.3.
NetSuite Approval Limitations
(Informational)

NetSuite has a workflow system for creating approvals that may cause issues with the

plugin. Approvals can occur at different stages in the lifecycle of a bill and payment. 

Generally, the Bill Approval workflow is supported by , while the Payment Approval

workflow is NOT supported. Having a Payment Approval workflow will result in a failed bill

payment. Additionally, support for Vendor/Employee Change Approval workflow depends

on your specific configuration. Typically, this workflow might block the Entity Bank Details

Approval functionality.

FISPAN

Unsupported Approvals

Payment Approval Workflow

This approval workflow is NOT supported by  and will result in failed bill payments.

This payment approval flow requires someone to approve each payment, based on rules or

configuration set up in NetSuite.

FISPAN

Why? Without a payment approval workflow, two things happen behind the scenes when a

payment is submitted:

The payment request is sent from NetSuite to the bank for processing.

A Bill Payment is created, marking the bill as Closed. Custom fields on the bill are

updated with the latest payment status information.

However, if the payment approval is set up, the plugin is blocked from creating a bill

payment record in NetSuite, resulting in a failed bill payment. 

NOTE: This page is for informational purposes only and should not be used as a

guide to make changes to the configuration of your NetSuite environment. For

support with your NetSuite native approval flows, please reach out to your NetSuite

consultant directly.



Vendor/Employee Change Approval Workflow

Some clients may have customizations or workflows related to vendor/employee creation,

deletion, or modification. These customizations/workflows may conflict with our Entity

Bank Details Approval functionality, preventing approvers from approving or rejecting

changes made to Entity Bank Details records.

TIP: To identify if your workflow is impacting the plugin, we recommend testing our

plugin functionality in your up-to-date Sandbox environment. This will help determine

if your current vendor/employee change approval workflow affects the plugin.



2.5.Release Notes

2.5.1. Release Notes (NetSuite)

The NetSuite plugin releases updates to the ERP bundle with new fixes, features, and

improvements. To learn how to update your bundle visit: Updating the SuiteApp (NetSuite)

Coming Soon!



2.5.2. Entity Bank Detail Release Notes

To learn how to update the Entity Bank Details bundle visit: Update Entity Bank Details

Bundle

Coming Soon!



3. Intacct

3.1.Plugin Setup



3.1.1. Pre-Onboarding Checklist (Intacct)

Prior to joining an onboarding call, please follow the steps below to ensure that the

installation process runs smoothly. Any missed steps may result in the onboarding call

being cancelled and rescheduled to a later time. 

Bring a Sage Intacct Administrator

Our onboarding calls require a Sage Intacct Administrator to be present, as they will need

to enable a number of settings, create a web service user, install the plugin, and assign

various permissions.

Enable Platform Services

Ensure that the Platform Services module has been enabled on your Sage Intacct

environment. This module allows third-party applications, such as the  to

be installed in your Sage Intacct environment. 

Goldman Sachs

The administrator of the ERP should see Platform Services on the menu bar. 



Platform Services enabled

If an administrator is not able to see Platform Services, please contact your Sage Intacct

Account Manager to enable Platform Services on your account. You will not be able to

onboard on the plugin without the Platform Services module. 

Enable Web Services Users

Enabling the Web Services feature on your Sage Intacct account is required to allow the

plugin to communicate with your Sage Intacct environment. 

1 Go to Company → Admin tab → Subscriptions.



2

3

Go to subscriptions

Confirm that Web Services is enabled, then select Done. 

If they are not, select the toggle to enable Web Services. 

Green toggle indicating that Web Services is enabled



Enable Banking Cloud

To utilize the Bank Feeds product, the Banking Cloud will also need to be enabled. 

1

2

3

4

Go to Company → Admin → Subscriptions. 

Confirm that Sage Cloud Services are enabled. If they are not, select the toggle to

enable Sage Cloud Services.

After enabling Sage Cloud Services, hit Configure, and confirm that the Enable Bank

Feeds functionality is checked.

Enable Bank Feeds

Then select Save.

Enable ISO Country Codes



1

2

3

Go to Company. 

Under the General Information section, confirm that ISO Country Codes is checked.

Enable ISO Country Codes

Select Save.

Disable Payment Approvals Inside Intacct 

The plugin does not support Payment Approvals inside Intacct. If you leverage Intacct's

payment approval currently, we strongly recommend moving that process inside the bank

approval portal. 

Continuing to use that process increases the chances that a bill stays open inside Intacct

even though it has been paid already. Navigate to the Intacct Approval Process

(Informational) section of the product guides for more information. 

Confirm Sandbox Testing



All users moving into Production can test the bank plugin in a Sage Intacct Sandbox

environment alongside any customizations or third-party plugins, or applications. This will

ensure a smoother transition onto the bank plugin and help avoid any future disruption to

service.

Please refer to the Sandbox Checklist (Intacct) page for a number of suggested scenarios

to test.

Review Custom Fields

The plugin requires at least 14 custom fields to be available to install within Intacct. Please

ensure you have at least 14 available custom fields to successfully install the plugin. 

This requirement is due to Intacct's limit of 100 custom fields. If further support is needed

in identifying which custom fields can be removed, clients should reach out directly to their

Sage Consultant. Their consultant can provide guidance on the purpose of each field and

whether it can be deleted. 

To review your current custom fields:

1

2

3

Navigate to Platform Services -> Custom Fields

Check the existing fields under Object: AP Bill.

Identify any unused or redundant fields that can be deleted.

Support for Console Environments

TIP: Speak with a  if you do not wish to enable a Sage Intacct

Sandbox environment.

TxB Representative

NOTE: After completing the prerequisites, proceed to Step 1 in the installation guide

to begin installing the plugin.



The plugin's full functionality is not currently guaranteed for clients operating within a

Multi-Entity Distributed Console or any form of console environment. 

Confirm Hardware & Software Requirements

Browser support (minimum versions):

Chrome: 65

Firefox: 66

Safari: 12

Edge: 79

Operating systems (minimum versions):

Windows 7

macOS - El Capitan

Minimum screen resolution:

1200x800px



3.1.2. Installation

3.1.2.1. Step 1: Enable Web Services

To get started, please contact your Sage Intacct Account Manager to enable Platform

Services on your account. 

Once you have done so, follow the steps below to enable the Web Services feature on your

Sage Intacct account. This is required by Intacct to install a third-party application.

1 Go to Company → Admin tab → Subscriptions.

Go to Subscriptions



2 Confirm that Web Services is enabled, then select Done.

Select Web Services



3.1.2.2. Step 2: Invitation Email

You should have received an invitation email from  with links to install the 

 and easy-to-follow instructions for installation.

Goldman Sachs

Goldman Sachs

The invitation email will arrive with the following subject line:

Welcome to   - Powered by FISPAN [Production] - [your-name]Goldman Sachs



3.1.2.3. Step 3: Registration & Login

Register & Login

1

2

Create an Account

In your invitation email, select the Get Started button. You will be brought to the 

. Create your login credentials and select Create Account.FISPAN Portal

Passwords are required to be 8 characters and contain at least one uppercase,

lowercase, number and special character

Login to Your Account

Once registered, you will be redirected to the login page. Your username and

password are unique per environment, and you will have separate logins between 

 and .Sandbox Production

NOTE: The password you create here will be used every time you want to

access the . If you need to update it later on, you have the option

to use the Forgot Password option.

FISPAN Portal

https://sandbox.fispan.cloud/login
https://sys.fispan.live/login


Welcome Page for Sandbox

From the welcome page, you'll be taken to the login page. Enter your username and

password to proceed. 

Setting Up SMS MFA

The first time you log in to the Production environment, you will be prompted to establish

your Multi-factor Authentication (MFA) setup. You have the option to select various

methods of MFA. 

1 Enroll Phone Number

NOTE: The Sandbox environment is used as a testing or UAT environment. For

Sandbox users, please refer to the Sandbox Checklist for test scenarios.

NOTE: Multi-factor Authentication (MFA) is only required if you are a user in the

Production environment. If accessing the Sandbox environment, you may skip this

step.



2

3

Select your country code then enter your phone number, you will receive a text

message with a 6-digit code via SMS to the phone number you provided for

enrollment.

If you are unable to receive a text message to this number, or you prefer a different

multi-factor authentication method, click Try Another Method. 

Enter Code

Enter the 6-digit code you received in the applicable field.

Select Continue.

6-digit Verification

Save Recovery Code

After setting up SMS and inputting the first one-time code, you will be presented with

a recovery code that should be stored in a safe location. This code is for resetting the

MFA, to switch the MFA type (i.e., Authenticator), or to use a different phone number. 



Recovery Code

If you would like to utilize another method for MFA (SMS, Authenticator, or Email)

instructions are available here: . Setting up Multi-Factor Authentication



3.1.2.4. Step 4: Select ERP

Select Install on the Intacct ERP box and the installation wizard will appear on your screen. 

Select Install



3.1.2.5. Step 5: Overview

The first page of the installation wizard provides a brief summary. Before you continue, you

must review and complete the pre-onboarding checklist.

When you're finished, click the toggle next to "I have completed the pre-onboarding

checklist." This will activate the Get Started button.

To proceed to the next step, click Get Started.

Select Get Started



3.1.2.6. Step 6: Permissions

To establish a connection between your bank and Sage Intacct, you must agree and grant

access by toggling the slider. 

Review the Permissions and then click the "I agree" toggle

Once completed, click Next.

To display account balances and transaction information, the plugin requires read access

to Intacct financial data but only modifies its own designated custom fields.

NOTE: Your permission list, found in your ERP, may contain more fields than the

example shown.



3.1.2.7. Step 7: Web Services Authorization

Authorization to the Web Services feature should be done in Intacct using the following

steps.

1

2

Go to Company

Company → Setup → Company.

Go to Company tab

Authorize Web Services

Under the Security in the Web Services Authorizations section, click Edit at the top

right and then click Add to add each of the following Sender IDs:

ajax

FI.SPAN MPP



Add Sender IDs

Then, click Save.

NOTE: The Sender IDs are case-sensitive.



3.1.2.8. Step 8: Create Web Service User

To ensure that the plugin is able to communicate with Sage Intacct, a Web Service User

needs to be created in Intacct before continuing with the next step. 

1

2

Go to Web Service Users

Go to Company → Admin tab → Web Service Users.

Go to Web Service Users

Add New Web Service User

Select Add to create a new Web Service User, then fill in the required fields:

User ID: Anything that will help you easily identify your users.

User type: Business

Admin Privileges: Full

Contact Name: Associate this Web Services User with a Contact of your

choosing 



Create Web Service User

Please note that the Contact selected within the Contact Name field must have a

First and Last Name. 

If you do not already have a Contact to choose from, you may create one by clicking

on the drop-down, then Add.

NOTE: An alert will appear, stating: "Check license availability before adding

users." 

It is recommended to validate this with your Sage Intacct representative.



Add a Contact, if one is not available

After clicking Add, fill in the following fields on the Contact Information tab of the

Contact Information window:

Last name

First name

Primary email address

Suggested contact name

Print as



3

Contact Information window

Then, click Save.

Complete Web Service User Form

On the Web Services user information page, the following fields will be auto-

populated from the chosen or newly created Contact.

Last Name

First Name

Email Address



Completed Web Services User form

Then, select Save.

NOTE: You will receive an email from Sage Intacct with the credentials. We

recommend saving the Web Service User credentials as they are required in the

installation wizard. 



3.1.2.9.
Step 9: Enter Web Service User
Credentials

Return to the installation wizard and type in the credentials you received in the previous

step. 

Enter Credentials

Then, select Next Step.

IMPORTANT: Please make sure you use the Web Service User credentials and not

the Sage Intacct login (normal user) credentials. 



3.1.2.10. Step 10: Install Plugin

This next step guides you through installing the plugin with the installation wizard.

1

2

Install the Plugin

Select the Start Automatic Install button. 

Install the Plugin

This will automatically install the plugin for you. 

If the installation fails, a clear reason for the failure will be provided.

Occasionally, the application may fail to install due to the unavailability of Sage

Intacct servers. 

In such cases, we recommend a manual installation by downloading the XML file

from the error page and then placing it inside Intacct's Platform Services →

Applications → New Application.

Successful Install



After the application has been successfully installed, click on Next Step.

Manual Install

If automatic installation fails, you can manually install the plugin by downloading the plugin

XML file using the link in the installation wizard. 

1

2

3

Download XML File

From the error page displayed in the installation wizard, select here to download the

XML file.

Once the XML file pops up, save it to your computer. 

Go to Applications

In Intacct, go to Platform Services →  Applications.

Go to Applications

Install From XML

Then, select Install from XML.



Select Install from XML

Upload the application XML file by selecting Choose File. 

Select the XML you just downloaded from the installation wizard, and click Install.





3.1.2.11. Step 11: Set Permissions for a Role

In Intacct:

Go to Company → Admin tab → Roles.

Go to Roles

On the role, Select SubscriptionsGoldman Sachs



Select Goldman Sachs



Select Permissions to enable permissions accordingly for each of the following:

Cash Management: Checking Accounts (List, View), Savings Accounts (List, View),

Credit Card Accounts (List, View)

Accounts Payable: All Permissions

Company: Transaction Currencies (List, View), Entities (View), Funds/Locations (View)

General Ledger: All Permissions

If you do not use roles inside Intacct, simply head over to the users and web service

user, click Subscriptions, and grant them the following permissions: 

List of web services users

Cash Management: Checking Accounts (List, View), Savings Accounts (List,

View), Credit Card Accounts (List, View)

Accounts Payable: All Permissions

Company: Transaction Currencies (List, View), Entities (View), Funds/Locations

(View)

General Ledger: All Permissions

: All PermissionsGoldman Sachs



: All PermissionsGoldman Sachs

Then, select Save.

Select Permissions

If you receive an error message, please confirm that you have granted the

appropriate Cash Management permissions to the Web Service User’s role subscription.



Account Matching - "Error loading bank accounts" error message

You may receive an error like the following: "You do not have permission for the API

operation READ_BY_QUERY on objects of type trxcurrencies."



You do not have permission for the API operation READ_BY_QUERY on objects of type

trxcurrencies. 

This error means you need to adjust the role permissions for the user who encountered the

issue. This affects the user role/permissions and NOT the Web Service User. 

For the affected user, please navigate to their role permissions and add the following:

Company → Transaction Currencies (List, View).



Adding Transaction Currencies permissions



3.1.2.12.
Step 12: Assign Role to Web Service
User

In Intacct, go to Company → Admin tab → Web Service Users. 

Go to Web Service Users

Then, select Edit on the Web Service User you would like to edit.

Under the Roles Information tab, add the following roles:

::SYS::Enterprise-ROLE-FOR – Module: Goldman Sachs

Then, select Save and enter your account password.



Add Role to Web Service User



3.1.2.13. Step 13: Assign Role to User

In Intacct, go to Company → Admin tab → Users. 

Go to Users

Then, click Edit on the User you would like to edit.

Under the Roles Information tab, add the following roles:

::SYS::Enterprise-ROLE-FOR – Module: Goldman Sachs

Then, select Save and enter your account password.





3.1.2.14. Step 14: Connection Status

Here, the installation wizard will begin to run a connection check to validate all details

entered in the previous steps and ensure that all permissions are correctly set up.

If there are no issues, a large green checkmark will appear to confirm that the connection

has been established. 

Connection Status

Click on Next Step to begin matching bank accounts.

Failed Connection Checks

If any permissions are missing, a red X will be displayed, as shown in the screenshot

below, along with a clear explanation of the failure.



Failed Connection Check



3.1.2.15. Step 15: Account Matching

Matching Accounts
The next step in the installation wizard is to match your ERP Accounts to the corresponding

Bank Accounts.

1

2

Match Accounts

Drag an ERP Account from the left column and drop it onto the desired Bank Account.

Continue until all accounts are matched.

Select Default Account

To select your preferred default account, hover over the desired source account and

click the star icon. This sets the default selection in the source account dropdown

(you can change it anytime in the Account Matching screen here).

Account Matching - ERP Accounts and Bank Accounts 

Once you've successfully matched your accounts, click Next Step.



NOTE: When installing the plugin in Sandbox, the Bank Account ending in 1133 is

used for testing purposes ONLY. This account is not linked to any of your live

accounts with your bank. 

When installing in Production, the Bank Accounts listed will reflect your accounts set

up for use with the plugin.



3.1.2.16.
Step 16: Set Default Payment
Information

Setting a default payment method per vendor will save you significant time by

automatically pre-filling the payment type for all future transactions.

Use the steps below to select a default payment method for each vendor.

1

2

﻿In Intacct, go to  → Payment Methods.﻿Goldman Sachs

Go to Payment Methods

Select the appropriate payment method from the Default Payment Method dropdown

menu.



Select a Default Payment Method

NOTE: You will only see the payment methods currently configured for both

your plugin and the specific vendor. If a payment method is missing from the

list, you must either add it to the vendor record or contact your 

 to have it added to the plugin setup.TxB Representative



3.1.2.17. Step 17: Store Vendor ACH Information

The plugin uses the Bank File fields when submitting ACH payments to vendors. The

instructions below show you how to enter this required information for your existing

vendors.

Before you begin, ensure you have permission to edit vendor bank details:

1

2

3

4

Go to Company → Admin tab → Roles. 

Then, select Subscriptions on the role you would like to edit. 

Select Permissions on the Accounts Payable Module, and check all the boxes

for Vendors (This includes List, View, Add, Edit, Delete, and Bank Details). 

Then, select Save.

Enter Vendor ACH Information

1 Go to Vendors

Navigate to Accounts Payable → Vendors and select Edit for the desired vendor.



2

Go to Vendors

Enter Vendor Details

Under the Vendor tab, enter the Vendor’s Address, City, State, Zip Code,

and Country.

Enter Vendor Details



3

4

Enable ACH Payments

Select the Bank file tab to access the vendor ACH information.

Scroll down to the Enable Setup section and select Enable ACH Payments.

Add ACH Information

The ACH Payments section will appear. Enter the Routing Number, Account

Number, Account Type, and Account Classification. 

Enter ACH Payment Information

Then, select Save. ACH will now be an available payment method for that vendor.



IMPORTANT: When you first begin using the plugin, it automatically syncs the

vendor's default payment method from the native Intacct record, but only if the

method is set to ACH or CHECK. The plugin also ensures this default is synced

when you create a new vendor.

In all other cases, the plugin will NOT be syncing the default payment method.

If you would like to change the default, follow the previous step, "Set default

payment information." This default can also be updated via CSV in a single

upload for all your vendors. 



3.1.2.18.
Step 18: Store Other Vendor Payment
Information

If applicable, you can add additional payment information within the plugin's Payment

Methods page by following the steps in this guide.

Only payment methods set up in your plugin and assigned to the specific vendor will be

visible. If a method is missing, please add it to the vendor or reach out to your 

 to have it added to the plugin.TxB Representative

Store Vendor Payment Information

Follow these steps to start storing any additional vendor payment information.

1 Go to Payment Methods 

In Intacct, go to  → Payment Methods tabGoldman Sachs

Go to the Payment Methods Tab



2 Add Bank Account

Select Edit on the vendor for which you would like to add payment information. Here,

you can choose to Add Bank Account, Add Address, or Add Email Group.

Vendor Details Panel

Click Add New and select Bank Account.

Here, you will see another pop-up window that will prompt you to enter a Country

and Currency.
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Selet Country and Currency

Enter the Country and Currency for this vendor, and click Continue to Details.

Add Account Details

On the Account Details pop-up, you will be prompted to fill in several fields. Please

refer to the Payment Requirements section of this Product Guide for required fields,

depending on the payment method you wish to use to pay your vendor.
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Enter Bank account details

Validate Payment Rail Eligibility 

After filling in the required fields or additional fields provided by your vendor, click 

Validate Payment Rail Eligibility.

The system may take a minute or two to validate your inputs. 

The system will verify that the information is formatted correctly for the available

payment types.

Once validation is successful, click Save Account. The new account will then appear

in the Bank Accounts list.

NOTE: Depending on the country and currency selected, as well as the number

of fields completed on the Account Details screen, you may be eligible to pay

the vendor using various payment methods. 
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Payment Rail Validated

Select Default Payment Method

Here, you can define a default payment method for this Vendor by clicking on the

dropdown for the Preferred Payment Method field.

Vendor Details Panel



Any changes to toggles (i.e., Combine Multiple Invoices) or the Default Payment

Method dropdown on the Payment Methods page are saved automatically.

Payment Methods Page

TIP: The plugin supports importing vendor payment information via CSV,

allowing for immediate mass updates across all vendors. Use the Updating

Vendors via CSV guide for more information.



3.1.2.19. Step 19: Enable Bank Feeds (Intacct)

By enabling Bank Feeds for the plugin, your bank establishes a reliable and secure flow of

transactions from your bank into Sage Intacct’s Reconciliation module.

Bank transactions that settled the previous day are imported each morning. For example,

transactions that are settled on Tuesday will be pushed into Sage Intacct early on

Wednesday morning. The exact timing can vary depending on when your bank sends the

first transaction file (PDR).

Step 1: Locate the Account

Go to Cash Management → Checking.

Go to Checking

On the Checking page, select Edit on the account you wish to turn on Bank Feeds for.



Select Edit

Step 2: Activate Bank Feeds

Under the Banking Cloud tab, click Connect.



Connect Banking Cloud

In the search bar, search  - Powered by FISPAN.Goldman Sachs

Search for Goldman Sachs

Note: The beta code is 559415.



Agree to conditions and select Continue. 

Agree to Conditions

You will be redirected to a landing page that will require you to sign in to the FISPAN

Wizard.

Select Login Now.



Select Login Now

Step 3: Match Account for Bank Feeds

After logging in, select the account from Step 1, then select Save and Finish. You will

automatically be redirected back to Sage.

Select Account



After being redirected back to Sage, select the same account and click OK.

Click Ok

Choose the date you want transactions to start from.

Choose Date



Step 4: Confirm Bank Feeds

Select Confirm to confirm the activation of Bank Feeds. Once the connection is

successful, the status will change to Connected.

Confirm Bank Feeds

NOTE: You must complete account matching within 60 minutes; otherwise, the

installation wizard will time out, the connection will fail, and the account will remain 

Pending with no transactions coming in. 

To retry, disable the account(s) under the Accounts table and reinitiate the mapping

process.

NOTE: If you are processing more than 100 transactions, we advise you to wait until

the next day to see the transactions posted.



Once the account is Connected, go to Cash Management -> Reconciliation -> Bank and

follow your native reconciliation process. 

Set Up Multi-Account Bank Feeds

Bank Feeds allows you to connect multiple accounts to the plugin. Once one bank account

has been connected to Bank Feeds by following the Enabling Bank Feeds page, other

accounts can be connected simultaneously through a financial institution connection.

Follow the steps below to set up multiple accounts for Bank Feeds.

1 Set up a Financial Institution

Go to Cash Management → Set up → Financial Institution and create a new

Financial Institution.

NOTE: If the account is in Pending status, it means that the transactions have not

been pushed for this account. You will need to wait until the transactions are

successfully pushed to this account before seeing it marked as Connected. 

NOTE:  Before you set up the Financial Institution, ensure that both Cash

Management and Sage Cloud Services are enabled in the Subscriptions section. In

the Sage Cloud Services configuration, confirm the Enable Bank Feeds checkbox is

checked as per the Enabling Bank Feeds page.

If this does not work, please contact Sage support and ask to get access to the

Financial Institution.
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Set-up Financial Institution

This allows you to create a connection to the bank. Create the ID and Name as

desired.

Create Financial Institution

Map Accounts for Bank Feeds



Select Map Accounts and choose which accounts you would like to enable on Bank

Feeds.

Map Accounts

If there are more than 100 transactions, the plugin will upload them into the system in

batches of 100. This may cause some transactions to appear initially, while others will

appear later. Typically, it takes a few hours to view all your transactions.

NOTE: You must complete account matching within 60 minutes; otherwise, the

installation wizard will time out, the connection will fail, and the account will

remain Pending with no transactions coming in.

To retry, disable the account(s) under the Accounts table and reinitiate the

mapping process.



Map Accounts

After mapping the accounts, the Banking cloud statuses can be seen in the Accounts

tab.

Account Status



To view your account information, click Bank Transactions in the Cash Management

module. You can also view this information through the Reconciliation module. 

Observe Bank Transactions



3.1.3. Post-Onboarding Checklist (Intacct)

You are almost ready to use the plugin. There are a few additional steps that are required in

order to use the product at its full potential. Follow this flow to make sure you are not

missing anything! 

1. Did you grant the right permissions to the other users of
the plugin?

If you want to give access to the plugin to someone else in your organization, follow 

,  and 

. This will ensure everyone who needs access is set up properly. 

Step

11: Set Permissions for a Role Step 12: Assign Role to Web Service User Step 13:

Assign Role to User

2. Do you have enabled all the payment methods that you
regularly use?

If you need more payment methods than what you see on the Pay Page, contact your bank

relationship manager. They are able to kick off the process of adding other payment

methods. That process is usually fast and painless. Do not hesitate to contact our support

team should you encounter any issues. 

Once set up, you will be able to add that information to the Payment Method’s Page for

each of the vendors you wish to pay with that new payment method. This is explained in

more detail in the following steps.  

3. Did you make sure the Check & ACH information stored
inside Intacct is accurate?

Sage Intacct native stores ACH and CHECK information. You are able to modify this

information by going into the vendor record. 

CHECK: you need a valid address on the vendor record. 

For Sandbox users, feel free to skip the steps that may not apply to your use case.

We strongly recommend following the . Sandbox Checklist (Intacct)



ACH: you need valid information inside Bank File on the vendor record. 

The plugin will offer ACH and CHECK options in the payment method dropdown if: 

Both methods have been enabled by the bank (see step 2)

There is sufficient information inside Intacct’s vendor record (see Step 3). 

4. Do you need to add additional payment information?

Are you looking to add other payment methods than CHECK & ACH? The plugin offers a

reliable way to store that information.

Navigate to  to find out how to add this

information. You are also able to add it via a simple CSV import (

). This takes minutes and updates all the records at once.

Step 18: Store Other Vendor Payment Information

Updating Vendors via

CSV (Intacct)

5. Did you set up your vendor's default payment method?

The last step in setting up your vendors is making sure they have a default payment

method enabled. You can do this manually by going into Plugin > Payment Methods > Hit

'Edit' on the right and select a default from the list of available payment methods. 

If you are looking at doing this via a CSV import, this is also possible. Follow similar steps

to what is explained in step 4 to make sure your vendors have default payment methods

set up in no time.

You are also able to mass import this information natively: 

.

Updating Vendors via CSV

(Intacct)



Select Default Payment Method

6. Did you add all your bank accounts to bank feeds?

If you would like to receive a daily push of bank transactions inside the reconciliation

module of Sage Intacct, we recommend setting up bank feeds. The setup process takes

minutes and allows you to set up all your accounts at once. 

Follow  for more information. Step 19: Enable Bank Feeds (Intacct)



3.1.4.Configuration

3.1.4.1. Updating Vendors via CSV (Intacct)

The plugin allows you to update their vendor payment information in bulk through CSV

files, eliminating the need for manual changes to each individual record.

You can use this process to edit existing vendor records, to add additional line items to

existing vendors, and to create new vendor records.

Keep in mind that information stored inside native Intacct cannot be updated in the plugin.

Export and Import Functionality

This functionality allows you to manage your vendor records through a two-part process:

Export and Import.

Export creates a file containing all your current vendor records.

Import allows you to update existing records by applying changes to your vendor data.

Always export first before you begin an import. This is the best way to ensure the CSV file

is structured correctly, as the row format changes depending on the type of data you are

working with.

You can re-import the same data multiple times to update existing rows, provided the ID

fields in the file have not been modified or changed.

Follow these steps to begin the export and import process. 



1

2

Navigate to Payment Methods

From anywhere in Intacct, you can navigate to the Payment Methods page. Click on

the  button and then Payment Methods.Goldman Sachs

Select Payment Methods

Export CSV

Click Export CSV. A CSV file containing all previously saved vendors is generated.



3

Select Export

The import from Intacct triggers a minimum of one row of data. There are three

different data types:

BANK ACCOUNT: Each vendor with a bank account creates a row with a

data_type of BANK ACCOUNT, allowing you to modify the vendor’s bank

account.

ADDRESS: Each vendor with an address record creates a row with a data_type

of ADDRESS, allowing you to modify the vendor’s address.

EMAIL: Each vendor with an address record creates a row with a data_type of 

EMAIL, allowing you to modify the vendor’s email.

Prepare the File for Import

IMPORTANT: The CSV is pre-structured for import functionality; do not modfiy

the column structures.

NOTE: Save a copy of this file for your records so you can easily re-import the

original if necessary.



Once you have exported the existing vendor information, create the import file

containing your revised vendor information by editing the data and adding new rows

if you are incorporating new vendors.

Do not remove any of the column headers or add additional columns; otherwise, the

import will fail.

Each of the three data types requires specific data fields. Use the existing records as

a guide to which columns require data, and be sure to follow the general rules to

avoid errors that prevent a successful import.

BANK ACCOUNT: To add a new bank account, add a row and enter BANK

ACCOUNT in the data_type column. 

ADDRESS: To add a new address, add a row and enter ADDRESS in the

data_type column. 

EMAIL: To add a new email, add a row and enter EMAIL in the data_type column.

Please do not fill in the email or address fields for these columns, and ensure that the

other columns are completed according to the guidance provided in the table below.



4 Fill the CSV Table

You need to use specific default_payment_method code values that correspond to

your payment rail types.

Since a vendor can only have one default account with a default_payment_method,

you must ensure the payment method you choose is compatible with the

corresponding data type.

Navigate to Payment Methods and check in the table which payment methods are

listed for a vendor.

Here is a complete list showing which payment rail types are supported by each data

type. Use only the payment rails supported by your plugin for this specific vendor.

CSV file - table rows

NOTE: Only one line entry per vendor can have the is_default_account set to Y.

Enter the default_payment_method for the default account address record.

Only one line entry per vendor can have the "is_default_account" set to "Y"



data_type Compatible default

payment_method(s) 

for this data type

Other rules

BANK

ACCOUNT

ACH

ACH_NEXT_DAY

CPA

BACS

SEPA

WIRE

EFT_AU

WIRE_AU

EFT_SG

WIRE_SG

WIRE_NZ

EFT_NZ

WIRE_ZA

EFT_ZA

INTERNATIONAL_WIRE

INTERNATIONAL_ACH

UK_FPS

Leave the email and address fields

empty.

ADDRESS CHECK Leave the bank account and email

fields empty.

EMAIL VCC Leave the bank account and

address fields empty

CSV file - table columns



Colum

n

Name

Allowable Values (CASE

SENSITIVE)

Notes

data_t

ype

Either: ADDRESS, BANK

ACCOUNT, EMAIL

Required Field

For BANK ACCOUNT, leave the email

and address fields empty. 

For ADDRESS, leave the bank account

and email fields empty. 

For EMAIL, leave the email and address

fields empty.  

id Internal ID Leave empty if adding a new payment

method. Do not modify the value if

modifying existing payment information.

erp_ve

ndor_i

d

Intacct vendor ID Required Field

Do not modify. This field protects against

duplicate records.

vendor

_name

Intacct vendor name

is_def

ault_a

ccount

Y/N Required Field

Can only have one default Y per vendor.

All others must be N. 

default

_paym

ent_m

ethod

Please confirm that they

are in capital letters (e.g.,

ACH, ACH NEXT DAY,

CHECK, INTERNATIONAL

ACH, INTERNATIONAL

WIRE, SEPA, VCC)

Anything from the list of available

payment methods. To see what is

enabled on the vendor, navigate to 

Plugin → Payment Methods and check in

the table which payment methods are

listed for that vendor. 

Any unsupported payment type will

result in the line failing to import. If you

would like to add some payment

methods to the plugin, please contact

your bank.



Colum

n

Name

Allowable Values (CASE

SENSITIVE)

Notes

is_edit

able

Y/N Required Field

For any new lines, please enter "Y". 

Do not modify an "N" and change it to a

"Y"; doing this may break the import. 

email_

addres

ses

Any email addresses, up to

5

Separate each email address with “,”

countr

y

ISO alpha-2 country

codes

Required Field For Bank Accounts

This field accepts upper, lower, and

mixed case values. Please enter the ISO

alpha-2 country codes format. The

import will error if the user enters the full

country name (i.e., New Zealand). 

curren

cy

Currency codes Required Field For Bank Accounts

Please enter the currency following the

currency code list. This field accepts

upper, lower, and mixed case values.

accou

nt_typ

e

CHECKING or SAVINGS Required Field For Bank Accounts

This field accepts upper, lower, and

mixed case values

accou

nt_nu

mber

Vendor's account number

institut

ion_nu

mber

Vendor's institution

number

transit

_numb

er

Vendor's transit number

https://www.iban.com/country-codes
https://www.iban.com/country-codes
https://www.iban.com/currency-codes


Colum

n

Name

Allowable Values (CASE

SENSITIVE)

Notes

routin

g_num

ber

Vendor's routing number

bank_

code

iban Two letter country code,

followed by two check

digits, and up to 35

alphanumeric characters

bic Vendor's BIC or SWIFT

code for the country and

bank

bank_

name

Anything

addres

s_line

Anything

addres

s_line_

2

Anything

addres

s_city

Anything

addres

s_state

_provi

nce

Anything

addres

s_post

al_Cod

e

Anything



Colum

n

Name

Allowable Values (CASE

SENSITIVE)

Notes

local_

branch

_code

Valid branch code for this

bank

Use this field for BSB codes if the

country requires it

payme

nt_pur

pose_

messa

ge

Anything

payme

nt_pur

pose_

code

Valid purpose code

payme

nt_pay

ment_i

so_co

de

Valid sender country code

payme

nt_pay

ment_

codew

ord

Valid receiving entity

codeword

payme

nt_pay

ment_

party_t

ype

P, T, G, N P = Parent, T = Subsidiary, G = Group, N

= Non-related

payme

nt_resi

dential

resident, nonresident
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Colum

n

Name

Allowable Values (CASE

SENSITIVE)

Notes

_statu

s

sort_c

ode

Valid sort code for this

bank

Import CSV

Once the file is ready, select the Import CSV button.

Select Import

Attach the file that is ready to import and enter one valid email address to receive a

status update.

NOTE: You are not able to modify this email address after clicking Import. If the

email is incorrect, you will not get the status email, but the import will complete.
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Add Import CSV

Once the file has been uploaded, a checkmark will appear. You can expect an email

with a status update within a few minutes. 

Processing Begins

Import Confirmation Email



Once the import status changes, you will receive an email notification.

This email notification will let you know if the import has been successful. There are

3 options:

File Successfully Imported

File Successfully Imported

Import is successful, but there are line errors.

In that case, please download the CSV attached to the email that lists those

errors and submit the file again. You may leave the error column in the newly

uploaded CSV. Please note that if an error is found in one of the rows, none of

the information present in that row will be updated.



File Was Not Imported

Import was not successful.

This issue may be caused by internet connectivity problems or unsupported file

formats. Please verify your internet connection, refresh the page to attempt

again, or contact support if the problem persists.

Import CSV Example

This file shows an example of what the import file can look like for one hypothetical

vendor.



Example Vendor CSV Import file

On the Payment Methods page, when you select the vendor, it shows that the bank

account has been added.

Click on Bank Account

When you open up the bank account, you can see the values match the import. 



Confirm Values

Potential Errors



Potential errors Explanation Steps to fix the error

data_type  must be:

DEFAULT PAYMENT

METHOD or DOMESTIC

BANK ACCOUNT or

INTERNATIONAL BANK

ACCOUNT

data_type

was not

filled in.

Always include a data_type, this is a

mandatory field.

vendor_id must be 

filled in.

vendor_id

was not

filled in.

Always include a vendor_id, this is a

mandatory field.

default_payment_method 

must be of a valid 

Payment Type.

default_pa

yment_metho

d  was not

correctly

filled in.

Ensure your account has this payment

method enabled.

email_addresses 

contains email(s) with 

an invalid email 

format.

Email

address

format was

not

respected.

Follow the following format: 

 If you would like to

add multiple email addresses, ensure they

are comma-separated as

below:  , 

something@email.com

email1@email.com email2@email.

com

Both country and 

currency must be filled 

in.

Country and

currency

both need to

be filled in.

country contains 

invalid country code

Country

code is not

valid.

Select a valid country code from this list: 

ISO alpha-2 country codes

currency contains an 

invalid currency code.

Currency

code is not

valid.

Select a valid currency code from this

list: Currency codes

https://archbee-doc-uploads.s3.amazonaws.com/export/html-space/PUBLISHED-Munv2jMWWp2mWtY_iUHP3-zFELy3D5hJbcA8a-6_7JD.html
https://archbee-doc-uploads.s3.amazonaws.com/export/html-space/PUBLISHED-Munv2jMWWp2mWtY_iUHP3-zFELy3D5hJbcA8a-6_7JD.html
https://archbee-doc-uploads.s3.amazonaws.com/export/html-space/PUBLISHED-Munv2jMWWp2mWtY_iUHP3-zFELy3D5hJbcA8a-6_7JD.html
https://archbee-doc-uploads.s3.amazonaws.com/export/html-space/PUBLISHED-Munv2jMWWp2mWtY_iUHP3-zFELy3D5hJbcA8a-6_7JD.html
https://www.iban.com/country-codes
https://www.iban.com/currency-codes


3.1.4.2.
Intacct Approval Process
(Informational)

Sage Intacct has two known base approval processes: Bill Approval and Payment Approval.

It is crucial to understand how each interacts with the .Goldman Sachs

The plugin provides support for Sage Intacct native configurations regarding Bill Approvals;

however, Sage Intacct's Payment Approvals are not supported, which may lead to

unforeseen issues in payment processing.

Viewing your Configuration

You must have sufficient permissions in Sage Intacct to view if you have approvals

enabled. 

To check your current settings:

1 Go to Accounts Payable → Setup → Configuration.

IMPORTANT: This page is for informational purposes only and should not be used as

a guide to make changes to the configuration of your Sage Intacct environment. For

support with your Sage Intacct native approval flows, please reach out to Sage or

your Intacct implementation partner directly.
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View Approval Processes 

Scroll down the page to find two sections: “Bill approval settings” and “Payment

approval settings.”

Locate Bill approval and Payment approval settings



Bill Approval (Supported)

The Sage Intacct Bill Approval process is generally supported by your bank's Sage Intacct

integration and does not interfere with the plugin payment flow.

How it Works

Bills that are created are required to be approved prior to being available for payment. In

the plugin, bills that are created but not approved are not shown as available for payment. 

Once a bill has been approved and is in the Posted status, it will be available for payment

in the plugin.

Payment Approval (Not Supported)

Payment Approval is NOT supported. Enabling this process, which requires an internal

approval step for each payment based on Intacct rules, will lead to unexpected payment

processing behavior with the plugin.

The plugin requires that users disable the Sage Intacct Payment Approval flow before

proceeding with Production payments. Failure to disable this process will result in adverse

consequences for any payments that are rejected within the native Intacct approval

system.

What is the Risk?

When Payment Approval is disabled, the process is straightforward:

1. The payment request is immediately sent to the bank for any approvals in the bank's

systems.

2. A Bill Payment record is created in Sage Intacct, marking the original bill as closed and

updating its status fields.

When Payment Approval is enabled, this synchronization is broken. This results in:

The payment is sent to the bank immediately upon submission, just like the non-

approved flow.



However, if the payment is later rejected within Intacct's native approval process, the

system cannot recall the payment already transmitted to the bank.

The bill is returned to the Posted status (unpaid/ready for payment), meaning Intacct

shows an unpaid bill even though the bank has already processed the funds. This

creates a considerable risk of duplicate payments.



3.1.4.3. Updating the Plugin (Intacct)

Keeping the  up to date with the latest version is crucial for ensuring you

have access to all the newest features, important bug fixes, and updates. To update,

please follow these steps.

Goldman Sachs

1

2

3

Log In to FISPAN Portal

To update the plugin in your Production environment, please go

to   and log in.﻿sys.fispan.live

If you are updating the plugin in your Sandbox environment, please go

to   and log in.sandbox.fispan.cloud

Update Plugin

Select the 3-dot action button in the top right corner of Intacct. Then,

select Update in order to update the plugin.

Select Update

Automatically Install 

https://sys.fispan.live/login
https://sandbox.fispan.cloud/


To install the updated plugin, select the Automatic Install button. 

Select Automatic Install

You have now successfully updated the plugin!

Manual Install

If automatic installation fails, you can manually install the updated plugin by downloading

the plugin XML file using the link in the installation wizard. 

1

2

Download XML File

From the error page displayed in the installation wizard, select here to download the

XML file.

Once the XML file pops up, save it to your computer. 

Go to Applications

In Intacct, go to Platform Services →  Applications.
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Go to Applications

Install From XML

Then, select Install from XML.

Select Install from XML



Upload the application XML file by selecting Choose File. 

Select the XML you just downloaded from the installation wizard, and click Install.



3.1.4.4. Mapping Bank Accounts (Intacct)

Once the  installation and setup are completed, you are still able to map any

new bank accounts that are added to the plugin. 

Goldman Sachs

Navigate to Accounts

1 Log in to FISPAN Portal

Head to the   or the  you used to register for an

account with  when you installed the plugin.

Production Portal Sandbox Portal

FISPAN

Go to the Portal

Log in to the portal with the email and password you used to register.

https://sys.fispan.live/login
https://sandbox.fispan.cloud/
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Log In

Go to Accounts

Select Associate Accounts and map the accounts you would like to map.

Select Associate Accounts



Matching Accounts
The next step in the installation wizard is to match your ERP Accounts to the corresponding

Bank Accounts.

1

2

Match Accounts

Drag an ERP Account from the left column and drop it onto the desired Bank Account.

Continue until all accounts are matched.

Select Default Account

To select your preferred default account, hover over the desired source account and

click the star icon. This sets the default selection in the source account dropdown

(you can change it anytime in the Account Matching screen here).

Account Matching - ERP Accounts and Bank Accounts 

Once you've successfully matched your accounts, click Next Step.



Map Additional Accounts or Change Existing Mapping

To map any additional accounts or alter an existing mapping, you would need to go to 

 and log in. sys.fispan.live

Once logged in, you can click on the three dots on the top right of the Sage Intacct® tile

and click on Associate Accounts. This will open the Account Matching screen, where you

can map any additional accounts or alter the existing mapping.

Select Associate Accounts

NOTE: When installing the plugin in Sandbox, the Bank Account ending in 1133 is

used for testing purposes ONLY. This account is not linked to any of your live

accounts with your bank. 

When installing in Production, the Bank Accounts listed will reflect your accounts set

up for use with the plugin.

https://sys.fispan.live/login


3.1.4.5. Supporting Multiple Entities

The Sage Intacct integration supports multiple entities. Pages within the integration behave

similarly to the native pages of Sage Intacct, with respect to presentation of bills, vendors,

and bank accounts. This is available for plugin versions 2021.4 and above.

Key Updates

Bills presented in the plugin will be reflective of the Entity level you are currently viewing.

For example, bills selectable for payment at the Top Level will only be bills that can be paid

at the Top Level through the traditional Pay Bills page in Sage Intacct.

At the Entity level, you will only be able to select bank accounts eligible for payment within

that Entity. For example, when making payments in Entity A, you will not be able to select

bank accounts owned by Entity B. 

Limitation

When submitting payments at the Top Level, the Confirmation page may present all linked

bank accounts, irrespective of the Entity they belong to. If an Entity-owned bank account is

selected for payment, the payment will immediately fail, and the bills will automatically be

reopened and available for repayment. 

Intacct does not allow the use of an Entity-level bank account to make payments at the Top

Level. Please confirm that when making payments from the Top Level, an appropriate Top

Level bank account is selected as the Source Account.



3.1.4.6. Setting up Multi-Factor Authentication

Multi-Factor Authentication (MFA) Overview

Multi-factor authentication (MFA) adds another level of security for all users when using

the  to . With MFA, your data is protected against account breaches and

is accessed by authorized users.

FISPAN Portal login

When registering, all new users must set up Multi-Factor Authentication (MFA) by choosing

an authentication method (the default option will be shown first).

If you prefer a different method, select Try Another Method to choose one of the following

options:

SMS (preferred)

Authenticator (or similar)

Email

Authentication Methods

NOTE: MFA does not apply to the Sandbox environment.

https://sys.fispan.live/login


Setting Up SMS MFA

The first time you log in to the Production environment, you will be prompted to establish

your Multi-factor Authentication (MFA) setup. You have the option to select various

methods of MFA. 

1

2

Enroll Phone Number

Select your country code then enter your phone number, you will receive a text

message with a 6-digit code via SMS to the phone number you provided for

enrollment.

If you are unable to receive a text message to this number, or you prefer a different

multi-factor authentication method, click Try Another Method. 

Enter Code

Enter the 6-digit code you received in the applicable field.

Select Continue.

NOTE: Multi-factor Authentication (MFA) is only required if you are a user in the

Production environment. If accessing the Sandbox environment, you may skip this

step.
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6-digit Verification

Save Recovery Code

After setting up SMS and inputting the first one-time code, you will be presented with

a recovery code that should be stored in a safe location. This code is for resetting the

MFA, to switch the MFA type (i.e., Authenticator), or to use a different phone number. 

Recovery Code



Setting Up Authenticator MFA

If you would like to use an authenticator application for MFA, follow these steps.

1

2

Set Up Authentication App

Download and install a compatible app, such as Auth0 Guardian App ( , )

or , on your mobile device and complete setup.

iOS Android

Google Authenticator

Verify Your Identity

Go into the Auth0 or Google Authenticator app to view your temporary verification

code. 

Enter the code from the app into the field on your screen and select Continue.

Authenticator

https://apps.apple.com/us/app/auth0-guardian/id1093447833
https://play.google.com/store/apps/details?id=com.auth0.guardian
https://support.google.com/accounts/answer/1066447?hl=en&co=GENIE.Platform%3DAndroid


Setting Up Email MFA

Follow these steps to set up Email MFA and verify your identity. 

1

2

3

Enter Email

Add the email address where you would like to receive your authentication code.

Check Inbox

Navigate to your email inbox to retrieve the 6-digit verification code sent to you.

Verify Your Identity

Return to this screen, enter the code, and select Continue.

Email Authentication



3.1.4.7. Uninstalling the Plugin (Intacct)

To disconnect from the plugin, follow the steps in this guide.

1

2

Disconnect Intacct from Plugin

Log in to  using your  credentials.https://sys.fispan.live/login FISPAN Portal

Click on the three dots on the top left of the box titled 'Intacct'. In the drop-down

menu, click Deactivate.

Click "Deactivate" in the drop-down menu

Remove the Application from Intacct

Log in to Intacct and navigate to Platform Services → Applications.

https://sys.fispan.live/login


Navigate to "Applications" in Intacct

Find your bank plugin in the Custom Applications list. Click Edit beside your bank

plugin.

Click "Edit" beside your bank plugin

Under Deployment Status, unselect the checkbox This application is deployed.



Unselect "This application is deployed"

Select Save at the top right. 

After unselecting "This application is deployed", click Save

Select Del beside the bank plugin and confirm the deletion.
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Click "Delete" beside the bank plugin

The plugin will disappear from the Intacct environment. 

Remove Smart Rules

Navigate to Platform Services -> Smart Rules
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Navigate to "Smart Rules"

Remove any Smart Rules containing your bank plugin name by selecting Delete.

Click "Delete" beside bank plugin-related smart rules

Remove Smart Events

Navigate to Platform Services → Smart Events



Navigate to "Smart Events"

Look up any events containing your bank plugin name and select Delete.

Click "Delete" beside bank plugin-related smart events

You've successfully disconnected your Intacct environment and completely removed

the plugin!





3.2.Features

3.2.1.Accounts Payable

3.2.1.1.Vendor Payments

3.2.1.1.1. Bill Payments (Intacct)

Paying bills in Intacct allows you to remain within your ERP system without needing to

access your bank account separately. You can pay a bill individually or improve efficiency



by processing them in groups. Follow this guide to learn how to do both in the Payments

page.

Pay a Bill

Follow these steps to pay your bills with the plugin.

1

2

Go To Payments

Go to Payments

Go to Payments.

Select Bills To Pay

The Pay Bills page will then load. This page will load every bill that is Open in your

company. 



Use the filters to find the bills you would like to pay. If a default payment method has

not yet been set for the vendor, choose your payment method from the respective

column. 

Select Bills to Pay

Then, select the bills you would like to pay using the boxes on the left.

NOTE: If your Payables page looks different than the screenshots below, you

may be running an outdated version of the plugin. Please update your plugin to

use the plugin's latest features by following the guidance on the Updating the

Plugin (Intacct) page.



3 Review Selection Summary

As you select bills, a Selection Summary appears at the top of the list. Hover over

this panel to view the total and currency breakdown for your selected bills and

vendors. 

TIP: Use these features in the Payments (Beta) page to locate and pay your

invoices more easily.

Fixed Columns: Fixed columns keep crucial information like Vendor Name

visible as you scroll horizontally, ensuring you never lose track of what you

are paying.

Quick Actions: Use quick actions to set a vendor’s default payment

method directly from this list without navigating to vendor settings.

Sorting & Filtering: Use the sorting and filtering available for every column

to quickly find specific bills. 

IMPORTANT: If you delete an open bill directly within the plugin by clicking the

delete icon on the right side of the bill, it will be removed and will not

automatically re-sync. 

To make sure a removed open bill can be reprocessed, you must go into native

Intacct (outside of the bank plugin). There, you need to make an edit to the

invoice and then resubmit it for approval. This action forces the necessary

update for the bill to be picked up and reprocessed.

NOTE: Ensure the bills you plan to pay are not duplicates of bills previously paid

via the plugin.
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View Summary of Selected Invoices

You now have two options for processing your selected bills: select Start Payment

Run for immediate processing or Schedule Payments for a future date.

Start Payment Run

If you've decided to go with the immediate processing option, select Start Payment

Run to initiate payments immediately.

With multi-source capability, you can include bills across various currencies and

bank accounts within a single batch. The system intelligently bundles these

payments, eliminating the need for multiple separate runs.

IMPORTANT: If a bill has data issues preventing payment, an error icon will

appear directly in the list. Click the icon to view the specific error message for

immediate troubleshooting.
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Review Payment Summary

Select the account from the dropdown menu. Before proceeding, confirm that the

number of bills, payments, and amounts are correct, and ensure all applicable credits

and discounts have been applied.

Click Review Payment Summary to continue.

Review Payment Run

Once you have validated your bills to be paid, select Confirm.
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Review summary and confirm payments

Confirm Payment Run

Once submitted, you will receive a confirmation.

Navigate to the History tab to track the status. Scheduled payments will appear here

with a distinct "Scheduled" status until they are processed.

IMPORTANT: Do not attempt to void and repay a bill if you realize you forgot to

apply a credit or discount after clicking Confirm. Voiding and repaying the bill

yourself may cause duplicate payments.

If this situation occurs, please contact  immediately. We

need to check if the payment has already been processed by the bank’s

systems before you attempt any voids and repayment.

TxB Representative



Go to History

The status will appear as Received until the payment has been Sent for Processing.

Once the payment is complete, the status will display as Completed

.

View Completed Bills



If any payment fails during the run, a banner on the Payments page will alert you

immediately.

A failed bill remains open on the Payments page and can be resubmitted for

payment.

Paying Grouped Bills

If you would like to make grouped bill payments, ensure the Combined Bills setting is

enabled for your vendors. You can decide to have this enabled for each vendor. If you

haven't done this yet, please refer to our Enabling Grouped Bills guide.

Follow these steps to group bills into a single payment.

1

2

Go to Payments

Go to Payments

Go to Payments.

Pay Grouped Bills

On the Pay page, select all the bills you wish to pay, and click Start Payment Run.



Click Send Start Payment Run

The Confirmation Payment window appears. You can select the Source Account and

verify the number of bills against payments. Click Send Payments to send the

payments.

Click Send Payments
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When grouped payments are enabled for a vendor with multiple bills, the total

number of payments will be less than the number of bills being paid.

After clicking Send Payments, your payment will begin transmitting.

Confirm Payment Run

Once submitted, you will receive a confirmation. Navigate to the History tab to track

the status. 

Go to History

The status will appear as Received until the payment has been cleared. Once the

payment is complete, the status will display as Completed.



Confirm Completed Status

If any payment fails during the run, a banner on the Payments page will alert you

immediately.

A failed bill remains open on the Payments page and can be resubmitted for

payment.

FAQs

How long do bills stay on the History Page?

Bills never leave the History page. As long as there is a working sync between Intacct

and the plugin, you should be able to see your paid bills. 

Why do I see multiple instances of the same bill on the History Page?

If you pay a bill with partial payments, the same bill will appear multiple times on the

History page. Similarly, if a bill has failed and has been repaid, it will also appear in

multiple payments on the History page.  



How many bills per page?

The plugin shows 200 bills per page. You are only able to pay one page at a time. 

Why do I receive an error 'You do not have the permissions for operation

READ_BY_QUERY on object of type locationentity'?

This is because you are missing the Entities permissions on the role/user. Navigate to 

Company -> Role -> Subscriptions and add the Entities permissions View.  

Location Error

I deleted a bill in the plugin, and I want it to appear again. How can I do that?

If you modify anything on the bill record, it should be picked up again and appear on

the Pay page of the plugin. 



Why am I not able to pay a bill that I created by duplicating an old bill I paid

previously through the bank plugin?

When a bill is paid through our bank plugin, certain custom fields on the bill record,

such as transaction IDs and statuses, are automatically filled in and are uneditable.

Duplicating these bills will copy over the contents of those custom fields into the new

bill, potentially causing payment failures.



3.2.1.1.1.1. Applying Discounts (Intacct)

The discount feature allows you to apply available discounts to payments processed

through the , and the payment request sent to the bank will automatically

reflect the discount amount.

Goldman Sachs

Applying Discounts

When paying a bill, you can apply the discount terms set in native Sage Intacct. Discount

terms cannot be applied to bills that are only partially paid.

To successfully apply a discount, you must meet one of the following two conditions:

1. You are paying the bill in full with a single payment (this payment can be part of a

combined payment run).

2. You are making the final payment on the bill. The discount can be applied only if this

final payment clears the remaining amount due on the bill.

Please refer to the "i" icon in the Discounts and To Pay columns for explanations of the

expected behavior.

Follow these steps to apply discounts to a payment.

1 Set Payment Terms

Start by creating the discount terms for the payment within native Sage Intacct.

Go to Accounts Payable → Bills to create or edit a bill.
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Go to Bills

Open a bill and select Terms. Enter the discount term you would like to use from the

dropdown menu.

Update Discount Terms

Pay with Discounts



Go to Payments. Use the filters to find the bills you would like to pay.

Go to Payments

The discount associated with that bill will auto-populate in the Discounts column and

apply to the bill by default.

View Discounts



The To Pay column is the Amount Due minus the Discounts (calculated based on the

terms and dates set on the bill) minus any additional credits applied.

Select the payment method and pay your bill as usual.

Removing a Discount 

If you want to pay a bill that has an applied discount term but choose not to use the

discount, you have two options:

1

2

Remove the Discount from Intacct

Navigate to Account Payables → Bills in native Intacct.

Select the bill you wish to modify.

Remove Discount Term

Ensure the term dropdown is left blank. This action effectively removes the discount

term from the bill record.

Temporarily Ignore the Discount



In the plugin's Payments page, simply unselect the Apply button next to the bill.

An orange notification text will appear, explaining that the bill is eligible for a

discount.

Update Discount as of Date

Modify the Discount as of date before making the payment, to ensure discounts are

applied appropriately.

To update the Discount as of date, follow these steps.

1 Locate Discount as of Date

Click on the Discount amount (in blue). This will open a pop-up where the discount

as of the date will be modifiable. 

NOTE: If you navigate away from or refresh the Payments page, the Apply 

checkbox will be automatically rechecked.



2 Edit Discount as of Date

Now, edit the Discount as of date and save. 

Make sure the Apply checkbox is checked and pay your bill as usual.

Please note that if a date after the discount cut-off date is selected, the discount will

be $0.

Change discount as of date

FAQs

What if the amount is not right?

If the amount auto-populated does not match what you would like to have as a

discount, you can simply modify the corresponding Accounts Payable [AP] Term. 

Simply head over to Account Payables -> Bills and select the bill you would like to

modify. Change the selected AP term, and the auto-populated discount in the plugin

will be automatically updated. This will directly be reflected in the To Pay Column.



How can I change the AP term settings?

Head over to Payables -> Set Up -> More -> Terms to edit AP terms.

Are discounts supported in different currencies?

Yes, discounts are supported in all currencies.

I changed the AP term in my bill, but it is not reflected in the plugin yet. What should

I do?

The plugin always reflects exactly what is in the bill on native Intacct. If you have

updated the bill, and it is not yet updated in the Payments page, wait 30 seconds and

refresh the plugin; the bill should then be updated.

Why can I not pay a partial payment with a discount?

Discount terms cannot be applied to partially paid bills. To benefit from discounts, you

have to either:

Be paying the bill in full in one payment

Be paying the last payment on the bill. If there is no amount due left on the bill

(after that last payment), you can apply the discount.

Please refer to the hover "i" in the Discounts and To Pay columns explaining the

expected behavior.

What is the discount as of date?

The discount as of date is the date at which the discount is processed.

Why are Grace Days not taken into account?

Grace Days are a native Sage Intacct field that define the number of days after an

invoice’s due date before late charges are applied to a vendor bill.

Grace Days are currently not supported.



I changed the bill, but it is not reflected in the plugin yet. What should I do?

The plugin always reflects exactly what is on the bill in native Intacct. If you have

updated the bill, and it is not yet updated in the plugin Payables page, wait 30 seconds

and refresh the plugin; the bill should then be updated.

If I have multiple line items, where will the discount be applied?

If the bill is paid in full, the plugin will apply the discount proportionally, split between

each line item. 

If the bill is paid in installments, the discount will be applied to the last line item of the

last payment (the discount will not be used before the bill is paid in full).

How does the Plugin's discount application differ from Intacct?

Intacct uses the payment date to determine discount eligibility. If the payment date is

after the discount cut-off date, the discount will not be applied, regardless of the

"discount as of date." The plugin does not follow this behavior.

Example: If a vendor bill has a discount deadline of March 10th and the payment is

dated March 11th, Intacct will not apply the discount. However, the plugin would still

apply the discount if the "discount as of date" was on or before March 10th.

Furthermore, when processing a partial payment via native Intacct, discounts cannot

be utilized. In contrast, the plugin can send a partial payment with the discount

applied.



3.2.1.1.1.2. Making Adjustments (Intacct)

Adjustments, such as credit notes, must be added at the vendor level. Once an adjustment

is created for a specific vendor, for example, a $20 credit, it will automatically appear on all

future bills for that vendor.

If you have access to the Remittance Advice product, please process all credit notes and

adjustments in Account Payables → Adjustments to ensure credit amounts and references

are included.

When applying a credit amount to a bill, the system follows a rule: the oldest available

credit value for that vendor will always be applied to the payment first.

Make an Adjustment

To make an adjustment, follow these steps. 

1 Go to Adjustments

Navigate to Account Payables → Payments → Adjustments.

NOTE: Make sure that the adjustment type is a Debit Memo. The plugin does not

currently support what native Intacct calls Credit Memos.



2 Make Adjustments

Input the amount you would like to apply to the bill in the Credits to Apply field.

The Credits Available column is updated every time the user modifies the adjustment

in native Intacct or inputs an amount in Credits to Apply.



Please note that the applied credit cannot reduce the amount in the To Pay column to

zero or a negative value. 

Select and pay the bill as usual, and the credit will be applied.

FAQs

What if the amount is not right?

If the amount auto-populated does not match what you would like to have as an

adjustment, you can simply modify the corresponding adjustment. 

Navigate to Account Payables -> Payments → Adjustment and select the adjustment

you would like to modify. Change the AP term, and the auto-populated adjustment in

the plugin will be automatically updated. This will directly be reflected in the Credits

Available Column.

What if there are no credits available?

It is not possible to add any adjustments within the plugin. Navigate to Account

Payables → Adjustment to modify any adjustment.

IMPORTANT: Using bills with a negative amount (i.e., -$10) as adjustments is

currently not supported by the plugin. If you are using bills with negative

amounts as part of your AP workflow to create credit memos, we recommend

switching to adjustments. This is what Intacct recommends natively. 



What if there are multiple adjustments?

If there is more than one adjustment for a single vendor, native Intacct is replicated,

and these are added together. This is reflected in the Credits Available column.

On the accounting side, the adjustment with the smallest adjustment number (1 is first,

taken over 2) is first used. The end-user does not notice any difference, but this has

an impact on the way the adjustments are used and closed.

The To Pay column will change every time a new adjustment is added in the Credits to

Apply column. After the payment is completed and the memo(s) applied, the journal

entries are written, the adjustment is marked as partially paid or paid, and the Credits

Available is updated.

Why do I get an error when paying two adjustments in a row?

If you attempt to pay two adjustments consecutively for the same vendor, you may

encounter the following error: "The credits available for Vendor A are less than what

was applied to this payment."

This occurs because you tried to apply more credits than the amount currently listed

as Credits Available in Intacct. The system may not have registered the depletion of

credits from your first adjustment payment yet.

To resolve this, please resubmit the payment with an accurate credit amount. You must

either:

1. Add more credits for the vendor in native Intacct.

2. Decrease the amount of credits you are attempting to apply for the payment.

Please note that when this error occurs, the bill will not be paid and will return to the 

Bills to Pay page. It will not appear on the history page.



3.2.1.1.1.3. Making Partial Payments

Initiate Partial Payments directly from Intacct. This feature gives you the flexibility to pay

only a portion of an invoice, supporting various business needs and helping you better

manage your cash flow.

Partial Payments are available to all Intacct users on plugin version 2022.23 or later.

Making Partial Payments

Follow these steps to make your first partial payment.

1 Modify the To Pay Amount

The To Pay column is now modifiable. You can enter any amount as long as: 

The To Pay amount is greater than 0. 

The To Pay amount is not more than the amount due - the discount applied -

credits applied.



2 Add Any Applicable Credits (Adjustments)

Partial Payments can be used in combination with adjustments. Refer to the Making

Adjustments article for more information. 

In the Credits to Apply column, add any amount that you would like to add to this

payment. This action does not reduce the To Pay amount; instead, it adds the

specified credit amount to your payment request. As a result, the Credits Available 

balance will be reduced by the amount you enter here.

Document image

IMPORTANT: Discount terms cannot be applied to partially paid bills. 

To take advantage of available discounts, your payment must meet one of the

following criteria:

Pay the bill in full with a single payment.

Make the final payment on the bill. The discount can only be applied when

this payment reduces the outstanding amount to zero.
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Select the Bills to Pay

Select the bills you would like to pay. You can add multiple bills (even with partial

payments) to one payment run. 

Confirm Payments

Confirm the payments to complete your first partial payment.



The bill(s) you've partially paid will remain on the Pay page. They will show the

updated outstanding amount due, allowing you to make future payments until the

balance is fully settled.

FAQs

IMPORTANT: The custom fields on the native bill record will be overwritten

each time a partial payment is made. Only the latest payment information will

be available in these fields.

For example, if a bill is partially paid five times, the custom fields will only show

the details of the fifth (latest) payment.

If you need to search and view all payments made against a single bill, you

have two options: 

1. Navigate to the History page of the plugin.

2. Go to the Accounts Payable page within native Intacct.

You can search this page using the payment or bill IDs.



Do I need specific permissions to use partial payments?

No, users who already have the  permissions will be able to make

partial payments.

Goldman Sachs

Why can I not see the payment information on the bill record when I do multiple

partial payments?

The plugin will overwrite the custom fields every time there is a new payment made

against that bill. Only the payment information from the latest payment is made

available. This is a technical limitation with how Sage Intacct stores the information on

this record. We have improved the History page to accommodate this. 

Why can I not apply a discount to a partially paid bill?

Sage Intacct does not allow discount terms to be applied to partially paid bills. To

benefit from discounts, you have to either:

Pay the bill in full in one payment

Pay the last partial payment on the bill. If there is no amount due left on the bill

(after that last payment), you can apply a discount.

Can I pay the same bill from two different entities?

This is currently not supported by the plugin, because the plugin does not read line

details of bills. You are able to partially pay a bill, but you are not able to choose which

line item gets paid and which one does not. It always follows the same logic,

independent of which bill is chosen (see next question for my information). 

How do I know which line item gets paid first?

The logic of which line item is paid first when submitting a partial payment is the same

as native Intacct. It uses the first line item first, and then the second, until there is

nothing left to be paid. 



Where does the 'View Details' at the top right bring?

View Details button

The View Details from the top right of the accordion opens up the ,

which shows more payment-related information than what is shown in the plugin. You

will be prompted to log in. Use the  password defined during the

onboarding process to log in. Reach out to support if you did not get a login during

onboarding. 

FISPAN Portal

FISPAN Portal



Example Payment Details



Where does the Eye Button next to the bill number bring?

The Eye Button next to the bill number opens the native Intacct bill record. 

Eye button next to the bill number



3.2.1.1.1.4. Voiding & Repaying Bills (Intacct)

Voiding bills that were previously paid via the plugin is supported directly within the plugin.

Voiding changes the status of the bill from paid to open but does not send a request to the

bank systems to cancel a payment that is processing. 

Voided bills can later be repaid by following the steps in this guide.

How to Void Bills

1 Find the Bill

Find a bill that has already been paid via the plugin on the History page, Payments →

History.

Locate a Paid Bil

Locate a Paid Bil

Or by navigating to Accounts Payable → Posted Payments
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Go to Posted Payments

Go to Posted Payments

Check Bill Status

Open the bill record (internalID) and confirm the bill has been PAID. 

You can select the tab in the submenu to confirm that the bill payment has reached

the plugin.

Select the Paid to see the corresponding journal entries.
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View Bill Status

Void the Payment

To void a bill in Sage Intacct after it has been paid, go to Accounts Payable -->

Posted payments.

Document image



4 Void the Bill

Void the bill by clicking the Void button on any line item. 

Document image

View Voided Payment Status



5 Check the Reopened Bill

Confirm the bill has been reopened. Fields under the subtab are still populated with

details from the first payment that was voided.

WARNING: When confirming the payment, do not reverse the bill. DO NOT

check the Reverse checkbox. Instead, simply add a payment date and an

optional memo. 

If you choose to reverse the bill, it will enter a Reversed state that the plugin

cannot read or process.

Voiding, without reversing the bill



Confirm the Open Bill

Repaying a Previously Voided Bill

1 Find & Pay Bill

Find the previously voided bill on the Pay Vendor Bills page in Payments → Pay.

Pay the bill as normal.

Confirm the bill has been paid and appears on the History page. Go to Payments →

History.
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View Payment History

Check the Bill Status

Click on the Bill ID to open the bill record and confirm the bill has been PAID. You can

select the submenu to confirm that the bill payment has hit the plugin and that the

reference IDs and transaction IDs are now different.

Check Bill Status





3.2.1.1.2.Bill Payment History

3.2.1.1.2.1. Viewing Bill History (Intacct)

All Vendor Bill Payment History is readily available in the Payments page. Follow the steps

below to view your Vendor Bill Payment History.

1 Go to Payments

In your ERP, go to -> PaymentsGoldman Sachs

Go to Payments

Click on the History tab.



2 View Payment History

The History tab provides a snapshot of all payments that have been made via the

plugin.

Vendor payments that are processed through the plugin will first appear Pending.

Depending on the payment method, payments may remain pending for up to 

business days after submission, after which the payment will automatically be moved

to a Completed state.

several

View Payment History

Pending Statuses for payments:

SENT FOR PROCESSING: This status indicates that the payment has been

processed through the plugin but has not yet reached the bank.

NOTE: The Sage Intacct bill payment General Ledger entry will be created at

the time of payment submission, not when the payment is marked as 

Completed. If your bank reports a payment failure, we will update the status in

the History page to Failed and attempt to reverse the initial Vendor Bill Payment

accounting entry. 
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PROCESSING: This status indicates that the payment has been approved (if

using the Payment Approval product) and has reached the bank.

A terminal payment status is a final status. In most scenarios, payments will not

automatically change from this status without intervention. Contact 

 if you need assistance.TxB Representative

Terminal Payment Statuses:

COMPLETED: Some payments are marked as autocomplete, based on the way

the payment network handles them. Completed is considered a terminal status

and should not change.

FAILED: Payments that fail to be processed will enter this status. Payments can

fail for a variety of reasons: initial validation as a result of missing or

inappropriate information, or if the payment fails in the payment network (e.g.,

the destination bank account is closed).

CANCELLED: This status will indicate that the payment was rejected in the bank

approval portal or cancelled in the platform.

View Bill Information

By default, the History page shows the payment-related information first. 

Every row contains one payment request, with all the payment-related information:

Payment Status, PaymentID (referenceID), Payment Date, Vendor Name, Number of

Bills in the payment request, Total Amount, Currency, Payment Method, and Last

Updated.



Payment-related information

A payment request can contain multiple bills. To see that information, click the arrow

on the left side. This brings down the bill-focused tab, which includes: Bill Number,

Due Date, Bill Amount, Amount Due, Credit Used, Discount Used, and Amount Paid.

Bill-related information



At the top right of the listed bills, click the View Action Log button to view the

progress of the payment and related actions.

View Action Log

TIP: If you are looking for a specific bill, you can enter its Bill Number in the

Payment ID/Bill Number filter. This will bring all the payments related to that

specific bill. 



3.2.1.1.3. Payment Methods (Intacct)

The Payment Methods page is designed to help you gain immediate insights into missing

vendor data and work more efficiently.

Simplify your vendor management with these key features.

Vendor Health Alert

If any vendors are missing a default payment method, you will see an alert at the top of

the page: "[x] vendors are missing a default payment method." 

Addressing this ensures smoother payment runs.



Vendor Template

You can easily add new vendor payment methods in bulk.

At the top right of the page, click the Import/Export dropdown and select Export

Vendor Template. This downloads a blank, pre-formatted template.

Export Vendor Template

Fill out this template with the bank accounts, addresses, or email information for your

vendors.

Return to the Import/Export menu and select Import to upload your completed file.



Quick Actions 

You can manage the following settings for any vendor directly from the main list:

Exclude Bills: Enable this toggle to prevent a vendor's bills from appearing on the

Payments page in the .Goldman Sachs

Combined Bills: Enable this to consolidate all approved bills for a vendor into a

single payment.

Remittance: Enable this to automatically send an email remittance advice to the

vendor upon payment.

Quick Actions (Grid Toggles)

Accessing the Payment Methods Page

From anywhere in your ERP, navigate to the  menu and select Payment

Methods to open the page.

Goldman Sachs

The main view provides a comprehensive overview of your vendors' payment information. 



Payment Methods Page



3.2.1.1.3.1.
Managing Vendor Payment Methods
(Intacct)

Manage vendor payment information more efficiently on the Payment Methods page. This

guide covers how to update vendor bank accounts, addresses, settings, and email groups.

Accessing Vendor Payment Information

Navigate to the  menu and select Payment Methods for an overview of

your vendors and their payment information.

Goldman Sachs

Click any vendor row to open the vendor details panel, where you can add payment

information or configure specific settings.

Vendor Details Panel

The panel is organized into Payment Methods on the left (where you add information) and 

Settings on the right (where you configure preferences).

Natively Stored Payment Information



Any bank accounts, addresses, or emails stored natively in your ERP will be imported

automatically. These records are identified by the ERP icon next to the label.

Natively Stored Information Synced

These details are not editable within the plugin. To modify this information, you must make

the changes directly within your ERP’s vendor record. The updates will then sync to the

plugin.



View Natively Stored Information

Managing Bank Accounts

Use the vendor details panel on the Payment Methods page to add, update, or delete

vendor bank account information.

Adding a Bank Account

From the vendor details panel, follow these steps to add a new bank account for your

vendor. 

1 Add New Bank Account

Click on the Add New button in the Payment Methods pane and select Bank

Account.

Select the Country and Currency of the bank account you would like to add next.
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Selet Country and Currency

Add Account Details

Fill in the required banking information (e.g., Routing Number, Account Number) and

provide a unique Label for easy identification.

Enter Bank account details



3 Add Intermediary Bank Details

You can also add intermediary bank information. An intermediary bank account is

used when making international payments to countries with which your bank may not

have a direct relationship.

To add this information, click the Intermediary Bank toggle.

Enable Intermediary Bank

Once enabled, you can enter the intermediary bank account information.
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Intermediary Bank details

Validate Payment Rail Eligibility 

After you have added all required information, click Validate Payment Rail Eligibility.

The system will verify that the information is formatted correctly for the available

payment types.

Once validation is successful, click Save Account. The new account will then appear

in the Bank Accounts list.



Payment Rail Validated

Edit a Bank Account

To edit a bank account for a vendor, navigate to the vendor's detail panel and follow these

steps.

1 Open Bank Account Details

In the Payment Methods pane, find the bank account you wish to edit and click on

the pen icon next to it.

IMPORTANT: This step validates the format of the data, not its accuracy. Please

ensure all account numbers are entered correctly.



2

Edit a Bank Account

The bank account details will appear as a pop-up. 

Vendor Bank Account Pop-Up

Update Bank Account Details
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Make your required changes (e.g., update the Account Number, Routing Number, or

Label). 

Validate and Save

Click Validate Payment Rail Eligibility to re-verify the new details. 

Re-Validate Payment Rail Eligibility

Once validated, click Save Account.



Save Account

Delete a Bank Account

To delete a bank account for a vendor, navigate to the vendor's detail panel and follow

these steps.

1 Open Bank Account Details

In the Payment Methods pane, find the bank account you wish to edit and click on

the pen icon next to it.
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Edit a Bank Account

The bank account details will appear as a pop-up. 

Bank Account Pop-Up

Delete Account



Click Delete Account on the top right of the pop-up. A prompt will appear. Click Yes,

Delete to permanently remove the bank account from the .Goldman Sachs

Delete Bank Account Pop-Up

Managing Addresses

Use the vendor details panel on the Payment Methods page to add, update, or delete

vendor address information.

NOTE: Deleting the Default Payment Method will leave the vendor without a

default. You must then set a new one. You can do this either:

Directly in the Default Payment Method column on the main vendor list, 

OR

By clicking the vendor and using the Preferred Payment Method

dropdown on the right side of the details panel.

NOTE: If the Check payment method is not enabled in the plugin, the option to add an

address will not be visible. Addresses are only required for Check payments.



Adding an Address

To add vendor mailing addresses, follow these steps.

1

2

Add New Address

Click the Add New button in the Payment Methods pane and select Address.

Click 'Address'

Add Address Details

Add your address details to the fields. After that, click Add Address.



Add Address Information

Edit an Address

To edit a bank account for a vendor, navigate to the vendor's detail panel and follow these

steps.

1 Open Address Details

In the Payment Methods pane, find the address you wish to edit and click on the pen

icon next to it.
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Edit an Address

The address details will appear as a pop-up. 

Update and Save Changes

Update Address

Update the address fields as needed and click Save Changes.



Delete an Address

To delete an address for a vendor, navigate to the vendor's detail panel and follow these

steps.

1 Open Address Details

In the Payment Methods pane, find the bank account you wish to edit and click on

the pen icon next to it.

Edit an Address

The bank account details will appear as a pop-up. 
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Address Pop-Up

Delete Address

Click Delete Address on the top right of the pop-up. A prompt will appear. Click Yes,

Delete to permanently remove the address from the .Goldman Sachs

Delete an Address Pop-Up



Configuring Vendor Settings

In the Settings pane on the right side of the vendor details panel, you can configure the

vendor’s payment preferences with the following toggles:

Do not show bills from this vendor: Toggle this on to exclude all bills for this vendor

from the Payments page in the plugin.

Combine Multiple Bills: Toggle this on to consolidate multiple bills for the same

payment method into a single payment.

Finally, select a Preferred Payment Method from the dropdown. This will populate as the

default for every bill for this vendor on the Pay Bills page and can be updated at any time.



3.2.1.1.3.2. Enabling Combined Bills (Intacct)

Simplify your payments by using the Combined Bills option for vendors, which allows you

to group multiple bills into a single payment. 

Enable Combined Bills for Vendors

Follow these steps to learn how to enable Combined Bills for your vendors.

1

2

Navigate to Payment Methods

From anywhere in your ERP, navigate to the  menu and select 

Payment Methods to open the page.

Goldman Sachs

Payment Methods Page

Enable Combine Bills/Invoices

Once the Payment Methods page loads, click on the gear icon placed next to the 

Combined Bills/Invoices.



Click on the Gear Icon

You will now be prompted to select the option you prefer.

Pick an Option

If you choose to enable this for all vendors, you will need to make updates for any

new vendors that are created in the future.
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Update Changes

Once the option has been selected, click Update Changes. 

Disable Combine Bills/Invoices

The page will refresh, and all the toggles will be updated to match the status you

selected. From this page, you can disable a specific vendor or do a bulk edit using

the above step.



Combined Bills/Invoices Enabled

Exclude Bills from Vendors

You can also exclude bills from certain vendors from being displayed on the Payments

page.

1 Navigate to Payment Methods

From anywhere in your ERP, navigate to the  menu and select 

Payment Methods to open the page.

Goldman Sachs
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Payment Methods Page

Exclude Bills/Invoices

On the Payment Methods page, simply enable the 'Exclude Bills' toggle to prevent a

vendor's bills/invoices from appearing on the Payments page.

Enable the toggle



Once the toggle is enabled, the bills/invoices for that respective period will not

appear on the Payments page anymore. 

Intacct Merge Payments Setting

Alternatively, Sage Intacct offers a native setting for grouped bill payments. To utilize this

feature, ensure the Merge payment requests checkbox is enabled on the relevant Vendor

record. Follow these steps to configure this setting. 

1

2

Go to Vendor Record

Navigate to the Vendor record and select the Payment Information tab. 

Enable Grouped Payments

Click on the Merge payment requests checkbox.

Enabling Grouped Payments

Once that is enabled, you are able to group bills when paying. 



3.2.2.
Bank Statements
(Intacct)

3.2.2.1.
Managing Balances & Transactions
(Intacct)

Access your bank account balances directly within your financial management software,

using the Cash Management Reporting features. 

The Bank Accounts page allows you to see previous and intraday balances directly from

your accounts in near real-time. You can also export this data in an Intacct CSV file to use

for reconciliation.

The bank accounts that are shown to a user depend on their level of permission. For

example, if a user is restricted to a specific entity, they will only see the accounts linked to

that entity.

Viewing Bank Accounts

1 Go to Bank Accounts

Go to  -> Bank Accounts.Goldman Sachs
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Bank Accounts Page

Here, you can view all of the bank accounts that you have connected with the plugin.

View Balances and Transactions

Select the account name or view to see the previous day and intraday balances for

the chosen bank account along with transaction data.



View Account Transactions

To see the Bank Transactions, scroll down. The screen displays the information as it

appears on a bank statement.

You’ll see all of the settled transactions, debits, and credits for the account.

View specific transaction



Go to the Details column → Select View to see more details about a transaction.

Balances & Transactions Reconciliation

Follow these steps to reconcile your accounts. For a much more efficient and automated

reconciliation process, we recommend leveraging the Bank Feeds product instead.

1 Export CSV File

Go to My Bank Pay -> Bank Accounts.



Bank Accounts

Select the account that you would like to access by selecting the Account Name or

by selecting View.

View Account

Select Export to export a CSV file of your transactions.



You will be given 3 export options. We recommend using the Intacct CSV if you plan

to utilize Intacct's Reconciliation module.

Export Options

If you would like to export a CSV from a different account, you can toggle between

accounts by selecting the drop-down next to Switch to Account.
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Select another account

Import CSV File

Go to Cash Management → Reconciliation → Bank

TIP: If the file does not download, make sure your pop-up blocker is disabled.



Go To Bank

Choose the Account to Reconcile, then enter the Beginning balance cutoff date, the

Statement ending date, and the Statement ending balance.

Choose to Account to Reconcile

Select Import to add a CSV file.



Import CSV File

To import your account transactions, select Choose File and upload the CSV you

exported from Balances & Transactions.

Choose Files

Select Done.



3 Select Transaction(s) to Match from Intacct

Select the transaction(s) you would like to match from Intacct and select Match to

view the unmatched transaction(s) from the plugin. 

Select Transaction to Match

Select the transaction(s) you would like to match from the plugin and select Match.



Match Transaction

These selected transaction(s) are now reconciled.



3.2.2.2. Bank Feed Requirements (Intacct)

To use Sage Bank Feeds, ensure you have enabled the subscription to Sage Cloud

Services as outlined in the Pre-Onboarding Checklist, and have selected the correct

permissions. Follow the steps below if there is no Banking Cloud tab available to enable

Bank Feeds.

1 Confirm ISO Country Codes are Enabled

Go to the Company.

Go to Company

Under the General Information section, confirm that ISO Country Codes is checked,

and then select Save.
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Enable ISO Country Codes

Enable Sage Cloud Services

Go to Company → Admin → Subscriptions.

Go to Subscriptions



Confirm that Sage Cloud Services are enabled. If they are not, toggle to enable Sage

Cloud Services.

Enable Sage Cloud Services

After enabling Sage Cloud Services, please confirm that the Enable Bank Feeds

functionality is checked in the configurations.
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Enable Bank Feeds

Then select Save.

Confirm Correct Permissions

To connect a bank account to bank feeds, you must have the following settings and

the permissions below. This can be checked and updated under Company -> Users.

Subscription

Cash Management

Sage Cloud Services

User type

Business user with admin privileges

Permissions

Checking accounts: Add, Edit, View, List

Savings accounts: Add, Edit, View, List

Credit card accounts: Add, Edit, View, List



Requirements to connect an account to a bank feed

If you want to find more information about this process, visit the Sage Website: 

Connect an account to a Bank Feed

Once the account has been connected, the user with the permissions to perform the

reconciliation will be able to view the incoming transactions. No special permissions

are needed to view the transactions.

https://www.intacct.com/ia/docs/en_US/help_action/Cash_Management/Banking_and_Payment_Cloud/Bank_feeds/Connections/bank-feeds-connect-account.htm?tocpath=Applications%7CCash%20Management%7CBank%20feeds%7CConnect%20to%20a%20bank%20feed%7C_____2


3.2.2.3. Enabling Bank Feeds (Intacct)

Enabling Bank Feeds

Step 1: Locate the Account

Go to Cash Management → Checking.

Go to Checking

On the Checking page, select Edit on the account you wish to turn on Bank Feeds for.



Select Edit

Step 2: Activate Bank Feeds

Under the Banking Cloud tab, click Connect.



Connect Banking Cloud

In the search bar, search  - Powered by FISPAN.Goldman Sachs

Search for Goldman Sachs



Agree to conditions and select Continue. 

Agree to Conditions

You will be redirected to a landing page that will require you to sign in to the FISPAN

Wizard.

Select Login Now.

Note: The beta code is 559415.



Select Login Now

Step 3: Match Account for Bank Feeds

After logging in, select the account from Step 1, then select Save and Finish. You will

automatically be redirected back to Sage.



Select Account

After being redirected back to Sage, select the same account and click OK.

Click Ok

Choose the date you want transactions to start from.



Choose Date

Step 4: Confirm Bank Feeds

Select Confirm to confirm the activation of Bank Feeds. Once the connection is

successful, the status will change to Connected.

NOTE: You must complete account matching within 60 minutes; otherwise, the

installation wizard will time out, the connection will fail, and the account will remain 

Pending with no transactions coming in. 

To retry, disable the account(s) under the Accounts table and reinitiate the mapping

process.



Confirm Bank Feeds

Once the account is Connected, go to Cash Management -> Reconciliation -> Bank and

follow your native reconciliation process. 

By enabling Bank Feeds for the plugin, your bank establishes a reliable and secure flow of

transactions from your bank into Sage Intacct’s Reconciliation module.

Bank transactions that settled the previous day are imported each morning. For example,

transactions that are settled on Tuesday will be pushed into Sage Intacct early on

Wednesday morning. The exact timing can vary depending on when your bank sends the

first transaction file (PDR).

NOTE: If you are processing more than 100 transactions, we advise you to wait until

the next day to see the transactions posted.

NOTE: If the account is in Pending status, it means that the transactions have not

been pushed for this account. You will need to wait until the transactions are

successfully pushed to this account before seeing it marked as Connected. 



Set Up Multi-Account Bank Feeds

Bank Feeds allows you to connect multiple accounts to the plugin. Once one bank account

has been connected to Bank Feeds by following the Enabling Bank Feeds page, other

accounts can be connected simultaneously through a financial institution connection.

Follow the steps below to set up multiple accounts for Bank Feeds.

1 Set up a Financial Institution

Go to Cash Management → Set up → Financial Institution and create a new

Financial Institution.

Set-up Financial Institution

NOTE:  Before you set up the Financial Institution, ensure that both Cash

Management and Sage Cloud Services are enabled in the Subscriptions section. In

the Sage Cloud Services configuration, confirm the Enable Bank Feeds checkbox is

checked as per the Enabling Bank Feeds page.

If this does not work, please contact Sage support and ask to get access to the

Financial Institution.
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This allows you to create a connection to the bank. Create the ID and Name as

desired.

Create Financial Institution

Map Accounts for Bank Feeds

Select Map Accounts and choose which accounts you would like to enable on Bank

Feeds.



Map Accounts

If there are more than 100 transactions, the plugin will upload them into the system in

batches of 100. This may cause some transactions to appear initially, while others will

appear later. Typically, it takes a few hours to view all your transactions.

NOTE: You must complete account matching within 60 minutes; otherwise, the

installation wizard will time out, the connection will fail, and the account will

remain Pending with no transactions coming in.

To retry, disable the account(s) under the Accounts table and reinitiate the

mapping process.



Map Accounts

After mapping the accounts, the Banking cloud statuses can be seen in the Accounts

tab.

Account Status



To view your account information, click Bank Transactions in the Cash Management

module. You can also view this information through the Reconciliation module. 

Observe Bank Transactions



3.2.2.4.
Adding Accounts to Bank Feeds
(Intacct)

If you have already enabled bank feeds and are using this for some of your existing

accounts already, use this procedure to add and set up additional accounts to use bank

feeds. 

Set Up Multi-Account Bank Feeds

Bank Feeds allows you to connect multiple accounts to the plugin. Once one bank account

has been connected to Bank Feeds by following the Enabling Bank Feeds page, other

accounts can be connected simultaneously through a financial institution connection.

Follow the steps below to set up multiple accounts for Bank Feeds.

1 Set up a Financial Institution

Go to Cash Management → Set up → Financial Institution and create a new

Financial Institution.

NOTE:  Before you set up the Financial Institution, ensure that both Cash

Management and Sage Cloud Services are enabled in the Subscriptions section. In

the Sage Cloud Services configuration, confirm the Enable Bank Feeds checkbox is

checked as per the Enabling Bank Feeds page.

If this does not work, please contact Sage support and ask to get access to the

Financial Institution.
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Set-up Financial Institution

This allows you to create a connection to the bank. Create the ID and Name as

desired.

Create Financial Institution

Map Accounts for Bank Feeds



Select Map Accounts and choose which accounts you would like to enable on Bank

Feeds.

Map Accounts

If there are more than 100 transactions, the plugin will upload them into the system in

batches of 100. This may cause some transactions to appear initially, while others will

appear later. Typically, it takes a few hours to view all your transactions.

NOTE: You must complete account matching within 60 minutes; otherwise, the

installation wizard will time out, the connection will fail, and the account will

remain Pending with no transactions coming in.

To retry, disable the account(s) under the Accounts table and reinitiate the

mapping process.



Map Accounts

After mapping the accounts, the Banking cloud statuses can be seen in the Accounts

tab.

Account Status



To view your account information, click Bank Transactions in the Cash Management

module. You can also view this information through the Reconciliation module. 

Observe Bank Transactions



3.2.2.5. Reconciliation Rule & Rule Set (Intacct)

Creating a Reconciliation Rule is the best way to streamline the reconciliation process, as it

allows you to automate it. These rules can either automatically map bank transactions to

existing Intacct transactions or create new, appropriate Intacct transactions. 

If you try to reconcile without setting up a Reconciliation Rule and an associated Rule Set,

you'll likely see errors such as:

"There are no rules associated with the rule set."

"Could not create banktxnrulerun record!"

"Apply a matching rule set to this account before reconciling with an import or bank

feeds."

Follow this guide to learn how to create Reconciliation Rules and Rule Sets needed to

prevent or resolve these issues.

Create Reconciliation Rules & Rule Set

1 Create a Rule

Navigate to Cash Management -> Setup -> Reconciliation Rules -> Rules.



Reconciliation Rules

You are then able to create rules based on your preferences. You have two options:

Match Rule: Automatically match banking transactions with existing Intacct

transactions.

Create Rule: Create Intacct transactions based on banking transactions.

Intacct requires you to create at least one rule.

As an example, you could create a rule based on the document number. This is

particularly useful for any check payments made with the plugin, which will directly

match based on the document number.

You can see an example below:



2

Creating a rule

Once you have created the rule, hit Save.

Apply Rule to Rule Set

Once you have created one or more rules, you need to apply them to a rule set.

Navigate to Cash Management -> Setup -> Reconciliation Rules -> Rule Set. You

should then add the rules to an existing rule set (if any) or create a new one. 

You can create a new one by clicking Add, and then adding the rule to that new rule

set. 

Hit Select Rules to add the rule you created in Step 1. Once you have added all the

rules that you want, navigate to Step 3 below. 

TIP: You may also add a Filter Rule, which allows you to filter your transactions

before applying a matching/creation rule. For more information about the rules

and their capabilities, visit:

About rules and rule sets

Please note that you cannot delete rules, but you can 

instead. 

set them to inactive

https://www-p02.intacct.com/ia/docs/en_US/help_action/Cash_Management/Reconcile/Reconciliation_rules/about-rules-rulesets.htm?cshid=Cash_Management/Reconcile/Reconciliation_rules/about-rules-rulesets.htm
https://www-p02.intacct.com/ia/docs/en_US/help_action/Cash_Management/Reconcile/Reconciliation_rules/Rules/inactivate-a-rule.htm


3

Add rule to rule set

Add Rule Set to Bank Account

The final step is to make sure that the Rule Set is added to the bank account.

Still on the Rule Set page, where you create the new Rule Set (or add the rule to the

existing one), navigate to the Account tab and select the accounts you want the Rule

Set to apply to. You can select as many accounts as you wish. 



Add Rule Set to Acounts

When you are done, click Save at the top right.

You can now easily reconcile your accounts without errors, as your bank transactions

automatically match with the corresponding Intacct transactions.



3.2.2.6. Disabling Bank Feeds (Intacct)

To disconnect an account from Bank Feeds, follow these steps.

1

2

3

Navigate to Accounts

Navigate to Cash Management -> Accounts. 

Disconnect Account

Select the bank account you would like to disconnect. 

Click Edit and navigate to Banking Cloud. From there, click Disconnect.

Disconnect Bank Feeds Account

Confirm Status

Once you have confirmed the disconnection, the status will update to Disconnecting.

The status may stay like this for a couple of minutes. 



Disconnecting Bank Feeds Account

Once the account has been fully disconnected, the status will revert to Connect. If

desired, you are able to start the connection process again by following the Enabling

Bank Feeds guide.

Back to 'Connect' status





3.2.3. Book Transfers (A2A)

With the  plugin, you can initiate transfers between your company’s

accounts directly from within Sage Intacct. 

Goldman Sachs

Before getting started, please verify that your accounts meet the following criteria:

Both accounts must belong to the same TxB branch.

Both accounts must be domiciled in the same currency.

Requirements

The Book Transfers feature within your bank plugin supports transferring funds between

two accounts within the same entity. To ensure a successful transfer, please verify that the

following prerequisites are met:

1

2

3

Both the source and destination accounts must belong to the same entity.

The associated General Ledger (GL) accounts must not have Required Dimensions

configured. 

Ensure that either the Cash Disbursements (CD) or Cash Disbursements – Cash-basis

(CDC) Journals are enabled.

Transferring Funds

IMPORTANT: Intacct does not allow the transferring of funds between two accounts

from two separate entities. The Bank Accounts must be set up at the top level, with

two different location IDs (or Fund IDs), or within the same entity (NOT at the top

level). This is an Intacct limitation. 



When using Account Transfers, ensure your Intacct bank accounts are correctly mapped to

the appropriate bank accounts.

To initiate transfers between bank accounts within the same subsidiary (Intracompany) or

between accounts in different subsidiaries (Inter-company), follow these steps.

1

2

Step 1: Go to the Funds Transfer Page

Go from Your Bank → Funds Transfer.

Go to Funds Transfer Page

Step 2: Initiate a Transfer

The overview page consists of two sections: the From (source) and To (destination)

accounts. When selecting these accounts, users can view both the Book and Bank

balances to assist with informed decision-making.

Enter the following information:

Under From Account, select a source bank account using the dropdown.

Under To Account, select a receiving bank account from the dropdown menu.

Transfer Amount

Memo (optional)
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Select Transfer.

Initiate a Transfer

Step 3: Confirm Transfer

A confirmation window will appear, displaying the transfer details. Select Confirm to

initiate the transfer.



Confirm Transfer

Transfer History

To view Transfer History, go to Your Bank → Transfer Funds → History

This tab lists all previous book transfers with their statuses and allows sorting on all

columns.



Transfer History

FAQs

Why do I get the ‘[BL01001973] Invalid Journal CDJ selected – Pick a valid active

Journal.’ error message?

This error occurs because the required journal has not been configured. To resolve

this, navigate to General Ledger → Configuration → Journals and create a new journal.

Ensure the journal symbol is set to CDJ.

What happens if the transfer is voided before it is processed at the bank?

In this case, the plugin changes the value of the original journal entries to 0 and marks

it as: 'Voided {amount} Transfer – {original message}.' 

You can always find the status of the transfer in the History tab.



When doing a transfer between different location IDs, how do I know which

accounts are debited/credited?

Intacct natively supports the balancing of such transactions. Check the inter-entity

map, which summarizes the balancing of any transactions between different location

IDs.

Where can I change my inter-entity map?

Navigate to Company -> Set up -> Inter-Account Mapping.

What happens if I do not include a memo in my transfer?

In this case, the plugin will automatically add a memo following From bank account

(sourceBankName) to bank account (destBankName). This is the same as Native

Intacct.

Can I transfer money between two different currencies?

No, both the ‘to’ and ‘from’ accounts need to have the same currency. The ‘to’ account

will only show the accounts that have been matched and that have the same currency.

/account



3.3.Troubleshooting

3.3.1. FAQ (Intacct)

This page is your go-to resource for quick troubleshooting. We've compiled a list of the

most common errors and frequently asked questions you might encounter when using the 

 in Intacct, providing you with immediate answers and resolutions.Goldman Sachs

Installation & Plugin Setup

Common Questions

This list provides answers to common questions that arise during the installation process,

to help ensure a smoother setup in Intacct.

Why can't I see the accounts in the Account Matching page of the installation

wizard?

This happens when you are missing some permissions on your Web Service User.

Please refer to the Create Web Service User step inside the Installation Guide. 



Why am I failing to pass the Connection step in the installation wizard?

This occurs when you have entered incorrect information in the previous step of the

installation wizard. Ensure that you include the Web Service User information and not

the user's native Intacct credentials. Additionally, you must verify that the Web Service

User has been created with admin access.

Bank Feeds

Common Questions

This list provides answers to common questions that arise when using the Bank Feeds

product in Intacct.

Why is my account stuck in Pending status when I connected my account to Bank

Feeds?

If the account is in Pending status, it means that there have not yet been any

transactions processed for this account. You will need to wait until transactions occur

on this account before it is marked as Connected.

How do I connect more than one account at a time to Bank Feeds?

Bank Feeds allows you to connect multiple accounts to the plugin. Once one bank

account is connected to bank feeds, other accounts can be connected simultaneously

via a financial institution connection. Please refer to the guide on Multi-Account Bank

Feeds Setup.

Accounts Payable

Common Questions

This list provides answers to common questions that arise when using the Accounts

Payable product in Intacct.



How long do bills stay on the History Page?

Bills never leave the history page. As long as there is a working sync between Intacct

and the plugin, you should be able to see your paid bills. 

Why do my bills not appear inside the plugin?

There could be a few reasons that a bill created inside Intacct does not appear inside

the plugin: 

The bill is not in Posted status. If you have a bill approval in place, the bill will only

show in the plugin once it has been approved. 

The Web Service User does not have the appropriate permissions. Please refer to

the Create Web Service User guide for more information.

The bill is in a specific entity that the Web Service User does not have access to.

You may need to grant the Web Service User access to that specific entity. 

The Vendor has been marked as Don't Pay. If that is the case, simply uncheck

that box. 

Why do I see multiple instances of the same bill on the History Page?

If you pay a bill with partial payments, the same bill will appear multiple times on the

History Page. Similarly, if a bill has failed and has been repaid, it will also appear in

multiple payments on the History Page.  

How many bills load per page?

The plugin displays 200 bills per page, and you can only combine payments from bills

on one page at a time.

Why do the bills in a specific entity not show up?

This is likely because your Web Service User is missing some permissions. Please

ensure it has access to any entities you would like to utilize. This situation should

occur only when you add entities after having created the Web Service User earlier.



For multi-entities, can the company name be unique per bank account?

Yes, please contact your bank and request that they enter a unique Account Holder

Name for each bank account using the details you provide. If there is an entry in the 

Account Details -> Account Holder Name field, this name will appear on vendor

payments; otherwise, it will default to the Account Label (i.e., Company Name).

For example, if the umbrella company is ACME Holdings, the name on the payments

would appear as coming from ACME North or ACME South, etc., based on the bank

account used for the payment.

Common Errors

Below is a list of common errors encountered when using the Accounts Payable product in

Intacct. Click on any error message to view the cause and immediate troubleshooting steps

for a resolution.

"You do not have the permissions for operation READ_BY_QUERY on object of type

trxcurrencies"

This is because the multi-currency module has not been enabled. We recommend

enabling this module to avoid this error. You may need to contact Sage Support to

have it enabled. Please note that you are still able to make payments even if you do not

have multi-currencies enabled.

"You do not have the permissions for operation READ_BY_QUERY on object of type

locationentity"

This is because you are missing the Entities permissions for the role/user. Please

navigate to Company -> Subscriptions -> Role and add the Entities permissions for 

View.



3.4. Sandbox Checklist (Intacct)

If you're testing the plugin in a Sandbox environment, it's recommended to test a variety of

scenarios. This will help you confirm that your setup is properly supported and functioning

as expected.

Scenarios to Test

Below is a list of scenarios you may wish to test. 

1

2

Vendor Setup

Modify or create two vendors: one listed as a company and the other as an

individual. The vendors should have bank details (under 'bank file') and a complete

address set up. Additionally, a default payment method can be configured within

Intacct.

Expected Outcome: These two vendors will be used when testing bill payments and

positive pay transmissions. Both vendors should appear in the Payment Methods tab

of the plugin. If any ACH information has been populated in Intacct, it will be visible in

this Payment Methods section (click Edit to view it).

If a default payment method has been set, it will also appear on the vendor record

within the plugin.

ACH Bill Setup and Payment

Verify that each vendor you test has a US address and ACH payment details entered.

Create a bill, ensuring all mandatory fields are populated.

1. Go to the Pay Bills page in the plugin.

2. Select the bill you just created.

3. Select ACH as the payment method (skip if ACH is set as the default).

4. Click Pay. 



3

4

Expected Outcome: Once the payment is successfully sent, it should disappear from

the Open Bills tab on the Pay Bills page. 

If the payment remains on the page, go to the Failed Bills tab on the same screen, or

view the payment status in the History page of the plugin.

Check Bill Setup and Payment

Verify that each vendor you test has an address and payment details entered.

Create a bill, ensuring all mandatory fields are populated.

1. Go to the Pay Bills page in the plugin.

2. Select the bill you just created.

3. Select Check as the payment method (skip if Check is set as the default).

4. Click Pay. 

Expected Outcome: Once the payment is successfully sent, it should disappear from

the Open Bills tab on the Pay Bills page. 

If the payment remains on the page, go to the Failed Bills tab on the same screen, or

view the payment status in the History page of the plugin.

Discount Setup and Payment

Verify that the plugin correctly applies a vendor discount during the bill payment

process. 

First, in Intacct, create a bill, filling in all mandatory fields and ensuring a valid

payment term (with a discount) is selected. If a suitable term doesn't exist, create

one under Accounts Payable -> Setup -> More -> Terms.

Then, on the plugin's Pay Bills page:

1. Select the bill that was created and choose the payment method (if no default).

2. Confirm the discount amount is populated (adjust the discount date by clicking

the amount if necessary).

3. Click Pay.

Expected Outcome: Once the payment is successful, the bill should disappear from

the Open Bills tab. If the payment remains on the page, go to the Failed Bills tab to



5

6

find if the bill failed. 

Navigate to the plugin's History Page and verify that the Paid Amount correctly

reflects the discount term deduction.

Adjustments Setup and Payment

Verify that the plugin correctly applies a debit adjustment (credit memo) during the

bill payment process.

In Intacct, go to the Bill page and create a new bill, filling in all mandatory fields.

Create an Adjustment (credit memo):

1. Navigate to Accounts Payable -> Adjustment.

2. Create a new Adjustment, ensuring the type is Debit Memo.

3. Complete all required fields.

Go back to the Adjustments page and confirm that the new debit memo appears in

the list.

Expected Outcome: The bill should disappear from the Open Bills tab upon

successful payment. If the payment remains on the page, go to the Failed Bills tab to

find if the bill failed. You can also view payment status in the History screen of the

plugin. 

To complete the test, verify the following:

From the History page, verify that the bill's Paid Amount correctly accounts for

the adjustment. 

Return to the plugin's Pay screen (or vendor detail). Verify that the Credits

Available balance has been correctly reduced by the amount you applied to the

paid bill. 

Failed Bills

All bills will automatically show as successful after clicking Pay. To test the process

for a failed bill, create a bill of $1991.00. Pay this bill on the Pay Bills screen.

Expected Outcome: The bill should automatically fail and remain on the Open Bills

page. An error message should also appear on the Failed Bills screen.



The bill's status should remain Posted.



3.4.1. Sandbox Checklist via the Portal

The Sandbox Checklist is a structured list of post-onboarding sandbox checklist that

guides you through the plugin. This allows you to gain immediate clarity on the next steps

once you complete the onboarding wizard. It eliminates the guesswork by giving you a

clear, prioritized path through FISPAN's core capabilities, at your own pace.

Overview

Instead of relying on guided walkthroughs or back-and-forth emails to help you explore 

, we now provide a structured, automated, and product-aware path to

follow along. This allows you to arrive at production conversations better prepared, with

higher confidence, and having already experienced the key workflows firsthand!

Goldman Sachs

Sandbox Checklist on the Portal

NOTE: This is only available on the Sandbox environment.



Key Features Breakdown

1

2

3

4

My Journey Tab

A new My Journey tab now appears in the  Portal once the

onboarding wizard has been completed. This allows for tracking progress through

your Sandbox. It remains up to date as you explore the plugin.

Goldman Sachs

Automated Task Completion

As you perform actions in their ERP, such as loading bills, viewing transactions, or

confirming a payment, the sandbox checklist will mark those tasks as complete upon

the next refresh.

Tailored to Your Bank’s Products

The checklist only displays tasks relevant to the products enabled for you.

Learn More Redirect

The Sandbox Checklist includes a Learn More link that takes you directly to the

relevant section of our Product Guide or Interactive Demo, providing step-by-step

guidance exactly when and where it's needed.



3.5. Release Notes (Intacct)

To learn about how to update your plugin visit: Updating the Plugin (Intacct)

Coming Soon!



4.Support

4.1. Contact Us

Need help with a specific topic? Enter keywords in the search bar on the left panel to

narrow your results. If you don't find what you need, our support team is ready to assist

you.

Search for Keywords

Support

The Goldman Sachs can be reached via:



Email: txb-client-service@gs.com

Phone: +1 (212) 902-2000

mailto:txb-client-service@gs.com

